<!DOCTYPE html>
<html>
<head>
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta name="generator" content="WordPress 4.9.8" />
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<title>Common opponent Alantez Fox analyzes Demetrius Andrade-Liam Williams - The Ring</title>
<script src="/cdn-cgi/apps/head/OyS6iIEAHbQ_LZQHUv76Gu1pruU.js"></script><link rel="apple-touch-icon" sizes="57x57" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-57x57.png">
<link rel="apple-touch-icon" sizes="60x60" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-60x60.png">
<link rel="apple-touch-icon" sizes="72x72" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-72x72.png">
<link rel="apple-touch-icon" sizes="76x76" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-76x76.png">
<link rel="apple-touch-icon" sizes="114x114" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-114x114.png">
<link rel="apple-touch-icon" sizes="120x120" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-120x120.png">
<link rel="apple-touch-icon" sizes="144x144" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-144x144.png">
<link rel="apple-touch-icon" sizes="152x152" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-152x152.png">
<link rel="apple-touch-icon" sizes="180x180" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-180x180.png">
<link rel="icon" type="image/png" sizes="192x192" href="https://www.ringtv.com/wp-content/themes/thering/images/android-icon-192x192.png">
<link rel="icon" type="image/png" sizes="32x32" href="https://www.ringtv.com/wp-content/themes/thering/images/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="96x96" href="https://www.ringtv.com/wp-content/themes/thering/images/favicon-96x96.png">
<link rel="icon" type="image/png" sizes="16x16" href="https://www.ringtv.com/wp-content/themes/thering/images/favicon-16x16.png">
<link rel="manifest" href="https://www.ringtv.com/wp-content/themes/thering/images/manifest.json">
<meta name="msapplication-TileColor" content="#ffffff">
<meta name="msapplication-TileImage" content="https://www.ringtv.com/wp-content/themes/thering/images/ms-icon-144x144.png">
<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="https://www.ringtv.com/feed/" />
<link rel="alternate" type="text/xml" title="RSS .92" href="https://www.ringtv.com/feed/rss/" />
<link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="https://www.ringtv.com/feed/atom/" />
<link rel="pingback" href="https://www.ringtv.com/xmlrpc.php" />

<script data-cfasync='false' type='text/javascript'>/*<![CDATA[*/(function (a, c, s, u){'Insticator'in a || (a.Insticator={ad:{loadAd: function (b){Insticator.ad.q.push(b)}, q: []}, helper:{}, embed:{}, version: "3.0", q: [], load: function (t, o){Insticator.q.push({t: t, o: o})}}); var b=c.createElement(s); b.src=u; b.async=!0; var d=c.getElementsByTagName(s)[0]; d.parentNode.insertBefore(b, d)})(window, document, 'script', '//d2na2p72vtqyok.cloudfront.net/client-embed/5f282198-b6f9-4fbf-9244-cfb0317339b5.js');/*]]>*/</script>

<link href="https://fonts.googleapis.com/css?family=Montserrat:400,500,600,700,800,900" rel="stylesheet">

<link rel="canonical" href="https://www.ringtv.com/620386-common-opponent-alantez-fox-analyzes-demetrius-andrade-liam-williams/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Common opponent Alantez Fox analyzes Demetrius Andrade-Liam Williams - The Ring" />
<meta property="og:description" content="Alantez Fox will be an interested observer when Demetrius Andrade defends his WBO 160-pound title against mandatory challenger Liam Williams on Saturday. Fox has previously shared the ring with both men. He lost his unbeaten record when he was outpointed by Andrade (UD 12) in October 2017. After exchanging barbs with Williams on social media, &hellip;" />
<meta property="og:url" content="https://www.ringtv.com/620386-common-opponent-alantez-fox-analyzes-demetrius-andrade-liam-williams/" />
<meta property="og:site_name" content="The Ring" />
<meta property="article:publisher" content="https://www.facebook.com/RingTV" />
<meta property="article:tag" content="Alantez Fox" />
<meta property="article:tag" content="Andrade-Williams" />
<meta property="article:tag" content="DAZN" />
<meta property="article:tag" content="demetrius andrade" />
<meta property="article:tag" content="Liam Williams" />
<meta property="article:tag" content="Matchroom boxing" />
<meta property="article:section" content="Boxing" />
<meta property="article:published_time" content="2021-04-15T07:10:55+00:00" />
<meta property="og:image" content="https://www.ringtv.com/wp-content/uploads/2017/10/Andrade-Fox_@HBOboxing.jpg" />
<meta property="og:image:secure_url" content="https://www.ringtv.com/wp-content/uploads/2017/10/Andrade-Fox_@HBOboxing.jpg" />
<meta property="og:image:width" content="800" />
<meta property="og:image:height" content="450" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="Alantez Fox will be an interested observer when Demetrius Andrade defends his WBO 160-pound title against mandatory challenger Liam Williams on Saturday. Fox has previously shared the ring with both men. He lost his unbeaten record when he was outpointed by Andrade (UD 12) in October 2017. After exchanging barbs with Williams on social media, [&hellip;]" />
<meta name="twitter:title" content="Common opponent Alantez Fox analyzes Demetrius Andrade-Liam Williams - The Ring" />
<meta name="twitter:site" content="@ringmagazine" />
<meta name="twitter:image" content="https://www.ringtv.com/wp-content/uploads/2017/10/Andrade-Fox_@HBOboxing.jpg" />
<meta name="twitter:creator" content="@ringmagazine" />
<script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Organization","url":"https:\/\/www.ringtv.com\/","sameAs":["https:\/\/www.facebook.com\/RingTV","https:\/\/www.instagram.com\/ringtv\/","https:\/\/www.youtube.com\/channel\/UC8ybHJltwhtpk0cFKU4G8kQ","https:\/\/twitter.com\/ringmagazine"],"@id":"https:\/\/www.ringtv.com\/#organization","name":"The Ring Magazine","logo":"https:\/\/www.ringtv.com\/wp-content\/uploads\/2016\/09\/RING-logo_black_on_white-w-shadow2.jpg"}</script>

<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Ring &raquo; Common opponent Alantez Fox analyzes Demetrius Andrade-Liam Williams Comments Feed" href="https://www.ringtv.com/620386-common-opponent-alantez-fox-analyzes-demetrius-andrade-liam-williams/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.ringtv.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.8"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='contact-form-7-css' href='https://www.ringtv.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.3' type='text/css' media='all' />
<link rel='stylesheet' id='wpos-slick-style-css' href='https://www.ringtv.com/wp-content/plugins/timeline-and-history-slider/assets/css/slick.css?ver=1.3.5' type='text/css' media='all' />
<link rel='stylesheet' id='tahs-public-style-css' href='https://www.ringtv.com/wp-content/plugins/timeline-and-history-slider/assets/css/slick-slider-style.css?ver=1.3.5' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://www.ringtv.com/wp-includes/css/dashicons.min.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='wpp_style-css' href="https://www.ringtv.com/wp-content/plugins/wp-poll/assets/front/css/style.css?ver=4.9.8" type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css' href="https://www.ringtv.com/wp-content/plugins/wp-poll/assets/global/css/font-awesome.css?ver=4.9.8" type='text/css' media='all' />
<link rel='stylesheet' id='jquery-issuem-flexslider-css' href='https://www.ringtv.com/wp-content/plugins/issuem/css/flexslider.css?ver=2.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='issuem-leaky-paywall-article-countdown-nag-css' href='https://www.ringtv.com/wp-content/plugins/leaky-paywall-article-countdown-nag//css/article-countdown-nag-slim.css?ver=3.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='leaky-paywall-coupons-css-css' href='https://www.ringtv.com/wp-content/plugins/leaky-paywall-coupons//css/leaky-paywall-coupons.css?ver=1.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-style-css' href='//ajax.googleapis.com/ajax/libs/jqueryui/1.11.2/themes/smoothness/jquery-ui.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='lp-gift-style-css' href='https://www.ringtv.com/wp-content/plugins/leaky-paywall-gift-subscriptions//css/lp-gift.css?ver=2.6.0' type='text/css' media='all' />
<link rel='stylesheet' id='issuem-leaky-paywall-css' href='https://www.ringtv.com/wp-content/plugins/leaky-paywall//css/issuem-leaky-paywall.css?ver=4.13.1' type='text/css' media='all' />
<link rel='stylesheet' id='unipress-api-css' href='https://www.ringtv.com/wp-content/plugins/unipress-api//css/unipress.css?ver=1.18.2' type='text/css' media='all' />
<link rel='stylesheet' id='leaky-paywall-trials-css' href='https://www.ringtv.com/wp-content/plugins/leaky-paywall-trials//css/style.css?ver=1.5.0' type='text/css' media='all' />
<link rel='stylesheet' id='flexslider-css' href='https://www.ringtv.com/wp-content/themes/thering/css/flexslider.css' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css' href='https://www.ringtv.com/wp-content/themes/thering/css/font-awesome.css' type='text/css' media='all' />
<link rel='stylesheet' id='normalize-css' href='https://www.ringtv.com/wp-content/themes/thering/css/normalize.css' type='text/css' media='all' />
<link rel='stylesheet' id='grid12-css' href='https://www.ringtv.com/wp-content/themes/thering/css/grid12.css' type='text/css' media='all' />
<link rel='stylesheet' id='movingboxes-css' href='https://www.ringtv.com/wp-content/themes/thering/css/movingboxes.css' type='text/css' media='all' />
<link rel='stylesheet' id='customscrollbar-css' href='https://www.ringtv.com/wp-content/themes/thering/css/jquery.mCustomScrollbar.css' type='text/css' media='all' />
<link rel='stylesheet' id='owlcarousel-css' href='https://www.ringtv.com/wp-content/themes/thering/css/owl.carousel.css' type='text/css' media='all' />
<link rel='stylesheet' id='owltheme-css' href='https://www.ringtv.com/wp-content/themes/thering/css/owl.theme.default.css' type='text/css' media='all' />
<link rel='stylesheet' id='fancybox-css' href='https://www.ringtv.com/wp-content/themes/thering/css/jquery.fancybox.css' type='text/css' media='all' />
<link rel='stylesheet' id='stylesheet-css' href='https://www.ringtv.com/wp-content/themes/thering/style.css?ver=b6e20697dd771845ae1d1d687cb23cbd' type='text/css' media='all' />
<link rel='stylesheet' id='responsive-css' href='https://www.ringtv.com/wp-content/themes/thering/css/responsive.css?ver=b6e20697dd771845ae1d1d687cb23cbd' type='text/css' media='all' />
<link rel='stylesheet' id='app-css-css' href='https://www.ringtv.com/wp-content/themes/thering/css/app.css?ver=b6e20697dd771845ae1d1d687cb23cbd' type='text/css' media='all' />
<script type='text/javascript' src='https://www.ringtv.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpp_ajax = {"wpp_ajaxurl":"https:\/\/www.ringtv.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/wp-poll/assets/front/js/scripts.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/issuem/js/jquery.flexslider-min.js?ver=2.7.4'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/leaky-paywall-article-countdown-nag//js/article-countdown-nag.js?ver=3.1.0'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/leaky-paywall-coupons/js/leaky-paywall-coupons.js?ver=1.8.2'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/leaky-paywall-gift-subscriptions//js/lp-gift.js?ver=2.6.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_object = {"ajax_url":"https:\/\/www.ringtv.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/unipress-api//js/unipress.js?ver=1.18.2'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/countdown.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var aamLocal = {"nonce":"c263a5ee3c","ajaxurl":"https:\/\/www.ringtv.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='//www.ringtv.com/wp-content/plugins/advanced-access-manager/media/js/aam-login.js?ver=4.9.8'></script>
<link rel='https://api.w.org/' href='https://www.ringtv.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.ringtv.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.ringtv.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 4.9.8" />
<link rel='shortlink' href='https://www.ringtv.com/?p=620386' />
<link rel="alternate" type="application/json+oembed" href="https://www.ringtv.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ringtv.com%2F620386-common-opponent-alantez-fox-analyzes-demetrius-andrade-liam-williams%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.ringtv.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ringtv.com%2F620386-common-opponent-alantez-fox-analyzes-demetrius-andrade-liam-williams%2F&#038;format=xml" />

<script>
!function(f,b,e,v,n,t,s)
{if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};
if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];
s.parentNode.insertBefore(t,s)}(window,document,'script',
'https://connect.facebook.net/en_US/fbevents.js');
 fbq('init', '161022561146884'); 
fbq('track', 'PageView');
</script>
<noscript>
 <img height="1" width="1" 
src="https://www.facebook.com/tr?id=161022561146884&ev=PageView&noscript=1"/>
</noscript>


<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
	(adsbygoogle = window.adsbygoogle || []).push({
		google_ad_client: "ca-pub-3782114432787829",
		enable_page_level_ads: true
	});
</script>

</head>
<body class="post-template-default single single-post postid-620386 single-format-standard loading common-opponent-alantez-fox-analyzes-demetrius-andrade-liam-williams unknown" <div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.10&appId=128026463954740";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
<div id="mobile-nav">
<a href="#" class="btn-close-mob"></a>
<div class="mob-logo"><img src="https://www.ringtv.com/wp-content/themes/thering/images/ring-logo.png" alt=""></div>
<ul id="menu-main-menu" class="mob-nav"><li id="menu-item-152" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-152"><a href="https://www.ringtv.com/news/">News</a></li>
<li id="menu-item-158" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-158"><a href="https://www.ringtv.com/videos/">Media</a></li>
<li id="menu-item-572626" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-572626"><a href="https://www.ringtv.com/category/trivia/">Trivia</a></li>
<li id="menu-item-516022" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-516022"><a href="https://www.ringtv.com/category/podcasts/">Podcasts</a></li>
<li id="menu-item-155" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-155"><a href="https://www.ringtv.com/ratings/">Ratings</a></li>
<li id="menu-item-156" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156"><a href="https://www.ringtv.com/upcoming-livestreams/schedule/">Schedule</a></li>
<li id="menu-item-249" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-249"><a target="_blank" href="https://ringmagshop.com">Shop</a></li>
<li id="menu-item-494633" class="hlogin-btn menu-item menu-item-type-post_type menu-item-object-page menu-item-494633"><a href="https://www.ringtv.com/subscription-login/">Login</a></li>
<li id="menu-item-531167" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-531167"><a href="https://www.ringtv.com/subscribe/">Subscribe</a></li>
</ul> <ul class="mobile-nav-social">
<li><a href="https://www.ringtv.com/search"><i class="fa fa-search"></i></a></li>
<li><a href="https://www.facebook.com/RingTV" target="_blank"><i class="fa fa-facebook"></i></a></li> <li><a href="https://www.youtube.com/user/TheRingDigital" target="_blank"><i class="fa fa-youtube"></i></a></li> <li><a href="https://twitter.com/ringmagazine" target="_blank"><i class="fa fa-twitter"></i></a></li> <li><a href="https://instagram.com/ringtv" target="_blank"><i class="fa fa-instagram"></i></a></li> </ul>
</div>
<div id="top_bar">
<div class="content-wrap">
<div class="left">
<div class="date">Thursday, April 15, 2021&nbsp; |</div>
<div class="follow">
<span class="label">Follow Us:</span>
<a href="https://www.facebook.com/RingTV" target="_blank"><i class="icon-facebook"></i></a> <a href="https://www.youtube.com/user/TheRingDigital" target="_blank"><i class="icon-youtube-play"></i></a> <a href="https://twitter.com/ringmagazine" target="_blank"><i class="icon-twitter"></i></a> <a href="https://instagram.com/ringtv" target="_blank"><i class="icon-instagram-1"></i></a> </div>
<div class="media-kit"><a href="https://www.ringtv.com/subscribe/" style="text-decoration: none; border-bottom: solid 1px #9c9c9c;">Subscribe</a></div>
<div class="search-bit">
<form id="searchform" method="get" action="https://www.ringtv.com/">
<input type="text" name="s" id="s" size="15" placeholder="Search RingTV..." />
<span><i class="icon-search"></i></span>
</form>
</div>
</div>
<div class="right">
<div class="cycle-slideshow" data-cycle-slides="> div.item" data-cycle-fx="flipVert" data-cycle-pause-on-hover="true" data-cycle-timeout="4500" data-cycle-speed="500">
<div class="item"><a href="https://www.ringtv.com/current-issue/" class="button-ppv"><span>NEW ISSUE OF RING MAG!</span></a></div>
<div class="item"><a href="https://www.ringtv.com/past-issues/" class="button-ppv"><span>BACK ISSUES OF RING MAG!</span></a></div>
</div>
</div>
</div>
</div>
<div id="masthead">
<div class="content-wrap">
<a href="https://www.ringtv.com" class="logo" title="Ring TV">Ring TV</a>
<ul id="menu-main-menu-1" class="main-nav desktop"><li class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-152"><a href="https://www.ringtv.com/news/">News</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-158"><a href="https://www.ringtv.com/videos/">Media</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-572626"><a href="https://www.ringtv.com/category/trivia/">Trivia</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-516022"><a href="https://www.ringtv.com/category/podcasts/">Podcasts</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-155"><a href="https://www.ringtv.com/ratings/">Ratings</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156"><a href="https://www.ringtv.com/upcoming-livestreams/schedule/">Schedule</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-249"><a target="_blank" href="https://ringmagshop.com">Shop</a></li>
<li class="hlogin-btn menu-item menu-item-type-post_type menu-item-object-page menu-item-494633"><a href="https://www.ringtv.com/subscription-login/">Login</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-531167"><a href="https://www.ringtv.com/subscribe/">Subscribe</a></li>
</ul> <a href="#" class="toggle-menu">
<span></span>
<span></span>
<span></span>
</a>
</div>
<div class="mobile-menu">
<ul id="menu-main-menu-2" class="main-nav-mobile"><li class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-152"><a href="https://www.ringtv.com/news/">News</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-158"><a href="https://www.ringtv.com/videos/">Media</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-572626"><a href="https://www.ringtv.com/category/trivia/">Trivia</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-516022"><a href="https://www.ringtv.com/category/podcasts/">Podcasts</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-155"><a href="https://www.ringtv.com/ratings/">Ratings</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156"><a href="https://www.ringtv.com/upcoming-livestreams/schedule/">Schedule</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-249"><a target="_blank" href="https://ringmagshop.com">Shop</a></li>
<li class="hlogin-btn menu-item menu-item-type-post_type menu-item-object-page menu-item-494633"><a href="https://www.ringtv.com/subscription-login/">Login</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-531167"><a href="https://www.ringtv.com/subscribe/">Subscribe</a></li>
</ul>
</div>
</div>
<div class="sub-header">
<div class="content-wrap">
<h1>News</h1>
<div class="ads728-90"><div class="addrop-wrap" data-id="612961"><a href="https://www.boxingaficionado.com/" target="_blank" rel="noopener"><img class="size-full wp-image-605999 aligncenter" src="https://www.ringtv.com/wp-content/uploads/2021/03/BA.ad_728x90_YELLOW-copy.gif" alt="Aficianado " width="728" height="90" /></a></div></div>
</div>
</div>
<div id="content">
<div class="content-wrap">
<div class="list-main">
<div class="news-content">
<div class="full-post">
<h1>Common opponent Alantez Fox analyzes Demetrius Andrade-Liam Williams</h1>
<div class="imagebox"><img src="https://www.ringtv.com/wp-content/uploads/2017/10/Andrade-Fox_@HBOboxing-770x433.jpg" alt=""></div>
<div class="image-desc">Demetrius Andrade (right) takes it to Alantez Fox en route to a 12-round unanimous decision on October 21, 2017. Photo courtesy of HBO Boxing.</div>
<div class="a-d-468x60-post hidden-md visible-sm visible-xs"><div class="addrop-wrap" data-id="516167"></div></div>
<div class="text-wrap">
<div class="date-col">
<div class="day">15</div>
<div class="month">Apr</div>
</div>
<div class="a-d-468x60-post hidden-sm hidden-xs"><div class="addrop-wrap" data-id="516167"></div></div>
<div class="posted-by"><a href="https://www.ringtv.com/author/anson-wainwright/">by Anson Wainwright</a></div>
<p class="p1"><span class="s1">Alantez Fox will be an interested observer when Demetrius Andrade defends his WBO 160-pound title against mandatory challenger Liam Williams on Saturday.</span></p>
<p class="p1"><span class="s1">Fox has previously shared the ring with both men. He lost his unbeaten record when he was outpointed by Andrade (UD 12) in October 2017. After exchanging barbs with Williams on social media, Fox met the Welshman and was stopped in five rounds in December 2019.</span></p>
<p class="p1"><span class="s1">The 29-year-old American believes the fight has all the ingredients to bring out the very best in both incumbents.</span></p>
<p class="p1"><span class="s1">&#8220;I think it&#8217;s going to be a great fight,&#8221; Fox (27-2-1, 12 knockouts) told The Ring. &#8220;I think the fight is actually going to be boxer vs. brawler. Almost like you can picture a Ray Leonard-Marvin Hagler fight. </span></p>
<p class="p1"><span class="s1">&#8220;I see Demetrius Andrade being the most flashy of the two guys and the boxer and I see Liam Williams &#8211; don&#8217;t get wrong he can box &#8211; trying to bully Demetrius Andrade the whole time. Whoever&#8217;s will can prevail, will be the winner.&#8221;</span></p>
<p class="p1"><span class="s1">Fox feels Andrade is an impressive technical boxer, who brings a lot of ring savvy.</span></p>
<p class="p1"><span class="s1">&#8220;I think Demetrius Andrade is a definitely a smart, skilled puncher,&#8221; acknowledged Fox, who is now campaigning up at super middleweight and was the backup for David Benavidez-Ronald Ellis last month. &#8220;He has a really good punch placement. He has a really good ring I.Q. He&#8217;s going to play it as safe as he&#8217;s allowed to. He doesn&#8217;t go in there and take natural risks.&#8221;</span></p>
<p class="p1"><span class="s1">He feels Williams all-action aggressive nature could serve him well.</span></p>
<p class="p1"><span class="s1">&#8220;Williams brings a lot of energy to the ring,&#8221; said Fox. &#8220;I remember in our fight, I looked across the ring at him, he was pacing back and forth. He was ready to go in there. He&#8217;s pretty strong but I don&#8217;t know if he&#8217;s stronger or not than Demetrius Andrade but he&#8217;s definitely going to go in there and press the issue.&#8221;</span></p>
<p class="p1"><span class="s1">Fox feels Andrade can&#8217;t let himself get out-hustled and has to be fully dialed in but not get too greedy.</span></p>
<p class="p1"><span class="s1">&#8220;Liam Williams is strong, you can&#8217;t sit on the ropes,&#8221; he explained. &#8220;You have to keep the activity up, you have to be in shape, move and outbox him for 12-rounds. Unless you feel you can hurt him and knock him out. You have to be on point with everything you&#8217;re doing, your defense, getting in and out, you can&#8217;t sit there and allow him to take advantage of your inactivity. </span></p>
<p class="p1"><span class="s1">&#8220;[Williams] is always ready to jump in there with a combination. He&#8217;s not a one punch person, he&#8217;s a combination puncher, he&#8217;s going to keep the work rate and activity up.</span></p>
<p><img class="aligncenter size-large wp-image-590348" src="https://www.ringtv.com/wp-content/uploads/2020/01/demetrius-andrade_9vxw06sufmge15fzsaw4sorwd-1024x576.jpg" alt="" width="1024" height="576" srcset="https://www.ringtv.com/wp-content/uploads/2020/01/demetrius-andrade_9vxw06sufmge15fzsaw4sorwd-1024x576.jpg 1024w, https://www.ringtv.com/wp-content/uploads/2020/01/demetrius-andrade_9vxw06sufmge15fzsaw4sorwd-300x169.jpg 300w, https://www.ringtv.com/wp-content/uploads/2020/01/demetrius-andrade_9vxw06sufmge15fzsaw4sorwd-768x432.jpg 768w, https://www.ringtv.com/wp-content/uploads/2020/01/demetrius-andrade_9vxw06sufmge15fzsaw4sorwd-763x430.jpg 763w, https://www.ringtv.com/wp-content/uploads/2020/01/demetrius-andrade_9vxw06sufmge15fzsaw4sorwd-770x433.jpg 770w, https://www.ringtv.com/wp-content/uploads/2020/01/demetrius-andrade_9vxw06sufmge15fzsaw4sorwd-1320x743.jpg 1320w" sizes="(max-width: 1024px) 100vw, 1024px" /></p>
<p class="p1"><span class="s1">&#8220;If Demetrius Andrade goes in there to try to knock Liam Williams out, he&#8217;s going to be in for a rude awakening but he&#8217;s smarter than that but I don&#8217;t think he&#8217;s going to go in there with a chip on his shoulder. I think he&#8217;s going to go in there do whatever he needs to do.&#8221;</span></p>
<p class="p1"><span class="s1">Conversely, Fox believes that although Williams will be the aggressor and look to get on the inside, the challenger has to be measured and disciplined so not to walk into something on his way in.</span></p>
<p class="p1"><span class="s1">&#8220;Demetrius Andrade is good at placing his punches, I believe Liam Williams has to move his head moving forward, have his defense A1,&#8221; said Fox. &#8220;You will get tagged with shots; Demetrius Andrade can box. Your counters have to be really on point. </span></p>
<p class="p1"><span class="s1">&#8220;I don&#8217;t think Liam Williams will let him dictate the pace, he&#8217;s going to push the pace and make Demetrius Andrade box and mind his Ps and Qs the entire time. If you&#8217;re not able to box like that against Liam Williams, you&#8217;re going to lose. If you&#8217;re not 100 percent or 90 percent to box Liam Williams he&#8217;s going to overwhelm you. I don&#8217;t think Demetrius Andrade is going to be able to keep the pace low.&#8221;</span></p>
<p class="p1"><span class="s1">Fox broke down each fighter in 10 key categories:</span></p>
<p class="p1"><span class="s1"><b>JAB</b></span></p>
<p class="p1"><span class="s1">Demetrius Andrade: I think Demetrius Andrade&#8217;s jab is a little better. Both Demetrius Andrade and Liam Williams were able to land jabs on me. Liam Williams being the shorter man, he was able to use his legs, close that distance to land that jab. Demetrius Andrade, who is shorter than me, he has a really good jab. </span></p>
<p class="p1"><span class="s1"><b>DEFENSE</b></span></p>
<p class="p1"><span class="s1">Andrade: Demetrius Andrade&#8217;s defense is definitely better. I hit Liam Williams with more shots than I hit Demetrius Andrade with but Liam Williams is good though. Liam Williams is going to be there to get hit, he&#8217;s going to be slipping, trying to catch the shots. When you&#8217;re the pursuer, you&#8217;re going to take more shots than you would normally.</span></p>
<p class="p1"><span class="s1"><b>HANDSPEED</b></span></p>
<p class="p1"><span class="s1">Andrade: I think [this category is] more even than people think. I was a little drained when I fought Liam Williams so his hands were looking a lot faster than I thought. Maybe Demetrius Andrade has slight edge in handspeed. I think Andrade places his punches a little better. </span></p>
<p class="p1"><span class="s1"><b>FOOTWORK</b></span></p>
<p class="p1"><span class="s1">Even: Demetrius Andrade tends to sometimes be overzealous and trip up a lot, it&#8217;s maybe because he&#8217;s a southpaw, his lead foot always crosses over and makes him be off-balance more often. In our fight I dropped him but I really didn&#8217;t have to do anything, he did that on his own, I threw a punch that grazed and his footwork made it so he fell and I got the knockdown. Liam Williams uses a little bit of footwork; he uses more head movement to get forward. I think Demetrius Andrade may take a bit of an advantage in that department but I don&#8217;t see Liam Williams falling around like that, so it maybe even.</span></p>
<p class="p1"><span class="s1"><b>SMARTEST</b></span></p>
<p class="p1"><span class="s1">Even: I think Liam Williams knows how to take advantage of the situations he&#8217;s in. In my fight with Demetrius Andrade, he came out in one round as if he was going to take me out. When he went back to the corner his father told him, &#8216;This guy isn&#8217;t there, we won&#8217;t even try to take him out, you need to relax.&#8217; That goes to ring I.Q., you need to be able to recognize situations you&#8217;re in. When I hurt Liam Williams in the fight, he knew how to cover up, hold, wrestle, that all goes to ring I.Q. That might be the most even [category]. </span></p>
<p class="p1"><span class="s1"><b>STRONGEST</b></span></p>
<p class="p1"><span class="s1">Liam Williams: If I had to gauge both of them, I may give the toughness and strength edge to Liam Williams. He can probably absorb more punishment than Demetrius Andrade. That&#8217;s his fight path. If things get rough for Andrade, I don&#8217;t know how well he&#8217;ll manage on that. I don&#8217;t see Liam Williams boxing on the outside, I see him trying to bully Demetrius Andrade.</span></p>
<div id="attachment_620192" style="width: 910px" class="wp-caption aligncenter"><img class="size-full wp-image-620192" src="https://www.ringtv.com/wp-content/uploads/2021/04/liam-williams.jpeg" alt="" width="900" height="677" srcset="https://www.ringtv.com/wp-content/uploads/2021/04/liam-williams.jpeg 900w, https://www.ringtv.com/wp-content/uploads/2021/04/liam-williams-300x226.jpeg 300w, https://www.ringtv.com/wp-content/uploads/2021/04/liam-williams-768x578.jpeg 768w" sizes="(max-width: 900px) 100vw, 900px" /><p class="wp-caption-text">Photo from MTK Global</p></div>
<p class="p1"><span class="s1"><b>POWER</b></span></p>
<p class="p1"><span class="s1">Williams: I might give the edge to Liam Williams; I think he might hit a little harder. Liam Williams hurt me in the third round and finished me in the fifth round. </span></p>
<p class="p1"><span class="s1"><b>CHIN</b></span></p>
<p class="p1"><span class="s1">Even: It&#8217;s hard to say because I didn&#8217;t hit Demetrius Andrade like that. I hit Liam Williams with a shot that hurt him, I hurt him to the body. You have to say Liam Williams chin but I wasn&#8217;t able to Demetrius Andrade&#8217;s chin. In past fights I&#8217;ve seen Demetrius Andrade dropped. Liam Williams has been stopped; it wasn&#8217;t because he was hurt but he was stopped. I hurt him myself, I know Liam Williams can be hurt. I&#8217;m going with a no comment.</span></p>
<p class="p1"><span class="s1"><b>SKILLS</b></span></p>
<p class="p1"><span class="s1">Andrade: Demetrius Andrade definitely has better skills; he gets hit less. I think his boxing skills are better but I think Liam Williams has good boxing skills as well.</span></p>
<p class="p1"><span class="s1"><b>OVERALL</b></span></p>
<p class="p1"><span class="s1">Andrade: I think Andrade is the better fighter all-around. He has zero loses, Williams has two. Liam Williams is the No. 1 contender. I don&#8217;t think Andrade is leagues better, I just think he&#8217;s better. </span></p>
<p class="p1"><span class="s1">Fox expects an evenly contested bout throughout but leans toward the defending titleholder.</span></p>
<p class="p1"><span class="s1">&#8220;I&#8217;m going with the boxer, I think Demetrius Andrade&#8217;s boxing skills and I.Q. will put him above [Williams],&#8221; said Fox. &#8220;It&#8217;s going to be a decision. I don&#8217;t think he&#8217;ll knock Liam Williams out; I don&#8217;t think he&#8217;s going to even try to knock Liam Williams out. I can see all three judges giving it to Demetrius Andrade. I can see a 7 [rounds to] 5. Andrade&#8217;s going to know he&#8217;s been in a fight.&#8221;</span></p>
<p class="p1"><span class="s1"><b><i>Questions and/or comments can be sent to Anson at </i></b><a href="/cdn-cgi/l/email-protection#03666f71626a6d606c6277436f6a75662d606c2d7668"><span class="s2"><b><i><span class="__cf_email__" data-cfemail="2c49405e4d45424f434d586c40455a49024f43025947">[email&#160;protected]</span></i></b></span></a><b><i> and you can follow him on </i></b></span></p>
<p class="p3"><span class="s3"><b><i><a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="6c381b051818091e2c2d021f03023b0d05021b1e050b0418">[email&#160;protected]</a></i></b></span></p>
<div class="clearboth"></div>
</div>

<div class="list-top3" id="minutemedia">
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>!function(e,t,a,n,g){e[n]=e[n]||[],e[n].push({"gtm.start":(new Date).getTime(),event:"gtm.js"});var m=t.getElementsByTagName(a)[0],r=t.createElement(a);r.async=!0,r.src="https://www.googletagmanager.com/gtm.js?id=GTM-PL4PD49",m.parentNode.insertBefore(r,m)}(window.parent,window.parent.document,"script","dataLayer");</script><script>var iframe=window.parent.document.createElement("iframe");iframe.src="https://www.googletagmanager.com/ns.html?id=GTM-PL4PD49";iframe.height="0";iframe.width="0";iframe.style="display:none;visibility:hidden";window.parent.document.body.appendChild(iframe);</script><script>window.parent['$$mm-analytics'] = window.parent['$$mm-analytics'] || {};if (typeof window.parent['$$mm-analytics'].firstEmbed === 'undefined') {window.parent['$$mm-analytics'].firstEmbed = Date.now();}</script><script async type='text/javascript' src="https://bucket1.mm-syringe.com/prod/configs/d87f0a04-0bc7-439f-c110-ea8069626049.js"></script><script async type='text/javascript' src="https://bucket1.mm-syringe.com/prod/injector/injector.1.5.3.js"></script>
</div>

<div class="a-d-468x60-post hidden-md visible-sm visible-xs"><div class="addrop-wrap" data-id="516167"></div></div>
<div class="share-story">
<div class="title-text">Share this story</div>
<ul class="share-social">
<li><a href="#" class="addthis_button_facebook"><i class="fa fa-facebook"></i></a></li>
<li><a href="#" class="addthis_button_twitter"><i class="fa fa-twitter"></i></a></li>
</ul>
</div>
<div class="comment-app">
<div id="disqus_thread"></div>
</div>
</div>
</div>
</div>
<div class="widgets">

<div id="media_image-2" class="widget-odd widget-first widget-1 widget widget_media_image"><a href="https://www.ringtv.com/current-issue/"><img width="300" height="300" src="https://www.ringtv.com/wp-content/uploads/2021/03/WIDGET-MONTHLY-MAY21.png" class="image wp-image-618943  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://www.ringtv.com/wp-content/uploads/2021/03/WIDGET-MONTHLY-MAY21.png 300w, https://www.ringtv.com/wp-content/uploads/2021/03/WIDGET-MONTHLY-MAY21-150x150.png 150w, https://www.ringtv.com/wp-content/uploads/2021/03/WIDGET-MONTHLY-MAY21-80x80.png 80w, https://www.ringtv.com/wp-content/uploads/2021/03/WIDGET-MONTHLY-MAY21-270x270.png 270w, https://www.ringtv.com/wp-content/uploads/2021/03/WIDGET-MONTHLY-MAY21-45x45.png 45w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><div id="ad_dropper_widget-3" class="widget-even widget-2 widget widget_ad_dropper_widget"><div class="addrop-wrap" data-id="516020">
<div id="insticator-container">
<div id="div-insticator-ad-1" style="height:280px"></div>
<div id="insticator-embed"></div>
<div id="div-insticator-ad-2" style="height:280px"></div>
<script data-cfasync='false' type="text/javascript">/*<![CDATA[*/Insticator.ad.loadAd("div-insticator-ad-1");Insticator.ad.loadAd("div-insticator-ad-2");Insticator.load("em",{id : "57efe63a-5598-4f49-989d-174127a70538"})/*]]>*/</script>
</div>
</div></div><div id="ad_dropper_widget-4" class="widget-odd widget-3 widget widget_ad_dropper_widget"><div class="addrop-wrap" data-id="564589"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:300px;height:250px" data-ad-client="ca-pub-3782114432787829" data-ad-slot="5845690645"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></div><div id="sidebar_ratings_widget-2" class="widget-even widget-4 widget Sidebar_Ratings_Widget widget-ratings">
<h4 class="widget-title">Ratings | <a href="https://www.ringtv.com/ratings/">View All</a></h4>
<p>Top 6 Pound for Pound</p>
<div class="small-ratings">
<div class="item">
<img src="https://www.ringtv.com/wp-content/uploads/2016/07/Canelo-Alvarez_Ring-Belts_ratings-crop_Hoganphotos6-270x270.jpg" alt="Canelo Alvarez" />
<span>1</span>
</div>
<div class="item">
<img src="https://www.ringtv.com/wp-content/uploads/2016/07/Naoya-Inoue-with-Ring-title_Ratings-crop_Fukuda-270x270.jpg" alt="Naoya Inoue" />
<span>2</span>
</div>
<div class="item">
<img src="https://www.ringtv.com/wp-content/uploads/2016/07/Terence-Crawford_undisptued-champ_Rankings-crop-270x270.jpg" alt="Terence Crawford" />
<span>3</span>
</div>
<div class="item">
<img src="https://www.ringtv.com/wp-content/uploads/2016/07/Aleksandr-Usyk-with-all-the-belts_Rankings-crop-270x270.jpg" alt="Aleksandr Usyk" />
<span>4</span>
</div>
<div class="item">
<img src="https://www.ringtv.com/wp-content/uploads/2016/07/errol-spence-ratings-270x270.jpg" alt="Errol Spence Jr." />
<span>5</span>
</div>
<div class="item">
<img src="https://www.ringtv.com/wp-content/uploads/2019/02/Teofimo-Lopez-with-Ring-title_Rankings-crop-270x270.jpg" alt="Teofimo Lopez" />
<span>6</span>
</div>
</div>
</div><div id="callouts-3" class="widget-odd widget-5 widget widget_callouts widget-trending">
<h4 class="widget-title">Trending</h4>
<div class="listing">
<a href="https://www.ringtv.com/620408-ivan-redkach-atlanta-will-always-remember-me-after-i-beat-regis-prograis/" class="item">
 <span class="image">
<img src="https://www.ringtv.com/wp-content/uploads/2021/04/Screen-Shot-2021-04-15-at-2.09.12-PM-80x80.png" alt="Ivan Redkach: Atlanta will always remember me after I beat Regis Prograis" />
</span>
Ivan Redkach: Atlanta will always remember me after I beat Regis Prograis </a>
<a href="https://www.ringtv.com/620394-peter-kahn-is-turning-into-boxings-newest-mogul/" class="item">
<span class="image">
<img src="https://www.ringtv.com/wp-content/uploads/2021/04/Peter-Kahn-in-front-of-Triller-sign-80x80.jpg" alt="Peter Kahn is turning into boxing’s newest mogul" />
</span>
Peter Kahn is turning into boxing’s newest mogul </a>
<a href="https://www.ringtv.com/620386-common-opponent-alantez-fox-analyzes-demetrius-andrade-liam-williams/" class="item">
<span class="image">
<img src="https://www.ringtv.com/wp-content/uploads/2017/10/Andrade-Fox_@HBOboxing-80x80.jpg" alt="Common opponent Alantez Fox analyzes Demetrius Andrade-Liam Williams" />
</span>
Common opponent Alantez Fox analyzes Demetrius Andrade-Liam Williams </a>
<a href="https://www.ringtv.com/620358-jaime-munguia-dmitrius-ballard-fight-postponed-after-ballard-suffers-injury/" class="item">
<span class="image">
<img src="https://www.ringtv.com/wp-content/uploads/2020/11/Munguia-vs.-Johnson-80x80.jpg" alt="Jaime Munguia-D’mitrius Ballard fight postponed after Ballard suffers injury" />
</span>
Jaime Munguia-D’mitrius Ballard fight postponed after Ballard suffers injury </a>
<a href="https://www.ringtv.com/620343-anthony-yarde-returns-to-action-on-april-24-targets-lyndon-arthur-rematch/" class="item">
<span class="image">
<img src="https://www.ringtv.com/wp-content/uploads/2019/08/2134915-44655710-2560-1440-80x80.jpg" alt="Anthony Yarde returns to action on April 24, targets Lyndon Arthur rematch" />
</span>
Anthony Yarde returns to action on April 24, targets Lyndon Arthur rematch </a>
</div>
</div><div id="sidebar_schedule_widget-2" class="widget-even widget-6 widget Sidebar_Schedule_Widget widget-scheds">
<h4 class="widget-title">Schedule | <a href="https://www.ringtv.com/schedule/">View All</a></h4>
<div class="list-streams">
<a href="https://www.ringtv.com/upcoming-livestreams/schedule/" class="item">
<span class="date"><span class="d">17</span><span class="m">Apr</span></span>
Demetrius Andrade vs. Liam Williams (DAZN) </a>
<a href="https://www.ringtv.com/upcoming-livestreams/schedule/" class="item">
<span class="date"><span class="d">23</span><span class="m">Apr</span></span>
Jaime Munguia vs. D'Mitrius Ballard (DAZN) </a>
<a href="https://www.ringtv.com/upcoming-livestreams/schedule/" class="item">
<span class="date"><span class="d">24</span><span class="m">Apr</span></span>
Emanuel Navarrete vs. Christopher Diaz (DAZN) </a>
</div>
</div><div id="sidebar_instagram_widget-2" class="widget-odd widget-7 widget Sidebar_Instagram_Widget widget-instagram"> <h4 class="widget-title">Instagram <i class="icon-instagram-1"></i></h4>
<div id="insta-feed"></div>
</div><div id="sidebar_facebook_widget-2" class="widget-even widget-8 widget Sidebar_Facebook_Widget widget-facebook">
<h4 class="widget-title">Facebook <img src="https://www.ringtv.com/wp-content/themes/thering/images/icon-facebook.png" alt=""></h4>
<div class="fb-page" data-href="https://www.facebook.com/RingTV" data-tabs="timeline" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="false"><blockquote cite="https://www.facebook.com/RingTV" class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/RingTV">RingTV</a></blockquote></div>
</div><div id="sidebar_product_widget-2" class="widget-odd widget-last widget-9 widget Sidebar_Product_Widget widget-product">
<h4 class="widget-title">Official Product</h4>
<div class="feat-product">
<a href="https://www.ringtv.com/products/brown-bomber-t-shirt/">
<img src="https://www.ringtv.com/wp-content/uploads/2016/04/home-product-2.jpg" alt="">
</a>
</div>
<a href="https://ringmagshop.com" class="green-btn">Shop Now!</a>
</div>
</div>  </div>
</div>
<div class="footer-wrap">
<div class="bg-top"></div>
<div class="wrap-inner">
<a class="foot-go-top-btn visible-xs" href="#"></a>
<div class="row">
<div class="col-lg-3 col-md-3 col-sm-6 col-xs-12 hidden-xs">
<div class="foot-logo"><img src="https://www.ringtv.com/wp-content/themes/thering/images/ring-logo.png" alt=""></div>
<div class="foot-small-desc"></div>
<ul class="foot-social">
<li><a href="https://www.facebook.com/RingTV" target="_blank"><i class="fa fa-facebook"></i></a></li> <li><a href="https://www.youtube.com/user/TheRingDigital" target="_blank"><i class="fa fa-youtube"></i></a></li> <li><a href="https://twitter.com/ringmagazine" target="_blank"><i class="fa fa-twitter"></i></a></li> <li><a href="https://instagram.com/ringtv" target="_blank"><i class="fa fa-instagram"></i></a></li> </ul>
</div>
<div class="col-xs-12 hidden-lg hidden-md hidden-sm visible-xs">
<h3>Quicklinks</h3>
<ul id="menu-footer-menu" class="foot-quicklinks"><li id="menu-item-186" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-186"><a href="https://www.ringtv.com/terms-conditions/">Terms &#038; Conditions</a></li>
<li id="menu-item-185" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-185"><a href="https://www.ringtv.com/privacy-policy/">Privacy Policy</a></li>
</ul> </div>
<div class="col-lg-3 col-md-3 col-sm-6 col-xs-12">
<h3>Contact Us</h3>
<div class="contact-info-row">
<span class="icon"><i class="fa fa-home"></i></span>
P.O. Box 90254 <br />
Brooklyn, NY 11209 </div>
<div class="contact-info-row">
<span class="icon"><i class="fa fa-envelope-o"></i></span>
<a class="email" href="/cdn-cgi/l/email-protection#23505653534c515763514a4d4457550d404c4e"><span class="__cf_email__" data-cfemail="c3b0b6b3b3acb1b783b1aaada4b7b5eda0acae">[email&#160;protected]</span></a>
</div>
</div>
<div class="col-lg-3 col-md-3 col-sm-6 col-xs-12 hidden-xs">
<h3>Quicklinks</h3>
<ul id="menu-quicklinks" class="foot-quicklinks"><li id="menu-item-178" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-178"><a href="https://www.ringtv.com/about-us/">About Us/Staff</a></li>
<li id="menu-item-179" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-179"><a href="https://www.ringtv.com/contact-us/">Contact Us/Advertise</a></li>
<li id="menu-item-180" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-180"><a href="https://www.ringtv.com/subscribe/">Subscribe</a></li>
</ul> </div>
<div class="col-lg-3 col-md-3 col-sm-6 col-xs-12 hidden-xs">
<h3>Join Our Newsletter</h3> <div class="foot-newsletter">
<div class="desc">Join our newsletter to get info about latest events and deals!</div>
<div id="mailpoet_form_5" class="mailpoet_form mailpoet_form_shortcode"><style type="text/css">.mailpoet_hp_email_label{display:none;}#mailpoet_form_5 .mailpoet_form {  }
#mailpoet_form_5 .mailpoet_paragraph { line-height: 20px; }
#mailpoet_form_5 .mailpoet_segment_label, #mailpoet_form_5 .mailpoet_text_label, #mailpoet_form_5 .mailpoet_textarea_label, #mailpoet_form_5 .mailpoet_select_label, #mailpoet_form_5 .mailpoet_radio_label, #mailpoet_form_5 .mailpoet_checkbox_label, #mailpoet_form_5 .mailpoet_list_label, #mailpoet_form_5 .mailpoet_date_label { display: block; font-weight: bold; }
#mailpoet_form_5 .mailpoet_text, #mailpoet_form_5 .mailpoet_textarea, #mailpoet_form_5 .mailpoet_select, #mailpoet_form_5 .mailpoet_date_month, #mailpoet_form_5 .mailpoet_date_day, #mailpoet_form_5 .mailpoet_date_year, #mailpoet_form_5 .mailpoet_date { display: block; }
#mailpoet_form_5 .mailpoet_text, #mailpoet_form_5 .mailpoet_textarea { width: 100%; }
#mailpoet_form_5 .mailpoet_checkbox {  }
#mailpoet_form_5 .mailpoet_submit input {  }
#mailpoet_form_5 .mailpoet_divider {  }
#mailpoet_form_5 .mailpoet_message {  }
#mailpoet_form_5 .mailpoet_validate_success { color: #468847; }
#mailpoet_form_5 .mailpoet_validate_error { color: #b94a48; }</style>
<form target="_self" method="post" action="https://www.ringtv.com/wp-admin/admin-post.php?action=mailpoet_subscription_form" class="mailpoet_form mailpoet_form_shortcode" novalidate>
<input type="hidden" name="data[form_id]" value="5" />
<input type="hidden" name="token" value="3c5b0f7156" />
<input type="hidden" name="api_version" value="v1" />
<input type="hidden" name="endpoint" value="subscribers" />
<input type="hidden" name="mailpoet_method" value="subscribe" /><label class="mailpoet_hp_email_label">Please leave this field empty<input type="email" name="data[email]"></label><p class="mailpoet_paragraph"><label class="mailpoet_text_label">Email <span class="mailpoet_required">*</span></label><input type="email" class="mailpoet_text" name="data[form_field_ZW1haWw=]" title="Email" value="" data-automation-id="form_email" data-parsley-required="true" data-parsley-minlength="6" data-parsley-maxlength="150" data-parsley-error-message="Please specify a valid email address." data-parsley-required-message="This field is required." /></p>
<p class="mailpoet_paragraph"><input type="submit" class="mailpoet_submit" value="Subscribe!" /></p>
<div class="mailpoet_message">
<p class="mailpoet_validate_success" style="display:none;">Check your inbox or spam folder to confirm your subscription.
</p>
<p class="mailpoet_validate_error" style="display:none;"> </p>
</div>
</form>
</div> </div>
</div>
<div class="col-xs-12 hidden-lg hidden-md hidden-sm visible-xs">
<ul class="foot-social">
<li><a href="https://www.facebook.com/RingTV" target="_blank"><i class="fa fa-facebook"></i></a></li> <li><a href="https://twitter.com/ringmagazine" target="_blank"><i class="fa fa-twitter"></i></a></li> <li><a href="https://instagram.com/ringtv" target="_blank"><i class="fa fa-instagram"></i></a></li> </ul>
<div class="foot-logo"><img src="https://www.ringtv.com/wp-content/themes/thering/images/ring-logo.png" alt=""></div>
<div class="foot-small-desc">Your destination for the best boxing news, videos and live streams!</div>
</div>
</div>
</div>
</div>
<div class="footer-bottom">
<div class="wrap-inner">
<ul id="menu-footer-menu-1" class="foot-btm-links"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-186"><a href="https://www.ringtv.com/terms-conditions/">Terms &#038; Conditions</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-185"><a href="https://www.ringtv.com/privacy-policy/">Privacy Policy</a></li>
</ul> <div class="copyright">&copy; 2021 RING TV LIVE. All rights reserved. </div>
</div>
</div>
<style></style><link rel='stylesheet' id='mailpoet_public-css' href='https://www.ringtv.com/wp-content/plugins/mailpoet/assets/css/public.cae357df.css?ver=4.9.8' type='text/css' media='all' />
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.ringtv.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"theringonline"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"620386 http:\/\/www.ringtv.com\/?p=620386","disqusShortname":"theringonline","disqusTitle":"Common opponent Alantez Fox analyzes Demetrius Andrade-Liam Williams","disqusUrl":"https:\/\/www.ringtv.com\/620386-common-opponent-alantez-fox-analyzes-demetrius-andrade-liam-williams\/","postId":"620386"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var addrop_script = {"ajaxurl":"https:\/\/www.ringtv.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/ad-dropper/js/script.js?ver=1.3.0'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":1,"isRTL":false});});
</script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/jquery.flexslider.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/jquery.easing.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/jquery.movingboxes.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/instafeed.min.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/jquery.cycle2.min.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/jquery.cycle2.flip.min.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/jquery.mCustomScrollbar.concat.min.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/fitvids.min.js?ver=b6e20697dd771845ae1d1d687cb23cbd'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/owl.carousel.min.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/jquery.lazy.min.js?ver=1.0.1'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/jquery.fancybox.pack.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/js.cookie.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/jquery.matchHeight.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/tweetie.min.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/isOnScreen.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_var = {"url":"https:\/\/www.ringtv.com\/wp-admin\/admin-ajax.php","nonce":"35275bdf6b","template_url":"https:\/\/www.ringtv.com\/wp-content\/themes\/thering"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/global.js?ver=b6e20697dd771845ae1d1d687cb23cbd'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-includes/js/wp-embed.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/mailpoet/assets/js/vendor.848ec4ca.js?ver=3.9.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var MailPoetForm = {"ajax_url":"https:\/\/www.ringtv.com\/wp-admin\/admin-ajax.php","is_rtl":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/mailpoet/assets/js/public.0ac1326d.js?ver=3.9.0'></script>
<script type='text/javascript'>
function initMailpoetTranslation() {
  if(typeof MailPoet !== 'undefined') {
    MailPoet.I18n.add('ajaxFailedErrorMessage', 'An error has happened while performing a request, please try again later.')
  } else {
    setTimeout(initMailpoetTranslation, 250);
  }
}
setTimeout(initMailpoetTranslation, 250);
</script>
<script>
 (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
 (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
 m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
 })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

 ga('create', 'UA-77508658-1', 'auto');
 ga('send', 'pageview');

</script>

<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-5MLLG9"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-5MLLG9');</script>


<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-4ef3d09874f075c2"></script>
<script type="text/javascript">
    
	jQuery(function($){
		
		if( $('#user_login').length ){
			$('#user_login').attr('placeholder','EMAIL ADDRESS');
		}
		
		/*if( $('#leaky-paywall-gift-subscription-plans').length ){
			$('#leaky-paywall-gift-subscription-plans option[value=3]').remove();
		}*/
		
				
                
                
                

        
    
		
	
		

        	
    

				$('select#leaky-paywall-gift-subscription-plans option:not(:nth-child(1))').remove();
					
	});
	
    var j = jQuery.noConflict();
    
	j(window).load(function(){
		
	});
	

    
    
    if( j('.widget-instagram').length ){
        var feed = new Instafeed({
            get: 'user',
            userId: '212360053',
            template: '<a href="{{link}}" class="item" style="background-image:url({{image}})"><img src="https://www.ringtv.com/wp-content/themes/thering/images/blank-feed.gif" /></a>',
            resolution: 'thumbnail',
            accessToken: '212360053.1677ed0.632fb768c9ee4638aad573370c8a61fd',
            limit: 6,
            target: 'insta-feed'
        });
        feed.run();   
    }
   
    
    
</script>
</body>
</html>