<!DOCTYPE html>
<html>
<head>
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta name="generator" content="WordPress 4.9.8" />
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<title>Fight Picks: Canelo Alvarez vs. Sergey Kovalev - The Ring</title>
<script src="/cdn-cgi/apps/head/OyS6iIEAHbQ_LZQHUv76Gu1pruU.js"></script><link rel="apple-touch-icon" sizes="57x57" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-57x57.png">
<link rel="apple-touch-icon" sizes="60x60" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-60x60.png">
<link rel="apple-touch-icon" sizes="72x72" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-72x72.png">
<link rel="apple-touch-icon" sizes="76x76" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-76x76.png">
<link rel="apple-touch-icon" sizes="114x114" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-114x114.png">
<link rel="apple-touch-icon" sizes="120x120" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-120x120.png">
<link rel="apple-touch-icon" sizes="144x144" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-144x144.png">
<link rel="apple-touch-icon" sizes="152x152" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-152x152.png">
<link rel="apple-touch-icon" sizes="180x180" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-180x180.png">
<link rel="icon" type="image/png" sizes="192x192" href="https://www.ringtv.com/wp-content/themes/thering/images/android-icon-192x192.png">
<link rel="icon" type="image/png" sizes="32x32" href="https://www.ringtv.com/wp-content/themes/thering/images/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="96x96" href="https://www.ringtv.com/wp-content/themes/thering/images/favicon-96x96.png">
<link rel="icon" type="image/png" sizes="16x16" href="https://www.ringtv.com/wp-content/themes/thering/images/favicon-16x16.png">
<link rel="manifest" href="https://www.ringtv.com/wp-content/themes/thering/images/manifest.json">
<meta name="msapplication-TileColor" content="#ffffff">
<meta name="msapplication-TileImage" content="https://www.ringtv.com/wp-content/themes/thering/images/ms-icon-144x144.png">
<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="https://www.ringtv.com/feed/" />
<link rel="alternate" type="text/xml" title="RSS .92" href="https://www.ringtv.com/feed/rss/" />
<link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="https://www.ringtv.com/feed/atom/" />
<link rel="pingback" href="https://www.ringtv.com/xmlrpc.php" />

<script data-cfasync='false' type='text/javascript'>/*<![CDATA[*/(function (a, c, s, u){'Insticator'in a || (a.Insticator={ad:{loadAd: function (b){Insticator.ad.q.push(b)}, q: []}, helper:{}, embed:{}, version: "3.0", q: [], load: function (t, o){Insticator.q.push({t: t, o: o})}}); var b=c.createElement(s); b.src=u; b.async=!0; var d=c.getElementsByTagName(s)[0]; d.parentNode.insertBefore(b, d)})(window, document, 'script', '//d2na2p72vtqyok.cloudfront.net/client-embed/5f282198-b6f9-4fbf-9244-cfb0317339b5.js');/*]]>*/</script>

<link href="https://fonts.googleapis.com/css?family=Montserrat:400,500,600,700,800,900" rel="stylesheet">

<link rel="canonical" href="https://www.ringtv.com/581908-fight-picks-canelo-alvarez-vs-sergey-kovalev/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Fight Picks: Canelo Alvarez vs. Sergey Kovalev - The Ring" />
<meta property="og:description" content="On Saturday, Canelo Alvarez will make an audacious leap from middleweight to light heavyweight, where he will take on WBO beltholder Sergey Kovalev at the MGM Grand, Las Vegas on DAZN (6 p.m. PT/9 p.m. ET). Canelo, who is ranked No. 3 on The Ring&#8217;s pound-for-pound list, turned professional as a teenager in 2005. He steadily built his career fighting &hellip;" />
<meta property="og:url" content="https://www.ringtv.com/581908-fight-picks-canelo-alvarez-vs-sergey-kovalev/" />
<meta property="og:site_name" content="The Ring" />
<meta property="article:publisher" content="https://www.facebook.com/RingTV" />
<meta property="article:tag" content="Anson Wainright" />
<meta property="article:tag" content="canelo alvarez" />
<meta property="article:tag" content="Canelo Alvarez Sergey Kovalev" />
<meta property="article:tag" content="sergey kovalev" />
<meta property="article:section" content="Boxing" />
<meta property="article:published_time" content="2019-10-29T05:17:34+00:00" />
<meta property="og:image" content="https://www.ringtv.com/wp-content/uploads/2019/10/canelokovalevlapc-091919hoganphotos2-ftrjpg_101o5f3qqysta1oaw8pbhwms5x-2.jpg" />
<meta property="og:image:secure_url" content="https://www.ringtv.com/wp-content/uploads/2019/10/canelokovalevlapc-091919hoganphotos2-ftrjpg_101o5f3qqysta1oaw8pbhwms5x-2.jpg" />
<meta property="og:image:width" content="1920" />
<meta property="og:image:height" content="1080" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="On Saturday, Canelo Alvarez will make an audacious leap from middleweight to light heavyweight, where he will take on WBO beltholder Sergey Kovalev at the MGM Grand, Las Vegas on DAZN (6 p.m. PT/9 p.m. ET). Canelo, who is ranked No. 3 on The Ring&#8217;s pound-for-pound list, turned professional as a teenager in 2005. He steadily built his career fighting [&hellip;]" />
<meta name="twitter:title" content="Fight Picks: Canelo Alvarez vs. Sergey Kovalev - The Ring" />
<meta name="twitter:site" content="@ringmagazine" />
<meta name="twitter:image" content="https://www.ringtv.com/wp-content/uploads/2019/10/canelokovalevlapc-091919hoganphotos2-ftrjpg_101o5f3qqysta1oaw8pbhwms5x-2.jpg" />
<meta name="twitter:creator" content="@ringmagazine" />
<script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Organization","url":"https:\/\/www.ringtv.com\/","sameAs":["https:\/\/www.facebook.com\/RingTV","https:\/\/www.instagram.com\/ringtv\/","https:\/\/www.youtube.com\/channel\/UC8ybHJltwhtpk0cFKU4G8kQ","https:\/\/twitter.com\/ringmagazine"],"@id":"https:\/\/www.ringtv.com\/#organization","name":"The Ring Magazine","logo":"https:\/\/www.ringtv.com\/wp-content\/uploads\/2016\/09\/RING-logo_black_on_white-w-shadow2.jpg"}</script>

<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Ring &raquo; Fight Picks: Canelo Alvarez vs. Sergey Kovalev Comments Feed" href="https://www.ringtv.com/581908-fight-picks-canelo-alvarez-vs-sergey-kovalev/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.ringtv.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.8"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='contact-form-7-css' href='https://www.ringtv.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.3' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://www.ringtv.com/wp-includes/css/dashicons.min.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='wpp_style-css' href="https://www.ringtv.com/wp-content/plugins/wp-poll/assets/front/css/style.css?ver=4.9.8" type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css' href="https://www.ringtv.com/wp-content/plugins/wp-poll/assets/global/css/font-awesome.css?ver=4.9.8" type='text/css' media='all' />
<link rel='stylesheet' id='access_ads_style-css' href='https://www.ringtv.com/wp-content/plugins/accessads//css/minimal.css?ver=1.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-issuem-flexslider-css' href='https://www.ringtv.com/wp-content/plugins/issuem/css/flexslider.css?ver=2.7.4' type='text/css' media='all' />
<link rel='stylesheet' id='issuem-leaky-paywall-article-countdown-nag-css' href='https://www.ringtv.com/wp-content/plugins/leaky-paywall-article-countdown-nag//css/article-countdown-nag-slim.css?ver=3.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='leaky-paywall-coupons-css-css' href='https://www.ringtv.com/wp-content/plugins/leaky-paywall-coupons//css/leaky-paywall-coupons.css?ver=1.8.2' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-style-css' href='//ajax.googleapis.com/ajax/libs/jqueryui/1.11.2/themes/smoothness/jquery-ui.css?ver=4.9.8' type='text/css' media='all' />
<link rel='stylesheet' id='lp-gift-style-css' href='https://www.ringtv.com/wp-content/plugins/leaky-paywall-gift-subscriptions//css/lp-gift.css?ver=2.6.0' type='text/css' media='all' />
<link rel='stylesheet' id='issuem-leaky-paywall-css' href='https://www.ringtv.com/wp-content/plugins/leaky-paywall//css/issuem-leaky-paywall.css?ver=4.13.1' type='text/css' media='all' />
<link rel='stylesheet' id='unipress-api-css' href='https://www.ringtv.com/wp-content/plugins/unipress-api//css/unipress.css?ver=1.18.2' type='text/css' media='all' />
<link rel='stylesheet' id='leaky-paywall-trials-css' href='https://www.ringtv.com/wp-content/plugins/leaky-paywall-trials//css/style.css?ver=1.5.0' type='text/css' media='all' />
<link rel='stylesheet' id='flexslider-css' href='https://www.ringtv.com/wp-content/themes/thering/css/flexslider.css' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css' href='https://www.ringtv.com/wp-content/themes/thering/css/font-awesome.css' type='text/css' media='all' />
<link rel='stylesheet' id='normalize-css' href='https://www.ringtv.com/wp-content/themes/thering/css/normalize.css' type='text/css' media='all' />
<link rel='stylesheet' id='grid12-css' href='https://www.ringtv.com/wp-content/themes/thering/css/grid12.css' type='text/css' media='all' />
<link rel='stylesheet' id='movingboxes-css' href='https://www.ringtv.com/wp-content/themes/thering/css/movingboxes.css' type='text/css' media='all' />
<link rel='stylesheet' id='customscrollbar-css' href='https://www.ringtv.com/wp-content/themes/thering/css/jquery.mCustomScrollbar.css' type='text/css' media='all' />
<link rel='stylesheet' id='owlcarousel-css' href='https://www.ringtv.com/wp-content/themes/thering/css/owl.carousel.css' type='text/css' media='all' />
<link rel='stylesheet' id='owltheme-css' href='https://www.ringtv.com/wp-content/themes/thering/css/owl.theme.default.css' type='text/css' media='all' />
<link rel='stylesheet' id='fancybox-css' href='https://www.ringtv.com/wp-content/themes/thering/css/jquery.fancybox.css' type='text/css' media='all' />
<link rel='stylesheet' id='stylesheet-css' href='https://www.ringtv.com/wp-content/themes/thering/style.css?ver=1ec709894c22ffa6be395f593801426f' type='text/css' media='all' />
<link rel='stylesheet' id='responsive-css' href='https://www.ringtv.com/wp-content/themes/thering/css/responsive.css?ver=1ec709894c22ffa6be395f593801426f' type='text/css' media='all' />
<link rel='stylesheet' id='app-css-css' href='https://www.ringtv.com/wp-content/themes/thering/css/app.css?ver=1ec709894c22ffa6be395f593801426f' type='text/css' media='all' />
<script type='text/javascript' src='https://www.ringtv.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpp_ajax = {"wpp_ajaxurl":"https:\/\/www.ringtv.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/wp-poll/assets/front/js/scripts.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/issuem/js/jquery.flexslider-min.js?ver=2.7.4'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/leaky-paywall-article-countdown-nag//js/article-countdown-nag.js?ver=3.1.0'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/leaky-paywall-coupons/js/leaky-paywall-coupons.js?ver=1.8.2'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/leaky-paywall-gift-subscriptions//js/lp-gift.js?ver=2.6.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_object = {"ajax_url":"https:\/\/www.ringtv.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/unipress-api//js/unipress.js?ver=1.18.2'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/countdown.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var aamLocal = {"nonce":"6991aaf1e3","ajaxurl":"https:\/\/www.ringtv.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='//www.ringtv.com/wp-content/plugins/advanced-access-manager/media/js/aam-login.js?ver=4.9.8'></script>
<link rel='https://api.w.org/' href='https://www.ringtv.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.ringtv.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.ringtv.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 4.9.8" />
<link rel='shortlink' href='https://www.ringtv.com/?p=581908' />
<link rel="alternate" type="application/json+oembed" href="https://www.ringtv.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ringtv.com%2F581908-fight-picks-canelo-alvarez-vs-sergey-kovalev%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.ringtv.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ringtv.com%2F581908-fight-picks-canelo-alvarez-vs-sergey-kovalev%2F&#038;format=xml" />

<script>
!function(f,b,e,v,n,t,s)
{if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};
if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];
s.parentNode.insertBefore(t,s)}(window,document,'script',
'https://connect.facebook.net/en_US/fbevents.js');
 fbq('init', '161022561146884'); 
fbq('track', 'PageView');
</script>
<noscript>
 <img height="1" width="1" 
src="https://www.facebook.com/tr?id=161022561146884&ev=PageView&noscript=1"/>
</noscript>


<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
	(adsbygoogle = window.adsbygoogle || []).push({
		google_ad_client: "ca-pub-3782114432787829",
		enable_page_level_ads: true
	});
</script>

</head>
<body class="post-template-default single single-post postid-581908 single-format-standard loading fight-picks-canelo-alvarez-vs-sergey-kovalev unknown" <div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.10&appId=128026463954740";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
<div id="mobile-nav">
<a href="#" class="btn-close-mob"></a>
<div class="mob-logo"><img src="https://www.ringtv.com/wp-content/themes/thering/images/ring-logo.png" alt=""></div>
<ul id="menu-main-menu" class="mob-nav"><li id="menu-item-152" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-152"><a href="https://www.ringtv.com/news/">News</a></li>
<li id="menu-item-158" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-158"><a href="https://www.ringtv.com/videos/">Media</a></li>
<li id="menu-item-572626" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-572626"><a href="https://www.ringtv.com/video-category/ring-report/">Ring Report</a></li>
<li id="menu-item-516022" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-516022"><a href="https://www.ringtv.com/category/podcasts/">Podcasts</a></li>
<li id="menu-item-155" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-155"><a href="https://www.ringtv.com/ratings/">Ratings</a></li>
<li id="menu-item-156" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156"><a href="https://www.ringtv.com/upcoming-livestreams/schedule/">Schedule</a></li>
<li id="menu-item-249" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-249"><a target="_blank" href="https://esolutionsmnec.ecenergy.com/eCatalog/Account/AnonymousLogon/38?customerName=RING">Shop</a></li>
<li id="menu-item-494633" class="hlogin-btn menu-item menu-item-type-post_type menu-item-object-page menu-item-494633"><a href="https://www.ringtv.com/subscription-login/">Login</a></li>
<li id="menu-item-531167" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-531167"><a href="https://www.ringtv.com/subscribe/">Subscribe</a></li>
</ul> <ul class="mobile-nav-social">
<li><a href="https://www.ringtv.com/search"><i class="fa fa-search"></i></a></li>
<li><a href="https://www.facebook.com/RingTV" target="_blank"><i class="fa fa-facebook"></i></a></li> <li><a href="https://www.youtube.com/user/TheRingDigital" target="_blank"><i class="fa fa-youtube"></i></a></li> <li><a href="https://twitter.com/ringmagazine" target="_blank"><i class="fa fa-twitter"></i></a></li> <li><a href="https://instagram.com/ringtv" target="_blank"><i class="fa fa-instagram"></i></a></li> </ul>
</div>
<div id="top_bar">
<div class="content-wrap">
<div class="left">
<div class="date">Tuesday, October 29, 2019&nbsp; |</div>
<div class="follow">
<span class="label">Follow Us:</span>
<a href="https://www.facebook.com/RingTV" target="_blank"><i class="icon-facebook"></i></a> <a href="https://www.youtube.com/user/TheRingDigital" target="_blank"><i class="icon-youtube-play"></i></a> <a href="https://twitter.com/ringmagazine" target="_blank"><i class="icon-twitter"></i></a> <a href="https://instagram.com/ringtv" target="_blank"><i class="icon-instagram-1"></i></a> </div>
<div class="media-kit"><a href="https://www.ringtv.com/subscribe/" style="text-decoration: none; border-bottom: solid 1px #9c9c9c;">Subscribe</a></div>
<div class="search-bit">
<form id="searchform" method="get" action="https://www.ringtv.com/">
<input type="text" name="s" id="s" size="15" placeholder="Search RingTV..." />
<span><i class="icon-search"></i></span>
</form>
</div>
</div>
<div class="right">
<div class="cycle-slideshow" data-cycle-slides="> div.item" data-cycle-fx="flipVert" data-cycle-pause-on-hover="true" data-cycle-timeout="4500" data-cycle-speed="500">
<div class="item"><a href="https://www.ringtv.com/canelo-vs-kovalev/" class="button-ppv"><span>CANELO VS KOVALEV HUB!</span></a></div>
<div class="item"><a href="https://www.ringtv.com/subscription/" class="button-ppv"><span>1 WEEK FREE DIGITAL TRIAL</span></a></div>
</div>
</div>
</div>
</div>
<div id="masthead">
<div class="content-wrap">
<a href="https://www.ringtv.com" class="logo" title="Ring TV">Ring TV</a>
<ul id="menu-main-menu-1" class="main-nav desktop"><li class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-152"><a href="https://www.ringtv.com/news/">News</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-158"><a href="https://www.ringtv.com/videos/">Media</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-572626"><a href="https://www.ringtv.com/video-category/ring-report/">Ring Report</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-516022"><a href="https://www.ringtv.com/category/podcasts/">Podcasts</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-155"><a href="https://www.ringtv.com/ratings/">Ratings</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156"><a href="https://www.ringtv.com/upcoming-livestreams/schedule/">Schedule</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-249"><a target="_blank" href="https://esolutionsmnec.ecenergy.com/eCatalog/Account/AnonymousLogon/38?customerName=RING">Shop</a></li>
<li class="hlogin-btn menu-item menu-item-type-post_type menu-item-object-page menu-item-494633"><a href="https://www.ringtv.com/subscription-login/">Login</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-531167"><a href="https://www.ringtv.com/subscribe/">Subscribe</a></li>
</ul> <a href="#" class="toggle-menu">
<span></span>
<span></span>
<span></span>
</a>
</div>
<div class="mobile-menu">
<ul id="menu-main-menu-2" class="main-nav-mobile"><li class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-152"><a href="https://www.ringtv.com/news/">News</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-158"><a href="https://www.ringtv.com/videos/">Media</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-572626"><a href="https://www.ringtv.com/video-category/ring-report/">Ring Report</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-516022"><a href="https://www.ringtv.com/category/podcasts/">Podcasts</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-155"><a href="https://www.ringtv.com/ratings/">Ratings</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156"><a href="https://www.ringtv.com/upcoming-livestreams/schedule/">Schedule</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-249"><a target="_blank" href="https://esolutionsmnec.ecenergy.com/eCatalog/Account/AnonymousLogon/38?customerName=RING">Shop</a></li>
<li class="hlogin-btn menu-item menu-item-type-post_type menu-item-object-page menu-item-494633"><a href="https://www.ringtv.com/subscription-login/">Login</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-531167"><a href="https://www.ringtv.com/subscribe/">Subscribe</a></li>
</ul>
</div>
</div>
<div class="sub-header">
<div class="content-wrap">
<h1>News</h1>
<div class="ads728-90"><div class="addrop-wrap" data-id="499853"><center><div id="div-insticator-ad-3"></div>
<script data-cfasync='false' type="text/javascript">
/*<![CDATA[*/Insticator.ad.loadAd("div-insticator-ad-3");/*]]>*/
</script>
</center></div></div>
</div>
</div>
<div id="content">
<div class="content-wrap">
<div class="list-main">
<div class="news-content">
<div class="full-post">
<h1>Fight Picks: Canelo Alvarez vs. Sergey Kovalev</h1>
<div class="imagebox"><img src="https://www.ringtv.com/wp-content/uploads/2019/10/canelokovalevlapc-091919hoganphotos2-ftrjpg_101o5f3qqysta1oaw8pbhwms5x-2-770x433.jpg" alt=""></div>
<div class="a-d-468x60-post hidden-md visible-sm visible-xs"><div class="addrop-wrap" data-id="516167"><a href="https://bit.ly/fightersnetwork" target="_blank"><img src="https://www.ringtv.com/wp-content/uploads/2017/09/468x60-Fighters-Network.jpg" alt="" width="468" height="60" class="alignnone size-full wp-image-516168" /></a></div></div>
<div class="text-wrap">
<div class="date-col">
<div class="day">29</div>
<div class="month">Oct</div>
</div>
<div class="a-d-468x60-post hidden-sm hidden-xs"><div class="addrop-wrap" data-id="516167"><a href="https://bit.ly/fightersnetwork" target="_blank"><img src="https://www.ringtv.com/wp-content/uploads/2017/09/468x60-Fighters-Network.jpg" alt="" width="468" height="60" class="alignnone size-full wp-image-516168" /></a></div></div>
<div class="posted-by"><a href="https://www.ringtv.com/author/anson-wainwright/">by Anson Wainwright</a></div>
<p>On Saturday, Canelo Alvarez will make an audacious leap from middleweight to light heavyweight, where he will take on WBO beltholder Sergey Kovalev at the MGM Grand, Las Vegas on DAZN (6 p.m. PT/9 p.m. ET).</p>
<p>Canelo, who is ranked No. 3 on The Ring&#8217;s pound-for-pound list, turned professional as a teenager in 2005. He steadily built his career fighting as a local attraction in different locations around Mexico against imported fighters while learning his trade. Since then, Canelo has unified world titles at junior middleweight and middleweight. The 28-year-old boxer-puncher has defeated Shane Mosley (UD 12), Austin Trout (UD 12), Erislandy Lara (SD 12), Miguel Cotto (UD 12), Gennadiy Golovkin (MD 12) and Danny Jacobs (UD 12) en route to becoming the biggest star in boxing. [Editor&#8217;s Note: The Ring doesn&#8217;t recognize the WBA &#8220;Regular&#8221; super middleweight title. Instead The Ring recognizes Callum Smith who is the &#8220;Super&#8221; champion.]</p>
<p>Kovalev, who is rated No. 2 by The Ring at 175-pounds, turned professional in 2009. The Russian&#8217;s career took off in 2013 when he won the WBO 175-pound title, bludgeoning Nathan Cleverly into defeat in four rounds. Although he wanted to face Adonis Stevenson, the fight wasn&#8217;t made and he had to wait until the following year, when he bested the ageless Bernard Hopkins to add the IBF and WBA titles to his growing collection. &#8220;Krusher&#8221; lost his titles in controversial fashion against Andre Ward in the fall of 2016. He lost the rematch, but was able to regain the vacant WBO belt after Ward retired. He has since lost and regained it against Eleider Alvarez.</p>
<p>How will Canelo (52-1-2, 35 knockouts) deal with the size and strength of a legitimate light heavyweight? Will Kovalev (34-3-1, 29 KOs) be able impose his jab and keep the naturally quicker Mexican honest and hold up under his body attack?</p>
<p>Online gambling group William Hill lists Canelo as a 2/9 (-450) favorite, while Kovalev is priced at 3/1 (+300); the draw is 25/1 (+2500).</p>
<p>Here&#8217;s how the experts see it:</p>
<p><strong>THE RING MAGAZINE/RINGTV.COM</strong></p>
<p><strong>TOM GRAY: CANELO UD </strong></p>
<p>I believe that Kovalev and trainer Buddy McGirt will formulate a game plan that will trouble Canelo. The Russian titleholder has huge advantages in weight, strength, height and reach, which I suspect will lead to jab-and-grab type tactics. Team Canelo will be expecting that, however, and I see the Mexican star utilizing his counterpunching ability to score well with eye-catching power shots from the outside. If Kovalev is being punished for using the jab, then he may stop using it as much as he needs to. Also, when Kovalev attempts to clinch, I think Canelo will free his hands to score well on the inside. Canelo will likely edge this fight, but it will be a lot closer than many people are expecting.</p>
<p><strong>MICHAEL WOODS: CANELO MD</strong></p>
<p>Mikey Garcia thought he saw something. We saw how that turned out for him, when Errol Spence gave him the business. The Canelo vs. Kovalev fight will not play out in close to the same fashion. You will see even rounds, tight rounds &#8230; but Canelo is so savvy. I trust his judgement, I trust that he knows, from casing Kovalev, that he will be able to box his way, cautiously, to a decision win. Canelo, by MD.</p>
<p><strong>MARTY MULCAHEY: CANELO UD</strong></p>
<p>A very good match-up of styles, and importantly there were no pre-conditions for this fight as has been the case with previous Saul “Canelo” Alvarez fights. I have more concerns about how Canelo’s hand-speed and frame reacts to the added weight than I do about Kovalev. I have always appreciated Kovalev (I believe he defeated Andre Ward in first bout). But like others have witnessed an appreciable decline in form in the last three years. That is why I am picking Alvarez, who will attack the body early and reap the benefits late for a unanimous decision victory. The size difference does give me some apprehension; but Alvarez showed against Golovkin and Jacobs that he can absorb punishment and big punches with his chin or defuse it with his feet. Kovalev wins some of the middle rounds in an admirable fightback, but loses the opening two and final four emphatically.</p>
<p><strong>ANSON WAINWRIGHT: CANELO UD</strong></p>
<p>Really intriguing fight. This is a sizeable jump in weight for Canelo against a career light heavyweight. Kovalev is no Rocky Fielding and Canelo will have to be careful. It&#8217;s a gamble for Canelo and Golden Boy. However, it looks like a calculated one. Kovalev is now 36 and starting to creek. Kovalev is no longer the fighter he once was, but to his credit he has morphed into more of a boxer than earlier in his career. It will still take an exceptional fighter to beat him, but he&#8217;s on the edge of the cliff and Canelo will pick and prod his openings early while being cautious of the Russian&#8217;s jab and thumping power. Canelo will step it up in the later rounds and work his way toward a unanimous decision.</p>
<p><strong>NORM FRAUENHEIM: CANELO UD</strong></p>
<p>Sergey Kovalev&#8217;s resilience in an ongoing comeback gets a defining test against a Canelo who only gets better. Kovalev has advantages, both obvious and intangible. His jab is a thing of beauty, a mix of power and precision. He appears to have the renewed confidence of a man who has encountered adversity and learned from it. Kovalev is also taller. But the light heavyweight is not necessarily bigger than the middleweight, which is a key difference. Canelo&#8217;s heavily-muscled upper torso on top of heavy legs is a well-balanced force hard to shake and harder to stop. It also provides Canelo with all of the leverage he’ll need to deliver punishing body blows. He’s smart enough to be cautious, and he will be throughout 12 rounds for a points victory on all three cards.</p>
<p><strong>MICHAEL MONTERO: CANELO PTS</strong></p>
<p>A handful of old boxing adages come to mind &#8230; &#8220;A good big man always beats a good little man,&#8221; &#8220;Styles make fights,&#8221; &#8220;Kill the body and the head will fall,&#8221; and lastly, &#8220;Speed kills.&#8221; When it comes to Canelo-Kovalev, all of the above come into play. Canelo has never stopped an elite opponent north of junior middleweight, yet his exceptional head movement and underrated defense figure to give Kovalev fits as he attempts to keep distance with his jab. All of that points to a distance fight in Las Vegas, which leads us to another old adage. The Russian will have to win nine rounds to get the draw. Look for Canelo to win by decision in a fight that is closer and more competitive than many expect.</p>
<p><strong>BOXING INSIDERS</strong></p>
<p><strong>REGGIE JOHNSON (FORMER TWO-DIVISION WORLD CHAMPION): CANELO KO</strong></p>
<p>This fight is a tough one to call with Canelo moving up two weight classes from 160 to 175-pounds. In 1998, that same opportunity was presented to me and I jumped on that grand opportunity and knocked out William Guthrie and won my second world title. I feel this is a fight Canelo will win, but it will be more difficult for him. I like Canelo and his awesome body shots in this fight. Canelo by late-round body shots KO.</p>
<p><strong>MIKE ALTAMURA (MANAGER): CANELO TKO 8</strong></p>
<p>I see some shaky spots early for Canelo, especially with closing the distance as Kovalev fires straight arrows. Eventually he gets his range and systematically breaks down Kovalev to the body for a mid-to-late stoppage.</p>
<p><strong>DUKE MCKENZIE (FORMER THREE-WEIGHT WORLD TITLEHOLDER/TV ANALYST): CANELO UD</strong></p>
<p>Canelo vs. Kovalev is a fascinating match up, because when a boxer moves up in weight it’s normally the lighter weight divisions. Canelo is moving up not one, but two weight divisions. Canelo undoubtedly is looking for legendary status. With one solitary loss to Floyd &#8220;Money&#8221; Mayweather, Canelo has bossed everyone he has fought and looked good doing so. Kovalev is a proud champion and served the light heavyweight division for many years and looks ready to go. Kovalev is tired and shopworn he can no longer pull the trigger to close the show. Canelo is too smart. He wins this fight via a unanimous decision to gain legendary status.</p>
<p><strong>CAMILLE ESTEPHAN (PROMOTER, EYE OF THE TIGER): CANELO TKO</strong></p>
<p>A very risky fight for both. Canelo has to deal with a giant compared to him, yet he will probably chop him down like a tree. I think Canelo stops him late.</p>
<p><strong>OSWALDO KULCHE (PROMOTER, PROMOCIONES DEL PUEBLO): CANELO TKO 11</strong></p>
<p>I think Kovalev will be too slow for Canelo, who will outbox Kovalev with speed and the stop him in the late rounds. If Kovalev connects, it could be an exciting match.</p>
<p><strong>CARL MORETTI (VICE PRESIDENT OF TOP RANK): CANELO TKO 11 </strong></p>
<p>There&#8217;s an old song, &#8220;If I could turn back the hands of time.&#8221; Well, for Kovalev, I don&#8217;t think he can. [Buddy] McGirt will have him ready with a great game plan but Canelo is in his prime and it just won&#8217;t be enough. Then again, I think the Cowboys will win the Super Bowl.</p>
<p><strong>ERIC BOTTJER (MATCHMAKER, MATCHROOM): CANELO TKO 9</strong></p>
<p>I think Kovalev should try and make it a street fight at the beginning. Whether he does or not, Canelo will avoid serious trouble and take over after five rounds. The end will come from an accumulation of punches. I think Canelo by stoppage in nine rounds.</p>
<p><strong>CAMERON DUNKIN (PROMOTER, NOW BOXING PROMOTIONS): KOVALEV PTS</strong></p>
<p>Kovalev has a great jab. GGG landed so many jabs on Canelo and he&#8217;s so much bigger than Canelo. But with that said, Canelo is younger, faster and a great fighter and a great champion, so I could be nuts. I may be wrong, but I liked [Artur] Beterbiev, and everyone said I was wrong, but it went the way I thought, so I&#8217;ll stick with Kovalev by decision.</p>
<p><strong>VADIM KORNILOV (MANAGER): KOVALEV TKO</strong></p>
<p>I believe that if Kovalev will be fully trained and prepared for this fight he can win the fight by stoppage. If he&#8217;s not fully prepared, Canelo can stop him with body shots.</p>
<p><strong>STEPHEN EDWARDS (TRAINER): CANELO TKO</strong></p>
<p>I like Canelo by stoppage. I think Kovalev&#8217;s jab will be tough early. But Kovalev doesn&#8217;t have a mid-range game or inside game. At some point, Canelo gets in that range like Ray Leonard did against Donnie Lalonde and he stops Kovalev in a great fight.</p>
<p><strong>JOHN SCULLY (TRAINER): CANELO UD</strong></p>
<p>I was originally picking Kovalev and convincingly at that, but as I think about it the more, I think that Canelo is going to utilize his great head movement and counterpunching ability and come away with a surprising 12-round unanimous decision. As long as he stays off the ropes and out of the corners, I think he is going to be too shifty for Sergey.</p>
<p><strong>WAYNE MCULLOUGH (FORMER WORLD CHAMPION/TRAINER): CANELO KO 9</strong></p>
<p>I think most people think it&#8217;s going to be hard for the smaller Canelo. But I think he will be too slick and counterpunch Kovalev pretty easily. Kovalev needs room to let his right hands go behind his jabs, but I think they will be too slow and Canelo will get close and land heavy punches to the head then body and force a stoppage win around the ninth.</p>
<p><strong>MARIO ABRAHAM: (MANAGER): CANELO UD</strong></p>
<p>I think Canelo wins a unanimous decision. Kovalev is too slow for Canelo. Canelo could get the KO with body shots, but I like him by unanimous decision.</p>
<p><strong>KALLE SAUERLAND (PROMOTER, SAUERLAND EVENT): CANELO TKO</strong></p>
<p>I think it&#8217;s a real test for Canelo bearing in mind the divisions he&#8217;s skipped over. Kovalev certainly still packs a punch, but we&#8217;ve all seen the weakness to the body and I expect Canelo to go hard to the body and win by stoppage.</p>
<p><strong>FINAL TALLY</strong></p>
<p>18-2 in favor of Canelo</p>
<p><strong><em>Questions and/or comments can be sent to Anson at <u><a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="d9bcb5abb8b0b7bab6b8ad99b5b0afbcf7bab6f7acb2">[email&#160;protected]</a></u></em></strong><em> <strong>and you can follow him on </strong></em><strong><em>Twitter <a href="https://twitter.com/AnsonWainwright">@AnsonWainwright</a></em></strong></p>
<p>&nbsp;</p>
<div class="addrop-wrap" data-id="562302">&nbsp;
<p style="text-align: center;"><strong>Struggling to locate a copy of The Ring Magazine? Try <a href="http://magfinder.magnetdata.net/"><span style="color: #ff0000;">here</span></a> or</strong>
<a href="https://www.ringtv.com/subscribe"><span style="color: #ff0000;"><strong>Subscribe</strong></span></a></p>
<img class="wp-image-579634 size-full aligncenter" src="https://www.ringtv.com/wp-content/uploads/2019/05/nov2019cover-sml.jpg" alt="" width="310" height="430" />
<p style="text-align: center;"><strong>You can order the current issue, which is on newsstands, or back issues from our subscribe page.</strong></p></div>
<div class="clearboth"></div>
<div class="a-d-468x60-post hidden-sm hidden-xs"><div class="addrop-wrap" data-id="581384"><a href="https://bit.ly/32EinQe" target="_blank" rel="noopener"><img class="size-full wp-image-581379 aligncenter" src="https://www.ringtv.com/wp-content/uploads/2019/10/468x60.jpg" alt="" width="468" height="60" /></a></div></div>
</div>
<div class="a-d-468x60-post hidden-md visible-sm visible-xs"><div class="addrop-wrap" data-id="581384"><a href="https://bit.ly/32EinQe" target="_blank" rel="noopener"><img class="size-full wp-image-581379 aligncenter" src="https://www.ringtv.com/wp-content/uploads/2019/10/468x60.jpg" alt="" width="468" height="60" /></a></div></div>
<div class="share-story">
<div class="title-text">Share this story</div>
<ul class="share-social">
<li><a href="#" class="addthis_button_facebook"><i class="fa fa-facebook"></i></a></li>
<li><a href="#" class="addthis_button_twitter"><i class="fa fa-twitter"></i></a></li>
</ul>
</div>
<div class="comment-app">
<div id="disqus_thread"></div>
</div>
</div>
</div>
</div>
<div class="widgets">

<div id="ad_dropper_widget-5" class="widget-odd widget-first widget-1 widget widget_ad_dropper_widget"><div class="addrop-wrap" data-id="516020">
<div id="insticator-container">
<div id="div-insticator-ad-1"></div>
<div id="insticator-embed"></div>
<div id="div-insticator-ad-2"></div>
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script data-cfasync='false' type="text/javascript">/*<![CDATA[*/Insticator.ad.loadAd("div-insticator-ad-1");Insticator.ad.loadAd("div-insticator-ad-2");Insticator.load("em",{id : "57efe63a-5598-4f49-989d-174127a70538"})/*]]>*/</script>
</div>
</div></div><div id="custom_html-2" class="widget_text widget-even widget-2 widget widget_custom_html"><div class="textwidget custom-html-widget"><div id="fightnight-widget-container"></div><script src="https://widget.goldenboypromotions.com/fightnight/static/src/js/widget.js"></script></div></div><div id="media_image-2" class="widget-odd widget-3 widget widget_media_image"><a href="https://www.ringtv.com/current-issue/"><img width="300" height="300" src="https://www.ringtv.com/wp-content/uploads/2019/09/widget-sept-2019.png" class="image wp-image-577700  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://www.ringtv.com/wp-content/uploads/2019/09/widget-sept-2019.png 300w, https://www.ringtv.com/wp-content/uploads/2019/09/widget-sept-2019-150x150.png 150w, https://www.ringtv.com/wp-content/uploads/2019/09/widget-sept-2019-80x80.png 80w, https://www.ringtv.com/wp-content/uploads/2019/09/widget-sept-2019-270x270.png 270w, https://www.ringtv.com/wp-content/uploads/2019/09/widget-sept-2019-45x45.png 45w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><div id="media_image-3" class="widget-even widget-4 widget widget_media_image"><a href="https://www.ringtv.com/video-category/ring-report/"><img width="300" height="250" src="https://www.ringtv.com/wp-content/uploads/2019/07/RingReportAd-300x250.png" class="image wp-image-572508  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" srcset="https://www.ringtv.com/wp-content/uploads/2019/07/RingReportAd.png 300w, https://www.ringtv.com/wp-content/uploads/2019/07/RingReportAd-150x125.png 150w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><div id="sidebar_ratings_widget-2" class="widget-odd widget-5 widget Sidebar_Ratings_Widget widget-ratings">
<h4 class="widget-title">Ratings | <a href="https://www.ringtv.com/ratings/">View All</a></h4>
<p>Top 6 Bantamweight</p>
<div class="small-ratings">
<div class="item champ">
<img src="https://www.ringtv.com/wp-content/uploads/2016/11/Naoya-Inoue-ratings-270x270.jpg" alt="Naoya Inoue" />
<span>C</span>
</div>
<div class="item">
<img src="https://www.ringtv.com/wp-content/uploads/2016/09/Luis-Nery-zanfer-270x270.jpg" alt="Luis Nery" />
<span>1</span>
</div>

<div class="item">
<img src="https://www.ringtv.com/wp-content/uploads/2015/03/Zolani-Tete-post-Butler-cropped-alex-livesey-getty-270x270.jpg" alt="Zolani Tete" />
<span>2</span>
</div>
<div class="item">
<img src="https://www.ringtv.com/wp-content/uploads/2016/08/nonito-donaire-ratings-farina-270x270.jpg" alt="Nonito Donaire" />
<span>3</span>
</div>
<div class="item">
<img src="https://www.ringtv.com/wp-content/uploads/2017/09/Nordine-Oubaali-ratings-270x270.jpg" alt="Nordine Oubaali" />
<span>4</span>
</div>
<div class="item">
<img src="https://www.ringtv.com/wp-content/uploads/2017/04/emmanuel-rodriguez_ratings-270x270.jpg" alt="Emmanuel Rodriguez" />
<span>5</span>
</div>
</div>
</div><div id="callouts-3" class="widget-even widget-6 widget widget_callouts widget-trending">
<h4 class="widget-title">Trending</h4>
<div class="listing">
<a href="https://www.ringtv.com/581908-fight-picks-canelo-alvarez-vs-sergey-kovalev/" class="item">
<span class="image">
<img src="https://www.ringtv.com/wp-content/uploads/2019/10/canelokovalevlapc-091919hoganphotos2-ftrjpg_101o5f3qqysta1oaw8pbhwms5x-2-80x80.jpg" alt="Fight Picks: Canelo Alvarez vs. Sergey Kovalev" />
</span>
Fight Picks: Canelo Alvarez vs. Sergey Kovalev </a>
<a href="https://www.ringtv.com/581890-miguel-berchelt-versus-jason-sosa-on-november-2/" class="item">
<span class="image">
<img src="https://www.ringtv.com/wp-content/uploads/2017/01/Francisco-Vargas-Miguel-Berchelt_tom-hogan-Hoganphotos-GBP-80x80.jpg" alt="Miguel Berchelt versus Jason Sosa on November 2" />
</span>
Miguel Berchelt versus Jason Sosa on November 2 </a>
<a href="https://www.ringtv.com/581884-dougies-monday-mailbag-taylor-prograis-canelo-kovalev/" class="item">
<span class="image">
<img src="https://www.ringtv.com/wp-content/uploads/2019/10/Taylor-vs-Prograis_Damon-Gonzalez_LatinBox-80x80.jpg" alt="Dougie&#8217;s Monday mailbag (Taylor-Prograis, Canelo-Kovalev)" />
</span>
Dougie&#8217;s Monday mailbag (Taylor-Prograis, Canelo-Kovalev) </a>
<a href="https://www.ringtv.com/581865-serhii-bohachuk-keeps-ko-streak-alive-stops-tyrone-brunson-in-4/" class="item">
<span class="image">
<img src="https://www.ringtv.com/wp-content/uploads/2019/10/DSC_5616-80x80.jpg" alt="Serhii Bohachuk keeps KO streak alive, stops Tyrone Brunson in 4" />
</span>
Serhii Bohachuk keeps KO streak alive, stops Tyrone Brunson in 4 </a>
<a href="https://www.ringtv.com/581850-opinion-josh-taylor-won-but-there-were-no-losers-in-regis-prograis-fight/" class="item">
<span class="image">
<img src="https://www.ringtv.com/wp-content/uploads/2019/10/josh-taylor-regis-prograis-80x80.jpeg" alt="OPINION: Josh Taylor won, but there were no losers in Regis Prograis fight" />
</span>
OPINION: Josh Taylor won, but there were no losers in Regis Prograis fight </a>
</div>
</div><div id="sidebar_schedule_widget-2" class="widget-odd widget-7 widget Sidebar_Schedule_Widget widget-scheds">
<h4 class="widget-title">Schedule | <a href="https://www.ringtv.com/schedule/">View All</a></h4>
<div class="list-streams">
<a href="https://www.ringtv.com/upcoming-livestreams/schedule/" class="item">
<span class="date"><span class="d">24</span><span class="m">Oct</span></span>
Elwin Soto vs. Edward Heno (RingTV, Facebook @GoldenBoyFN) </a>
<a href="https://www.ringtv.com/upcoming-livestreams/schedule/" class="item">
<span class="date"><span class="d">25</span><span class="m">Oct</span></span>
Francesco Patera vs. Domenico Valentino (DAZN) </a>
<a href="https://www.ringtv.com/upcoming-livestreams/schedule/" class="item">
<span class="date"><span class="d">26</span><span class="m">Oct</span></span>
Josh Taylor vs. Regis Prograis (DAZN) </a>
</div>
</div><div id="sidebar_instagram_widget-2" class="widget-even widget-8 widget Sidebar_Instagram_Widget widget-instagram"> <h4 class="widget-title">Instagram <i class="icon-instagram-1"></i></h4>
<div id="insta-feed"></div>
</div><div id="sidebar_facebook_widget-2" class="widget-odd widget-9 widget Sidebar_Facebook_Widget widget-facebook">
<h4 class="widget-title">Facebook <img src="https://www.ringtv.com/wp-content/themes/thering/images/icon-facebook.png" alt=""></h4>
<div class="fb-page" data-href="https://www.facebook.com/RingTV" data-tabs="timeline" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="false"><blockquote cite="https://www.facebook.com/RingTV" class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/RingTV">RingTV</a></blockquote></div>
</div><div id="sidebar_product_widget-2" class="widget-even widget-10 widget Sidebar_Product_Widget widget-product">
<h4 class="widget-title">Official Product</h4>
<div class="feat-product">
<a href="https://www.ringtv.com/products/brown-bomber-t-shirt/">
<img src="https://www.ringtv.com/wp-content/uploads/2016/04/home-product-2.jpg" alt="">
</a>
</div>
<a href="https://esolutionsmnec.ecenergy.com/eCatalog/Account/AnonymousLogon/38?customerName=RING" class="green-btn">Shop Now!</a>
</div><div id="ad_dropper_widget-6" class="widget-odd widget-11 widget widget_ad_dropper_widget"><div class="addrop-wrap" data-id="581382"><a href="https://bit.ly/32EinQe" target="_blank"><img class="size-full wp-image-581377 aligncenter" src="https://www.ringtv.com/wp-content/uploads/2019/10/300x250.jpg" alt="" width="300" height="250" border="0" /></a></div></div><div id="custom_html-3" class="widget_text widget-even widget-last widget-12 widget widget_custom_html"><div class="textwidget custom-html-widget"><div id="minutemedia" style="max-width:350px;height:250px;">
<script>!function(e,t,a,n,g){e[n]=e[n]||[],e[n].push({"gtm.start":(new Date).getTime(),event:"gtm.js"});var m=t.getElementsByTagName(a)[0],r=t.createElement(a);r.async=!0,r.src="https://www.googletagmanager.com/gtm.js?id=GTM-PL4PD49",m.parentNode.insertBefore(r,m)}(window.parent,window.parent.document,"script","dataLayer");</script><script>var iframe=window.parent.document.createElement("iframe");iframe.src="https://www.googletagmanager.com/ns.html?id=GTM-PL4PD49";iframe.height="0";iframe.width="0";iframe.style="display:none;visibility:hidden";window.parent.document.body.appendChild(iframe);</script><script>window.parent['$$mm-analytics'] = window.parent['$$mm-analytics'] || {};if (typeof window.parent['$$mm-analytics'].firstEmbed === 'undefined') {window.parent['$$mm-analytics'].firstEmbed = Date.now();}</script><script async type='text/javascript' src="https://bucket1.mm-syringe.com/prod/configs/ed120ca8-c2e8-b9b6-826e-20416dfe909b.js"></script><script async type='text/javascript' src="https://bucket1.mm-syringe.com/prod/injector/injector.1.5.2.js"></script></div></div></div>
</div>  </div>
</div>
<div class="footer-wrap">
<div class="bg-top"></div>
<div class="wrap-inner">
<a class="foot-go-top-btn visible-xs" href="#"></a>
<div class="row">
<div class="col-lg-3 col-md-3 col-sm-6 col-xs-12 hidden-xs">
<div class="foot-logo"><img src="https://www.ringtv.com/wp-content/themes/thering/images/ring-logo.png" alt=""></div>
<div class="foot-small-desc"></div>
<ul class="foot-social">
<li><a href="https://www.facebook.com/RingTV" target="_blank"><i class="fa fa-facebook"></i></a></li> <li><a href="https://www.youtube.com/user/TheRingDigital" target="_blank"><i class="fa fa-youtube"></i></a></li> <li><a href="https://twitter.com/ringmagazine" target="_blank"><i class="fa fa-twitter"></i></a></li> <li><a href="https://instagram.com/ringtv" target="_blank"><i class="fa fa-instagram"></i></a></li> </ul>
</div>
<div class="col-xs-12 hidden-lg hidden-md hidden-sm visible-xs">
<h3>Quicklinks</h3>
<ul id="menu-footer-menu" class="foot-quicklinks"><li id="menu-item-186" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-186"><a href="https://www.ringtv.com/terms-conditions/">Terms &#038; Conditions</a></li>
<li id="menu-item-185" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-185"><a href="https://www.ringtv.com/privacy-policy/">Privacy Policy</a></li>
</ul> </div>
<div class="col-lg-3 col-md-3 col-sm-6 col-xs-12">
<h3>Contact Us</h3>
<div class="contact-info-row">
<span class="icon"><i class="fa fa-home"></i></span>
P.O. Box 90254 <br />
Brooklyn, NY 11209 </div>
<div class="contact-info-row">
<span class="icon"><i class="fa fa-envelope-o"></i></span>
<a class="email" href="/cdn-cgi/l/email-protection#e1929491918e9395a193888f869597cf828e8c"><span class="__cf_email__" data-cfemail="fa898f8a8a95888eba8893949d8e8cd4999597">[email&#160;protected]</span></a>
</div>
</div>
<div class="col-lg-3 col-md-3 col-sm-6 col-xs-12 hidden-xs">
<h3>Quicklinks</h3>
<ul id="menu-quicklinks" class="foot-quicklinks"><li id="menu-item-178" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-178"><a href="https://www.ringtv.com/about-us/">About Us/Staff</a></li>
<li id="menu-item-179" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-179"><a href="https://www.ringtv.com/contact-us/">Contact Us/Advertise</a></li>
<li id="menu-item-180" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-180"><a href="https://www.ringtv.com/subscribe/">Subscribe</a></li>
</ul> </div>
<div class="col-lg-3 col-md-3 col-sm-6 col-xs-12 hidden-xs">
<h3>Join Our Newsletter</h3> <div class="foot-newsletter">
<div class="desc">Join our newsletter to get info about latest events and deals!</div>
<div id="mailpoet_form_5" class="mailpoet_form mailpoet_form_shortcode">
<style type="text/css">.mailpoet_hp_email_label{display:none;}#mailpoet_form_5 .mailpoet_form {  }
#mailpoet_form_5 .mailpoet_paragraph { line-height: 20px; }
#mailpoet_form_5 .mailpoet_segment_label, #mailpoet_form_5 .mailpoet_text_label, #mailpoet_form_5 .mailpoet_textarea_label, #mailpoet_form_5 .mailpoet_select_label, #mailpoet_form_5 .mailpoet_radio_label, #mailpoet_form_5 .mailpoet_checkbox_label, #mailpoet_form_5 .mailpoet_list_label, #mailpoet_form_5 .mailpoet_date_label { display: block; font-weight: bold; }
#mailpoet_form_5 .mailpoet_text, #mailpoet_form_5 .mailpoet_textarea, #mailpoet_form_5 .mailpoet_select, #mailpoet_form_5 .mailpoet_date_month, #mailpoet_form_5 .mailpoet_date_day, #mailpoet_form_5 .mailpoet_date_year, #mailpoet_form_5 .mailpoet_date { display: block; }
#mailpoet_form_5 .mailpoet_text, #mailpoet_form_5 .mailpoet_textarea { width: 100%; }
#mailpoet_form_5 .mailpoet_checkbox {  }
#mailpoet_form_5 .mailpoet_submit input {  }
#mailpoet_form_5 .mailpoet_divider {  }
#mailpoet_form_5 .mailpoet_message {  }
#mailpoet_form_5 .mailpoet_validate_success { color: #468847; }
#mailpoet_form_5 .mailpoet_validate_error { color: #b94a48; }</style>
<form target="_self" method="post" action="https://www.ringtv.com/wp-admin/admin-post.php?action=mailpoet_subscription_form" class="mailpoet_form mailpoet_form_shortcode" novalidate>
<input type="hidden" name="data[form_id]" value="5" />
<input type="hidden" name="token" value="5d30dc90fb" />
<input type="hidden" name="api_version" value="v1" />
<input type="hidden" name="endpoint" value="subscribers" />
<input type="hidden" name="mailpoet_method" value="subscribe" />
<label class="mailpoet_hp_email_label">Please leave this field empty<input type="email" name="data[email]"></label><p class="mailpoet_paragraph"><label class="mailpoet_text_label">Email <span class="mailpoet_required">*</span></label><input type="email" class="mailpoet_text" name="data[form_field_ZW1haWw=]" title="Email" value="" data-automation-id="form_email" data-parsley-required="true" data-parsley-minlength="6" data-parsley-maxlength="150" data-parsley-error-message="Please specify a valid email address." data-parsley-required-message="This field is required." /></p>
<p class="mailpoet_paragraph"><input type="submit" class="mailpoet_submit" value="Subscribe!" /></p>
<div class="mailpoet_message">
<p class="mailpoet_validate_success" style="display:none;">Check your inbox or spam folder to confirm your subscription.
</p>
<p class="mailpoet_validate_error" style="display:none;"> </p>
</div>
</form>
</div>
</div>
</div>
<div class="col-xs-12 hidden-lg hidden-md hidden-sm visible-xs">
<ul class="foot-social">
<li><a href="https://www.facebook.com/RingTV" target="_blank"><i class="fa fa-facebook"></i></a></li> <li><a href="https://twitter.com/ringmagazine" target="_blank"><i class="fa fa-twitter"></i></a></li> <li><a href="https://instagram.com/ringtv" target="_blank"><i class="fa fa-instagram"></i></a></li> </ul>
<div class="foot-logo"><img src="https://www.ringtv.com/wp-content/themes/thering/images/ring-logo.png" alt=""></div>
<div class="foot-small-desc">Your destination for the best boxing news, videos and live streams!</div>
</div>
</div>
</div>
</div>
<div class="footer-bottom">
<div class="wrap-inner">
<ul id="menu-footer-menu-1" class="foot-btm-links"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-186"><a href="https://www.ringtv.com/terms-conditions/">Terms &#038; Conditions</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-185"><a href="https://www.ringtv.com/privacy-policy/">Privacy Policy</a></li>
</ul> <div class="copyright">&copy; 2019 RING TV LIVE. All rights reserved. </div>
</div>
</div>
<style></style><link rel='stylesheet' id='mailpoet_public-css' href='https://www.ringtv.com/wp-content/plugins/mailpoet/assets/css/public.cae357df.css?ver=4.9.8' type='text/css' media='all' />
<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.ringtv.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"theringonline"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"581908 http:\/\/www.ringtv.com\/?p=581908","disqusShortname":"theringonline","disqusTitle":"Fight Picks: Canelo Alvarez vs. Sergey Kovalev","disqusUrl":"https:\/\/www.ringtv.com\/581908-fight-picks-canelo-alvarez-vs-sergey-kovalev\/","postId":"581908"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var addrop_script = {"ajaxurl":"https:\/\/www.ringtv.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/ad-dropper/js/script.js?ver=1.3.0'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":1,"isRTL":false});});
</script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/jquery.flexslider.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/jquery.easing.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/jquery.movingboxes.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/instafeed.min.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/jquery.cycle2.min.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/jquery.cycle2.flip.min.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/jquery.mCustomScrollbar.concat.min.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/fitvids.min.js?ver=1ec709894c22ffa6be395f593801426f'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/owl.carousel.min.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/jquery.lazy.min.js?ver=1.0.1'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/jquery.fancybox.pack.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/js.cookie.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/jquery.matchHeight.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/tweetie.min.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/isOnScreen.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_var = {"url":"https:\/\/www.ringtv.com\/wp-admin\/admin-ajax.php","nonce":"b6530b6a7b","template_url":"https:\/\/www.ringtv.com\/wp-content\/themes\/thering"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/global.js?ver=1ec709894c22ffa6be395f593801426f'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-includes/js/wp-embed.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/mailpoet/assets/js/vendor.848ec4ca.js?ver=3.9.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var MailPoetForm = {"ajax_url":"https:\/\/www.ringtv.com\/wp-admin\/admin-ajax.php","is_rtl":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/mailpoet/assets/js/public.0ac1326d.js?ver=3.9.0'></script>
<script type='text/javascript'>
function initMailpoetTranslation() {
  if(typeof MailPoet !== 'undefined') {
    MailPoet.I18n.add('ajaxFailedErrorMessage', 'An error has happened while performing a request, please try again later.')
  } else {
    setTimeout(initMailpoetTranslation, 250);
  }
}
setTimeout(initMailpoetTranslation, 250);
</script>
<script>
 (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
 (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
 m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
 })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

 ga('create', 'UA-77508658-1', 'auto');
 ga('send', 'pageview');

</script>

<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-5MLLG9"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-5MLLG9');</script>


<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-4ef3d09874f075c2"></script>
<script type="text/javascript">
    
	jQuery(function($){
		
		if( $('#user_login').length ){
			$('#user_login').attr('placeholder','EMAIL ADDRESS');
		}
		
		/*if( $('#leaky-paywall-gift-subscription-plans').length ){
			$('#leaky-paywall-gift-subscription-plans option[value=3]').remove();
		}*/
		
				
                
                
                

        
    
		
	
		

        	
    

				$('select#leaky-paywall-gift-subscription-plans option:not(:nth-child(1))').remove();
					
	});
	
    var j = jQuery.noConflict();
    
	j(window).load(function(){
		
	});
	

    
    
    if( j('.widget-instagram').length ){
        var feed = new Instafeed({
            get: 'user',
            userId: '212360053',
            template: '<a href="{{link}}" class="item" style="background-image:url({{image}})"><img src="https://www.ringtv.com/wp-content/themes/thering/images/blank-feed.gif" /></a>',
            resolution: 'thumbnail',
            accessToken: '212360053.1677ed0.632fb768c9ee4638aad573370c8a61fd',
            limit: 6,
            target: 'insta-feed'
        });
        feed.run();   
    }
   
    
    
</script>
</body>
</html>