<!DOCTYPE html>
<html>
<head>
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta name="generator" content="WordPress 4.8.4" />
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<title>Dougie&#039;s Friday mailbag (boxers fighting past their primes, the early-mid 1990s) - The Ring</title>
<script src="/cdn-cgi/apps/head/sTZ1OmmcIFk8d3jz46qmP2UAby4.js"></script><link rel="apple-touch-icon" sizes="57x57" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-57x57.png">
<link rel="apple-touch-icon" sizes="60x60" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-60x60.png">
<link rel="apple-touch-icon" sizes="72x72" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-72x72.png">
<link rel="apple-touch-icon" sizes="76x76" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-76x76.png">
<link rel="apple-touch-icon" sizes="114x114" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-114x114.png">
<link rel="apple-touch-icon" sizes="120x120" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-120x120.png">
<link rel="apple-touch-icon" sizes="144x144" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-144x144.png">
<link rel="apple-touch-icon" sizes="152x152" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-152x152.png">
<link rel="apple-touch-icon" sizes="180x180" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-180x180.png">
<link rel="icon" type="image/png" sizes="192x192" href="https://www.ringtv.com/wp-content/themes/thering/images/android-icon-192x192.png">
<link rel="icon" type="image/png" sizes="32x32" href="https://www.ringtv.com/wp-content/themes/thering/images/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="96x96" href="https://www.ringtv.com/wp-content/themes/thering/images/favicon-96x96.png">
<link rel="icon" type="image/png" sizes="16x16" href="https://www.ringtv.com/wp-content/themes/thering/images/favicon-16x16.png">
<link rel="manifest" href="https://www.ringtv.com/wp-content/themes/thering/images/manifest.json">
<meta name="msapplication-TileColor" content="#ffffff">
<meta name="msapplication-TileImage" content="https://www.ringtv.com/wp-content/themes/thering/images/ms-icon-144x144.png">
<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="https://www.ringtv.com/feed/" />
<link rel="alternate" type="text/xml" title="RSS .92" href="https://www.ringtv.com/feed/rss/" />
<link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="https://www.ringtv.com/feed/atom/" />
<link rel="pingback" href="https://www.ringtv.com/xmlrpc.php" />
 <script data-cfasync='false' type='text/javascript'>/*<![CDATA[*/(function (a, c, s, u){'Insticator'in a || (a.Insticator={ad:{loadAd: function (b){Insticator.ad.q.push(b)}, q: []}, helper:{}, embed:{}, version: "3.0", q: [], load: function (t, o){Insticator.q.push({t: t, o: o})}}); var b=c.createElement(s); b.src=u; b.async=!0; var d=c.getElementsByTagName(s)[0]; d.parentNode.insertBefore(b, d)})(window, document, 'script', '//d2na2p72vtqyok.cloudfront.net/client-embed/5f282198-b6f9-4fbf-9244-cfb0317339b5.js');/*]]>*/</script> 
<link href="https://fonts.googleapis.com/css?family=Montserrat:400,500,600,700,800,900" rel="stylesheet">

<link rel="canonical" href="https://www.ringtv.com/523352-dougies-friday-mailbag-boxers-fighting-past-their-primes-the-early-mid-1990s/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Dougie&#039;s Friday mailbag (boxers fighting past their primes, the early-mid 1990s) - The Ring" />
<meta property="og:description" content="We&#039;ve got a mixed mailbag with somewhat obscure questions posed by hardcore fans today, but hopefully Dougie&#039;s answers entertain and inform." />
<meta property="og:url" content="https://www.ringtv.com/523352-dougies-friday-mailbag-boxers-fighting-past-their-primes-the-early-mid-1990s/" />
<meta property="og:site_name" content="The Ring" />
<meta property="article:publisher" content="https://www.facebook.com/RingTV" />
<meta property="article:author" content="https://www.facebook.com/douglass.fischer" />
<meta property="article:tag" content="90s" />
<meta property="article:tag" content="bert cooper" />
<meta property="article:tag" content="doug fischer" />
<meta property="article:tag" content="Hajime no Ippo" />
<meta property="article:tag" content="julian jackson" />
<meta property="article:tag" content="mailbag" />
<meta property="article:tag" content="ray mercer" />
<meta property="article:tag" content="roy jones jr." />
<meta property="article:tag" content="terry norris" />
<meta property="article:tag" content="tommy morrison" />
<meta property="article:section" content="Boxing" />
<meta property="article:published_time" content="2017-12-01T06:13:33+00:00" />
<meta property="article:modified_time" content="2017-12-01T06:21:12+00:00" />
<meta property="og:updated_time" content="2017-12-01T06:21:12+00:00" />
<meta property="og:image" content="https://www.ringtv.com/wp-content/uploads/2017/02/Roy-Jones-vs.-Bobby-Gunn_Greenhill.jpg" />
<meta property="og:image:secure_url" content="https://www.ringtv.com/wp-content/uploads/2017/02/Roy-Jones-vs.-Bobby-Gunn_Greenhill.jpg" />
<meta property="og:image:width" content="1200" />
<meta property="og:image:height" content="765" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="We&#039;ve got a mixed mailbag with somewhat obscure questions posed by hardcore fans today, but hopefully Dougie&#039;s answers entertain and inform." />
<meta name="twitter:title" content="Dougie&#039;s Friday mailbag (boxers fighting past their primes, the early-mid 1990s) - The Ring" />
<meta name="twitter:site" content="@ringmagazine" />
<meta name="twitter:image" content="https://www.ringtv.com/wp-content/uploads/2017/02/Roy-Jones-vs.-Bobby-Gunn_Greenhill.jpg" />
<meta name="twitter:creator" content="@dougiefischer" />
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"https:\/\/www.ringtv.com\/","name":"The Ring","alternateName":"RingTV","potentialAction":{"@type":"SearchAction","target":"https:\/\/www.ringtv.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script>
<script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"Organization","url":"https:\/\/www.ringtv.com\/523352-dougies-friday-mailbag-boxers-fighting-past-their-primes-the-early-mid-1990s\/","sameAs":["https:\/\/www.facebook.com\/RingTV","https:\/\/www.instagram.com\/ringtv\/","https:\/\/www.youtube.com\/channel\/UC8ybHJltwhtpk0cFKU4G8kQ","https:\/\/twitter.com\/ringmagazine"],"@id":"#organization","name":"The Ring Magazine","logo":"https:\/\/www.ringtv.com\/wp-content\/uploads\/2016\/09\/RING-logo_black_on_white-w-shadow2.jpg"}</script>

<link rel='dns-prefetch' href='//js.stripe.com' />
<link rel='dns-prefetch' href='//ajax.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="The Ring &raquo; Dougie&#8217;s Friday mailbag (boxers fighting past their primes, the early-mid 1990s) Comments Feed" href="https://www.ringtv.com/523352-dougies-friday-mailbag-boxers-fighting-past-their-primes-the-early-mid-1990s/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.3\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.ringtv.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.8.4"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,56826,8203,55356,56819),0,0),c=j.toDataURL(),b!==c&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55358,56794,8205,9794,65039),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55358,56794,8203,9794,65039),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='mailpoet_public-css' href='https://www.ringtv.com/wp-content/plugins/mailpoet/assets/css/public.cae357df.css?ver=4.8.4' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css' href='https://www.ringtv.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.9' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css' href='https://www.ringtv.com/wp-includes/css/dashicons.min.css?ver=4.8.4' type='text/css' media='all' />
<link rel='stylesheet' id='wpp_style-css' href="https://www.ringtv.com/wp-content/plugins/wp-poll/assets/front/css/style.css?ver=4.8.4" type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css' href="https://www.ringtv.com/wp-content/plugins/wp-poll/assets/global/css/font-awesome.css?ver=4.8.4" type='text/css' media='all' />
<link rel='stylesheet' id='access_ads_style-css' href='https://www.ringtv.com/wp-content/plugins/accessads//css/minimal.css?ver=1.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-issuem-flexslider-css' href='https://www.ringtv.com/wp-content/plugins/issuem/css/flexslider.css?ver=2.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='issuem-leaky-paywall-article-countdown-nag-css' href='https://www.ringtv.com/wp-content/plugins/leaky-paywall-article-countdown-nag//css/article-countdown-nag-slim.css?ver=3.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='leaky-paywall-coupons-css-css' href='https://www.ringtv.com/wp-content/plugins/leaky-paywall-coupons//css/leaky-paywall-coupons.css?ver=1.4.0' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-style-css' href='//ajax.googleapis.com/ajax/libs/jqueryui/1.11.2/themes/smoothness/jquery-ui.css?ver=4.8.4' type='text/css' media='all' />
<link rel='stylesheet' id='lp-gift-style-css' href='https://www.ringtv.com/wp-content/plugins/leaky-paywall-gift-subscriptions//css/lp-gift.css?ver=2.6.0' type='text/css' media='all' />
<link rel='stylesheet' id='issuem-leaky-paywall-css' href='https://www.ringtv.com/wp-content/plugins/leaky-paywall//css/issuem-leaky-paywall.css?ver=4.9.2' type='text/css' media='all' />
<link rel='stylesheet' id='unipress-api-css' href='https://www.ringtv.com/wp-content/plugins/unipress-api//css/unipress.css?ver=1.16.0' type='text/css' media='all' />
<link rel='stylesheet' id='flexslider-css' href='https://www.ringtv.com/wp-content/themes/thering/css/flexslider.css' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css' href='https://www.ringtv.com/wp-content/themes/thering/css/font-awesome.css' type='text/css' media='all' />
<link rel='stylesheet' id='normalize-css' href='https://www.ringtv.com/wp-content/themes/thering/css/normalize.css' type='text/css' media='all' />
<link rel='stylesheet' id='grid12-css' href='https://www.ringtv.com/wp-content/themes/thering/css/grid12.css' type='text/css' media='all' />
<link rel='stylesheet' id='movingboxes-css' href='https://www.ringtv.com/wp-content/themes/thering/css/movingboxes.css' type='text/css' media='all' />
<link rel='stylesheet' id='customscrollbar-css' href='https://www.ringtv.com/wp-content/themes/thering/css/jquery.mCustomScrollbar.css' type='text/css' media='all' />
<link rel='stylesheet' id='owlcarousel-css' href='https://www.ringtv.com/wp-content/themes/thering/css/owl.carousel.css' type='text/css' media='all' />
<link rel='stylesheet' id='owltheme-css' href='https://www.ringtv.com/wp-content/themes/thering/css/owl.theme.default.css' type='text/css' media='all' />
<link rel='stylesheet' id='fancybox-css' href='https://www.ringtv.com/wp-content/themes/thering/css/jquery.fancybox.css' type='text/css' media='all' />
<link rel='stylesheet' id='stylesheet-css' href='https://www.ringtv.com/wp-content/themes/thering/style.css?ver=88a810210524d69527b667638c6c35d0' type='text/css' media='all' />
<link rel='stylesheet' id='responsive-css' href='https://www.ringtv.com/wp-content/themes/thering/css/responsive.css?ver=88a810210524d69527b667638c6c35d0' type='text/css' media='all' />
<link rel='stylesheet' id='app-css-css' href='https://www.ringtv.com/wp-content/themes/thering/css/app.css?ver=88a810210524d69527b667638c6c35d0' type='text/css' media='all' />
<script type='text/javascript' src='https://www.ringtv.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpp_ajax = {"wpp_ajaxurl":"https:\/\/www.ringtv.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/wp-poll/assets/front/js/scripts.js?ver=4.8.4'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/issuem/js/jquery.flexslider-min.js?ver=2.7.1'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/leaky-paywall-article-countdown-nag//js/article-countdown-nag.js?ver=3.1.0'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/leaky-paywall-coupons/js/leaky-paywall-coupons.js?ver=1.4.0'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/leaky-paywall-gift-subscriptions//js/lp-gift.js?ver=2.6.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_object = {"ajax_url":"https:\/\/www.ringtv.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/unipress-api//js/unipress.js?ver=1.16.0'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/countdown.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var aamLocal = {"nonce":"f5c961e24c","ajaxurl":"https:\/\/www.ringtv.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='//www.ringtv.com/wp-content/plugins/advanced-access-manager/media/js/aam-login.js?ver=4.8.4'></script>
<script type='text/javascript' src='https://js.stripe.com/v2/?ver=4.8.4'></script>
<link rel='https://api.w.org/' href='https://www.ringtv.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.ringtv.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.ringtv.com/wp-includes/wlwmanifest.xml" />
<meta name="generator" content="WordPress 4.8.4" />
<link rel='shortlink' href='https://www.ringtv.com/?p=523352' />
<link rel="alternate" type="application/json+oembed" href="https://www.ringtv.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ringtv.com%2F523352-dougies-friday-mailbag-boxers-fighting-past-their-primes-the-early-mid-1990s%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.ringtv.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ringtv.com%2F523352-dougies-friday-mailbag-boxers-fighting-past-their-primes-the-early-mid-1990s%2F&#038;format=xml" />

<script>
!function(f,b,e,v,n,t,s)
{if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};
if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];
s.parentNode.insertBefore(t,s)}(window,document,'script',
'https://connect.facebook.net/en_US/fbevents.js');
 fbq('init', '641303409343758'); 
fbq('track', 'PageView');
</script>
<noscript>
 <img height="1" width="1" 
src="https://www.facebook.com/tr?id=641303409343758&ev=PageView&noscript=1"/>
</noscript>

</head>
<body class="post-template-default single single-post postid-523352 single-format-standard loading dougies-friday-mailbag-boxers-fighting-past-their-primes-the-early-mid-1990s unknown">
<div id="fb-root"></div>
<script>(function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/sdk.js#xfbml=1&version=v2.10&appId=128026463954740";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>
<div id="mobile-nav">
<a href="#" class="btn-close-mob"></a>
<div class="mob-logo"><img src="https://www.ringtv.com/wp-content/themes/thering/images/ring-logo.png" alt=""></div>
<ul id="menu-main-menu" class="mob-nav"><li id="menu-item-151" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-151"><a href="https://www.ringtv.com/">Home</a></li>
<li id="menu-item-152" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-152"><a href="https://www.ringtv.com/news/">News</a></li>
<li id="menu-item-158" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-158"><a href="https://www.ringtv.com/videos/">Videos</a></li>
<li id="menu-item-516022" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-516022"><a href="https://www.ringtv.com/category/podcasts/">Podcasts</a></li>
<li id="menu-item-153" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-153"><a href="https://www.ringtv.com/photos/">Photos</a></li>
<li id="menu-item-155" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-155"><a href="https://www.ringtv.com/ratings/">Ratings</a></li>
<li id="menu-item-156" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156"><a href="https://www.ringtv.com/schedule/">Schedule</a></li>
<li id="menu-item-249" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-249"><a target="_blank" href="https://esolutionsmnec.ecenergy.com/eCatalog/Account/AnonymousLogon/38?customerName=RING">Shop</a></li>
<li id="menu-item-494633" class="hlogin-btn menu-item menu-item-type-post_type menu-item-object-page menu-item-494633"><a href="https://www.ringtv.com/subscription-login/">Login</a></li>
<li id="menu-item-494630" class="hsubscribe-btn menu-item menu-item-type-post_type menu-item-object-page menu-item-494630"><a href="https://www.ringtv.com/subscription/">Subscribe</a></li>
</ul> <ul class="mobile-nav-social">
<li><a href="https://www.ringtv.com/search"><i class="fa fa-search"></i></a></li>
<li><a href="https://www.facebook.com/RingTV" target="_blank"><i class="fa fa-facebook"></i></a></li> <li><a href="https://www.youtube.com/user/TheRingDigital" target="_blank"><i class="fa fa-youtube"></i></a></li> <li><a href="https://twitter.com/ringmagazine" target="_blank"><i class="fa fa-twitter"></i></a></li> <li><a href="https://instagram.com/ringtv" target="_blank"><i class="fa fa-instagram"></i></a></li> </ul>
</div>
<div id="top_bar">
<div class="content-wrap">
<div class="left">
<div class="date">Friday, December 01, 2017&nbsp; |</div>
<div class="follow">
<span class="label">Follow Us:</span>
<a href="https://www.facebook.com/RingTV" target="_blank"><i class="icon-facebook"></i></a> <a href="https://www.youtube.com/user/TheRingDigital" target="_blank"><i class="icon-youtube-play"></i></a> <a href="https://twitter.com/ringmagazine" target="_blank"><i class="icon-twitter"></i></a> <a href="https://instagram.com/ringtv" target="_blank"><i class="icon-instagram-1"></i></a> </div>
<div class="search-bit">
<form id="searchform" method="get" action="https://www.ringtv.com/">
<input type="text" name="s" id="s" size="15" placeholder="Search RingTV..." />
<span><i class="icon-search"></i></span>
</form>
</div>
</div>
<div class="right">
<div class="cycle-slideshow" data-cycle-slides="> div.item" data-cycle-fx="flipVert" data-cycle-pause-on-hover="true" data-cycle-timeout="4500" data-cycle-speed="500">
<div class="item"><a href="https://www.ringtv.com/subscription/" class="button-ppv"><span>Get Ringside Ticket!</span></a></div>
</div>
</div>
</div>
</div>
<div id="masthead">
<div class="content-wrap">
<a href="https://www.ringtv.com" class="logo" title="Ring TV">Ring TV</a>
<ul id="menu-main-menu-1" class="main-nav desktop"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-151"><a href="https://www.ringtv.com/">Home</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-152"><a href="https://www.ringtv.com/news/">News</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-158"><a href="https://www.ringtv.com/videos/">Videos</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-516022"><a href="https://www.ringtv.com/category/podcasts/">Podcasts</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-153"><a href="https://www.ringtv.com/photos/">Photos</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-155"><a href="https://www.ringtv.com/ratings/">Ratings</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156"><a href="https://www.ringtv.com/schedule/">Schedule</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-249"><a target="_blank" href="https://esolutionsmnec.ecenergy.com/eCatalog/Account/AnonymousLogon/38?customerName=RING">Shop</a></li>
<li class="hlogin-btn menu-item menu-item-type-post_type menu-item-object-page menu-item-494633"><a href="https://www.ringtv.com/subscription-login/">Login</a></li>
<li class="hsubscribe-btn menu-item menu-item-type-post_type menu-item-object-page menu-item-494630"><a href="https://www.ringtv.com/subscription/">Subscribe</a></li>
</ul> <a href="#" class="toggle-menu">
<span></span>
<span></span>
<span></span>
</a>
</div>
<div class="mobile-menu">
<ul id="menu-main-menu-2" class="main-nav-mobile"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-151"><a href="https://www.ringtv.com/">Home</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-152"><a href="https://www.ringtv.com/news/">News</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-158"><a href="https://www.ringtv.com/videos/">Videos</a></li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-516022"><a href="https://www.ringtv.com/category/podcasts/">Podcasts</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-153"><a href="https://www.ringtv.com/photos/">Photos</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-155"><a href="https://www.ringtv.com/ratings/">Ratings</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156"><a href="https://www.ringtv.com/schedule/">Schedule</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-249"><a target="_blank" href="https://esolutionsmnec.ecenergy.com/eCatalog/Account/AnonymousLogon/38?customerName=RING">Shop</a></li>
<li class="hlogin-btn menu-item menu-item-type-post_type menu-item-object-page menu-item-494633"><a href="https://www.ringtv.com/subscription-login/">Login</a></li>
<li class="hsubscribe-btn menu-item menu-item-type-post_type menu-item-object-page menu-item-494630"><a href="https://www.ringtv.com/subscription/">Subscribe</a></li>
</ul>
</div>
</div>
<div class="sub-header">
<div class="content-wrap">
<h1>News</h1>
<div class="ads728-90"><div class="addrop-wrap" data-id="499853"><script id="mNCC" language="javascript">
   medianet_width = "728";
   medianet_height = "90";
   medianet_crid = "766595921";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUV3K88Q' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script>
</div></div>
</div>
</div>
<div id="content">
<div class="content-wrap">
<div class="list-main">
<div class="news-content">
<div class="full-post">
<h1>Dougie&#8217;s Friday mailbag (boxers fighting past their primes, the early-mid 1990s)</h1>
<div class="imagebox"><img src="https://www.ringtv.com/wp-content/uploads/2017/02/Roy-Jones-vs.-Bobby-Gunn_Greenhill-770x491.jpg" alt=""></div>
<div class="image-desc">Almost 10 years removed from his last significant victory (a decision over Felix Trinidad in January 2008), Roy Jones Jr. (pictured here against Bobby Gunn in February) continues to fight despite the dangers that come with professional boxing. Photo by Mike Greenhill</div>
<div class="a-d-468x60-post hidden-md visible-sm visible-xs"><div class="addrop-wrap" data-id="516167"><a href="https://bit.ly/fightersnetwork" target="_blank"><img src="https://www.ringtv.com/wp-content/uploads/2017/09/468x60-Fighters-Network.jpg" alt="" width="468" height="60" class="alignnone size-full wp-image-516168" /></a></div></div>
<div class="text-wrap">
<div class="date-col">
<div class="day">01</div>
<div class="month">Dec</div>
</div>
<div class="a-d-468x60-post hidden-sm hidden-xs"><div class="addrop-wrap" data-id="516167"><a href="https://bit.ly/fightersnetwork" target="_blank"><img src="https://www.ringtv.com/wp-content/uploads/2017/09/468x60-Fighters-Network.jpg" alt="" width="468" height="60" class="alignnone size-full wp-image-516168" /></a></div></div>
<div class="posted-by"><a href="https://www.ringtv.com/author/doug/">by Doug Fischer</a></div>
<p><strong>NERD TALK AND HARD TRUTHS</strong></p>
<p>Big fan. I think this is like the 5th time I write to the mailbag.</p>
<p><img class="alignleft size-full wp-image-523353" src="http://www.ringtv.com/wp-content/uploads/2017/12/Hajime-no-Ippo_mailbag.jpg" alt="" width="300" height="300" srcset="https://www.ringtv.com/wp-content/uploads/2017/12/Hajime-no-Ippo_mailbag.jpg 300w, https://www.ringtv.com/wp-content/uploads/2017/12/Hajime-no-Ippo_mailbag-150x150.jpg 150w, https://www.ringtv.com/wp-content/uploads/2017/12/Hajime-no-Ippo_mailbag-80x80.jpg 80w, https://www.ringtv.com/wp-content/uploads/2017/12/Hajime-no-Ippo_mailbag-270x270.jpg 270w, https://www.ringtv.com/wp-content/uploads/2017/12/Hajime-no-Ippo_mailbag-45x45.jpg 45w" sizes="(max-width: 300px) 100vw, 300px" />I want to talk about a boxing manga that I remember being mentioned by another reader, Hajime no Ippo, and you saying you had heard about it but not really read. I started watching it first around the time I was 12 when I was looking for anime to watch and thought there has to be 1 on my favorite sport, found it and been interested since then, moved on to the manga and I am closing in on 30, so I have gotten very into this series. I’ve been reading it every time it&#8217;s been updated. A recent chapter starts to go deep in the plot of the main character being punch drunk that they had been building for a while. I like it as it shows hard truths about our sport and the possibility of him retiring due to, he himself, noticing that he isn&#8217;t the same anymore.</p>
<p>Being a fan of this sport far more knowledgeable then me and having met a lot of fighters, how many fighters have you personally seen show signs of potential brain damage or other signs of permanent damage and continue to fight or retire?</p>
<p>Fighters that came to mind for me is Joe Frazier, who was partially blind in one fight but continued to fight, and Sergio Martinez (one of my favs), who retired after it was obvious his knee would continue to get worse. Also, I would like to get your personal opinion on why these fighters continued to fight even though they knew they were damaged goods and the public could already tell they were damaged goods (like JuanMa Lopez). – Ivan, Brooklyn, NYC</p>
<p><strong>Only a fighter can share with you what’s really going on in his or head when they make the choice to continue fighting far past their athletic primes (risking permanent neurological and bodily damage).</strong></p>
<p><strong>I’m just a journalist. All I do is observe and write about what I observe. So, if you REALLY want to know why a boxer (or any combat sports athlete) would want to continue competing after sustaining serious physical damage over the course of his or her career, you’re going to have to get to know one and gain his or her trust.</strong></p>
<p><strong>And even then, they may not tell you. It can be very personal. </strong></p>
<p><strong>In my opinion, most professional boxers continue fighting way past their primes because boxing is part of their identity (most notable prize fighters began in the amateur ranks as children), it’s a challenge or thrill (they’re very competitive by nature), it’s their livelihood (because they’ve dedicated their lives to the sport and thus lack foundations in other lines of work), and because they are in denial about their physical condition and the late stage of their careers. </strong></p>
<p><strong>The denial has nothing to do with boxing, that’s a trait all human beings share. </strong></p>
<p><strong>However, with boxers (and standout athletes of other sports), the denial is tied in with the</strong></p>
<div id="attachment_450852" style="width: 360px" class="wp-caption alignright"><img class="wp-image-450852" src="http://www.ringtv.com/wp-content/uploads/gallery/barclays-center-undercard-8-9-14/danny-jacobs-vs-jarrod-fletcher-11-photo-by-naoki-fukuda.jpg" alt="" width="350" height="234" /><p class="wp-caption-text">Daniel Jacobs celebrates winning a major title three years after being diagnosed with cancer. Photo / Naoki Fukuda</p></div>
<p><strong>iron wills that make them special. That’s why you get “miracle” stories like Vinny Pazienza coming back from a broken neck, or Daniel Jacobs returning to the sport and excelling after beating cancer, or a 45-year-old George Foreman regaining the heavyweight title 20 years after losing it, or Evander Holyfield beating huge odds favorite Mike Tyson two years after being diagnosed with a congenital heart condition, or Willie Pep  returning to the sport after suffering serious injuries in a plane crash, or Bernard Hopkins and Archie Moore fighting on the world-class level into their late 40s. And there are many other stories of boxers overcoming serious injuries and ailments, or fighting at an age when most pro athletes would be retired or on the “senior circuit.” The same will and self-belief that made them defy doctor’s orders, family pleas and common sense, and triumph in the ring against all odds becomes self-destructive denial at some point in their careers.</strong></p>
<p><strong>That denial is every bit as strong as their desire to win and prove themselves at the start of their careers. I’ve had a few aging former champs threaten to kick my ass for suggesting they retire in columns and fight reports. </strong></p>
<p><strong>Roy Jones Jr. should have retired <em>at least</em> 10 years ago, but nobody can tell him to hang up the gloves. You know why? Because he’s ROY JONES JR.! He was super-talent! He was god-like in his prime, and we are mere mortals. Even though he’s fraction of what he was, he’s still a damn META-HUMAN compared to our sorry asses. Jones is going to be 49 in a couple months, but I bet you he still views himself as Superman. </strong></p>
<p><strong>And Superman ain’t gonna listen to me. I’m Perry White. I’m a big-mouth jerk-off editor. Superman ain’t gonna listen to YOU, either. You’re Jimmy Olson. You’re a geeky dude who’s into Hajime no Ippo manga… and boxing.</strong></p>
<p><em>Being a fan of this sport far more knowledgeable then me and having met a lot of fighters, how many fighters have you personally seen show signs of potential brain damage or other signs of permanent damage and continue to fight or retire?</em> <strong>Probably 50% of all the fighters I’ve ever met. Maybe 60-65 percent. I start noticing things like slurred speech, memory loss and a decline in other cognitive functions, as well as a drop off in reflexes, after they’ve spent six or seven years in the professional ranks. However, there are many fighters who had standout careers that lasted over 10-20 years that seem just fine. Some of them are hall of famers. Many of them – especially, the Mexican legends, such as Julio Cesar Chavez, Ricardo Lopez, Marco Antonio Barrera and Erik Morales – are now boxing commentators that I see along press row at all the big fights.</strong></p>
<p><strong>The good news is that it seems like more boxing standouts are knowing when to call it career. We’ve witnessed several future hall of famers announce their retirements this year – including Wladimir Klitschko, Tim Bradley and Andre Ward – while still at or near the top of their games and in good places, mentally and financially. One of them, Miguel Cotto, plans to retire after his WBO 154-pound title defense against Sadam Ali tomorrow night. </strong></p>
<p><strong>Regarding Hajime no Ippo, I still haven’t seen the anime or read the manga of this longtime series, but you’ve piqued my interest enough to check out the books the next time I’m at my favorite comic shop.</strong></p>
<p><strong> </strong></p>
<p><strong>JACOBS’ P4P WHAT IF</strong></p>
<p>Hi Dougie,</p>
<p>Hope all is well out there state side – been hooked on your boxing reportage since the ol&#8217; Maxboxing days! All the B-HOP and your &#8216;son&#8217; Edwin Valero coverage has had me hooked since. Anyhow thought I&#8217;d get in touch and say thanks.</p>
<p>And whilst I&#8217;m here I may as well throw you a question; where would Danny Jacobs rank on your P4P list if he had won the decision that night against GGG? Was a damnnn close fight&#8230;</p>
<p>All the best. – Adil from London, UK</p>
<div id="attachment_490458" style="width: 310px" class="wp-caption alignleft"><img class="size-medium wp-image-490458" src="http://www.ringtv.com/wp-content/uploads/2017/03/GGG-Jacobs-post-fight-respect_Hoganphotos-300x215.jpg" alt="" width="300" height="215" srcset="https://www.ringtv.com/wp-content/uploads/2017/03/GGG-Jacobs-post-fight-respect_Hoganphotos-300x215.jpg 300w, https://www.ringtv.com/wp-content/uploads/2017/03/GGG-Jacobs-post-fight-respect_Hoganphotos.jpg 400w" sizes="(max-width: 300px) 100vw, 300px" /><p class="wp-caption-text">Photo by: Tom Hogan/ Hoganphotos/K2 Promotions</p></div>
<p><strong>I had it 115-112 for Golovkin (or seven rounds to five with a point deduction for the fourth-round knockdown) after viewing the fight live inside Madison Square Garden in March. Viewing it on TV a day or so later, I scored it eight rounds to four for GGG, but I agree that it was a competitive, arguably close, fight. </strong></p>
<p><strong>Had Jacobs done enough to get the decision it would have been a candidate for upset of the year, the most significant boxing victory of Jacobs’ career, and I believe it would have landed him in most pound-for-pound rankings, including THE RING’s and my own. </strong></p>
<p><strong>Where would the talented middleweight have landed? Not inside the top five. He didn’t have body of work of Andre Ward, Sergey Kovalev or Roman Gonzalez, or the dominance and consistency of Terence Crawford or GGG. But a win over Golovkin, who was No. 3 in THE RING’s rankings at the time, could have pushed him past the lower-top-10 rated players at the time, such as Canelo Alvarez and Shinsuke Yamanaka, maybe even Guillermo Rigondeaux. I’d have placed him between No. 7 or 9 if the win over GGG was legit.</strong></p>
<p>&nbsp;</p>
<p><strong>SEXISM IN BOXING?</strong></p>
<p>Hi Dougie,</p>
<p>I hope this email finds you well.</p>
<p>I was reading an article over the weekend about Katie Taylor, and being Irish I’m naturally very supportive of her, but what in my mind makes her more of a star than say Conor McGregor is the way she carries herself. She is an elite boxer with none of the prima donna behavior, which is refreshing!</p>
<p>Anyway, the reason I wanted your opinion on this was actually nothing to do with Katie Taylor (despite her winning a world title before her tenth fight), it was to do with the article mentioning that Katie might fight Holly Holms. It got me thinking – surely Holly Holms should be celebrated as one of the most elite “fighters” of the last 20 years. When Conor McGregor got beaten badly by Floyd Mayweather we all said, “well what do you expect, he’s not a boxer – Sure Conor would kill Floyd in a UFC fight”. However here we have a lady who was undisputed world champion in boxing moving to UFC and fighting the ladies equivalent of Conor McGregor (actually Ronda Rousey was probably seen as more of a dangerous fighter than McGregor). Rousey was seen as unbeatable in most quarters and Holly Holm destroyed her. Yet I don’t see much coverage following Holly’s progress since, asking if she will come back to boxing, hyping fights with Katie Taylor, etc.</p>
<p>It got me to thinking are we still watching boxing through sexist goggles?</p>
<p>Cheers. – Leo</p>
<p><strong>Yeah, we are, to an extent. We’re a sexist society, Leo, but I think there are other factors involved in the manner in which Holm’s victory over Rousey was received by the general public. </strong></p>
<p><strong>For starters, she’s never been as popular as McGregor. Despite being a gross mismatch (and a fake fight, in my opinion), Mayweather vs. McGregor commanded WAY more attention than Rousey-Holm because it involved the biggest name in boxing and the biggest name in MMA. Rousey was the biggest name in MMA going into the Holm fight, but Holm was not a huge name in boxing or MMA. </strong></p>
<div id="attachment_484826" style="width: 310px" class="wp-caption alignright"><img class="size-medium wp-image-484826" src="http://www.ringtv.com/wp-content/uploads/2017/02/Holm-kicks-Rousey_UFC-300x240.jpg" alt="" width="300" height="240" srcset="https://www.ringtv.com/wp-content/uploads/2017/02/Holm-kicks-Rousey_UFC-300x240.jpg 300w, https://www.ringtv.com/wp-content/uploads/2017/02/Holm-kicks-Rousey_UFC.jpg 400w" sizes="(max-width: 300px) 100vw, 300px" /><p class="wp-caption-text">Holm utilizing her kickboxing skills to brutal effect vs. Rousey.</p></div>
<p><strong>Also, while Holm was a huge underdog against Rousey (as McGregor was against Mayweather, obviously), she wasn’t making her MMA debut as Conor was. She carried a 9-0 MMA record going into the Rousey fight, which included two UFC appearances, one Bellator bout, and three in the Legacy Fighting Championships. Holm also had some amateur and pro kickboxing and Muy Thai experience prior to, and during, the early stages of her pro boxing career. So, she wasn’t nearly as wet-behind-the-ears in MMA as McGregor was in boxing. Knowledgeable MMA fans took this into account after Holm scored the upset. </strong></p>
<p><strong>Another factor is Rousey. She’s a polarizing figure. Like Mayweather in boxing, Rousey was as hated as she was popular in and out of the MMA world. So, when she got KTFO, the focus was more on her downfall (or “humbling” as her haters – some of whom are sexist and/or misogynist – would call it) than it was on Holm’s victory. It wasn’t fair to Holm, but hey, life isn’t fair. And in the world of sports, hate is often stronger than love. </strong></p>
<p><strong>Yet another factor in the lack of celebration for Holm’s upset of Rousey is that she lost her next bout, which took place less than four months after her greatest triumph. The woman she lost to, Meisha Tate, is a celebrated MMA veteran, and the setback shouldn’t have counted that much against Holm, but losses are not tolerated by casual fans (and hardcore dips__ts) in this era. MMA fans are better about this than boxing fans, but Holm proceeded to lose her next two UFC fights, which effectively cooled off the buzz she had from the Rousey victory.</strong></p>
<p><strong>Anyway, I think women’s boxing made serious strides forward in 2017, due in part to the bourgeoning pro careers for Olympic standouts, such as Taylor and Claressa Shields. And future bodes well for female fighters. </strong></p>
<p>&nbsp;</p>
<p><strong>POP CULTURE START TO BOXING HISTORY</strong></p>
<p>Hi Dougie,</p>
<p>I’m sort of new to boxing and was wondering where would be a good place to start looking at videos of great fighters. I play guitar so if I was say start at the beginning of electric I&#8217;d say Charlie Christian, but I know most people don&#8217;t like 30&#8217;s music. So where would be a good &#8220;pop culture start&#8221;? Thanks. – Chris</p>
<p><strong>I think most new boxing fans would look to the 1980s because of the modern folklore of the Four Kings – Sugar Ray Leonard, Marvin Hagler, Thomas Hearns and Roberto Duran – and one can’t really go wrong with their legendary round robin from 147 to 168 pounds during that decade.</strong></p>
<p><strong>However, I think a lot of really good fighters that emerged in the late 80s and early 90s – such as middleweight titleholders Sumbu Kalambay, Frank Tate, Mike McCallum, Iran Barkley, Julian Jackson, and even Michael Nunn, who had a lot of buzz about him in the industry – were tragically overshadowed by the legends of the Four Kings. And they weren’t alone. </strong></p>
<p><strong>So, I’m going to suggest the early-to-mid ‘90s as a great place to start. Pernell Whitaker, Terry Norris, Roy Jones Jr. and James Toney – all incredible boxing talents – rose to the peak of their ring prowess during that portion of the decade. Future superstars, such as Oscar De La Hoya (who was sensational at 135 and 140 pounds) and Felix Trinidad (who was downright frightening as a young welterweight titleholder) also began to emerge during that period of time.</strong></p>
<p><strong>The heavyweight division was hot thanks to 1988 Olympic medalists Lennox Lewis, Riddick Bowe and Ray Mercer, who developed into contenders while Mike Tyson, Buster Douglas and Evander Holyfield reigned as undisputed champ. Adding even more spice to the glamor division were hard-punching contenders Michael Moorer, Tommy Morrison and Razor Rudduck, “old” but savvy and still-competitive former champs George Foreman and Larry Holmes, and dangerous gatekeepers, such as Bert Cooper and Alex Stewart. </strong></p>
<div id="attachment_522458" style="width: 310px" class="wp-caption alignleft"><img class="size-medium wp-image-522458" src="http://www.ringtv.com/wp-content/uploads/2017/11/rsz_gettyimages-157079101-300x221.jpg" alt="" width="300" height="221" srcset="https://www.ringtv.com/wp-content/uploads/2017/11/rsz_gettyimages-157079101-300x221.jpg 300w, https://www.ringtv.com/wp-content/uploads/2017/11/rsz_gettyimages-157079101-768x565.jpg 768w, https://www.ringtv.com/wp-content/uploads/2017/11/rsz_gettyimages-157079101-150x110.jpg 150w, https://www.ringtv.com/wp-content/uploads/2017/11/rsz_gettyimages-157079101.jpg 1000w" sizes="(max-width: 300px) 100vw, 300px" /><p class="wp-caption-text">The Holyfield-Bowe trilogy helped make the early-to-mid &#8217;90s a great time to be a boxing fan. Photo: THE RING Archive</p></div>
<p><strong>The big men made for exciting and dramatic fights, such as the Holyfield-Bowe trilogy, Holyfiled-Foreman, Tyson-Rudduck I and II, Holyfield-Cooper, Moorer-Cooper, Mercer-Cooper (damn, I really miss “Smokin’” Bert’s crazy ass), Mercer-Morrison, Holmes-Mercer, Holyfield-Mercer (s__t, I miss “Merciless” Ray, too!), Morrison-Joe Hipp, Morrison-Carl Williams, Morrison-Rudduck (Rest In Peace, Duke) and that’s just off the top of my head.</strong></p>
<p><strong>The welterweight division was also hot thanks to Simon Brown, Buddy McGirt, Aaron “Superman” Davis and Meldrick Taylor. Check out Brown-Tyrone Trice II, Brown-Maurice Blocker and Davis-Breland for some grueling battles. See McGirt-Brown and Taylor-Davis for underrated boxing clinics and Whitaker-McGirt I for two savvy boxers going tit-for-tat for 12 rounds. </strong></p>
<div id="attachment_520131" style="width: 310px" class="wp-caption alignright"><img class="size-medium wp-image-520131" src="http://www.ringtv.com/wp-content/uploads/2017/10/mccallum-vs-toney_ring-300x195.jpg" alt="" width="300" height="195" srcset="https://www.ringtv.com/wp-content/uploads/2017/10/mccallum-vs-toney_ring-300x195.jpg 300w, https://www.ringtv.com/wp-content/uploads/2017/10/mccallum-vs-toney_ring-768x500.jpg 768w, https://www.ringtv.com/wp-content/uploads/2017/10/mccallum-vs-toney_ring-1024x667.jpg 1024w, https://www.ringtv.com/wp-content/uploads/2017/10/mccallum-vs-toney_ring-150x98.jpg 150w, https://www.ringtv.com/wp-content/uploads/2017/10/mccallum-vs-toney_ring-567x367.jpg 567w, https://www.ringtv.com/wp-content/uploads/2017/10/mccallum-vs-toney_ring-1320x860.jpg 1320w, https://www.ringtv.com/wp-content/uploads/2017/10/mccallum-vs-toney_ring.jpg 1400w" sizes="(max-width: 300px) 100vw, 300px" /><p class="wp-caption-text">Toney and McCallum put on another joint master class in their 1992 rematch. Photo / THE RING archives</p></div>
<p><strong>Also check out some of the middleweight title bouts of this period. Toney-McCallum I and II delivered as much as a boxer-vs.-boxer matchup can. There were also some sweet shootouts at 160 pounds, such as Nigel Benn-Barkley and Gerald McClellan-Jackson.</strong></p>
<p><strong>Julian Jackson scored some of his most celebrated one-hitter-quitters from 1990-’92, and Norris (a 1989 KO victim of The Hawk) was like a force of nature at 154 pounds in the early ‘90s.</strong></p>
<p><strong>You want boxing culture with “pop”? Explore the early/mid ‘90s, Chris.</strong></p>
<p><strong> </strong></p>
<p><em>Email Fischer at </em><a href="/cdn-cgi/l/email-protection#77131802101e123715180f1e19101a161e1b1516105914181a"><em><span class="__cf_email__" data-cfemail="41252e3426282401232e39282f262c20282d2320266f222e2c">[email&#160;protected]</span></em></a><em>. Follow him on Twitter at @dougiefischer</em></p>
<p><strong> </strong></p>
<div class="clearboth"></div>
<div class="a-d-468x60-post hidden-sm hidden-xs"><div class="addrop-wrap" data-id="499862"><script data-cfasync="false" src="/cdn-cgi/scripts/ddc5a536/cloudflare-static/email-decode.min.js"></script><script id="mNCC" language="javascript">
   medianet_width = "468";
   medianet_height = "60";
   medianet_crid = "887466222";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUV3K88Q' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script></div></div>
</div>
<div class="a-d-468x60-post hidden-md visible-sm visible-xs"><div class="addrop-wrap" data-id="499862"><script id="mNCC" language="javascript">
   medianet_width = "468";
   medianet_height = "60";
   medianet_crid = "887466222";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUV3K88Q' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script></div></div>
<div class="share-story">
<div class="title-text">Share this story</div>
<ul class="share-social">
 <li><a href="#" class="addthis_button_facebook"><i class="fa fa-facebook"></i></a></li>
<li><a href="#" class="addthis_button_twitter"><i class="fa fa-twitter"></i></a></li>
</ul>
</div>
<div class="comment-app">
<div id="disqus_thread">
<div id="dsq-content">
<ul id="dsq-comments">
<li class="comment even thread-even depth-1" id="dsq-comment-193308">
<div id="dsq-comment-header-193308" class="dsq-comment-header">
<cite id="dsq-cite-193308">
<span id="dsq-author-user-193308">Orca</span>
</cite>
</div>
<div id="dsq-comment-body-193308" class="dsq-comment-body">
<div id="dsq-comment-message-193308" class="dsq-comment-message"><p>I agree that the early to mid 90&#8217;s is a great place for new fans to start. Youtube is your friend. Some great memories from the fights Doug mentioned. Saying that, for brand new fans to the sport, I&#8217;d always recommend a few documentaries. Knowing the story behind the fights makes a big difference. Champions Forever and Fabulous 4 were key to me falling in love with this amazing sport. The HBO series, Legendary Nights is brilliant and well worth finding. Boxers are the most interesting of all sportsmen, imo, they are worth getting to know. These men are really something special, even the ones that are assholes, ha. It&#8217;s their stories and personalities that can keep your backside rooted in front of the TV watching even when the fight itself is dragging. You&#8217;re gonna have a lot of fun Chris 🙂</p>
</div>
</div>
</li>
<li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-193310">
<div id="dsq-comment-header-193310" class="dsq-comment-header">
<cite id="dsq-cite-193310">
<span id="dsq-author-user-193310">ceylon mooney</span>
</cite>
</div>
<div id="dsq-comment-body-193310" class="dsq-comment-body">
<div id="dsq-comment-message-193310" class="dsq-comment-message"><p>man i luv mailbag responses like the last one. im all bout some gettin stronger fundamentals as a boxing fan. </p>
<p>id add 122-126 of the late 70s/early 80s as a rpund robin</p>
</div>
</div>
</li>
<li class="comment even thread-even depth-1" id="dsq-comment-193312">
<div id="dsq-comment-header-193312" class="dsq-comment-header">
<cite id="dsq-cite-193312">
<span id="dsq-author-user-193312">Left Hook2</span>
</cite>
</div>
<div id="dsq-comment-body-193312" class="dsq-comment-body">
<div id="dsq-comment-message-193312" class="dsq-comment-message"><p>Freekin Superman Davis vs Breland! My God what a classic!<br />
I also vividly remember seeing Tommy Morrison bobbing and weaving on his stool AFTER Mercer knocked him out. Scary stuff.</p>
</div>
</div>
</li>
<li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-193314">
<div id="dsq-comment-header-193314" class="dsq-comment-header">
<cite id="dsq-cite-193314">
<span id="dsq-author-user-193314">philoe bedoe</span>
</cite>
</div>
<div id="dsq-comment-body-193314" class="dsq-comment-body">
<div id="dsq-comment-message-193314" class="dsq-comment-message"><p>Excellent mailbag again Doug.<br />
1993 to 2000 was the time in my life where I didn&#8217;t catch as many fights as I did during other stages of my life.<br />
Even though I participated and still watched as much as I could, it was due to age and no Sky Tv that made me miss so many of those great fights and fighters back then&#8230;&#8230;&#8230;&#8230;</p>
</div>
</div>
</li>
<li class="comment even thread-even depth-1" id="dsq-comment-193315">
<div id="dsq-comment-header-193315" class="dsq-comment-header">
<cite id="dsq-cite-193315">
<span id="dsq-author-user-193315">learnmore</span>
</cite>
</div>
<div id="dsq-comment-body-193315" class="dsq-comment-body">
<div id="dsq-comment-message-193315" class="dsq-comment-message"><p>Good read Dougie</p>
</div>
</div>
</li>
<li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-193316">
<div id="dsq-comment-header-193316" class="dsq-comment-header">
<cite id="dsq-cite-193316">
<span id="dsq-author-user-193316">Juan Manuel Valverde</span>
</cite>
</div>
<div id="dsq-comment-body-193316" class="dsq-comment-body">
<div id="dsq-comment-message-193316" class="dsq-comment-message"><p>I started casually watching boxing in the mid to late 80&#8217;s with the rise of Mike Tyson, 1990 gave us Chavez-Taylor and Douglas-Tyson and I was hooked. It&#8217;s funny to me reading KO Magazine, Boxing Illustrated, The Ring, Boxing 90, etc. how journalist back then thought the heavyweight division and boxing in general was in the worst shape talentwise ever. Journalist like Steve Farhood, Jeff Ryan, Bert Sugar, Wally Matthews, etc, all would complaint on how bad the heavyweight division was. I didn&#8217;t understand, they seemed perfectly fine to me (I was a newbie); they were always talking about how 15 years back, heavyweights were great. </p>
<p>Today, reading emails and answers like the one Doug gave to Chris, and watching and remembering those days, I realize that what I thought back then was actually true, we were seeing good talented heavyweights fighting good quality fights, and the media was just longing for the glories of the past. I think this is common human behaviour, much like the movie Midnight in Paris artistically explains, its very human to always long for the good old days instead of looking at what we actually have. </p>
<p>My guess is that 15 years from now, we&#8217;ll be talking about Joshua, Klitschko, Wilder, in a better way that what we say today. Great mailbag Doug, thanks again for your hard work.</p>
</div>
</div>
</li>
</ul>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="widgets">

<div id="media_image-2" class="widget-odd widget-first widget-1 widget widget_media_image"><a href="https://www.ringtv.com/subscription/" class="" rel="" target=""><img width="300" height="254" src="https://www.ringtv.com/wp-content/uploads/2017/09/widgets-1.png" class="image wp-image-516021  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://www.ringtv.com/wp-content/uploads/2017/09/widgets-1.png 300w, https://www.ringtv.com/wp-content/uploads/2017/09/widgets-1-150x127.png 150w" sizes="(max-width: 300px) 100vw, 300px" /></a></div><div id="sidebar_ticket_widget-2" class="widget-even widget-2 widget Sidebar_Ticket_Widget widget-tickets">
<a href="https://www.ringtv.com/subscription/" class="green-btn">Get The Ring Digital Edition on Ringside Ticket!</a>
<div class="padded">
<img src="https://www.ringtv.com/wp-content/themes/thering/images/widgets-2.jpg" alt="">
<h4 class="widget-title">Livestreams</h4>
</div>
<a href="https://www.ringtv.com/subscription/" class="green-btn">Watch Select Fights Subscribe Now!</a>
</div><div id="ad_dropper_widget-5" class="widget-odd widget-3 widget widget_ad_dropper_widget"><div class="addrop-wrap" data-id="516020">
<div id="insticator-container">
<div id="div-insticator-ad-1"></div>
<div id="insticator-embed"></div>
<div id="div-insticator-ad-2"></div>
<script data-cfasync='false' type="text/javascript">/*<![CDATA[*/Insticator.ad.loadAd("div-insticator-ad-1");Insticator.ad.loadAd("div-insticator-ad-2");Insticator.load("em",{id : "57efe63a-5598-4f49-989d-174127a70538"})/*]]>*/</script>
</div>
</div></div><div id="sidebar_ratings_widget-2" class="widget-even widget-4 widget Sidebar_Ratings_Widget widget-ratings">
<h4 class="widget-title">Ratings | <a href="https://www.ringtv.com/ratings/">View All</a></h4>
<p>Top 6 Pound for Pound</p>
<div class="small-ratings">
<div class="item">
<img src="https://www.ringtv.com/wp-content/uploads/2016/08/gennady-golovkin-ratings-fukuda-270x270.jpg" alt="Gennady Golovkin" />
<span>1</span>
</div>
<div class="item">
<img src="https://www.ringtv.com/wp-content/uploads/2016/11/Terence-Crawford-ratings-270x270.jpg" alt="Terence Crawford" />
<span>2</span>
</div>
<div class="item">
<img src="https://www.ringtv.com/wp-content/uploads/2016/07/Vasyl-Lomachenko-ratings-270x270.jpg" alt="Vasyl Lomachenko" />
<span>3</span>
</div>
<div class="item">
<img src="https://www.ringtv.com/wp-content/uploads/2016/07/rigondeaux-ratings-270x270.jpg" alt="Guillermo Rigondeaux" />
<span>4</span>
</div>
<div class="item">
<img src="https://www.ringtv.com/wp-content/uploads/2016/07/Sergey-Kovalev-ratings-270x270.jpg" alt="Sergey Kovalev" />
<span>5</span>
</div>
<div class="item">
<img src="https://www.ringtv.com/wp-content/uploads/2016/07/canelo-e1473365393257-270x270.jpg" alt="Canelo Alvarez" />
<span>6</span>
</div>
</div>
</div><div id="callouts-3" class="widget-odd widget-5 widget widget_callouts widget-trending">
<h4 class="widget-title">Trending</h4>
<div class="listing">
<a href="https://www.ringtv.com/523360-toka-kahn-clary-headline-cbs-sports-network-tripleheader-tonight/" class="item">
 <span class="image">
<img src="https://www.ringtv.com/wp-content/uploads/2016/12/CBS-Sports-Network-e1512138159655-80x80.jpg" alt="Toka Kahn Clary to headline CBS Sports Network tripleheader tonight" />
</span>
Toka Kahn Clary to headline CBS Sports Network tripleheader tonight </a>
<a href="https://www.ringtv.com/523352-dougies-friday-mailbag-boxers-fighting-past-their-primes-the-early-mid-1990s/" class="item">
<span class="image">
<img src="https://www.ringtv.com/wp-content/uploads/2017/02/Roy-Jones-vs.-Bobby-Gunn_Greenhill-80x80.jpg" alt="Dougie&#8217;s Friday mailbag (boxers fighting past their primes, the early-mid 1990s)" />
</span>
Dougie&#8217;s Friday mailbag (boxers fighting past their primes, the early-mid 1990s) </a>
<a href="https://www.ringtv.com/523336-claressa-shields-finds-inspiration-cris-cyborg-holly-holm/" class="item">
<span class="image">
<img src="https://www.ringtv.com/wp-content/uploads/2017/08/Claressa-Shields-Nikki-Adler-Stephanie-Trapp-TrappPhotos-Showtime-80x80.jpg" alt="Claressa Shields finds inspiration in Cris Cyborg and Holly Holm" />
</span>
Claressa Shields finds inspiration in Cris Cyborg and Holly Holm </a>
<a href="https://www.ringtv.com/523338-lamont-roach-jr-outpoints-rey-perez-over-10-rounds/" class="item">
<span class="image">
<img src="https://www.ringtv.com/wp-content/uploads/2017/11/RoachPerez_Hoganphotos1-80x80.jpg" alt="Lamont Roach Jr. outpoints Rey Perez over 10 rounds" />
</span>
Lamont Roach Jr. outpoints Rey Perez over 10 rounds </a>
<a href="https://www.ringtv.com/523329-guillermo-rigondeaux-im-going-produce-masterpiece-vs-vasyl-lomachenko/" class="item">
<span class="image">
<img src="https://www.ringtv.com/wp-content/uploads/2017/06/Guillermo-Rigondeaux_simon-calloway-80x80.jpg" alt="Guillermo Rigondeaux: I&#8217;ll produce a masterpiece against Vasyl Lomachenko" />
</span>
Guillermo Rigondeaux: I&#8217;ll produce a masterpiece against Vasyl Lomachenko </a>
</div>
</div><div id="sidebar_schedule_widget-2" class="widget-even widget-6 widget Sidebar_Schedule_Widget widget-scheds">
<h4 class="widget-title">Schedule | <a href="https://www.ringtv.com/schedule/">View All</a></h4>
<div class="list-streams">
<a href="https://www.ringtv.com/schedule/" class="item">
<span class="date"><span class="d">25</span><span class="m">Nov</span></span>
 Sergey Kovalev (No. 2, No. 5 P4P) vs. Vyacheslav Shabranskyy 12 rounds – light heavyweights </a>
<a href="https://www.ringtv.com/schedule/" class="item">
<span class="date"><span class="d">02</span><span class="m">Dec</span></span>
Miguel Cotto (No. 3) vs. Sadam Ali 12 rounds – junior middleweights </a>
<a href="https://www.ringtv.com/schedule/" class="item">
<span class="date"><span class="d">09</span><span class="m">Dec</span></span>
Vasyl Lomachenko (No. 1, No. 3 P4P) vs. Guillermo Rigondeaux (No. 1 jr. featherweight, No. 4 P4P) 12 rounds – junior lightweights (for Lomachenko’s WBO title) </a>
</div>
</div><div id="sidebar_instagram_widget-2" class="widget-odd widget-7 widget Sidebar_Instagram_Widget widget-instagram"> <h4 class="widget-title">Instagram <i class="icon-instagram-1"></i></h4>
<div id="insta-feed"></div>
</div><div id="sidebar_facebook_widget-2" class="widget-even widget-8 widget Sidebar_Facebook_Widget widget-facebook">
<h4 class="widget-title">Facebook <img src="https://www.ringtv.com/wp-content/themes/thering/images/icon-facebook.png" alt=""></h4>
<div class="fb-page" data-href="https://www.facebook.com/RingTV" data-tabs="timeline" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="false"><blockquote cite="https://www.facebook.com/RingTV" class="fb-xfbml-parse-ignore"><a href="https://www.facebook.com/RingTV">RingTV</a></blockquote></div>
</div><div id="sidebar_product_widget-2" class="widget-odd widget-9 widget Sidebar_Product_Widget widget-product">
<h4 class="widget-title">Official Product</h4>
<div class="feat-product">
<a href="https://www.ringtv.com/products/ring-canelo-ggg-t-shirt/">
<img src="https://www.ringtv.com/wp-content/uploads/2017/09/ring-circle-bomber-canel-ggg.jpg" alt="">
</a>
</div>
<a href="https://esolutionsmnec.ecenergy.com/eCatalog/Account/AnonymousLogon/38?customerName=RING" class="green-btn">Shop Now!</a>
</div><div id="custom_html-2" class="widget_text widget-even widget-last widget-10 current-poll widget widget_custom_html"><h4 class="widget-title">Current Poll</h4><div class="textwidget custom-html-widget"><script type="text/javascript" charset="utf-8" src="https://static.polldaddy.com/p/9848185.js"></script>
<noscript><a href="https://polldaddy.com/poll/9848185/">Who should be No. 1 pound for pound?</a></noscript></div></div>
</div>  </div>
</div>
<div class="footer-wrap">
<div class="bg-top"></div>
<div class="wrap-inner">
<a class="foot-go-top-btn visible-xs" href="#"></a>
<div class="row">
<div class="col-lg-3 col-md-3 col-sm-6 col-xs-12 hidden-xs">
<div class="foot-logo"><img src="https://www.ringtv.com/wp-content/themes/thering/images/ring-logo.png" alt=""></div>
<div class="foot-small-desc"></div>
<ul class="foot-social">
<li><a href="https://www.facebook.com/RingTV" target="_blank"><i class="fa fa-facebook"></i></a></li> <li><a href="https://www.youtube.com/user/TheRingDigital" target="_blank"><i class="fa fa-youtube"></i></a></li> <li><a href="https://twitter.com/ringmagazine" target="_blank"><i class="fa fa-twitter"></i></a></li> <li><a href="https://instagram.com/ringtv" target="_blank"><i class="fa fa-instagram"></i></a></li> </ul>
</div>
<div class="col-xs-12 hidden-lg hidden-md hidden-sm visible-xs">
<h3>Quicklinks</h3>
<ul id="menu-footer-menu" class="foot-quicklinks"><li id="menu-item-186" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-186"><a href="https://www.ringtv.com/terms-conditions/">Terms &#038; Conditions</a></li>
<li id="menu-item-185" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-185"><a href="https://www.ringtv.com/privacy-policy/">Privacy Policy</a></li>
</ul> </div>
<div class="col-lg-3 col-md-3 col-sm-6 col-xs-12">
<h3>Contact Us</h3>
<div class="contact-info-row">
<span class="icon"><i class="fa fa-home"></i></span>
P.O. Box 90254 <br />
Brooklyn, NY 11209 </div>
<div class="contact-info-row">
<span class="icon"><i class="fa fa-envelope-o"></i></span>
<a class="email" href="/cdn-cgi/l/email-protection#33404643435c414773415a5d5447451d505c5e"><span class="__cf_email__" data-cfemail="d7a4a2a7a7b8a5a397a5beb9b0a3a1f9b4b8ba">[email&#160;protected]</span></a>
</div>
</div>
<div class="col-lg-3 col-md-3 col-sm-6 col-xs-12 hidden-xs">
<h3>Quicklinks</h3>
<ul id="menu-quicklinks" class="foot-quicklinks"><li id="menu-item-178" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-178"><a href="https://www.ringtv.com/about-us/">About Us/Staff</a></li>
<li id="menu-item-179" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-179"><a href="https://www.ringtv.com/contact-us/">Contact Us/Advertise</a></li>
<li id="menu-item-180" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-180"><a href="https://www.ringtv.com/subscribe/">Subscribe</a></li>
</ul> </div>
<div class="col-lg-3 col-md-3 col-sm-6 col-xs-12 hidden-xs">
<h3>Join Our Newsletter</h3> <div class="foot-newsletter">
<div class="desc">Join our newsletter to get info about latest events and deals!</div>
<div id="mailpoet_form_5" class="mailpoet_form mailpoet_form_shortcode">
<style type="text/css">.mailpoet_hp_email_label{position: absolute;left: -999em;}#mailpoet_form_5 .mailpoet_form {  }
#mailpoet_form_5 .mailpoet_paragraph { line-height: 20px; }
#mailpoet_form_5 .mailpoet_segment_label, #mailpoet_form_5 .mailpoet_text_label, #mailpoet_form_5 .mailpoet_textarea_label, #mailpoet_form_5 .mailpoet_select_label, #mailpoet_form_5 .mailpoet_radio_label, #mailpoet_form_5 .mailpoet_checkbox_label, #mailpoet_form_5 .mailpoet_list_label, #mailpoet_form_5 .mailpoet_date_label { display: block; font-weight: bold; }
#mailpoet_form_5 .mailpoet_text, #mailpoet_form_5 .mailpoet_textarea, #mailpoet_form_5 .mailpoet_select, #mailpoet_form_5 .mailpoet_date_month, #mailpoet_form_5 .mailpoet_date_day, #mailpoet_form_5 .mailpoet_date_year, #mailpoet_form_5 .mailpoet_date { display: block; }
#mailpoet_form_5 .mailpoet_text, #mailpoet_form_5 .mailpoet_textarea { width: 100%; }
#mailpoet_form_5 .mailpoet_checkbox {  }
#mailpoet_form_5 .mailpoet_submit input {  }
#mailpoet_form_5 .mailpoet_divider {  }
#mailpoet_form_5 .mailpoet_message {  }
#mailpoet_form_5 .mailpoet_validate_success { color: #468847; }
#mailpoet_form_5 .mailpoet_validate_error { color: #b94a48; }</style>
<form target="_self" method="post" action="https://www.ringtv.com/wp-admin/admin-post.php?action=mailpoet_subscription_form" class="mailpoet_form mailpoet_form_shortcode" novalidate>
<input type="hidden" name="data[form_id]" value="5" />
<input type="hidden" name="token" value="c7092f81da" />
<input type="hidden" name="api_version" value="v1" />
<input type="hidden" name="endpoint" value="subscribers" />
<input type="hidden" name="mailpoet_method" value="subscribe" />
<label class="mailpoet_hp_email_label">Please leave this field empty<input type="email" name="data[email]"></label><p class="mailpoet_paragraph"><label class="mailpoet_text_label">Email <span class="mailpoet_required">*</span></label><input type="email" class="mailpoet_text" name="data[form_field_ZW1haWw=]" title="Email" value="" data-parsley-required="true" data-parsley-error-message="Please specify a valid email address." /></p>
<p class="mailpoet_paragraph"><input type="submit" class="mailpoet_submit" value="Subscribe!" /></p>
<div class="mailpoet_message">
<p class="mailpoet_validate_success" style="display:none;">Check your inbox or spam folder to confirm your subscription.</p>
<p class="mailpoet_validate_error" style="display:none;"> </p>
</div>
</form>
</div>
</div>
</div>
<div class="col-xs-12 hidden-lg hidden-md hidden-sm visible-xs">
<ul class="foot-social">
<li><a href="https://www.facebook.com/RingTV" target="_blank"><i class="fa fa-facebook"></i></a></li> <li><a href="https://twitter.com/ringmagazine" target="_blank"><i class="fa fa-twitter"></i></a></li> <li><a href="https://instagram.com/ringtv" target="_blank"><i class="fa fa-instagram"></i></a></li> </ul>
<div class="foot-logo"><img src="https://www.ringtv.com/wp-content/themes/thering/images/ring-logo.png" alt=""></div>
<div class="foot-small-desc">Your destination for the best boxing news, videos and live streams!</div>
</div>
</div>
</div>
</div>
<div class="footer-bottom">
<div class="wrap-inner">
<ul id="menu-footer-menu-1" class="foot-btm-links"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-186"><a href="https://www.ringtv.com/terms-conditions/">Terms &#038; Conditions</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-185"><a href="https://www.ringtv.com/privacy-policy/">Privacy Policy</a></li>
</ul> <div class="copyright">&copy; 2017 RING TV LIVE. All rights reserved. </div>
</div>
</div>
<div style="display: none;">
<div class="subscribe-modal" id="subscribe-now">
<div class="mc-form">
<div class="inner">
<div id="mailpoet_form_5" class="mailpoet_form mailpoet_form_shortcode">
<style type="text/css">.mailpoet_hp_email_label{position: absolute;left: -999em;}#mailpoet_form_5 .mailpoet_form {  }
#mailpoet_form_5 .mailpoet_paragraph { line-height: 20px; }
#mailpoet_form_5 .mailpoet_segment_label, #mailpoet_form_5 .mailpoet_text_label, #mailpoet_form_5 .mailpoet_textarea_label, #mailpoet_form_5 .mailpoet_select_label, #mailpoet_form_5 .mailpoet_radio_label, #mailpoet_form_5 .mailpoet_checkbox_label, #mailpoet_form_5 .mailpoet_list_label, #mailpoet_form_5 .mailpoet_date_label { display: block; font-weight: bold; }
#mailpoet_form_5 .mailpoet_text, #mailpoet_form_5 .mailpoet_textarea, #mailpoet_form_5 .mailpoet_select, #mailpoet_form_5 .mailpoet_date_month, #mailpoet_form_5 .mailpoet_date_day, #mailpoet_form_5 .mailpoet_date_year, #mailpoet_form_5 .mailpoet_date { display: block; }
#mailpoet_form_5 .mailpoet_text, #mailpoet_form_5 .mailpoet_textarea { width: 100%; }
#mailpoet_form_5 .mailpoet_checkbox {  }
#mailpoet_form_5 .mailpoet_submit input {  }
#mailpoet_form_5 .mailpoet_divider {  }
#mailpoet_form_5 .mailpoet_message {  }
#mailpoet_form_5 .mailpoet_validate_success { color: #468847; }
#mailpoet_form_5 .mailpoet_validate_error { color: #b94a48; }</style>
<form target="_self" method="post" action="https://www.ringtv.com/wp-admin/admin-post.php?action=mailpoet_subscription_form" class="mailpoet_form mailpoet_form_shortcode" novalidate>
<input type="hidden" name="data[form_id]" value="5" />
<input type="hidden" name="token" value="c7092f81da" />
<input type="hidden" name="api_version" value="v1" />
<input type="hidden" name="endpoint" value="subscribers" />
<input type="hidden" name="mailpoet_method" value="subscribe" />
<label class="mailpoet_hp_email_label">Please leave this field empty<input type="email" name="data[email]"></label><p class="mailpoet_paragraph"><label class="mailpoet_text_label">Email <span class="mailpoet_required">*</span></label><input type="email" class="mailpoet_text" name="data[form_field_ZW1haWw=]" title="Email" value="" data-parsley-required="true" data-parsley-error-message="Please specify a valid email address." /></p>
<p class="mailpoet_paragraph"><input type="submit" class="mailpoet_submit" value="Subscribe!" /></p>
<div class="mailpoet_message">
<p class="mailpoet_validate_success" style="display:none;">Check your inbox or spam folder to confirm your subscription.</p>
<p class="mailpoet_validate_error" style="display:none;"> </p>
</div>
</form>
</div>
</div>
</div>
</div>
</div>
<script data-cfasync="false" src="/cdn-cgi/scripts/ddc5a536/cloudflare-static/email-decode.min.js"></script><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-7578637367237225",
    enable_page_level_ads: true
  });
</script>
<style></style><script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/mailpoet/assets/js/vendor.2e3b215c.js?ver=3.0.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var MailPoetForm = {"ajax_url":"https:\/\/www.ringtv.com\/wp-admin\/admin-ajax.php","is_rtl":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/mailpoet/assets/js/public.5b18b937.js?ver=3.0.0'></script>
<script type='text/javascript'>
function initMailpoetTranslation() {
  if(typeof MailPoet !== 'undefined') {
    MailPoet.I18n.add('ajaxFailedErrorMessage', 'An error has happened while performing a request, please try again later.')
  } else {
    setTimeout(initMailpoetTranslation, 250);
  }
}
setTimeout(initMailpoetTranslation, 250);
</script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.ringtv.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.9'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var addrop_script = {"ajaxurl":"https:\/\/www.ringtv.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/ad-dropper/js/script.js?ver=1.2.0'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":1,"isRTL":false});});
</script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/jquery.flexslider.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/jquery.easing.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/jquery.movingboxes.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/instafeed.min.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/jquery.cycle2.min.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/jquery.cycle2.flip.min.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/jquery.mCustomScrollbar.concat.min.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/fitvids.min.js?ver=88a810210524d69527b667638c6c35d0'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/owl.carousel.min.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/jquery.lazy.min.js?ver=1.0.1'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/jquery.fancybox.pack.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/js.cookie.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/jquery.matchHeight.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/tweetie.min.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/isOnScreen.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_var = {"url":"https:\/\/www.ringtv.com\/wp-admin\/admin-ajax.php","nonce":"50bfc4be88","template_url":"https:\/\/www.ringtv.com\/wp-content\/themes\/thering"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/global.js?ver=88a810210524d69527b667638c6c35d0'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-includes/js/wp-embed.min.js?ver=4.8.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"platform":"wordpress@4.8.4","language":""},"disqusIdentifier":"523352 http:\/\/www.ringtv.com\/?p=523352","disqusShortname":"theringonline","disqusTitle":"Dougie\u2019s Friday mailbag (boxers fighting past their primes, the early-mid 1990s)","disqusUrl":"https:\/\/www.ringtv.com\/523352-dougies-friday-mailbag-boxers-fighting-past-their-primes-the-early-mid-1990s\/","options":{"manualSync":false},"postId":"523352"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/disqus-comment-system/media/js/disqus.js?ver=4.8.4'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"theringonline"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/disqus-comment-system/media/js/count.js?ver=4.8.4'></script>
<script type='text/javascript' src="https://www.springboardplatform.com/jsapi/embed"></script>
<script>
 (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
 (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
 m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
 })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

 ga('create', 'UA-77508658-1', 'auto');
 ga('send', 'pageview');

</script>

<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-5MLLG9"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-5MLLG9');</script>


<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-4ef3d09874f075c2"></script>
<script type="text/javascript">
    
	jQuery(function($){
		
		if( $('#user_login').length ){
			$('#user_login').attr('placeholder','EMAIL ADDRESS');
		}
		
		/*if( $('#leaky-paywall-gift-subscription-plans').length ){
			$('#leaky-paywall-gift-subscription-plans option[value=3]').remove();
		}*/
		
		if (typeof(Cookies.get('subscribemod')) == 'undefined' || Cookies.get('subscribemod') == null) {
			//cookie is not present
			
			$.fancybox( {href : '#subscribe-now', openEffect : 'none', closeEffect : 'none', padding : 0, closeClick : false, afterClose: function(){
				Cookies.set('subscribemod', 'done', { path: '/', expires: 7 });
			} } ); 
			
			$('.joinus-modal').on('click',function(){
				Cookies.set('subscribemod', 'done', { path: '/', expires: 365 });
				$(this).parents('form').submit();
			});
		}	
                
                
                

        
    
		
	
		

        	
    

				$('select#leaky-paywall-gift-subscription-plans option:not(:nth-child(1))').remove();
					
	});
	
    var j = jQuery.noConflict();
    
	j(window).load(function(){
		
	});
	

    
    
    if( j('.widget-instagram').length ){
        var feed = new Instafeed({
            get: 'user',
            userId: '212360053',
            template: '<a href="{{link}}" class="item" style="background-image:url({{image}})"><img src="https://www.ringtv.com/wp-content/themes/thering/images/blank-feed.gif" /></a>',
            resolution: 'thumbnail',
            accessToken: '212360053.1677ed0.632fb768c9ee4638aad573370c8a61fd',
            limit: 6,
            target: 'insta-feed'
        });
        feed.run();   
    }
   
    
    
</script>
</body>
</html>