<!DOCTYPE html>
<html>
<head>
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta name="generator" content="WordPress 4.7.5"/>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>
<title>Badou Jack: Original plan was to fight Adonis Stevenson - The Ring</title>
<script src="/cdn-cgi/apps/head/sTZ1OmmcIFk8d3jz46qmP2UAby4.js"></script><link rel="apple-touch-icon" sizes="57x57" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-57x57.png">
<link rel="apple-touch-icon" sizes="60x60" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-60x60.png">
<link rel="apple-touch-icon" sizes="72x72" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-72x72.png">
<link rel="apple-touch-icon" sizes="76x76" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-76x76.png">
<link rel="apple-touch-icon" sizes="114x114" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-114x114.png">
<link rel="apple-touch-icon" sizes="120x120" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-120x120.png">
<link rel="apple-touch-icon" sizes="144x144" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-144x144.png">
<link rel="apple-touch-icon" sizes="152x152" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-152x152.png">
<link rel="apple-touch-icon" sizes="180x180" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-180x180.png">
<link rel="icon" type="image/png" sizes="192x192" href="https://www.ringtv.com/wp-content/themes/thering/images/android-icon-192x192.png">
<link rel="icon" type="image/png" sizes="32x32" href="https://www.ringtv.com/wp-content/themes/thering/images/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="96x96" href="https://www.ringtv.com/wp-content/themes/thering/images/favicon-96x96.png">
<link rel="icon" type="image/png" sizes="16x16" href="https://www.ringtv.com/wp-content/themes/thering/images/favicon-16x16.png">
<link rel="manifest" href="https://www.ringtv.com/wp-content/themes/thering/images/manifest.json">
<meta name="msapplication-TileColor" content="#ffffff">
<meta name="msapplication-TileImage" content="https://www.ringtv.com/wp-content/themes/thering/images/ms-icon-144x144.png">
<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="https://www.ringtv.com/feed/"/>
<link rel="alternate" type="text/xml" title="RSS .92" href="https://www.ringtv.com/feed/rss/"/>
<link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="https://www.ringtv.com/feed/atom/"/>
<link rel="pingback" href="https://www.ringtv.com/xmlrpc.php"/>
 <script data-cfasync="false" type="text/javascript">/*<![CDATA[*/(function (a, c, s, u){'Insticator'in a || (a.Insticator={ad:{loadAd: function (b){Insticator.ad.q.push(b)}, q: []}, helper:{}, embed:{}, version: "3.0", q: [], load: function (t, o){Insticator.q.push({t: t, o: o})}}); var b=c.createElement(s); b.src=u; b.async=!0; var d=c.getElementsByTagName(s)[0]; d.parentNode.insertBefore(b, d)})(window, document, 'script', '//d2na2p72vtqyok.cloudfront.net/client-embed/5f282198-b6f9-4fbf-9244-cfb0317339b5.js');/*]]>*/</script> 

<link rel="canonical" href="https://www.ringtv.com/515025-badou-jack-original-plan-fight-adonis-stevenson/"/>
<meta property="og:locale" content="en_US"/>
<meta property="og:type" content="article"/>
<meta property="og:title" content="Badou Jack: Original plan was to fight Adonis Stevenson - The Ring"/>
<meta property="og:description" content="Former 168-pound titleholder Badou Jack fights light heavyweight contender Nathan Cleverly on the Mayweather-McGregor undercard but he wanted lineal 175-pound champ Adonis Stevenson."/>
<meta property="og:url" content="https://www.ringtv.com/515025-badou-jack-original-plan-fight-adonis-stevenson/"/>
<meta property="og:site_name" content="The Ring"/>
<meta property="article:publisher" content="https://www.facebook.com/RingTV"/>
<meta property="article:tag" content="andre ward"/>
<meta property="article:tag" content="Andreas Hale"/>
<meta property="article:tag" content="badou jack"/>
<meta property="article:tag" content="Jack-Cleverly"/>
<meta property="article:tag" content="Mayweather-McGregor"/>
<meta property="article:tag" content="nathan cleverly"/>
<meta property="article:section" content="Boxing"/>
<meta property="article:published_time" content="2017-08-24T13:02:33+00:00"/>
<meta property="article:modified_time" content="2017-08-24T13:03:37+00:00"/>
<meta property="og:updated_time" content="2017-08-24T13:03:37+00:00"/>
<meta property="og:image" content="https://www.ringtv.com/wp-content/uploads/2017/08/029_Badou_Jack_esther-lin_vox-media.jpg"/>
<meta property="og:image:secure_url" content="https://www.ringtv.com/wp-content/uploads/2017/08/029_Badou_Jack_esther-lin_vox-media.jpg"/>
<meta property="og:image:width" content="1200"/>
<meta property="og:image:height" content="800"/>
<meta name="twitter:card" content="summary"/>
<meta name="twitter:description" content="Former 168-pound titleholder Badou Jack fights light heavyweight contender Nathan Cleverly on the Mayweather-McGregor undercard but he wanted lineal 175-pound champ Adonis Stevenson."/>
<meta name="twitter:title" content="Badou Jack: Original plan was to fight Adonis Stevenson - The Ring"/>
<meta name="twitter:site" content="@ringmagazine"/>
<meta name="twitter:image" content="https://www.ringtv.com/wp-content/uploads/2017/08/029_Badou_Jack_esther-lin_vox-media.jpg"/>
<meta name="twitter:creator" content="@ringmagazine"/>

<link rel="dns-prefetch" href="//js.stripe.com"/>
<link rel="dns-prefetch" href="//ajax.googleapis.com"/>
<link rel="dns-prefetch" href="//s.w.org"/>
<link rel="alternate" type="application/rss+xml" title="The Ring &raquo; Badou Jack: Original plan was to fight Adonis Stevenson Comments Feed" href="https://www.ringtv.com/515025-badou-jack-original-plan-fight-adonis-stevenson/feed/"/>
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.ringtv.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.5"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel="stylesheet" id="validate-engine-css-css" href="https://www.ringtv.com/wp-content/plugins/wysija-newsletters/css/validationEngine.jquery.css?ver=2.7.11.3" type="text/css" media="all"/>
<link rel="stylesheet" id="contact-form-7-css" href="https://www.ringtv.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.8.1" type="text/css" media="all"/>
<link rel="stylesheet" id="dashicons-css" href="https://www.ringtv.com/wp-includes/css/dashicons.min.css?ver=4.7.5" type="text/css" media="all"/>
<link rel="stylesheet" id="wpp_style-css" href="https://www.ringtv.com/wp-content/plugins/wp-poll/assets/front/css/style.css?ver=4.7.5" type="text/css" media="all"/>
<link rel="stylesheet" id="font-awesome-css" href="https://www.ringtv.com/wp-content/plugins/wp-poll/assets/global/css/font-awesome.css?ver=4.7.5" type="text/css" media="all"/>
<link rel="stylesheet" id="access_ads_style-css" href="https://www.ringtv.com/wp-content/plugins/accessads//css/minimal.css?ver=1.1.0" type="text/css" media="all"/>
<link rel="stylesheet" id="jquery-issuem-flexslider-css" href="https://www.ringtv.com/wp-content/plugins/issuem/css/flexslider.css?ver=2.7.1" type="text/css" media="all"/>
<link rel="stylesheet" id="issuem-leaky-paywall-article-countdown-nag-css" href="https://www.ringtv.com/wp-content/plugins/leaky-paywall-article-countdown-nag//css/article-countdown-nag-slim.css?ver=3.1.0" type="text/css" media="all"/>
<link rel="stylesheet" id="leaky-paywall-coupons-css-css" href="https://www.ringtv.com/wp-content/plugins/leaky-paywall-coupons//css/leaky-paywall-coupons.css?ver=1.4.0" type="text/css" media="all"/>
<link rel="stylesheet" id="jquery-style-css" href="//ajax.googleapis.com/ajax/libs/jqueryui/1.11.2/themes/smoothness/jquery-ui.css?ver=4.7.5" type="text/css" media="all"/>
<link rel="stylesheet" id="lp-gift-style-css" href="https://www.ringtv.com/wp-content/plugins/leaky-paywall-gift-subscriptions//css/lp-gift.css?ver=2.6.0" type="text/css" media="all"/>
<link rel="stylesheet" id="issuem-leaky-paywall-css" href="https://www.ringtv.com/wp-content/plugins/leaky-paywall//css/issuem-leaky-paywall.css?ver=4.8.0" type="text/css" media="all"/>
<link rel="stylesheet" id="unipress-api-css" href="https://www.ringtv.com/wp-content/plugins/unipress-api//css/unipress.css?ver=1.15.0" type="text/css" media="all"/>
<link rel="stylesheet" id="flexslider-css" href="https://www.ringtv.com/wp-content/themes/thering/css/flexslider.css" type="text/css" media="all"/>
<link rel="stylesheet" id="fontawesome-css" href="https://www.ringtv.com/wp-content/themes/thering/css/font-awesome.css" type="text/css" media="all"/>
<link rel="stylesheet" id="normalize-css" href="https://www.ringtv.com/wp-content/themes/thering/css/normalize.css" type="text/css" media="all"/>
<link rel="stylesheet" id="grid12-css" href="https://www.ringtv.com/wp-content/themes/thering/css/grid12.css" type="text/css" media="all"/>
<link rel="stylesheet" id="movingboxes-css" href="https://www.ringtv.com/wp-content/themes/thering/css/movingboxes.css" type="text/css" media="all"/>
<link rel="stylesheet" id="customscrollbar-css" href="https://www.ringtv.com/wp-content/themes/thering/css/jquery.mCustomScrollbar.css" type="text/css" media="all"/>
<link rel="stylesheet" id="owlcarousel-css" href="https://www.ringtv.com/wp-content/themes/thering/css/owl.carousel.css" type="text/css" media="all"/>
<link rel="stylesheet" id="fancybox-css" href="https://www.ringtv.com/wp-content/themes/thering/css/jquery.fancybox.css" type="text/css" media="all"/>
<link rel="stylesheet" id="stylesheet-css" href="https://www.ringtv.com/wp-content/themes/thering/style.css?ver=0d09f3d478fb88ba939219b1d9c56383" type="text/css" media="all"/>
<link rel="stylesheet" id="responsive-css" href="https://www.ringtv.com/wp-content/themes/thering/css/responsive.css?ver=0d09f3d478fb88ba939219b1d9c56383" type="text/css" media="all"/>
<script type="text/javascript" src="https://www.ringtv.com/wp-includes/js/jquery/jquery.js?ver=1.12.4"></script>
<script type="text/javascript" src="https://www.ringtv.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1"></script>
<script type="text/javascript">
/* <![CDATA[ */
var wpp_ajax = {"wpp_ajaxurl":"https:\/\/www.ringtv.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type="text/javascript" src="https://www.ringtv.com/wp-content/plugins/wp-poll/assets/front/js/scripts.js?ver=4.7.5"></script>
<script type="text/javascript" src="https://www.ringtv.com/wp-content/plugins/issuem/js/jquery.flexslider-min.js?ver=2.7.1"></script>
<script type="text/javascript" src="https://www.ringtv.com/wp-content/plugins/leaky-paywall-article-countdown-nag//js/article-countdown-nag.js?ver=3.1.0"></script>
<script type="text/javascript" src="https://www.ringtv.com/wp-content/plugins/leaky-paywall-coupons/js/leaky-paywall-coupons.js?ver=1.4.0"></script>
<script type="text/javascript" src="https://www.ringtv.com/wp-content/plugins/leaky-paywall-gift-subscriptions//js/lp-gift.js?ver=2.6.0"></script>
<script type="text/javascript">
/* <![CDATA[ */
var ajax_object = {"ajax_url":"https:\/\/www.ringtv.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type="text/javascript" src="https://www.ringtv.com/wp-content/plugins/unipress-api//js/unipress.js?ver=1.15.0"></script>
<script type="text/javascript" src="https://www.ringtv.com/wp-content/themes/thering/js/countdown.js"></script>
<script type="text/javascript" src="https://js.stripe.com/v2/?ver=4.7.5"></script>
<link rel="https://api.w.org/" href="https://www.ringtv.com/wp-json/"/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.ringtv.com/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.ringtv.com/wp-includes/wlwmanifest.xml"/>
<meta name="generator" content="WordPress 4.7.5"/>
<link rel="shortlink" href="https://www.ringtv.com/?p=515025"/>
<link rel="alternate" type="application/json+oembed" href="https://www.ringtv.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ringtv.com%2F515025-badou-jack-original-plan-fight-adonis-stevenson%2F"/>
<link rel="alternate" type="text/xml+oembed" href="https://www.ringtv.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ringtv.com%2F515025-badou-jack-original-plan-fight-adonis-stevenson%2F&#038;format=xml"/>
</head>
<body class="post-template-default single single-post postid-515025 single-format-standard loading badou-jack-original-plan-fight-adonis-stevenson unknown">
<div id="mobile-nav">
<a href="#" class="btn-close-mob"></a>
<div class="mob-logo"><img src="https://www.ringtv.com/wp-content/themes/thering/images/ring-logo.png" alt></div>
<ul id="menu-main-menu" class="mob-nav"><li id="menu-item-151" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-151"><a href="https://www.ringtv.com/">Home</a></li>
<li id="menu-item-152" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-has-children menu-item-152"><a href="https://www.ringtv.com/news/">News</a></li>
<li id="menu-item-158" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-158"><a href="https://www.ringtv.com/videos/">Videos</a></li>
<li id="menu-item-153" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-153"><a href="https://www.ringtv.com/photos/">Photos</a></li>
<li id="menu-item-155" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-155"><a href="https://www.ringtv.com/ratings/">Ratings</a></li>
<li id="menu-item-156" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156"><a href="https://www.ringtv.com/schedule/">Schedule</a></li>
<li id="menu-item-249" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-249"><a target="_blank" href="https://esolutionsmnec.ecenergy.com/eCatalog/Account/AnonymousLogon/38?customerName=RING">Shop</a></li>
<li id="menu-item-494633" class="hlogin-btn menu-item menu-item-type-post_type menu-item-object-page menu-item-494633"><a href="https://www.ringtv.com/subscription-login/">Login</a></li>
<li id="menu-item-494630" class="hsubscribe-btn menu-item menu-item-type-post_type menu-item-object-page menu-item-494630"><a href="https://www.ringtv.com/subscription/">Subscribe</a></li>
</ul> <ul class="mobile-nav-social">
<li><a href="https://www.ringtv.com/search"><i class="fa fa-search"></i></a></li>
<li><a href="https://www.facebook.com/RingTV" target="_blank"><i class="fa fa-facebook"></i></a></li> <li><a href="https://www.youtube.com/user/TheRingDigital?sub_confirmation=1" target="_blank"><i class="fa fa-youtube"></i></a></li> <li><a href="https://twitter.com/ringmagazine" target="_blank"><i class="fa fa-twitter"></i></a></li> <li><a href="https://instagram.com/ringtv" target="_blank"><i class="fa fa-instagram"></i></a></li> </ul>
</div>
<div class="header">
<div class="header-inner">
<a href="https://www.ringtv.com" class="logo"><img src="https://www.ringtv.com/wp-content/themes/thering/images/ring-logo.png" alt></a>
<ul id="menu-main-menu-1" class="main-nav"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-151"><a href="https://www.ringtv.com/">Home</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-has-children menu-item-152"><a href="https://www.ringtv.com/news/">News</a>
<ul class="sub-menu">
<li id="menu-item-458877" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-458877"><a href="https://www.ringtv.com/category/boxing/">Boxing</a></li>
<li id="menu-item-163" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163"><a href="https://www.ringtv.com/category/mma/">MMA</a></li>
<li id="menu-item-164" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164"><a href="https://www.ringtv.com/category/press-releases/">Press Releases</a></li>
<li id="menu-item-161" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-161"><a href="https://www.ringtv.com/category/exclusive-editorial/">Exclusive Editorial</a></li>
<li id="menu-item-506556" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-506556"><a href="https://www.ringtv.com/canelo-vs-ggg/">Canelo VS GGG Fight Hub</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-158"><a href="https://www.ringtv.com/videos/">Videos</a>
<ul class="sub-menu">
<li id="menu-item-165" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-165"><a href="https://www.ringtv.com/videos/">Latest</a></li>
<li id="menu-item-166" class="menu-item menu-item-type-taxonomy menu-item-object-video_cat menu-item-166"><a href="https://www.ringtv.com/video-category/featured/">Featured</a></li>
<li id="menu-item-167" class="menu-item menu-item-type-taxonomy menu-item-object-video_cat menu-item-167"><a href="https://www.ringtv.com/video-category/classic-fights/">Classic Fights</a></li>
<li id="menu-item-168" class="menu-item menu-item-type-taxonomy menu-item-object-video_cat menu-item-168"><a href="https://www.ringtv.com/video-category/live-events/">Live Events</a></li>
<li id="menu-item-507158" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-507158"><a href="https://www.ringtv.com/canelo-ggg-ppv/">Canelo VS GGG Online PPV</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-153"><a href="https://www.ringtv.com/photos/">Photos</a>
<ul class="sub-menu">
<li id="menu-item-169" class="menu-item menu-item-type-taxonomy menu-item-object-photo_cat menu-item-169"><a href="https://www.ringtv.com/photo-category/featured/">Featured</a></li>
<li id="menu-item-171" class="menu-item menu-item-type-taxonomy menu-item-object-photo_cat menu-item-171"><a href="https://www.ringtv.com/photo-category/classic/">Classic</a></li>
<li id="menu-item-170" class="menu-item menu-item-type-taxonomy menu-item-object-photo_cat menu-item-170"><a href="https://www.ringtv.com/photo-category/boxing/">Boxing</a></li>
<li id="menu-item-172" class="menu-item menu-item-type-taxonomy menu-item-object-photo_cat menu-item-172"><a href="https://www.ringtv.com/photo-category/mma/">MMA</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-155"><a href="https://www.ringtv.com/ratings/">Ratings</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156"><a href="https://www.ringtv.com/schedule/">Schedule</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-249"><a target="_blank" href="https://esolutionsmnec.ecenergy.com/eCatalog/Account/AnonymousLogon/38?customerName=RING">Shop</a></li>
<li class="hlogin-btn menu-item menu-item-type-post_type menu-item-object-page menu-item-494633"><a href="https://www.ringtv.com/subscription-login/">Login</a></li>
<li class="hsubscribe-btn menu-item menu-item-type-post_type menu-item-object-page menu-item-494630"><a href="https://www.ringtv.com/subscription/">Subscribe</a></li>
</ul>
<div class="mobile-menu-btn"><i class="fa fa-bars"></i></div>
<ul class="head-social">
<li><a href="https://www.ringtv.com/search"><i class="fa fa-search"></i></a></li>
<li><a href="https://www.facebook.com/RingTV" target="_blank"><i class="fa fa-facebook"></i></a></li> <li><a href="https://www.youtube.com/user/TheRingDigital?sub_confirmation=1" target="_blank"><i class="fa fa-youtube"></i></a></li> <li><a href="https://twitter.com/ringmagazine" target="_blank"><i class="fa fa-twitter"></i></a></li> <li><a href="https://instagram.com/ringtv" target="_blank"><i class="fa fa-instagram"></i></a></li> </ul>
<div style="display:none">
</div>
</div>
</div>
<div class="sub-header">
<div class="wrap-inner">
<h1>News</h1>
<div class="ads728-90"><div class="addrop-wrap" data-id="499853"><script id="mNCC" language="javascript">
   medianet_width = "728";
   medianet_height = "90";
   medianet_crid = "766595921";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUV3K88Q' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script>
</div></div>
</div>
</div>
<div class="sub-content-wrap">
<div class="a-d-wrap">
<div class="wrap-inner">
<div class="row">
<div class="col-lg-8 col-md-8 col-sm-12 col-xs-12 news-content">
<div class="full-post">
<h1 class="xxxxxxxxxxxx">Badou Jack: Original plan was to fight Adonis Stevenson</h1>
</div>
</div>
</div>
<div class="row">
<div class="col-lg-8 col-md-8 col-sm-8 col-xs-12 news-content">
<div class="full-post">
<div class="imagebox"><img src="https://www.ringtv.com/wp-content/uploads/2017/08/029_Badou_Jack_esther-lin_vox-media-770x513.jpg" alt></div>
<div class="image-desc">Photo / Esther Lin-Vox Media</div>

<div class="a-d-468x60-post hidden-md visible-sm visible-xs"><div class="addrop-wrap" data-id="499862"><script id="mNCC" language="javascript">
   medianet_width = "468";
   medianet_height = "60";
   medianet_crid = "887466222";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUV3K88Q' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script></div></div>
<div class="text-wrap">
<div class="date-col">
<div class="day">24</div>
<div class="month">Aug</div>
</div>
<div class="a-d-468x60-post hidden-sm hidden-xs"><div class="addrop-wrap" data-id="499862"><script id="mNCC" language="javascript">
   medianet_width = "468";
   medianet_height = "60";
   medianet_crid = "887466222";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUV3K88Q' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script></div></div>
<div class="a-d-120x600-post"><div class="addrop-wrap" data-id="499864"><script id="mNCC" language="javascript">
   medianet_width = "120";
   medianet_height = "600";
   medianet_crid = "601834232";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUV3K88Q' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script>
</div></div>
<div class="posted-by"><a href="https://www.ringtv.com/author/andreas-hale/">by Andreas Hale</a></div>
<p>The undercard for the Floyd Mayweather vs. Conor McGregor superfight came together quite slowly for an event of this magnitude. Although Badou Jack knew he was going to be on the card, he didn’t have a clue who he would end up stepping into the ring with on August 26 until about a month before the fight. But the Swedish boxer who now resides in Las Vegas will face Nathan Cleverly as he makes the leap to light heavyweight after a successful campaign as a super middleweight.</p>
<p>RingTV.com spoke to Jack (21-1-2, 12 knockouts) inside of the Mayweather Boxing Club and found out that Jack had his sights set on another opponent for his light heavyweight debut.</p>
<p>“The original plan all along was to fight (WBC and lineal light heavyweight champion) Adonis Stevenson and that plan was even before the fight with James DeGale,” Jack said while explaining that he wasn’t sure why Stevenson wasn’t interested in being on the biggest combat sports card in history. “I don’t know (why he didn’t want to fight me). We haven’t negotiated but it seems like he doesn’t want to fight top guys.”</p>
<p>It’s a fascinating reveal that came a week before Jack fights at the T-Mobile Arena in Las Vegas. Jack wasn’t quite sure of the details as to why that fight didn’t come together but was confident in saying that Stevenson was who he wanted to face and partially the reason the undercard was announced at such a late stage.</p>
<p>But with Cleverly (30-3, 16 KOs) being his primary focus, Jack says he isn’t disappointed at all with his new opponent and plans to begin his campaign at light heavyweight with a bang on Saturday night. Should he dispatch of Cleverly, Badou has his sights set on the biggest and best the light heavyweight division has to offer.</p>
<p>“I want the big money fights,” Jack said. “I want to get paid and test myself against the best. Adonis is one of the best. I heard that Andre Ward might leave the division. But he’s the best pound for pound fighter in the world so that should be everybody’s goal to fight him. It’s not everyone’s but it should be. I’d love to fight him because he’s the best. Why not?”</p>
<div class="clearboth"></div>
<div class="a-d-468x60-post hidden-sm hidden-xs"><div class="addrop-wrap" data-id="499862"><script id="mNCC" language="javascript">
   medianet_width = "468";
   medianet_height = "60";
   medianet_crid = "887466222";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUV3K88Q' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script></div></div>
</div>
<div class="a-d-468x60-post hidden-md visible-sm visible-xs"><div class="addrop-wrap" data-id="499862"><script id="mNCC" language="javascript">
   medianet_width = "468";
   medianet_height = "60";
   medianet_crid = "887466222";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUV3K88Q' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script></div></div>
<div class="share-story">
<div class="title-text">Share this story</div>
<ul class="share-social">
<li><a href="#" class="addthis_button_facebook"><i class="fa fa-facebook"></i></a></li>
<li><a href="#" class="addthis_button_twitter"><i class="fa fa-twitter"></i></a></li>
</ul>
</div>
<div class="comment-app">
<div id="disqus_thread">
<div id="dsq-content">
<ul id="dsq-comments">
<li class="comment even thread-even depth-1" id="dsq-comment-170604">
<div id="dsq-comment-header-170604" class="dsq-comment-header">
<cite id="dsq-cite-170604">
<span id="dsq-author-user-170604">Antony916</span>
</cite>
</div>
<div id="dsq-comment-body-170604" class="dsq-comment-body">
<div id="dsq-comment-message-170604" class="dsq-comment-message"><p>Jack is to big a threat for Stevenson, its pretty simple.</p>
</div>
</div>
<ul class="children">
<li class="comment odd alt depth-2" id="dsq-comment-170609">
<div id="dsq-comment-header-170609" class="dsq-comment-header">
<cite id="dsq-cite-170609">
<span id="dsq-author-user-170609">Wade Wilson</span>
</cite>
</div>
<div id="dsq-comment-body-170609" class="dsq-comment-body">
<div id="dsq-comment-message-170609" class="dsq-comment-message"><p>When I think about the light heavies I don&#8217;t think of Stevenson at all. Literally, I really mean it! I forget all about him, he&#8217;s out of my brain unless he&#8217;s mentioned.</p>
</div>
</div>
</li>
<li class="comment even depth-2" id="dsq-comment-170610">
<div id="dsq-comment-header-170610" class="dsq-comment-header">
<cite id="dsq-cite-170610">
<span id="dsq-author-user-170610">Chris Gonzalez</span>
</cite>
</div>
<div id="dsq-comment-body-170610" class="dsq-comment-body">
<div id="dsq-comment-message-170610" class="dsq-comment-message"><p>Exactly right. Stevenson wont fight anyone ranked top 5.</p>
</div>
</div>
</li>
</ul>
</li>
</ul>
</div>
</div>
</div>
</div>
</div>
<div class="col-lg-4 col-md-4 col-sm-4 col-xs-12 right-sidebar">
<div id="ad_dropper_widget-2" class="widget-odd widget-first widget-1 each-block widget_ad_dropper_widget"><div class="addrop-wrap" data-id="504640">
<div id="insticator-container"><div id="div-insticator-ad-1"></div><div id="insticator-embed"></div><div id="div-insticator-ad-2"></div><script data-cfasync="false" type="text/javascript">/*<![CDATA[*/Insticator.ad.loadAd("div-insticator-ad-1");Insticator.ad.loadAd("div-insticator-ad-2");Insticator.load("em",{id : "57efe63a-5598-4f49-989d-174127a70538"})/*]]>*/</script></div>
</div></div><div id="callouts-2" class="widget-even widget-2 each-block widget_callouts box-img">
<ul class="most-active-posts">
<li>
<div class="thumbnail"><a href="https://www.ringtv.com/515055-business-mayweather-mcgregor/">
<img src="https://www.ringtv.com/wp-content/uploads/2017/08/contents-maymac-bus-80x80.jpg" alt="The business of Mayweather-McGregor"/>
</a>
</div>
<div class="text-wrap">
<a class="title" href="https://www.ringtv.com/515055-business-mayweather-mcgregor/">The business of Mayweather-McGregor</a>
<div class="posted-by">by Mike Coppinger</div>
</div>
</li>
<li>
<div class="thumbnail"><a href="https://www.ringtv.com/514819-miguel-cotto-wont-fight-2018-beyond-no-matter/">
<img src="https://www.ringtv.com/wp-content/uploads/2017/05/Miguel-Cotto-KamegaiPC_Hoganphotos-80x80.jpg" alt="Miguel Cotto: I won&#8217;t fight in 2018 or beyond &#8216;no matter what&#8217;"/>
</a>
</div>
<div class="text-wrap">
<a class="title" href="https://www.ringtv.com/514819-miguel-cotto-wont-fight-2018-beyond-no-matter/">Miguel Cotto: I won&#8217;t fight in 2018 or beyond &#8216;no matter what&#8217;</a>
<div class="posted-by">by Mike Coppinger</div>
</div>
</li>
<li>
<div class="thumbnail"><a href="https://www.ringtv.com/505587-jermell-charlo-erickson-lubin-lara-gausha-title-tilts-agreed/">
<img src="https://www.ringtv.com/wp-content/uploads/2017/06/Jermell-Charlo-80x80.jpg" alt="Jermell Charlo-Erickson Lubin tops 154-pound title tripleheader on Oct. 14"/>
</a>
</div>
<div class="text-wrap">
<a class="title" href="https://www.ringtv.com/505587-jermell-charlo-erickson-lubin-lara-gausha-title-tilts-agreed/">Jermell Charlo-Erickson Lubin tops 154-pound title tripleheader on Oct. 14</a>
<div class="posted-by">by Mike Coppinger</div>
</div>
</li>
<li>
<div class="thumbnail"><a href="https://www.ringtv.com/515025-badou-jack-original-plan-fight-adonis-stevenson/">
<img src="https://www.ringtv.com/wp-content/uploads/2017/08/029_Badou_Jack_esther-lin_vox-media-80x80.jpg" alt="Badou Jack: Original plan was to fight Adonis Stevenson"/>
</a>
</div>
<div class="text-wrap">
<a class="title" href="https://www.ringtv.com/515025-badou-jack-original-plan-fight-adonis-stevenson/">Badou Jack: Original plan was to fight Adonis Stevenson</a>
<div class="posted-by">by Andreas Hale</div>
</div>
</li>
<li>
<div class="thumbnail"><a href="https://www.ringtv.com/515000-filipino-brit-john-marvin-wins-sea-games-gold-in-21-seconds/">
<img src="https://www.ringtv.com/wp-content/uploads/2017/08/SEA-2017-Kuala-Lumpur_logo-80x80.jpg" alt="Filipino-Brit John Marvin wins SEA Games gold in 21 seconds"/>
</a>
</div>
<div class="text-wrap">
<a class="title" href="https://www.ringtv.com/515000-filipino-brit-john-marvin-wins-sea-games-gold-in-21-seconds/">Filipino-Brit John Marvin wins SEA Games gold in 21 seconds</a>
<div class="posted-by">by Ryan Songalia</div>
</div>
</li>
</ul>
</div><div id="ad_dropper_widget-3" class="widget-odd widget-3 each-block widget_ad_dropper_widget"><div class="addrop-wrap" data-id="499855"><script id="mNCC" language="javascript">
   medianet_width = "200";
   medianet_height = "200";
   medianet_crid = "227933193";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUV3K88Q' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script></div></div><div id="text-6" class="widget-even widget-4 current-poll each-block widget_text"><h2>Current Poll</h2> <div class="textwidget"><script type="text/javascript" charset="utf-8" src="https://secure.polldaddy.com/p/9796934.js"></script>
<noscript><a href="http://polldaddy.com/poll/9796934/">What will be the result of the Canelo Alvarez-Gennady Golovkin fight?</a></noscript></div>
</div><div id="ad_dropper_widget-4" class="widget-odd widget-5 each-block widget_ad_dropper_widget"><div class="addrop-wrap" data-id="499858"><center><a href="https://bit.ly/fightersnetwork" target="_blank" rel="noopener noreferrer"><img src="https://www.ringtv.com/custom-ads/fightersnetwork/160x90/160x90FN.png"/></a></center></div></div><div id="extension-slug-widget--2" class="widget-even widget-last widget-6 each-block widget_callouts box-img">
<h2>Ratings: Pound for Pound</h2>
<div class="boxer-ratings">
<div class="each-row">
<div class="imagebox">
<img src="https://www.ringtv.com/wp-content/uploads/2016/07/Andre-Ward-ratings_Hoganphotos6-270x270.jpg" alt="Andre Ward"/>
</div>
<div class="number">1</div>
<div class="text">Andre Ward</div>
<div class="text">Record: 32-0-0 (16 KOs)</div> </div>
<div class="each-row">
<div class="imagebox">
<img src="https://www.ringtv.com/wp-content/uploads/2016/08/gennady-golovkin-ratings-fukuda-270x270.jpg" alt="Gennady Golovkin"/>
</div>
<div class="number">2</div>
<div class="text">Gennady Golovkin</div>
<div class="text">Record: 37-0-0 (33 KOs)</div> </div>
<div class="each-row">
<div class="imagebox">
<img src="https://www.ringtv.com/wp-content/uploads/2016/11/Terence-Crawford-ratings-270x270.jpg" alt="Terence Crawford"/>
</div>
<div class="number">3</div>
<div class="text">Terence Crawford</div>
<div class="text">Record: 32-0-0 (23 KOs)</div> </div>
<div class="each-row">
<div class="imagebox">
<img src="https://www.ringtv.com/wp-content/uploads/2016/07/roman-gonzalez-ratings-fukuda-270x270.jpg" alt="Roman Gonzalez"/>
</div>
<div class="number">4</div>
<div class="text">Roman Gonzalez</div>
<div class="text">Record: 46-1-0 (38 KOs)</div> </div>
<div class="each-row">
<div class="imagebox">
<img src="https://www.ringtv.com/wp-content/uploads/2016/07/Vasyl-Lomachenko-ratings-270x270.jpg" alt="Vasyl Lomachenko"/>
</div>
<div class="number">5</div>
<div class="text">Vasyl Lomachenko</div>
<div class="text">Record: 9-1-0 (7 KOs)</div> </div>
<div class="each-row">
<div class="imagebox">
<img src="https://www.ringtv.com/wp-content/uploads/2016/07/rigondeaux-ratings-270x270.jpg" alt="Guillermo Rigondeaux"/>
</div>
<div class="number">6</div>
<div class="text">Guillermo Rigondeaux</div>
<div class="text">Record: 17-0-0 (11 KOs)</div> </div>
<div class="each-row">
<div class="imagebox">
<img src="https://www.ringtv.com/wp-content/uploads/2016/07/Sergey-Kovalev-ratings-270x270.jpg" alt="Sergey Kovalev"/>
</div>
<div class="number">7</div>
<div class="text">Sergey Kovalev</div>
<div class="text">Record: 30-2-1 (26 KOs)</div> </div>
<div class="each-row">
<div class="imagebox">
<img src="https://www.ringtv.com/wp-content/uploads/2016/07/canelo-e1473365393257-270x270.jpg" alt="Canelo Alvarez"/>
</div>
<div class="number">8</div>
<div class="text">Canelo Alvarez</div>
 <div class="text">Record: 49-1-1 (34 KOs)</div> </div>
<div class="each-row">
<div class="imagebox">
<img src="https://www.ringtv.com/wp-content/uploads/2017/01/Mikey_Garcia-ratings-_esther-lin-showtime-270x270.jpg" alt="Mikey Garcia"/>
</div>
<div class="number">9</div>
<div class="text">Mikey Garcia</div>
<div class="text">Record: 37-0-0 (30 KOs)</div> </div>
<div class="each-row">
<div class="imagebox">
<img src="https://www.ringtv.com/wp-content/uploads/2016/11/Naoya-Inoue-ratings-270x270.jpg" alt="Naoya Inoue"/>
</div>
<div class="number">10</div>
<div class="text">Naoya Inoue</div>
<div class="text">Record: 13-0-0 (11 KOs)</div> </div>
</div>
</div>
</div>
</div>
<div class="clearboth"></div>
</div>
</div> 
</div>
<div class="footer-wrap">
<div class="bg-top"></div>
<div class="wrap-inner">
<a class="foot-go-top-btn visible-xs" href="#"></a>
<div class="row">
<div class="col-lg-3 col-md-3 col-sm-6 col-xs-12 hidden-xs">
<div class="foot-logo"><img src="https://www.ringtv.com/wp-content/themes/thering/images/ring-logo.png" alt></div>
<div class="foot-small-desc">Your destination for the best boxing news, videos and live streams!</div>
<ul class="foot-social">
<li><a href="https://www.facebook.com/RingTV" target="_blank"><i class="fa fa-facebook"></i></a></li> <li><a href="https://www.youtube.com/user/TheRingDigital?sub_confirmation=1" target="_blank"><i class="fa fa-youtube"></i></a></li> <li><a href="https://twitter.com/ringmagazine" target="_blank"><i class="fa fa-twitter"></i></a></li> <li><a href="https://instagram.com/ringtv" target="_blank"><i class="fa fa-instagram"></i></a></li> </ul>
</div>
<div class="col-xs-12 hidden-lg hidden-md hidden-sm visible-xs">
<h3>Quicklinks</h3>
<ul id="menu-footer-menu" class="foot-quicklinks"><li id="menu-item-186" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-186"><a href="https://www.ringtv.com/terms-conditions/">Terms &#038; Conditions</a></li>
<li id="menu-item-185" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-185"><a href="https://www.ringtv.com/privacy-policy/">Privacy Policy</a></li>
</ul> </div>
<div class="col-lg-3 col-md-3 col-sm-6 col-xs-12">
<h3>Contact Us</h3>
<div class="contact-info-row">
<span class="icon"><i class="fa fa-home"></i></span>
P.O. Box 90254<br> Brooklyn, NY 11209 </div>
<div class="contact-info-row">
<span class="icon"><i class="fa fa-phone"></i></span>
<a class="telnum" href="tel:+">215-643-3069</a>
</div>
<div class="contact-info-row">
<span class="icon"><i class="fa fa-envelope-o"></i></span>
<a class="email" href="/cdn-cgi/l/email-protection#592a2c2929362b2d192b30373e2d2f773a3634"><span class="__cf_email__" data-cfemail="483b3d3838273a3c083a21262f3c3e662b2725">[email&#160;protected]</span></a>
</div>
</div>
<div class="col-lg-3 col-md-3 col-sm-6 col-xs-12 hidden-xs">
<h3>Quicklinks</h3>
<ul id="menu-quicklinks" class="foot-quicklinks"><li id="menu-item-178" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-178"><a href="https://www.ringtv.com/about-us/">About Us/Staff</a></li>
<li id="menu-item-179" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-179"><a href="https://www.ringtv.com/contact-us/">Contact Us/Advertise</a></li>
<li id="menu-item-180" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-180"><a href="https://www.ringtv.com/subscribe/">Subscribe</a></li>
</ul> </div>
<div class="col-lg-3 col-md-3 col-sm-6 col-xs-12 hidden-xs">
<h3>Join Our Newsletter</h3> <div class="foot-newsletter">
<div class="desc">Join our newsletter to get info about latest events and deals!</div>
<script>!function(e,t,r,a,n,c,l,o){function h(e,t,r,a){for(r='',a='0x'+e.substr(t,2)|0,t+=2;t<e.length;t+=2)r+=String.fromCharCode('0x'+e.substr(t,2)^a); return r}try{for(n=e.getElementsByTagName('a'),l='/cdn-cgi/l/email-protection#',o=l.length,a=0;a<n.length;a++)try{c=n[a],t=c.href.indexOf(l),t>-1&&(c.href='mailto:'+h(c.href,t+o))}catch(f){}for(n=Array.prototype.slice.apply(e.getElementsByClassName('__cf_email__')),a=0;a<n.length;a++)try{c=n[a],c.parentNode.replaceChild(e.createTextNode(h(c.getAttribute('data-cfemail'),0)),c)}catch(f){}}catch(f){}}(document)</script><script type="text/javascript">(function() {
	if (!window.mc4wp) {
		window.mc4wp = {
			listeners: [],
			forms    : {
				on: function (event, callback) {
					window.mc4wp.listeners.push({
						event   : event,
						callback: callback
					});
				}
			}
		}
	}
})();
</script><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-462750" method="post" data-id="462750" data-name="Newsletter Subscription"><div class="mc4wp-form-fields"><input class="textbox" type="email" name="EMAIL" placeholder="YOUR EMAIL ADDRESS" required/>
<input class="btn-light-pink" type="submit" value="Subscribe"><div style="display: none;"><input type="text" name="_mc4wp_honeypot" value tabindex="-1" autocomplete="off"/></div><input type="hidden" name="_mc4wp_timestamp" value="1503642283"/><input type="hidden" name="_mc4wp_form_id" value="462750"/><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1"/></div><div class="mc4wp-response"></div></form> </div>
</div>
<div class="col-xs-12 hidden-lg hidden-md hidden-sm visible-xs">
<ul class="foot-social">
<li><a href="https://www.facebook.com/RingTV" target="_blank"><i class="fa fa-facebook"></i></a></li> <li><a href="https://twitter.com/ringmagazine" target="_blank"><i class="fa fa-twitter"></i></a></li> <li><a href="https://instagram.com/ringtv" target="_blank"><i class="fa fa-instagram"></i></a></li> </ul>
<div class="foot-logo"><img src="https://www.ringtv.com/wp-content/themes/thering/images/ring-logo.png" alt></div>
<div class="foot-small-desc">Your destination for the best boxing news, videos and live streams!</div>
</div>
</div>
</div>
</div>
<div class="footer-bottom">
<div class="wrap-inner">
<ul id="menu-footer-menu-1" class="foot-btm-links"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-186"><a href="https://www.ringtv.com/terms-conditions/">Terms &#038; Conditions</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-185"><a href="https://www.ringtv.com/privacy-policy/">Privacy Policy</a></li>
</ul> <div class="copyright">&copy; 2017 RING TV LIVE. All rights reserved. </div>
</div>
</div>
<div style="display: none;">
<div class="subscribe-modal" id="subscribe-now">
<div class="inner">
<span class="modal-logo"><img src="https://www.ringtv.com/wp-content/themes/thering/images/ring-logo.png" alt></span>
<h4>Get Our Newsletter.</h4> <p>Subscribe to our newsletter to get the latest news, events and deals in your inbox!</p> <div class="clearfix"></div>
</div>
<div class="mc-form">
<div class="inner">
<script type="text/javascript">(function() {
	if (!window.mc4wp) {
		window.mc4wp = {
			listeners: [],
			forms    : {
				on: function (event, callback) {
					window.mc4wp.listeners.push({
						event   : event,
						callback: callback
					});
				}
			}
		}
	}
})();
</script><form id="mc4wp-form-2" class="mc4wp-form mc4wp-form-462750" method="post" data-id="462750" data-name="Newsletter Subscription"><div class="mc4wp-form-fields"><input class="textbox" type="email" name="EMAIL" placeholder="YOUR EMAIL ADDRESS" required/>
<input class="btn-light-pink" type="submit" value="Subscribe"><div style="display: none;"><input type="text" name="_mc4wp_honeypot" value tabindex="-1" autocomplete="off"/></div><input type="hidden" name="_mc4wp_timestamp" value="1503642283"/><input type="hidden" name="_mc4wp_form_id" value="462750"/><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-2"/></div><div class="mc4wp-response"></div></form> </div>
</div>
</div>
</div>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-7578637367237225",
    enable_page_level_ads: true
  });
</script>
<style></style><script type="text/javascript">(function() {function addEventListener(element,event,handler) {
	if(element.addEventListener) {
		element.addEventListener(event,handler, false);
	} else if(element.attachEvent){
		element.attachEvent('on'+event,handler);
	}
}function maybePrefixUrlField() {
	if(this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if( urlFields && urlFields.length > 0 ) {
	for( var j=0; j < urlFields.length; j++ ) {
		addEventListener(urlFields[j],'blur',maybePrefixUrlField);
	}
}/* test if browser supports date fields */
var testInput = document.createElement('input');
testInput.setAttribute('type', 'date');
if( testInput.type !== 'date') {

	/* add placeholder & pattern to all date fields */
	var dateFields = document.querySelectorAll('.mc4wp-form input[type="date"]');
	for(var i=0; i<dateFields.length; i++) {
		if(!dateFields[i].placeholder) {
			dateFields[i].placeholder = 'YYYY-MM-DD';
		}
		if(!dateFields[i].pattern) {
			dateFields[i].pattern = '[0-9]{4}-(0[1-9]|1[012])-(0[1-9]|1[0-9]|2[0-9]|3[01])';
		}
	}
}

})();</script><script type="text/javascript">
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.ringtv.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};
/* ]]> */
</script>
<script type="text/javascript" src="https://www.ringtv.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.8.1"></script>
<script type="text/javascript">
/* <![CDATA[ */
var addrop_script = {"ajaxurl":"https:\/\/www.ringtv.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type="text/javascript" src="https://www.ringtv.com/wp-content/plugins/ad-dropper/js/script.js?ver=1.2.0"></script>
<script type="text/javascript" src="https://www.ringtv.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4"></script>
<script type="text/javascript" src="https://www.ringtv.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.11.4"></script>
<script type="text/javascript">
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":1,"isRTL":false});});
</script>
<script type="text/javascript" src="https://www.ringtv.com/wp-content/themes/thering/js/jquery.flexslider.js"></script>
<script type="text/javascript" src="https://www.ringtv.com/wp-content/themes/thering/js/jquery.easing.js"></script>
<script type="text/javascript" src="https://www.ringtv.com/wp-content/themes/thering/js/jquery.movingboxes.js"></script>
<script type="text/javascript" src="https://www.ringtv.com/wp-content/themes/thering/js/instafeed.min.js"></script>
<script type="text/javascript" src="https://www.ringtv.com/wp-content/themes/thering/js/jquery.cycle2.min.js"></script>
<script type="text/javascript" src="https://www.ringtv.com/wp-content/themes/thering/js/jquery.mCustomScrollbar.concat.min.js"></script>
<script type="text/javascript" src="https://www.ringtv.com/wp-content/themes/thering/js/fitvids.min.js?ver=0d09f3d478fb88ba939219b1d9c56383"></script>
<script type="text/javascript" src="https://www.ringtv.com/wp-content/themes/thering/js/owl.carousel.min.js"></script>
<script type="text/javascript" src="https://www.ringtv.com/wp-content/themes/thering/js/jquery.lazy.min.js?ver=1.0.1"></script>
<script type="text/javascript" src="https://www.ringtv.com/wp-content/themes/thering/js/jquery.fancybox.pack.js"></script>
<script type="text/javascript" src="https://www.ringtv.com/wp-content/themes/thering/js/js.cookie.js"></script>
<script type="text/javascript" src="https://www.ringtv.com/wp-content/themes/thering/js/jquery.matchHeight.js"></script>
<script type="text/javascript" src="https://www.ringtv.com/tweetie.min.js"></script>
<script type="text/javascript">
/* <![CDATA[ */
var ajax_var = {"url":"https:\/\/www.ringtv.com\/wp-admin\/admin-ajax.php","nonce":"1f0c473387","template_url":"https:\/\/www.ringtv.com\/wp-content\/themes\/thering"};
/* ]]> */
</script>
<script type="text/javascript" src="https://www.ringtv.com/wp-content/themes/thering/js/global.js?ver=0d09f3d478fb88ba939219b1d9c56383"></script>
<script type="text/javascript" src="https://www.ringtv.com/wp-includes/js/wp-embed.min.js?ver=4.7.5"></script>
<script type="text/javascript">
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"platform":"wordpress@4.7.5","language":""},"disqusIdentifier":"515025 http:\/\/www.ringtv.com\/?p=515025","disqusShortname":"theringonline","disqusTitle":"Badou Jack: Original plan was to fight Adonis Stevenson","disqusUrl":"https:\/\/www.ringtv.com\/515025-badou-jack-original-plan-fight-adonis-stevenson\/","options":{"manualSync":false},"postId":"515025"};
/* ]]> */
</script>
<script type="text/javascript" src="https://www.ringtv.com/wp-content/plugins/disqus-comment-system/media/js/disqus.js?ver=4.7.5"></script>
<script type="text/javascript">
/* <![CDATA[ */
var countVars = {"disqusShortname":"theringonline"};
/* ]]> */
</script>
<script type="text/javascript" src="https://www.ringtv.com/wp-content/plugins/disqus-comment-system/media/js/count.js?ver=4.7.5"></script>
<script type="text/javascript">
/* <![CDATA[ */
var mc4wp_forms_config = [];
/* ]]> */
</script>
<script type="text/javascript" src="https://www.ringtv.com/wp-content/plugins/mailchimp-for-wp/assets/js/forms-api.min.js?ver=4.1.5"></script>
<!--[if lte IE 9]>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/mailchimp-for-wp/assets/js/third-party/placeholders.min.js?ver=4.1.5'></script>
<![endif]-->
<script type="text/javascript" src="https://www.springboardplatform.com/jsapi/embed"></script>
<script>
 (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
 (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
 m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
 })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

 ga('create', 'UA-77508658-1', 'auto');
 ga('send', 'pageview');

</script>

<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-5MLLG9"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-5MLLG9');</script>


<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-4ef3d09874f075c2"></script>
<script type="text/javascript">
    
	jQuery(function($){
		
		if( $('#user_login').length ){
			$('#user_login').attr('placeholder','EMAIL ADDRESS');
		}
		
		/*if( $('#leaky-paywall-gift-subscription-plans').length ){
			$('#leaky-paywall-gift-subscription-plans option[value=3]').remove();
		}*/
		
		if (typeof(Cookies.get('subscribemod')) == 'undefined' || Cookies.get('subscribemod') == null) {
			//cookie is not present
			
			$.fancybox( {href : '#subscribe-now', openEffect : 'none', closeEffect : 'none', padding : 0, closeClick : false, afterClose: function(){
				Cookies.set('subscribemod', 'done', { path: '/', expires: 7 });
			} } ); 
			
			$('.joinus-modal').on('click',function(){
				Cookies.set('subscribemod', 'done', { path: '/', expires: 365 });
				$(this).parents('form').submit();
			});
		}	
                
                
                

        

		
	
		


				$('select#leaky-paywall-gift-subscription-plans option:not(:nth-child(1))').remove();
					
	});
	
    var j = jQuery.noConflict();
    
	j(window).load(function(){
		
	});
	

    
    
</script>
</body>
</html>