<!DOCTYPE html>
<html>
<head>
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta name="generator" content="WordPress 4.7.5"/>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>
<title>Dougie&#039;s Friday mailbag - The Ring</title>
<script type="text/javascript">
//<![CDATA[
var _gaq = _gaq || [];_gaq.push(['_setAccount', 'UA-77508658-1']);_gaq.push(['_trackPageview']);(function() {var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);})();(function(b){(function(a){"__CF"in b&&"DJS"in b.__CF?b.__CF.DJS.push(a):"addEventListener"in b?b.addEventListener("load",a,!1):b.attachEvent("onload",a)})(function(){"FB"in b&&"Event"in FB&&"subscribe"in FB.Event&&(FB.Event.subscribe("edge.create",function(a){_gaq.push(["_trackSocial","facebook","like",a])}),FB.Event.subscribe("edge.remove",function(a){_gaq.push(["_trackSocial","facebook","unlike",a])}),FB.Event.subscribe("message.send",function(a){_gaq.push(["_trackSocial","facebook","send",a])}));"twttr"in b&&"events"in twttr&&"bind"in twttr.events&&twttr.events.bind("tweet",function(a){if(a){var b;if(a.target&&a.target.nodeName=="IFRAME")a:{if(a=a.target.src){a=a.split("#")[0].match(/[^?=&]+=([^&]*)?/g);b=0;for(var c;c=a[b];++b)if(c.indexOf("url")===0){b=unescape(c.split("=")[1]);break a}}b=void 0}_gaq.push(["_trackSocial","twitter","tweet",b])}})})})(window);//]]>
</script><script type="text/javascript">
//<![CDATA[
try{if (!window.CloudFlare) {var CloudFlare=[{verbose:0,p:0,byc:0,owlid:"cf",bag2:1,mirage2:0,oracle:0,paths:{cloudflare:"/cdn-cgi/nexp/dok3v=1613a3a185/"},atok:"9c4742974bd3c9261646ee812e624d60",petok:"71c9b33670f2a8bf5e61e74f05da1e2135bc143b-1498818352-1800",zone:"ringtv.com",rocket:"0",apps:{"ga_key":{"ua":"UA-77508658-1","ga_bs":"2"}}}];!function(a,b){a=document.createElement("script"),b=document.getElementsByTagName("script")[0],a.async=!0,a.src="//ajax.cloudflare.com/cdn-cgi/nexp/dok3v=85b614c0f6/cloudflare.min.js",b.parentNode.insertBefore(a,b)}()}}catch(e){};
//]]>
</script>
<link rel="apple-touch-icon" sizes="57x57" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-57x57.png">
<link rel="apple-touch-icon" sizes="60x60" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-60x60.png">
<link rel="apple-touch-icon" sizes="72x72" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-72x72.png">
<link rel="apple-touch-icon" sizes="76x76" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-76x76.png">
<link rel="apple-touch-icon" sizes="114x114" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-114x114.png">
<link rel="apple-touch-icon" sizes="120x120" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-120x120.png">
<link rel="apple-touch-icon" sizes="144x144" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-144x144.png">
<link rel="apple-touch-icon" sizes="152x152" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-152x152.png">
<link rel="apple-touch-icon" sizes="180x180" href="https://www.ringtv.com/wp-content/themes/thering/images/apple-icon-180x180.png">
<link rel="icon" type="image/png" sizes="192x192" href="https://www.ringtv.com/wp-content/themes/thering/images/android-icon-192x192.png">
<link rel="icon" type="image/png" sizes="32x32" href="https://www.ringtv.com/wp-content/themes/thering/images/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="96x96" href="https://www.ringtv.com/wp-content/themes/thering/images/favicon-96x96.png">
<link rel="icon" type="image/png" sizes="16x16" href="https://www.ringtv.com/wp-content/themes/thering/images/favicon-16x16.png">
<link rel="manifest" href="https://www.ringtv.com/wp-content/themes/thering/images/manifest.json">
<meta name="msapplication-TileColor" content="#ffffff">
<meta name="msapplication-TileImage" content="https://www.ringtv.com/wp-content/themes/thering/images/ms-icon-144x144.png">
<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="https://www.ringtv.com/feed/"/>
<link rel="alternate" type="text/xml" title="RSS .92" href="https://www.ringtv.com/feed/rss/"/>
<link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="https://www.ringtv.com/feed/atom/"/>
<link rel="pingback" href="https://www.ringtv.com/xmlrpc.php"/>
 
<link rel="canonical" href="https://www.ringtv.com/503933-dougies-friday-mailbag-109/"/>
<meta property="og:locale" content="en_US"/>
<meta property="og:type" content="article"/>
<meta property="og:title" content="Dougie&#039;s Friday mailbag - The Ring"/>
<meta property="og:description" content="Fans share their thoughts on future fight options for Miguel Cotto, Kell Brook and Guillermo Rigondeaux; the pound-for-pound merits of Anthony Joshua, the Wilder-Whyte beef and more."/>
<meta property="og:url" content="https://www.ringtv.com/503933-dougies-friday-mailbag-109/"/>
<meta property="og:site_name" content="The Ring"/>
<meta property="article:publisher" content="https://www.facebook.com/RingTV"/>
<meta property="article:author" content="https://www.facebook.com/douglass.fischer"/>
<meta property="article:tag" content="anthony joshua"/>
<meta property="article:tag" content="deontay wilder"/>
<meta property="article:tag" content="dillian whyte"/>
<meta property="article:tag" content="doug fischer"/>
<meta property="article:tag" content="dougie&#039;s mailbag"/>
<meta property="article:tag" content="friday mailbag"/>
<meta property="article:tag" content="guillermo rigondeaux"/>
<meta property="article:tag" content="kell brook"/>
<meta property="article:tag" content="mailbag"/>
<meta property="article:tag" content="miguel cotto"/>
<meta property="article:tag" content="Wilder-Whyte"/>
<meta property="article:section" content="Boxing"/>
<meta property="article:published_time" content="2017-06-30T03:04:33+00:00"/>
<meta property="article:modified_time" content="2017-06-30T03:08:19+00:00"/>
<meta property="og:updated_time" content="2017-06-30T03:08:19+00:00"/>
<meta property="og:image" content="https://www.ringtv.com/wp-content/uploads/2017/05/Miguel-Cotto_KamegaiPC_Hoganphotos8.jpg"/>
<meta property="og:image:width" content="1000"/>
<meta property="og:image:height" content="667"/>
<meta name="twitter:card" content="summary"/>
<meta name="twitter:description" content="Fans share their thoughts on future fight options for Miguel Cotto, Kell Brook and Guillermo Rigondeaux; the pound-for-pound merits of Anthony Joshua, the Wilder-Whyte beef and more."/>
<meta name="twitter:title" content="Dougie&#039;s Friday mailbag - The Ring"/>
<meta name="twitter:site" content="@ringmagazine"/>
<meta name="twitter:image" content="https://www.ringtv.com/wp-content/uploads/2017/05/Miguel-Cotto_KamegaiPC_Hoganphotos8.jpg"/>
<meta name="twitter:creator" content="@dougiefischer"/>
 
<link rel='dns-prefetch' href='//js.stripe.com'/>
<link rel='dns-prefetch' href='//ajax.googleapis.com'/>
<link rel='dns-prefetch' href='//s.w.org'/>
<link rel="alternate" type="application/rss+xml" title="The Ring &raquo; Dougie&#8217;s Friday mailbag Comments Feed" href="https://www.ringtv.com/503933-dougies-friday-mailbag-109/feed/"/>
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.ringtv.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.5"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important;}</style>
<link rel='stylesheet' id='validate-engine-css-css' href='https://www.ringtv.com/wp-content/plugins/wysija-newsletters/css/validationEngine.jquery.css?ver=2.7.10' type='text/css' media='all'/>
<link rel='stylesheet' id='contact-form-7-css' href='https://www.ringtv.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.8' type='text/css' media='all'/>
<link rel='stylesheet' id='access_ads_style-css' href='https://www.ringtv.com/wp-content/plugins/accessads//css/minimal.css?ver=1.1.0' type='text/css' media='all'/>
<link rel='stylesheet' id='jquery-issuem-flexslider-css' href='https://www.ringtv.com/wp-content/plugins/issuem/css/flexslider.css?ver=2.7.1' type='text/css' media='all'/>
<link rel='stylesheet' id='issuem-leaky-paywall-article-countdown-nag-css' href='https://www.ringtv.com/wp-content/plugins/leaky-paywall-article-countdown-nag//css/article-countdown-nag-slim.css?ver=3.1.0' type='text/css' media='all'/>
<link rel='stylesheet' id='leaky-paywall-coupons-css-css' href='https://www.ringtv.com/wp-content/plugins/leaky-paywall-coupons//css/leaky-paywall-coupons.css?ver=1.4.0' type='text/css' media='all'/>
<link rel='stylesheet' id='jquery-style-css' href='//ajax.googleapis.com/ajax/libs/jqueryui/1.11.2/themes/smoothness/jquery-ui.css?ver=4.7.5' type='text/css' media='all'/>
<link rel='stylesheet' id='lp-gift-style-css' href='https://www.ringtv.com/wp-content/plugins/leaky-paywall-gift-subscriptions//css/lp-gift.css?ver=2.6.0' type='text/css' media='all'/>
<link rel='stylesheet' id='issuem-leaky-paywall-css' href='https://www.ringtv.com/wp-content/plugins/leaky-paywall//css/issuem-leaky-paywall.css?ver=4.8.0' type='text/css' media='all'/>
<link rel='stylesheet' id='unipress-api-css' href='https://www.ringtv.com/wp-content/plugins/unipress-api//css/unipress.css?ver=1.15.0' type='text/css' media='all'/>
<link rel='stylesheet' id='flexslider-css' href='https://www.ringtv.com/wp-content/themes/thering/css/flexslider.css' type='text/css' media='all'/>
<link rel='stylesheet' id='fontawesome-css' href='https://www.ringtv.com/wp-content/themes/thering/css/font-awesome.css' type='text/css' media='all'/>
<link rel='stylesheet' id='normalize-css' href='https://www.ringtv.com/wp-content/themes/thering/css/normalize.css' type='text/css' media='all'/>
<link rel='stylesheet' id='grid12-css' href='https://www.ringtv.com/wp-content/themes/thering/css/grid12.css' type='text/css' media='all'/>
<link rel='stylesheet' id='movingboxes-css' href='https://www.ringtv.com/wp-content/themes/thering/css/movingboxes.css' type='text/css' media='all'/>
<link rel='stylesheet' id='customscrollbar-css' href='https://www.ringtv.com/wp-content/themes/thering/css/jquery.mCustomScrollbar.css' type='text/css' media='all'/>
<link rel='stylesheet' id='owlcarousel-css' href='https://www.ringtv.com/wp-content/themes/thering/css/owl.carousel.css' type='text/css' media='all'/>
<link rel='stylesheet' id='fancybox-css' href='https://www.ringtv.com/wp-content/themes/thering/css/jquery.fancybox.css' type='text/css' media='all'/>
<link rel='stylesheet' id='stylesheet-css' href='https://www.ringtv.com/wp-content/themes/thering/style.css?ver=e370e146a94dbea8ac1321998961468f' type='text/css' media='all'/>
<link rel='stylesheet' id='responsive-css' href='https://www.ringtv.com/wp-content/themes/thering/css/responsive.css?ver=e370e146a94dbea8ac1321998961468f' type='text/css' media='all'/>
<script type='text/javascript' src='https://www.ringtv.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/issuem/js/jquery.flexslider-min.js?ver=2.7.1'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/leaky-paywall-article-countdown-nag//js/article-countdown-nag.js?ver=3.1.0'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/leaky-paywall-coupons/js/leaky-paywall-coupons.js?ver=1.4.0'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/leaky-paywall-gift-subscriptions//js/lp-gift.js?ver=2.6.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_object = {"ajax_url":"https:\/\/www.ringtv.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/unipress-api//js/unipress.js?ver=1.15.0'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/countdown.js'></script>
<script type='text/javascript' src='https://js.stripe.com/v2/?ver=4.7.5'></script>
<link rel='https://api.w.org/' href='https://www.ringtv.com/wp-json/'/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.ringtv.com/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.ringtv.com/wp-includes/wlwmanifest.xml"/>
<meta name="generator" content="WordPress 4.7.5"/>
<link rel='shortlink' href='https://www.ringtv.com/?p=503933'/>
<link rel="alternate" type="application/json+oembed" href="https://www.ringtv.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ringtv.com%2F503933-dougies-friday-mailbag-109%2F"/>
<link rel="alternate" type="text/xml+oembed" href="https://www.ringtv.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ringtv.com%2F503933-dougies-friday-mailbag-109%2F&#038;format=xml"/>
</head>
<body class="post-template-default single single-post postid-503933 single-format-standard loading dougies-friday-mailbag-109 unknown">
<div id="mobile-nav">
<a href="#" class="btn-close-mob"></a>
<div class="mob-logo"><img src="https://www.ringtv.com/wp-content/themes/thering/images/ring-logo.png" alt=""></div>
<ul id="menu-main-menu" class="mob-nav"><li id="menu-item-151" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-151"><a href="https://www.ringtv.com/">Home</a></li>
<li id="menu-item-152" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-has-children menu-item-152"><a href="https://www.ringtv.com/news/">News</a></li>
<li id="menu-item-158" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-158"><a href="https://www.ringtv.com/videos/">Videos</a></li>
<li id="menu-item-153" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-153"><a href="https://www.ringtv.com/photos/">Photos</a></li>
<li id="menu-item-155" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-155"><a href="https://www.ringtv.com/ratings/">Ratings</a></li>
<li id="menu-item-156" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156"><a href="https://www.ringtv.com/schedule/">Schedule</a></li>
<li id="menu-item-249" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-249"><a target="_blank" href="https://esolutionsmnec.ecenergy.com/eCatalog/Account/AnonymousLogon/38?customerName=RING">Shop</a></li>
<li id="menu-item-494633" class="hlogin-btn menu-item menu-item-type-post_type menu-item-object-page menu-item-494633"><a href="https://www.ringtv.com/subscription-login/">Login</a></li>
<li id="menu-item-494630" class="hsubscribe-btn menu-item menu-item-type-post_type menu-item-object-page menu-item-494630"><a href="https://www.ringtv.com/subscription/">Subscribe</a></li>
</ul> <ul class="mobile-nav-social">
<li><a href="https://www.ringtv.com/search"><i class="fa fa-search"></i></a></li>
<li><a href="https://www.facebook.com/RingTV" target="_blank"><i class="fa fa-facebook"></i></a></li> <li><a href="https://www.youtube.com/user/TheRingDigital?sub_confirmation=1" target="_blank"><i class="fa fa-youtube"></i></a></li> <li><a href="https://twitter.com/ringmagazine" target="_blank"><i class="fa fa-twitter"></i></a></li> <li><a href="https://instagram.com/ringtv" target="_blank"><i class="fa fa-instagram"></i></a></li> </ul>
</div> 
<div class="header">
<div class="header-inner">
<a href="https://www.ringtv.com" class="logo"><img src="https://www.ringtv.com/wp-content/themes/thering/images/ring-logo.png" alt=""></a>
<ul id="menu-main-menu-1" class="main-nav"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-151"><a href="https://www.ringtv.com/">Home</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-has-children menu-item-152"><a href="https://www.ringtv.com/news/">News</a>
<ul class="sub-menu">
<li id="menu-item-458877" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-458877"><a href="https://www.ringtv.com/category/boxing/">Boxing</a></li>
<li id="menu-item-163" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163"><a href="https://www.ringtv.com/category/mma/">MMA</a></li>
<li id="menu-item-162" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-162"><a href="https://www.ringtv.com/category/kickboxing/">Kickboxing</a></li>
<li id="menu-item-164" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164"><a href="https://www.ringtv.com/category/press-releases/">Press Releases</a></li>
<li id="menu-item-161" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-161"><a href="https://www.ringtv.com/category/exclusive-editorial/">Exclusive Editorial</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-158"><a href="https://www.ringtv.com/videos/">Videos</a>
<ul class="sub-menu">
<li id="menu-item-165" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-165"><a href="https://www.ringtv.com/videos/">Latest</a></li>
<li id="menu-item-166" class="menu-item menu-item-type-taxonomy menu-item-object-video_cat menu-item-166"><a href="https://www.ringtv.com/video-category/featured/">Featured</a></li>
<li id="menu-item-167" class="menu-item menu-item-type-taxonomy menu-item-object-video_cat menu-item-167"><a href="https://www.ringtv.com/video-category/classic-fights/">Classic Fights</a></li>
<li id="menu-item-168" class="menu-item menu-item-type-taxonomy menu-item-object-video_cat menu-item-168"><a href="https://www.ringtv.com/video-category/live-events/">Live Events</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-153"><a href="https://www.ringtv.com/photos/">Photos</a>
<ul class="sub-menu">
<li id="menu-item-169" class="menu-item menu-item-type-taxonomy menu-item-object-photo_cat menu-item-169"><a href="https://www.ringtv.com/photo-category/featured/">Featured</a></li>
<li id="menu-item-171" class="menu-item menu-item-type-taxonomy menu-item-object-photo_cat menu-item-171"><a href="https://www.ringtv.com/photo-category/classic/">Classic</a></li>
<li id="menu-item-170" class="menu-item menu-item-type-taxonomy menu-item-object-photo_cat menu-item-170"><a href="https://www.ringtv.com/photo-category/boxing/">Boxing</a></li>
<li id="menu-item-172" class="menu-item menu-item-type-taxonomy menu-item-object-photo_cat menu-item-172"><a href="https://www.ringtv.com/photo-category/mma/">MMA</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-155"><a href="https://www.ringtv.com/ratings/">Ratings</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156"><a href="https://www.ringtv.com/schedule/">Schedule</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-249"><a target="_blank" href="https://esolutionsmnec.ecenergy.com/eCatalog/Account/AnonymousLogon/38?customerName=RING">Shop</a></li>
<li class="hlogin-btn menu-item menu-item-type-post_type menu-item-object-page menu-item-494633"><a href="https://www.ringtv.com/subscription-login/">Login</a></li>
<li class="hsubscribe-btn menu-item menu-item-type-post_type menu-item-object-page menu-item-494630"><a href="https://www.ringtv.com/subscription/">Subscribe</a></li>
</ul>
<div class="mobile-menu-btn"><i class="fa fa-bars"></i></div>
<ul class="head-social">
<li><a href="https://www.ringtv.com/search"><i class="fa fa-search"></i></a></li>
<li><a href="https://www.facebook.com/RingTV" target="_blank"><i class="fa fa-facebook"></i></a></li> <li><a href="https://www.youtube.com/user/TheRingDigital?sub_confirmation=1" target="_blank"><i class="fa fa-youtube"></i></a></li> <li><a href="https://twitter.com/ringmagazine" target="_blank"><i class="fa fa-twitter"></i></a></li> <li><a href="https://instagram.com/ringtv" target="_blank"><i class="fa fa-instagram"></i></a></li> </ul>
<div style="display:none">
</div>
</div> 
</div> 
<div class="sub-header">
<div class="wrap-inner">
<h1>News</h1>
<div class="ads728-90"><div class="addrop-wrap" data-id="499853"><script id="mNCC" language="javascript">
   medianet_width = "728";
   medianet_height = "90";
   medianet_crid = "766595921";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUV3K88Q' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script>
</div></div>
</div>
</div> 
<div class="sub-content-wrap">
<div class="a-d-wrap">
<a href="https://bit.ly/2onCPAV" target="_blank" class="a-d-link"></a>
<div class="wrap-inner">
<div class="row">
<div class="col-lg-8 col-md-8 col-sm-12 col-xs-12 news-content">
<div class="full-post">
<h1>Dougie&#8217;s Friday mailbag</h1>
</div>
</div>
</div>
<div class="row">
<div class="col-lg-8 col-md-8 col-sm-8 col-xs-12 news-content">
<div class="full-post">
<div class="imagebox"><img src="https://www.ringtv.com/wp-content/uploads/2017/05/Miguel-Cotto_KamegaiPC_Hoganphotos8-770x514.jpg" alt=""></div>
<div class="a-d-468x60-post hidden-md visible-sm visible-xs"><div class="addrop-wrap" data-id="499862"><script id="mNCC" language="javascript">
   medianet_width = "468";
   medianet_height = "60";
   medianet_crid = "887466222";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUV3K88Q' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script></div></div>
<div class="text-wrap">
<div class="date-col">
<div class="day">30</div>
<div class="month">Jun</div>
</div>
<div class="a-d-468x60-post hidden-sm hidden-xs"><div class="addrop-wrap" data-id="499862"><script id="mNCC" language="javascript">
   medianet_width = "468";
   medianet_height = "60";
   medianet_crid = "887466222";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUV3K88Q' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script></div></div>
<div class="a-d-120x600-post"><div class="addrop-wrap" data-id="499864"><script id="mNCC" language="javascript">
   medianet_width = "120";
   medianet_height = "600";
   medianet_crid = "601834232";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUV3K88Q' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script>
</div></div>
<div class="posted-by"><a href="https://www.ringtv.com/author/doug/">by Doug Fischer</a></div>
<p><strong>COTTO’S &amp; RIGO’S OPTIONS</strong><strong> </strong></p>
<p>heh. no way miguel cotto fights kell brook at 154. uh-uh. he’d sooner fight juan manuel marquez at 147.</p>
<p>i think brook would be better off at 160. i hate sayin this, but it just ain&#8217;t as competitive, and he has the time and space there to adjust to the weight class. in a year or 18 months that’ll be a different landscape anyway, but it’ll be one where he’s got a solid place.</p>
<p>when’s sulecki gonna step up and fight some competition?</p>
<p>what did u think about murata-ndam?</p>
<p>rigo at 130? hmm. he looks like he fights real close to his walkin around weight or at least his in-ring weight. am i wrong?</p>
<p>(btw lemme go on record here as sayin i luv rigo. hey, a coupla real boring fights. many more ain’t. get fresh with that mean lil cubano like flores and u get a shot of RIGO MORTISS.)</p>
<p>let’s see that rematch. – Ceylon</p>
<p><strong>I’ll pass on Rigondeaux-Flores II. Despite his high sanctioning body ranking and unbeaten record, Flores is clearly outclassed by Rigo. I’m only interested in watching Rigo fight opponents who are in (or relatively close to) his league. </strong></p>
<p><strong>Although I’m not a fan of the Cuban (and I swore I would never advocate for the two-time Olympic gold medalist after he half-assed it through that Drian Francisco fight – an obvious “layup” for him that shouldn’t have even been permitted by the NSAC – on the Cotto-Canelo PPV undercard), but I admit that there aren’t many fighters from 118-126 who are in his class (and most of those who come close are unwilling to fight him).</strong></p>
<p><strong>I agree with you, that his natural fighting weight is 122 pounds, and I believe he would be pushing the limits of his body and boxing effectiveness by moving eight pounds north (especially if his opponent is the superbly gifted Vasyl Lomachenko – one of the few boxers in history to boast amateur accomplishments more stellar than Rigo’s). I’ve said for years (no exaggeration) that instead of chasing after unwilling junior featherweights beltholders and nervous featherweight standouts, Rigondeaux’s team needs to invite the best of the 118-pound division to step up and challenge best man at 122 pounds.</strong></p>
<p><strong>There’s real talent at bantamweight, and most of the best 118 pounders dream about making the mere six-figure “pittance” Rigo made against Flores, so I’m sure that Roc Nation really wanted to entice standouts just south of the Cuban southpaw to step up in weight they could do that.</strong></p>
<p><strong>I think Shinsuke Yamanaka (a fellow pound-for-pound player) and Zolani Tete (who has exhibited excellent form in recent bout) could give Rigo a fight. (The bantamweight badasses would definitely be more competitive than Flores or “Jaza” Dickens – and if Rigo were to ice blitz Yamanaka and Tete the way he did his last two opponents, he would be lauded for his achievement.)</strong></p>
<p><em>no way miguel cotto fights kell brook at 154. uh-uh. He’d sooner fight juan manuel marquez at 147.</em> <strong>Bro, you’re getting way ahead of yourself. We have to see how Brook looks after his</strong></p>
<div id="attachment_501780" style="width: 410px" class="wp-caption alignleft"><img class="wp-image-501780" src="http://www.ringtv.com/wp-content/uploads/2017/05/Cotto-De-La-Hoya-Kamegai-PC_Hoganphotos4.jpg" alt="" width="400" height="267"/><p class="wp-caption-text">Photo by Tom Hogan &#8211; Hoganphotos/Golden Boy Promotions</p></div>
<p><strong>targeted November return date before we start playing matchmaker with whatever is left of his career. He sustained the kind of physical damage and injuries in his last two bouts that are very hard to bounce back from. And there’s no guarantee that Cotto gets by my new favorite gatekeeper, Yoshihio Kamegai, on Aug. 26. Kamegai earned his shot at the future hall of famer by holding the most reliable gatekeeper since Darnell Boone (the Godfather of Gatekeepers), Jesus Soto Karass, to a scintillating draw last April and then looking damn sharp en route to stopping JSK in September under the HBO-televised Carlos Cuadras-Roman Gonzalez showdown. If he’s able to get to Cotto’s 36-year-old body the way was able to get to the Mexican slugger’s liver, all bets are off. #WarKamegai! </strong></p>
<p><em>i think brook would be better off at 160.</em> <strong>I totally disagree. The FRINGE contenders at middleweight are too damn big for Special K. Even if he were to get by a mid-level 160 pounder to earn another big payday against a titleholder or top contender, I’d hate to see what heavy hitter like Canelo, David Lemieux or Chris Eubank Jr. would do to his already fragile face. Honestly, I think Billy Joe Saunders and Andy Lee could outbox him just by keeping him at the end of their long southpaw jabs.</strong> <strong>I think Brook belongs at junior middleweight where interesting domestic showdowns with Amir Khan, Liam Smith and Liam Williams can be made. (If Brook were to get the Cotto-Kamegai winner sometime during the first part of 2018, my guess is the winner of the Smith-Williams rematch – whenever that happens – will be rated high in the WBO and thus be in line to fight the Special One.)</strong></p>
<p><em>when’s sulecki gonna step up and fight some competition?</em> <strong>Good question. The Polish standout looks promising and he’s on a seven-bout KO streak – that includes a tough gatekeeper (Derrick Findley), a former fringe contender (Grzegorz Proksa) and a prospect (Hugo Centeno Jr.) – but it’s time for him to face a legit top-10 rated fighter and time to decide if he’s gonna campaign at middleweight or junior middleweight. </strong></p>
<p><em>what did u think about murata-ndam?</em> <strong>I thought Murata was robbed. But I’m happy for Ndam, who is one of the more courageous middleweight veterans of the game. The dude’s balance and footwork are for s__t, but he can take a hell of a shot and he never lets a knockdown (or two or three or four) discourage him.</strong></p>
<p><strong> </strong><strong> </strong><strong> </strong></p>
<p><strong>CIRCUS ODDS</strong></p>
<p>Hi Dougie,</p>
<p>First of all, I want to thank you for the mailbag. I&#8217;ve been reading religiously for 3 years now and it really makes my Monday and Friday mornings a little sweeter coming into work. I got my morning tradition set: I get my sandwich, I get my coffee, and I turn the page to Dougie&#8217;s Mailbox to slack off for a good hour. LOL! Really no better way to start the mornings.</p>
<p>I&#8217;m mailing for the first time because I just checked out the odds for the Mayweather circus and the over / under kind of baffles me. The over is 9.5 rounds at +120, meaning you risk 100 win 120. This means it’s the &#8216;underdog pick&#8217;, or in other words, more people are betting that it goes under than over.</p>
<p>We know Conor McGregor won&#8217;t get knocked out. If he can&#8217;t get knocked out by Nate Diaz’s bare knuckles, he&#8217;s not gonna get knocked out by 40-year-old Mayweather&#8217;s pillow punches. Besides, when was the last time Mayweather knocked someone out without sucker punching them? Hatton? Pre-2010???</p>
<p>At the same time, I really doubt McGregor will even graze Mayweather, let alone catch him or KO him. In fact, I&#8217;ll bet there&#8217;s a clause in their contract where it says if you knock me out, you don’t get paid. There&#8217;s no way Mayweather would risk his career and record by giving a KO the slightest chance.</p>
<p>A wild chase for 10 rounds whole rounds is a little hard to imagine, but how could it possible go any other way? Unless McGregor quits, which I don’t think is in his character or stage persona.</p>
<p>Seems to me like the over is a no-brainer and a chance to make a nice chunk of dough.</p>
<p>Are you a betting man Dougie? What do you think?? Thanks. – Johnny</p>
<p><strong>No, I’m not a betting man, and I’d never waste my time wagering on an entertainment/business venture masquerading as an exhibition that’s been dressed up as a legitimate boxing match by Mayweather Promotions, the UFC, the Showtime network and the Nevada State Athletic Commission (NSAC).</strong></p>
<p><strong><img class="alignright wp-image-499966 size-medium" src="http://www.ringtv.com/wp-content/uploads/2017/05/mayweather-mcgregor-300x169.jpg" alt="" width="300" height="169" srcset="https://www.ringtv.com/wp-content/uploads/2017/05/mayweather-mcgregor-300x169.jpg 300w, https://www.ringtv.com/wp-content/uploads/2017/05/mayweather-mcgregor-768x432.jpg 768w, https://www.ringtv.com/wp-content/uploads/2017/05/mayweather-mcgregor-600x338.jpg 600w, https://www.ringtv.com/wp-content/uploads/2017/05/mayweather-mcgregor-150x84.jpg 150w, https://www.ringtv.com/wp-content/uploads/2017/05/mayweather-mcgregor-763x430.jpg 763w, https://www.ringtv.com/wp-content/uploads/2017/05/mayweather-mcgregor-770x433.jpg 770w, https://www.ringtv.com/wp-content/uploads/2017/05/mayweather-mcgregor.jpg 785w" sizes="(max-width: 300px) 100vw, 300px"/>Mayweather and McGregor are prideful athletes but they’re also shrewd businessmen who want to collect as much money as they can while they can – so who knows what kind of “gentlemen’s agreement” they have with each other?</strong></p>
<p><strong>Having said that, I don’t think it’s out of the realm of possibility for Mayweather to stop McGregor. I agree that Mayweather generally doesn’t want to risk going for the knockout for fear of getting clipped by his opponent, and I agree that McGregor is a tough S.O.B., but the Irish star isn’t used to being restricted to only punching at a three-minute round pace for nine-plus rounds. True, Diaz couldn’t stop him (with punches) while wearing those tiny MMA gloves at 170 pounds, but they weren’t BOXING in a boxing ring. McGregor isn’t going to be able to kick at Mayweather’s legs and he isn’t going to have as much room to retreat (as he had in the Octagon vs. Diaz) when Floyd dazes him by beating him to the jab and repeatedly counter-punching the s__t out of him. Even if Mayweather holds back on McGregor, the MMA fighter is going to wear himself out if he’s going to be swinging and missing as much you (and everybody else) believes he will. If he’s huffing and puffing midway through the second round of UFC fights, how do you think he’s going to feel after five or six rounds of loading up and whiffing air? And what’s he going to do about it if he does punch himself out?</strong></p>
<p><strong>He’ll be allowed to hold (to an extent) when he’s hurt or tired (or both) but he won’t be able to take Mayweather to the canvas (like I’m sure he’d want to). And don’t forget that Mayweather is comfortable and adept at holding and the referees that are appointed to his bouts generally look out for his well being during these grappling situations.<br/>
</strong></p>
<p><strong>By the way, thanks for the very kind words about the mailbag. It means a lot to me that so many boxing fans have made it a part of their morning routines twice a week.</strong></p>
<p><strong> </strong></p>
<p><strong>WARD-KOVALEV REPLAY</strong></p>
<p>Dear Doug,</p>
<p>I finally caught up with HBO&#8217;s rebroadcast of Ward-Kovalev last  night. (Busy weekend.) I wouldn&#8217;t want to take Ward&#8217;s hard-fought victory away from him. It was impressive. But:</p>
<ol>
<li>The very last punch Ward landed, from one angle shown in slow-mo replay, was clearly below the belt. Not one of those borderline shots which were legitimate.</li>
</ol>
<ol start="2">
<li>I think Tony Weeks made a mistake stopping the fight when he did.</li>
</ol>
<p>Kovalev was slumped down against the ropes, a clear knockdown. Weeks should have given him a count before waving it off. Kovalev was</p>
<p>entitled to those 9 seconds to recover.</p>
<p>He said he was ready to continue, which of course he would say, but he didn&#8217;t have a chance to prove it.</p>
<p>Best. – Leslie Gerber, Woodstock, NY</p>
<p><strong>I think Paulie Malignaggi said it best during the Sky Sports broadcast of the fight: “Let the fighters decide the outcome&#8230;”</strong></p>
<p><strong>I agree with both of your points, even though I didn’t have a huge problem with the stoppage in real time because it looked to me like Kovalev had mentally capitulated. But who knows if that was the truly the case?<br/>
</strong></p>
<p><strong>Kovalev had been hurt to the body (with borderline shots) and then to the head (with that big right hand) before getting worked over the ropes with more borderline shots punctuated with a low blow, but maybe a 10-count or a pause in the action to give him time to recover from the foul punch would have enabled him to survive the round. Maybe Kovalev could have recovered enough between rounds to get back on track. Or maybe Ward would have decisively finished him in Round 8 or the next round. We will never know. And I can see how that is frustrating to fight fans (even to staunch Ward supporters).</strong></p>
<p><strong> </strong><strong> </strong></p>
<p><strong>BOXING RESUME DECONSTRUCTION</strong></p>
<p>Hey, Doug!</p>
<p>I&#8217;ve been enjoying reading the resume comparison arguments in the last few mailbags. It definitely seems like a lot of boxing fans have really short memories. I agree with you that there&#8217;s no way Andre Ward&#8217;s accomplishments have yet come close to those of Mayweather&#8217;s, Pacquiao&#8217;s, or even Roman Gonzalez. For that matter, arguments can be made that among active (albeit declining) fighters, Wlad Klitschko, Nonito Donaire, or even Orlando Salido, have done more in the ring. If Juan Marquez successfully returns, he&#8217;d be on that list. And the only-recently retired Bernard Hopkins arguably accomplished more than Floyd or Pac, much less Ward!</p>
<p>Besides focusing on the here and now a little too much, boxing fans are also adept at cherry picking resumes. Yeah, there&#8217;s nuance in individual fights, but the big picture sometimes gets neglected. And vice versa. For example, did you hear about this heavyweight from the 60s and 70s? Top ten scalps on his resume include guys like George Logan, Alejandro Lavorante, Karl Mildenberger, and Alfredo Evangelista? Those are among his best? And he struggled against double-digit loss Jimmy Young? Same with Doug Jones? And probably deserved to lose 2 out of 3 against weak-chinned Ken Norton? And Henry freaking Cooper dropped him? Jeez, what a bum.</p>
<p>Without context, and a calmer, less emotional eye, it can be easy to fall for knee-jerk armchair &#8220;analyses&#8221; such as this.</p>
<p>Fighters are human, and when we elevate them above or below that level, we start to lose sight who they really are. It becomes easy for the emotional and the immature to lose all perspective when talking about these people.</p>
<p>Having said that, a good resume debate *can* be fun, as long as we remember that we&#8217;re talking about human beings here.</p>
<p>Apologies for my lack of brevity, and I understand if it keeps me from getting published this week, but I felt like getting that rant off my chest.</p>
<p>In addition, I wrote to you before, and mentioned my personal project involving ranking the all-time heavyweights (and we talked comics!). You had said I should keep you updated with my progress, or something along those lines. If it&#8217;s okay to plug another boxing project on this site, check out my project index page: <a href="https://hunterboxing.net/2014/11/24/the-200-greatest-heavyweights-index-page/">https://hunterboxing.net/2014/11/24/the-200-greatest-heavyweights-index-page/</a></p>
<p>The &#8220;introduction and overview&#8221; link at the top provides an explanation of my methodologies, but the fun parts are the actual profiles. I&#8217;ve learned a lot in researching this project and have a renewed appreciation for many nearly forgotten fighters. It&#8217;s been slow going, but I should have another 30 or 40 profiles up over the course of this summer. – Hunter from KC</p>
<p><strong>Thanks for sharing your thoughts and your all-time heavyweight rankings project with us, Hunter. I’m always happy to post emails (no matter lengthy) from thoughtful fans (not to mention ones from The Show-Me State).</strong><strong> </strong></p>
<p><strong>I love to discuss and debate the merits of “greatness” in boxing and how the best of the best compare and compete with each other in the form of all-time rankings or “mythical matchups.”</strong><strong> </strong></p>
<p><strong>However, it is a real drag when the folks who want to debate you don’t really follow boxing that closely, or have only been fans for five or six years, or have given very little attention to the sport’s long and glorious history. </strong><strong> </strong></p>
<p><strong>I used to butt heads often with fans (and sadly members of the boxing media) who would proclaim one modern boxer or another as “the greatest” of a particular division or era or even of all time. But in recent years I’ve tried to avoid getting into long and pointless arguments by either suggesting that the fan with the “knee-jerk armchair” analysis/opinion research a list of fighters that I believe have comparable or superior talent/accomplishments to the one they&#8217;re touting as an ATG (or TBE). Every now and then a relatively new fan will actually look those fighters up and get back to me (via social media) to admit that the research gave them “food for thought.” Which always gives me a good feeling (whether they ultimately agree with me or not).</strong><strong> </strong></p>
<p><strong>Other times, especially when debating in person, I just stump them with a few questions. For example, when Mayweather was still relatively active (prior to the Pacquiao and Berto fights), I would occasionally meet Money Teamsters that would tell me that their favorite fighter was the best junior lightweight, lightweight or welterweight of all time. I’d ask them to name five-to-10 junior lightweights, lightweights or welterweights currently in the International Boxing Hall of Fame. Nine out of 10 couldn’t do this. </strong></p>
<p><strong>I had two follow-up questions for the very few that could name around five hall of famers in one of the weight classes that Floyd campaigned in (usually the welterweight division – and nobody could name 10):</strong><strong> </strong></p>
<p><strong>Why are those fighters enshrined in the hall of fame?</strong><strong> </strong></p>
<p><strong>And why does Mayweather deserve to be ranked among them, or above them?</strong><strong> </strong></p>
<p><strong>These questions seem to perplex most enough to walk away (or just laugh without answering). Those who gave it some thought always came back with “OK, so maybe he isn’t THE best at that weight…”</strong><strong> </strong></p>
<p><strong>Bottom line: A good resume debate can be fun, as you noted, but it requires some research and more than a little thought. </strong><strong> </strong></p>
<p><em>Besides focusing on the here and now a little too much, boxing fans are also adept at cherry picking resumes.</em> <strong>True, but I guess that kind of fastidious and overly critical analysis is part of being a hardcore fan. By the way, I have no problem with fans and members of the media being 100% focused on the “here and now.” There’s are a lot of excellent active fighters and plenty of quality action taking place today. I’m obviously very much into the sport’s history, but I don’t expect others to appreciate everything that fascinates me. It does, however, irk me when someone who doesn’t know a damn about boxing’s extensive history feels the need to rank active fighters among past greats.</strong></p>
<p><em>Did you hear about this heavyweight from the 60s and 70s? Top ten scalps on his resume include guys like George Logan, Alejandro Lavorante, Karl Mildenberger, and Alfredo Evangelista? Those are among his best? And he struggled against double-digit loss Jimmy Young? Same with Doug Jones? And probably deserved to lose 2 out of 3 against weak-chinned Ken Norton? And Henry freaking Cooper dropped him? Jeez, what a bum. </em><strong>This was genius. Even “The Greatest” can be crapped on if one tries hard enough.</strong></p>
<p><em>Without context, and a calmer, less emotional eye, it can be easy to fall for knee-jerk armchair &#8220;analyses&#8221; such as this.</em> <strong>And this type of analysis, unfortunately, comprises at least 75% of what I see on Twitter. It’s often more “jerk” than “knee-jerk.”</strong><strong> </strong><strong> </strong></p>
<p>&nbsp;</p>
<p><strong>WHAT A REPLY…</strong><strong> </strong></p>
<p>“Are you and the other TBE pom-poms wavers ready to do that?</p>
<p>Didn’t think so.”</p>
<p>Hysterical 😁✌️👍  – Craig</p>
<p><strong> </strong><strong>They ain’t ready.</strong><strong> </strong><strong> </strong></p>
<p>&nbsp;</p>
<p><strong>BEEF WITH BUNCEY</strong></p>
<p>Doug,</p>
<p>Longtime fan of the mailbag. Obligatory reading for anyone interested in the fight game. There is nothing else quite like it.</p>
<p>As a U.K. reader I was distressed to read a few weeks ago that there is a bit of beef between you and Steve Bunce, one of our most respected pundits.</p>
<p>Have been meaning to ask about this for a while now but life got ahead of me.</p>
<p>What&#8217;s the story though? Something you feel able to share with your loyal readership?</p>
<p>One mythical matchup for the road:</p>
<p>David Haye (prime) vs Andre Ward (6 months from now) at cruiserweight.</p>
<p>Yours expectantly. – Ryan, Suffolk, U.K.</p>
<p><strong>I think the prime Haye would knock a 200-pound version of Ward out (cold) sometime before the sixth or seventh round.</strong></p>
<p><strong>Regarding Bunce, there is no “beef” between us. He just doesn’t like me and I’m OK with that.</strong></p>
<p><strong>Seriously. I don’t feel the need to bash him about anything and I wasn’t aware that boxing fans and/or media on your side of the pond were talking/writing about Bunce’s opinion of me. </strong></p>
<p><strong>I haven’t heard about him ripping me in several years (perhaps eight or nine years). Back when I served as a color commentator for some of Top Rank’s “Latin Fury” pay-per-view shows (which were often carried by Setanta Sports and later on BoxNation), Bunce used to criticize my post-fight interviews, which probably were awkward and less-than-professional. (Those were my first broadcast experiences.) I seem to remember him getting really irked after watching a post-fight in-the-ring interview I did with Ivan Calderon following the Puerto Rican junior flyweight champ’s rematch victory over Hugo Cazares in August 2008.</strong></p>
<p><strong>Bottom line: Buncey thinks I suck.</strong></p>
<p><strong>Hey, maybe he’s right. He’s certainly not alone in that opinion. I get at least one email every week from somebody who thinks I’m a no-nothing a__hole.</strong></p>
<p><strong>But here’s the deal: I’m going to keep covering boxing until the industry kicks me out. I enjoy the fights too much to quit, plus the money is good.</strong></p>
<p><strong> </strong></p>
<p><strong>WILDER-WHYTE &amp; THE P4P</strong></p>
<p>Hey Dougie,</p>
<p>Hope all is well for you pal.</p>
<p>Last weekend&#8217;s events and the subsequent changes in the magazine&#8217;s P4P rankings have gotten me thinking&#8230; how close is Anthony Joshua to earning a spot on the mythical list? He&#8217;s beaten three Ring top 10 ranked fighters, all destructively by knockout, including one 1st ballot HOF&#8217;er, is unbeaten, has a 100% KO ratio and by most people&#8217;s reasoning passes the eye test with flying colours. Admittedly my knowledge of the lower weight divisions is shallow in comparison to yours, but is his record that different from Inoue&#8217;s or Rigondeaux&#8217;s?</p>
<p>I&#8217;m not necessarily cat calling for his inclusion, just interested in how close you think he is and as a proud Englishman I want to see the big man make it on the list!</p>
<p>Talking of the big men, what do you make of the social media barbs between Dillian Whyte and Deontay Wilder? Whyte has been trying to push for a fight but #BongSquad has gone on record saying he wants $7m to make the fight in London. Yes he is the champion but he is not a draw over here so Eddie Hearn and Sky would risk making a loss at that price. Surely it would make sense for Wilder to take the fight, beat Whyte and make a name for himself UK-side then set up the mega money fight with AJ.</p>
<p>Who do you have winning if they face off? Call me bias but Whyte&#8217;s sturdy chin and iron will would push him to a late KO victory in my book, I&#8217;m just not sure Wilder has the temperament for a big fight in a hostile environment against a true baddass like Whyte.</p>
<p>One final recommendation for you, there&#8217;s a Matchroom card on Friday night in the UK featuring Josh Kelly. If you&#8217;ve not seem him yet check him out, excellent showmanship and (dare I say it) Loma-esque movement. Heresy I know!</p>
<p>Take it easy mate and hope to make the cut. – Mike, England</p>
<p><strong>Sorry you missed the cut before Kelly’s last fight, Mike. I have seen the new “Pretty Boy” fight I watched his pro debut on the Burns-Indongo undercard live and I checked out his second and third pro bouts on YouTube. </strong></p>
<p><strong>I like what I see. The 2016 Olympian’s natural talent, athleticism, footwork and confidence are impressive. And, obviously, his showmanship and fighter instincts are going to turn heads on both sides of the pond. It’s not every day that we see a prospect score a <a href="https://www.youtube.com/watch?v=-I_owtI48D0" target="_blank" rel="noopener noreferrer">first-round stoppage off six consecutive left hooks</a>.</strong></p>
<p><strong>But before we compare him to a young Roy Jones Jr., or Floyd Mayweather Jr., or Vasyl Lomachnko, we need to see if the 23-year-old welterweight/junior middleweight can perform like that against solid 10-round fighters. It’s too early to compare him to future hall of famers and today’s pound-for-pound elite, but it’s not too early to be excited about him.</strong></p>
<p><em><img class="alignleft wp-image-503934" src="http://www.ringtv.com/wp-content/uploads/2017/06/AJ-on-Ring-cover_mailbag.jpg" alt="" width="400" height="535"/>How close is Anthony Joshua to earning a spot on the mythical list?</em> <strong>He’s probably close. In my opinion, his only notable victory is the 11<sup>th</sup>-round stoppage of Wladimir Klitschko, but as you said, he passes the “eye test,” which holds a lot of pound-for-pound weight these days. I’d like to see AJ defeat Tyson Fury or earn another major title (preferably against Wilder) before he cracks the mythical rankings, but my guess is that he’ll be in the top 10 before either of those bouts take place. He’s already good enough to be on the cover of THE RING. That tells me that the editors of the magazine are looking at him as the Heir Apparent (if not the Heavyweight King already). All he has to do is keep winning, and keep looking good (which isn’t hard for him). Being very popular and near the top of the sport’s glamor division will help AJ get that pound-for-pound recognition that you (and probably many others) want to see.</strong></p>
<p><em>He&#8217;s beaten three Ring top 10 ranked fighters, all destructively by knockout, including one 1st ballot HOF&#8217;er, is unbeaten, has a 100% KO ratio and by most people&#8217;s reasoning passes the eye test with flying colours.</em> <strong>Has he <em>really</em> beaten three RING-rated heavyweights? Who are they? Whyte, Charles Martin and Klitschko? I don’t think Whyte was ranked when AJ fought him. Martin maybe have had a lower top-10 ranking but that’s a sign of how weak the division is right now because he’s arguably the worst major heavyweight titleholder EVER. Klitschko is a legit contender, but keep in mind that the future hall of famer is 40 (with a lot of miles on his odometer) and had been inactive for more than a year when he faced Joshua.</strong></p>
<p><em>Admittedly my knowledge of the lower weight divisions is shallow in comparison to yours, but is his record that different from Inoue&#8217;s or Rigondeaux&#8217;s?</em> <strong>I think it is a little different because The Monster won major titles in two divisions before his ninth pro bout, and one of them (though very long in the tooth) was a decorated veteran and THE RING’s No. 1-rated 115 pounder (Omar Narvaez – who he obliterated); plus, the youngster leapfrogged a division (flyweight). Rigo beat Nonito Donaire when the Filipino Flash was still a pound-for-pound player.</strong></p>
<p><em>Talking of the big men, what do you make of the social media barbs between Dillian Whyte and Deontay Wilder?</em> <strong>Not much. It was just two braggadocious types talking s__t on social media. It was fun but no big deal.</strong></p>
<p><em>Whyte has been trying to push for a fight but #BongSquad has gone on record saying he wants $7m to make the fight in London.</em> <strong>Hey, if Wilder wants to continue to fight fringe contenders in Alabama for a fraction of that amount that’s his business. </strong></p>
<p><em>Yes he is the champion but he is not a draw over here so Eddie Hearn and Sky would risk making a loss at that price.</em> <strong>Wilder would probably be a bigger draw in the U.K. than he is in the U.S., especially if he were fighting a well-known and bombastic fighter like Dillian.</strong></p>
<p><em>Surely it would make sense for Wilder to take the fight, beat Whyte and make a name for himself UK-side then set up the mega money fight with AJ.</em> <strong>That makes a lot of sense, but does Wilder strike you as a sensible guy?</strong></p>
<p><em>Who do you have winning if they face off? </em><strong>I have no idea. It’s a very good matchup</strong><em>.</em> <strong>Whyte’s got a good jab and a busy, aggressive boxing styles, plus loads of confidence and that sturdy chin you spoke of, but Wilder is a pure puncher who can dent any chin if he’s able to land flush. </strong></p>
<p><em>I&#8217;m just not sure Wilder has the temperament for a big fight in a hostile environment against a true baddass like Whyte.</em> <strong>Wilder held it together a boxed a disciplined fight against the one top-10 contender he faced (Stiverne) and he was willing to travel to Russia to face Alexander Povetkin before the former beltholder tested positive for a banned substance, so I’m not certain that he’d implode by traveling to the U.K. Yes, Whyte is a card-carrying badass, but so is Wilder.</strong></p>
<p><strong> </strong></p>
<p>&nbsp;</p>
<p><em>Email Fischer at </em><a href="/cdn-cgi/l/email-protection#fd9992889a9498bd9f928594939a909c94919f9c9ad39e9290"><em><span class="__cf_email__" data-cfemail="294d465c4e404c694b465140474e444840454b484e074a4644">[email&#160;protected]</span><script data-cfhash='f9e31' type="text/javascript">/* <![CDATA[ */!function(t,e,r,n,c,a,p){try{t=document.currentScript||function(){for(t=document.getElementsByTagName('script'),e=t.length;e--;)if(t[e].getAttribute('data-cfhash'))return t[e]}();if(t&&(c=t.previousSibling)){p=t.parentNode;if(a=c.getAttribute('data-cfemail')){for(e='',r='0x'+a.substr(0,2)|0,n=2;a.length-n;n+=2)e+='%'+('0'+('0x'+a.substr(n,2)^r).toString(16)).slice(-2);p.replaceChild(document.createTextNode(decodeURIComponent(e)),c)}p.removeChild(t)}}catch(u){}}()/* ]]> */</script></em></a><em>. Follow him on Twitter at @dougiefischer</em></p>
<div class="clearboth"></div>
<div class="a-d-468x60-post hidden-sm hidden-xs"><div class="addrop-wrap" data-id="499862"><script id="mNCC" language="javascript">
   medianet_width = "468";
   medianet_height = "60";
   medianet_crid = "887466222";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUV3K88Q' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script></div></div>
</div> 
<div class="a-d-468x60-post hidden-md visible-sm visible-xs"><div class="addrop-wrap" data-id="499862"><script id="mNCC" language="javascript">
   medianet_width = "468";
   medianet_height = "60";
   medianet_crid = "887466222";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUV3K88Q' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script></div></div>
<div class="share-story">
<div class="title-text">Share this story</div>
<ul class="share-social">
<li><a href="#" class="addthis_button_facebook"><i class="fa fa-facebook"></i></a></li>
<li><a href="#" class="addthis_button_twitter"><i class="fa fa-twitter"></i></a></li>
</ul>
</div>
<div class="comment-app">
<div id="disqus_thread">
</div>
</div>
</div> 
</div>
<div class="col-lg-4 col-md-4 col-sm-4 col-xs-12 right-sidebar">
<div id="ad_dropper_widget-2" class="widget-1 widget-first widget-odd each-block widget_ad_dropper_widget"><div class="addrop-wrap" data-id="499854"><script id="mNCC" language="javascript">
   medianet_width = "300";
   medianet_height = "250";
   medianet_crid = "366235639";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUV3K88Q' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script></div></div><div id="callouts-2" class="widget-2 widget-even each-block widget_callouts box-img">
<ul class="most-active-posts">
<li>
<div class="thumbnail"><a href="https://www.ringtv.com/503933-dougies-friday-mailbag-109/">
<img src="https://www.ringtv.com/wp-content/uploads/2017/05/Miguel-Cotto_KamegaiPC_Hoganphotos8-80x80.jpg" alt="Dougie&#8217;s Friday mailbag"/>
</a>
</div>
<div class="text-wrap">
<a class="title" href="https://www.ringtv.com/503933-dougies-friday-mailbag-109/">Dougie&#8217;s Friday mailbag</a>
<div class="posted-by">by Doug Fischer</div>
</div>
</li>
<li>
<div class="thumbnail"><a href="https://www.ringtv.com/503925-vasyl-lomachenko-defend-title-vs-miguel-marriaga-aug-5-espn/">
<img src="https://www.ringtv.com/wp-content/uploads/2017/04/Lomachenko-victory_@TRBoxing-80x80.jpg" alt="Vasyl Lomachenko to defend title vs. Miguel Marriaga on Aug. 5 on ESPN"/>
</a>
</div>
<div class="text-wrap">
<a class="title" href="https://www.ringtv.com/503925-vasyl-lomachenko-defend-title-vs-miguel-marriaga-aug-5-espn/">Vasyl Lomachenko to defend title vs. Miguel Marriaga on Aug. 5 on ESPN</a>
<div class="posted-by">by Mike Coppinger</div>
</div>
</li>
<li>
<div class="thumbnail"><a href="https://www.ringtv.com/503888-gym-notes-badou-jack-readies-for-his-light-heavyweight-debut/">
<img src="https://www.ringtv.com/wp-content/uploads/2017/06/badou-jack-1-by-Mike-Coppin-80x80.jpg" alt="Gym Notes: Badou Jack readies for his light heavyweight debut"/>
</a>
</div>
<div class="text-wrap">
<a class="title" href="https://www.ringtv.com/503888-gym-notes-badou-jack-readies-for-his-light-heavyweight-debut/">Gym Notes: Badou Jack readies for his light heavyweight debut</a>
<div class="posted-by">by Mike Coppinger</div>
</div>
</li>
<li>
<div class="thumbnail"><a href="https://www.ringtv.com/503883-watch-jeff-horn-shows-punching-power-pacquiao-fight/">
<img src="https://www.ringtv.com/wp-content/uploads/2016/12/Jeff-Horn-Photo-credit-Glenn-Hunt-80x80.jpeg" alt="WATCH: Jeff Horn shows his punching power before Pacquiao fight"/>
</a>
</div>
<div class="text-wrap">
<a class="title" href="https://www.ringtv.com/503883-watch-jeff-horn-shows-punching-power-pacquiao-fight/">WATCH: Jeff Horn shows his punching power before Pacquiao fight</a>
<div class="posted-by">by Ryan Songalia</div>
</div>
</li>
<li>
<div class="thumbnail"><a href="https://www.ringtv.com/503771-manny-pacquiao-feels-jeff-horn-bout-will-prove-theres-lots-left-tank/">
<img src="https://www.ringtv.com/wp-content/uploads/2017/05/Manny-Pacquiao-training-5-11-17-photo-by-Wendell-Alinea-OSMP-08-80x80.jpg" alt="Manny Pacquiao feels he still has a lot left in the tank"/>
</a>
</div>
<div class="text-wrap">
<a class="title" href="https://www.ringtv.com/503771-manny-pacquiao-feels-jeff-horn-bout-will-prove-theres-lots-left-tank/">Manny Pacquiao feels he still has a lot left in the tank</a>
<div class="posted-by">by Mike Coppinger</div>
</div>
</li>
</ul>
</div><div id="ad_dropper_widget-3" class="widget-3 widget-odd each-block widget_ad_dropper_widget"><div class="addrop-wrap" data-id="499855"><script id="mNCC" language="javascript">
   medianet_width = "200";
   medianet_height = "200";
   medianet_crid = "227933193";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUV3K88Q' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script></div></div><div id="text-6" class="widget-4 widget-even current-poll each-block widget_text"><h2>Current Poll</h2> <div class="textwidget"><script type="text/javascript" charset="utf-8" src="https://secure.polldaddy.com/p/9768819.js"></script>
<noscript><a href="http://polldaddy.com/poll/9768819/">Who is the greatest British fighter of the past 30 years?</a></noscript></div>
</div><div id="ad_dropper_widget-4" class="widget-5 widget-odd each-block widget_ad_dropper_widget"><div class="addrop-wrap" data-id="499858"><center><a href="https://bit.ly/fightersnetwork" target="_blank"><img src="http://www.ringtv.com/custom-ads/fightersnetwork/160x90/160x90FN.png"></a></center></div></div><div id="extension-slug-widget--2" class="widget-6 widget-last widget-even each-block widget_callouts box-img">
<h2>Ratings: Pound for Pound</h2>
<div class="boxer-ratings">
<div class="each-row">
<div class="imagebox">
<img src="https://www.ringtv.com/wp-content/uploads/2016/07/Andre-Ward-ratings_Hoganphotos6-270x270.jpg" alt="Andre Ward"/>
</div>
<div class="number">1</div>
<div class="text">Andre Ward</div>
<div class="text">Record: 32-0-0 (16 KOs)</div> </div>
<div class="each-row">
<div class="imagebox">
<img src="https://www.ringtv.com/wp-content/uploads/2016/08/gennady-golovkin-ratings-fukuda-270x270.jpg" alt="Gennady Golovkin"/>
</div>
<div class="number">2</div>
<div class="text">Gennady Golovkin</div>
<div class="text">Record: 37-0-0 (33 KOs)</div> </div>
<div class="each-row">
<div class="imagebox">
<img src="https://www.ringtv.com/wp-content/uploads/2016/07/roman-gonzalez-ratings-fukuda-270x270.jpg" alt="Roman Gonzalez"/>
</div>
<div class="number">3</div>
<div class="text">Roman Gonzalez</div>
<div class="text">Record: 46-1-0 (38 KOs)</div> </div>
<div class="each-row">
<div class="imagebox">
<img src="https://www.ringtv.com/wp-content/uploads/2016/11/Terence-Crawford-ratings-270x270.jpg" alt="Terence Crawford"/>
</div>
<div class="number">4</div>
<div class="text">Terence Crawford</div>
<div class="text">Record: 31-0-0 (22 KOs)</div> </div>
<div class="each-row">
<div class="imagebox">
<img src="https://www.ringtv.com/wp-content/uploads/2016/07/Vasyl-Lomachenko-ratings-270x270.jpg" alt="Vasyl Lomachenko"/>
</div>
<div class="number">5</div>
<div class="text">Vasyl Lomachenko</div>
<div class="text">Record: 8-1-0 (6 KOs)</div> </div>
<div class="each-row">
<div class="imagebox">
<img src="https://www.ringtv.com/wp-content/uploads/2016/07/rigondeaux-ratings-270x270.jpg" alt="Guillermo Rigondeaux"/>
</div>
<div class="number">6</div>
<div class="text">Guillermo Rigondeaux</div>
<div class="text">Record: 17-0-0 (11 KOs)</div> </div>
<div class="each-row">
<div class="imagebox">
<img src="https://www.ringtv.com/wp-content/uploads/2016/07/Sergey-Kovalev-ratings-270x270.jpg" alt="Sergey Kovalev"/>
</div>
<div class="number">7</div>
<div class="text">Sergey Kovalev</div>
<div class="text">Record: 30-2-1 (26 KOs)</div> </div>
<div class="each-row">
<div class="imagebox">
<img src="https://www.ringtv.com/wp-content/uploads/2016/07/canelo-e1473365393257-270x270.jpg" alt="Canelo Alvarez"/>
</div>
<div class="number">8</div>
<div class="text">Canelo Alvarez</div>
<div class="text">Record: 49-1-1 (34 KOs)</div> </div>
<div class="each-row">
<div class="imagebox">
<img src="https://www.ringtv.com/wp-content/uploads/2016/08/shinsuke-yamanaka-ratings-fukuda-270x270.jpg" alt="Shinsuke Yamanaka"/>
</div>
<div class="number">9</div>
<div class="text">Shinsuke Yamanaka</div>
<div class="text">Record: 27-0-2 (19 KOs)</div> </div>
<div class="each-row">
<div class="imagebox">
<img src="https://www.ringtv.com/wp-content/uploads/2016/11/Naoya-Inoue-ratings-270x270.jpg" alt="Naoya Inoue"/>
</div>
<div class="number">10</div>
<div class="text">Naoya Inoue</div>
<div class="text">Record: 13-0-0 (11 KOs)</div> </div>
</div>
</div>
</div>
</div>
<div class="clearboth"></div>
</div>
</div>  
</div> 
<div class="footer-wrap">
<div class="bg-top"></div>
<div class="wrap-inner">
<a class="foot-go-top-btn visible-xs" href="#"></a>
<div class="row">
<div class="col-lg-3 col-md-3 col-sm-6 col-xs-12 hidden-xs">
<div class="foot-logo"><img src="https://www.ringtv.com/wp-content/themes/thering/images/ring-logo.png" alt=""></div>
<div class="foot-small-desc">Your destination for the best boxing news, videos and live streams!</div>
<ul class="foot-social">
<li><a href="https://www.facebook.com/RingTV" target="_blank"><i class="fa fa-facebook"></i></a></li> <li><a href="https://www.youtube.com/user/TheRingDigital?sub_confirmation=1" target="_blank"><i class="fa fa-youtube"></i></a></li> <li><a href="https://twitter.com/ringmagazine" target="_blank"><i class="fa fa-twitter"></i></a></li> <li><a href="https://instagram.com/ringtv" target="_blank"><i class="fa fa-instagram"></i></a></li> </ul>
</div>
<div class="col-xs-12 hidden-lg hidden-md hidden-sm visible-xs">
<h3>Quicklinks</h3>
<ul id="menu-footer-menu" class="foot-quicklinks"><li id="menu-item-186" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-186"><a href="https://www.ringtv.com/terms-conditions/">Terms &#038; Conditions</a></li>
<li id="menu-item-185" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-185"><a href="https://www.ringtv.com/privacy-policy/">Privacy Policy</a></li>
</ul> </div>
<div class="col-lg-3 col-md-3 col-sm-6 col-xs-12">
<h3>Contact Us</h3>
<div class="contact-info-row">
<span class="icon"><i class="fa fa-home"></i></span>
P.O. Box 90254<br> Brooklyn, NY 11209 </div>
<div class="contact-info-row">
<span class="icon"><i class="fa fa-phone"></i></span>
<a class="telnum" href="tel:+">215-643-3069</a>
</div>
<div class="contact-info-row">
<span class="icon"><i class="fa fa-envelope-o"></i></span>
<a class="email" href="/cdn-cgi/l/email-protection#c1b2b4b1b1aeb3b581b3a8afa6b5b7efa2aeac"><span class="__cf_email__" data-cfemail="92e1e7e2e2fde0e6d2e0fbfcf5e6e4bcf1fdff">[email&#160;protected]</span><script data-cfhash='f9e31' type="text/javascript">/* <![CDATA[ */!function(t,e,r,n,c,a,p){try{t=document.currentScript||function(){for(t=document.getElementsByTagName('script'),e=t.length;e--;)if(t[e].getAttribute('data-cfhash'))return t[e]}();if(t&&(c=t.previousSibling)){p=t.parentNode;if(a=c.getAttribute('data-cfemail')){for(e='',r='0x'+a.substr(0,2)|0,n=2;a.length-n;n+=2)e+='%'+('0'+('0x'+a.substr(n,2)^r).toString(16)).slice(-2);p.replaceChild(document.createTextNode(decodeURIComponent(e)),c)}p.removeChild(t)}}catch(u){}}()/* ]]> */</script></a>
</div>
</div>
<div class="col-lg-3 col-md-3 col-sm-6 col-xs-12 hidden-xs">
<h3>Quicklinks</h3>
<ul id="menu-quicklinks" class="foot-quicklinks"><li id="menu-item-178" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-178"><a href="https://www.ringtv.com/about-us/">About Us/Staff</a></li>
<li id="menu-item-179" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-179"><a href="https://www.ringtv.com/contact-us/">Contact Us/Advertise</a></li>
<li id="menu-item-180" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-180"><a href="https://www.ringtv.com/subscribe/">Subscribe</a></li>
</ul> </div>
<div class="col-lg-3 col-md-3 col-sm-6 col-xs-12 hidden-xs">
<h3>Join Our Newsletter</h3> <div class="foot-newsletter">
<div class="desc">Join our newsletter to get info about latest events and deals!</div>
<script type="text/javascript">(function() {
	if (!window.mc4wp) {
		window.mc4wp = {
			listeners: [],
			forms    : {
				on: function (event, callback) {
					window.mc4wp.listeners.push({
						event   : event,
						callback: callback
					});
				}
			}
		}
	}
})();
</script> <form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-462750" method="post" data-id="462750" data-name="Newsletter Subscription"><div class="mc4wp-form-fields"><input class="textbox" type="email" name="EMAIL" placeholder="YOUR EMAIL ADDRESS" required />
<input class="btn-light-pink" type="submit" value="Subscribe"><div style="display: none;"><input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off"/></div><input type="hidden" name="_mc4wp_timestamp" value="1498818352"/><input type="hidden" name="_mc4wp_form_id" value="462750"/><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1"/></div><div class="mc4wp-response"></div></form>  </div>
</div>
<div class="col-xs-12 hidden-lg hidden-md hidden-sm visible-xs">
<ul class="foot-social">
<li><a href="https://www.facebook.com/RingTV" target="_blank"><i class="fa fa-facebook"></i></a></li> <li><a href="https://twitter.com/ringmagazine" target="_blank"><i class="fa fa-twitter"></i></a></li> <li><a href="https://instagram.com/ringtv" target="_blank"><i class="fa fa-instagram"></i></a></li> </ul>
<div class="foot-logo"><img src="https://www.ringtv.com/wp-content/themes/thering/images/ring-logo.png" alt=""></div>
<div class="foot-small-desc">Your destination for the best boxing news, videos and live streams!</div>
</div>
</div> 
</div>
</div> 
<div class="footer-bottom">
<div class="wrap-inner">
<ul id="menu-footer-menu-1" class="foot-btm-links"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-186"><a href="https://www.ringtv.com/terms-conditions/">Terms &#038; Conditions</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-185"><a href="https://www.ringtv.com/privacy-policy/">Privacy Policy</a></li>
</ul> <div class="copyright">&copy; 2017 RING TV LIVE. All rights reserved. </div>
</div>
</div>
<div style="display: none;">
<div class="subscribe-modal" id="subscribe-now">
<div class="inner">
<span class="modal-logo"><img src="https://www.ringtv.com/wp-content/themes/thering/images/ring-logo.png" alt=""></span>
<h4>Get Our Newsletter.</h4> <p>Subscribe to our newsletter to get the latest news, events and deals in your inbox!</p> <div class="clearfix"></div>
</div>
<div class="mc-form">
<div class="inner">
<script type="text/javascript">(function() {
	if (!window.mc4wp) {
		window.mc4wp = {
			listeners: [],
			forms    : {
				on: function (event, callback) {
					window.mc4wp.listeners.push({
						event   : event,
						callback: callback
					});
				}
			}
		}
	}
})();
</script> <form id="mc4wp-form-2" class="mc4wp-form mc4wp-form-462750" method="post" data-id="462750" data-name="Newsletter Subscription"><div class="mc4wp-form-fields"><input class="textbox" type="email" name="EMAIL" placeholder="YOUR EMAIL ADDRESS" required />
<input class="btn-light-pink" type="submit" value="Subscribe"><div style="display: none;"><input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off"/></div><input type="hidden" name="_mc4wp_timestamp" value="1498818352"/><input type="hidden" name="_mc4wp_form_id" value="462750"/><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-2"/></div><div class="mc4wp-response"></div></form>  </div>
</div> 
</div>
</div>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-7578637367237225",
    enable_page_level_ads: true
  });
</script>
<div id="issuem-leaky-paywall-articles-remaining-nag">
<div id="issuem-leaky-paywall-articles-remaining-close">x</div>
<div id="issuem-leaky-paywall-articles-remaining-count">
<p>19</p>
</div>
<div id="issuem-leaky-paywall-articles-remaining">
<div id="issuem-leaky-paywall-articles-remaining-text">Posts Remaining</div>
<p>
<span id="issuem-leaky-paywall-articles-remaining-subscribe-link"><a href="https://www.ringtv.com/subscription/">Subscribe</a></span>
|
<span id="issuem-leaky-paywall-articles-remaining-login-link"><a href="https://www.ringtv.com/subscription-login/">Login</a></span>
</p>
</div>
</div>
<script type="text/javascript">(function() {function addEventListener(element,event,handler) {
	if(element.addEventListener) {
		element.addEventListener(event,handler, false);
	} else if(element.attachEvent){
		element.attachEvent('on'+event,handler);
	}
}function maybePrefixUrlField() {
	if(this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if( urlFields && urlFields.length > 0 ) {
	for( var j=0; j < urlFields.length; j++ ) {
		addEventListener(urlFields[j],'blur',maybePrefixUrlField);
	}
}/* test if browser supports date fields */
var testInput = document.createElement('input');
testInput.setAttribute('type', 'date');
if( testInput.type !== 'date') {

	/* add placeholder & pattern to all date fields */
	var dateFields = document.querySelectorAll('.mc4wp-form input[type="date"]');
	for(var i=0; i<dateFields.length; i++) {
		if(!dateFields[i].placeholder) {
			dateFields[i].placeholder = 'YYYY-MM-DD';
		}
		if(!dateFields[i].pattern) {
			dateFields[i].pattern = '[0-9]{4}-(0[1-9]|1[012])-(0[1-9]|1[0-9]|2[0-9]|3[01])';
		}
	}
}

})();</script><script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/www.ringtv.com\/wp-json\/","namespace":"contact-form-7\/v1"},"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.8'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var addrop_script = {"ajaxurl":"https:\/\/www.ringtv.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/ad-dropper/js/script.js?ver=1.2.0'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-includes/js/jquery/ui/datepicker.min.js?ver=1.11.4'></script>
<script type='text/javascript'>
jQuery(document).ready(function(jQuery){jQuery.datepicker.setDefaults({"closeText":"Close","currentText":"Today","monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Previous","dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"dateFormat":"MM d, yy","firstDay":1,"isRTL":false});});
</script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/jquery.flexslider.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/jquery.easing.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/jquery.movingboxes.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/instafeed.min.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/jquery.cycle2.min.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/jquery.mCustomScrollbar.concat.min.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/fitvids.min.js?ver=e370e146a94dbea8ac1321998961468f'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/owl.carousel.min.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/jquery.lazy.min.js?ver=1.0.1'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/jquery.fancybox.pack.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/js.cookie.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/jquery.matchHeight.js'></script>
<script type='text/javascript' src='https://www.ringtv.com/tweetie.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_var = {"url":"https:\/\/www.ringtv.com\/wp-admin\/admin-ajax.php","nonce":"7c93164527","template_url":"https:\/\/www.ringtv.com\/wp-content\/themes\/thering"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/themes/thering/js/global.js?ver=e370e146a94dbea8ac1321998961468f'></script>
<script type='text/javascript' src='https://www.ringtv.com/wp-includes/js/wp-embed.min.js?ver=4.7.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"platform":"wordpress@4.7.5","language":""},"disqusIdentifier":"503933 http:\/\/www.ringtv.com\/?p=503933","disqusShortname":"theringonline","disqusTitle":"Dougie\u2019s Friday mailbag","disqusUrl":"https:\/\/www.ringtv.com\/503933-dougies-friday-mailbag-109\/","options":{"manualSync":false},"postId":"503933"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/disqus-comment-system/media/js/disqus.js?ver=4.7.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"theringonline"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/disqus-comment-system/media/js/count.js?ver=4.7.5'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mc4wp_forms_config = [];
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/mailchimp-for-wp/assets/js/forms-api.min.js?ver=4.1.3'></script>
<!--[if lte IE 9]>
<script type='text/javascript' src='https://www.ringtv.com/wp-content/plugins/mailchimp-for-wp/assets/js/third-party/placeholders.min.js?ver=4.1.3'></script>
<![endif]-->
<script type='text/javascript' src="https://www.springboardplatform.com/jsapi/embed"></script>
<script>
 (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
 (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
 m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
 })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

 ga('create', 'UA-77508658-1', 'auto');
 ga('send', 'pageview');

</script>
 
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-5MLLG9" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-5MLLG9');</script>
 
 
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-4ef3d09874f075c2"></script>
<script type="text/javascript">
    
	jQuery(function($){
		
		if( $('#user_login').length ){
			$('#user_login').attr('placeholder','EMAIL ADDRESS');
		}
		
		if( $('#leaky-paywall-gift-subscription-plans').length ){
			$('#leaky-paywall-gift-subscription-plans option[value=3]').remove();
		}
		
		if (typeof(Cookies.get('subscribemod')) == 'undefined' || Cookies.get('subscribemod') == null) {
			//cookie is not present
			
			$.fancybox( {href : '#subscribe-now', openEffect : 'none', closeEffect : 'none', padding : 0, closeClick : false, afterClose: function(){
				Cookies.set('subscribemod', 'done', { path: '/', expires: 7 });
			} } ); 
			
			$('.joinus-modal').on('click',function(){
				Cookies.set('subscribemod', 'done', { path: '/', expires: 365 });
				$(this).parents('form').submit();
			});
		}	
                
                
                

       

		
	
				
				
	})
	
    var j = jQuery.noConflict();
    
	j(window).load(function(){
		
	});
	

    
    
</script>
<script>/* <![CDATA[ */(function(d,s,a,i,j,r,l,m,t){try{l=d.getElementsByTagName('a');t=d.createElement('textarea');for(i=0;l.length-i;i++){try{a=l[i].href;s=a.indexOf('/cdn-cgi/l/email-protection');m=a.length;if(a&&s>-1&&m>28){j=28+s;s='';if(j<m){r='0x'+a.substr(j,2)|0;for(j+=2;j<m&&a.charAt(j)!='X';j+=2)s+='%'+('0'+('0x'+a.substr(j,2)^r).toString(16)).slice(-2);j++;s=decodeURIComponent(s)+a.substr(j,m-j)}t.innerHTML=s.replace(/</g,'&lt;').replace(/\>/g,'&gt;');l[i].href='mailto:'+t.value}}catch(e){}}}catch(e){}})(document);/* ]]> */</script></body>
</html>