<!DOCTYPE html>
<html>
<head>
<meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
<meta name="viewport" content="width=device-width, initial-scale=1">
<meta name="generator" content="WordPress 4.7.3"/>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8"/>
<title>Dougie&#039;s Monday mailbag - The Ring</title>
<link rel="apple-touch-icon" sizes="57x57" href="http://www.ringtv.com/wp-content/themes/thering/images/apple-icon-57x57.png">
<link rel="apple-touch-icon" sizes="60x60" href="http://www.ringtv.com/wp-content/themes/thering/images/apple-icon-60x60.png">
<link rel="apple-touch-icon" sizes="72x72" href="http://www.ringtv.com/wp-content/themes/thering/images/apple-icon-72x72.png">
<link rel="apple-touch-icon" sizes="76x76" href="http://www.ringtv.com/wp-content/themes/thering/images/apple-icon-76x76.png">
<link rel="apple-touch-icon" sizes="114x114" href="http://www.ringtv.com/wp-content/themes/thering/images/apple-icon-114x114.png">
<link rel="apple-touch-icon" sizes="120x120" href="http://www.ringtv.com/wp-content/themes/thering/images/apple-icon-120x120.png">
<link rel="apple-touch-icon" sizes="144x144" href="http://www.ringtv.com/wp-content/themes/thering/images/apple-icon-144x144.png">
<link rel="apple-touch-icon" sizes="152x152" href="http://www.ringtv.com/wp-content/themes/thering/images/apple-icon-152x152.png">
<link rel="apple-touch-icon" sizes="180x180" href="http://www.ringtv.com/wp-content/themes/thering/images/apple-icon-180x180.png">
<link rel="icon" type="image/png" sizes="192x192" href="http://www.ringtv.com/wp-content/themes/thering/images/android-icon-192x192.png">
<link rel="icon" type="image/png" sizes="32x32" href="http://www.ringtv.com/wp-content/themes/thering/images/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="96x96" href="http://www.ringtv.com/wp-content/themes/thering/images/favicon-96x96.png">
<link rel="icon" type="image/png" sizes="16x16" href="http://www.ringtv.com/wp-content/themes/thering/images/favicon-16x16.png">
<link rel="manifest" href="http://www.ringtv.com/wp-content/themes/thering/images/manifest.json">
<meta name="msapplication-TileColor" content="#ffffff">
<meta name="msapplication-TileImage" content="http://www.ringtv.com/wp-content/themes/thering/images/ms-icon-144x144.png">
<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="http://www.ringtv.com/feed/"/>
<link rel="alternate" type="text/xml" title="RSS .92" href="http://www.ringtv.com/feed/rss/"/>
<link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="http://www.ringtv.com/feed/atom/"/>
<link rel="pingback" href="http://www.ringtv.com/xmlrpc.php"/>
 
<script>
!function(f,b,e,v,n,t,s)
{if(f.fbq)return;n=f.fbq=function(){n.callMethod?
n.callMethod.apply(n,arguments):n.queue.push(arguments)};
if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
n.queue=[];t=b.createElement(e);t.async=!0;
t.src=v;s=b.getElementsByTagName(e)[0];
s.parentNode.insertBefore(t,s)}(window,document,'script',
'https://connect.facebook.net/en_US/fbevents.js');
 fbq('init', '641303409343758'); 
fbq('track', 'PageView');
</script>
<noscript>
<img height="1" width="1" src="https://www.facebook.com/tr?id=641303409343758&ev=PageView&noscript=1"/>
</noscript>
 
 
<link rel="canonical" href="http://www.ringtv.com/490141-dougies-monday-mailbag-65/"/>
<meta property="og:locale" content="en_US"/>
<meta property="og:type" content="article"/>
<meta property="og:title" content="Dougie&#039;s Monday mailbag - The Ring"/>
<meta property="og:description" content="Lots of feedback on Genandy Golovkin&#039;s close decision over Daniel Jacobs and Roman Gonzalez&#039;s controversial loss to Srisaket Sor Rungvisai."/>
<meta property="og:url" content="http://www.ringtv.com/490141-dougies-monday-mailbag-65/"/>
<meta property="og:site_name" content="The Ring"/>
<meta property="article:publisher" content="https://www.facebook.com/RingTV"/>
<meta property="article:author" content="https://www.facebook.com/douglass.fischer"/>
<meta property="article:tag" content="chocolatito"/>
<meta property="article:tag" content="daniel jacobs"/>
<meta property="article:tag" content="doug fischer"/>
<meta property="article:tag" content="dougie&#039;s monday mailbag"/>
<meta property="article:tag" content="gennady golovkin"/>
<meta property="article:tag" content="ggg"/>
<meta property="article:tag" content="GGG-Jacobs"/>
<meta property="article:tag" content="Golovkin-Jacobs"/>
<meta property="article:tag" content="Gonzalez-Sor Rungvisai"/>
<meta property="article:tag" content="mailbag"/>
<meta property="article:tag" content="monday mailbag"/>
<meta property="article:tag" content="mythical matchup"/>
<meta property="article:tag" content="mythical matchups"/>
<meta property="article:tag" content="RingTV PPV"/>
<meta property="article:tag" content="Romang onzalez"/>
<meta property="article:tag" content="Srisaket Sor Rungvisai"/>
<meta property="article:section" content="Boxing"/>
<meta property="article:published_time" content="2017-03-20T04:11:52+00:00"/>
<meta property="article:modified_time" content="2017-03-20T04:32:48+00:00"/>
<meta property="og:updated_time" content="2017-03-20T04:32:48+00:00"/>
<meta property="og:image" content="http://www.ringtv.com/wp-content/uploads/2017/03/Golovkin-attacks-Jacobs_Hoganphotos.jpg"/>
<meta property="og:image:width" content="1800"/>
<meta property="og:image:height" content="1200"/>
<meta name="twitter:card" content="summary"/>
<meta name="twitter:description" content="Lots of feedback on Genandy Golovkin&#039;s close decision over Daniel Jacobs and Roman Gonzalez&#039;s controversial loss to Srisaket Sor Rungvisai."/>
<meta name="twitter:title" content="Dougie&#039;s Monday mailbag - The Ring"/>
<meta name="twitter:site" content="@ringmagazine"/>
<meta name="twitter:image" content="http://www.ringtv.com/wp-content/uploads/2017/03/Golovkin-attacks-Jacobs_Hoganphotos.jpg"/>
<meta name="twitter:creator" content="@dougiefischer"/>
 
<link rel='dns-prefetch' href='//s.w.org'/>
<link rel="alternate" type="application/rss+xml" title="The Ring &raquo; Dougie&#8217;s Monday mailbag Comments Feed" href="http://www.ringtv.com/490141-dougies-monday-mailbag-65/feed/"/>
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/2.2.1\/svg\/","svgExt":".svg","source":{"concatemoji":"http:\/\/www.ringtv.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.7.3"}};
			!function(a,b,c){function d(a){var b,c,d,e,f=String.fromCharCode;if(!k||!k.fillText)return!1;switch(k.clearRect(0,0,j.width,j.height),k.textBaseline="top",k.font="600 32px Arial",a){case"flag":return k.fillText(f(55356,56826,55356,56819),0,0),!(j.toDataURL().length<3e3)&&(k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,65039,8205,55356,57096),0,0),b=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55356,57331,55356,57096),0,0),c=j.toDataURL(),b!==c);case"emoji4":return k.fillText(f(55357,56425,55356,57341,8205,55357,56507),0,0),d=j.toDataURL(),k.clearRect(0,0,j.width,j.height),k.fillText(f(55357,56425,55356,57341,55357,56507),0,0),e=j.toDataURL(),d!==e}return!1}function e(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g,h,i,j=b.createElement("canvas"),k=j.getContext&&j.getContext("2d");for(i=Array("flag","emoji4"),c.supports={everything:!0,everythingExceptFlag:!0},h=0;h<i.length;h++)c.supports[i[h]]=d(i[h]),c.supports.everything=c.supports.everything&&c.supports[i[h]],"flag"!==i[h]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[i[h]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<style type="text/css">img.wp-smiley,img.emoji{display:inline!important;border:none!important;box-shadow:none!important;height:1em!important;width:1em!important;margin:0 .07em!important;vertical-align:-0.1em!important;background:none!important;padding:0!important;}</style>
<link rel='stylesheet' id='contact-form-7-css' href='http://www.ringtv.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=4.6' type='text/css' media='all'/>
<link rel='stylesheet' id='flexslider-css' href='http://www.ringtv.com/wp-content/themes/thering/css/flexslider.css' type='text/css' media='all'/>
<link rel='stylesheet' id='fontawesome-css' href='http://www.ringtv.com/wp-content/themes/thering/css/font-awesome.css' type='text/css' media='all'/>
<link rel='stylesheet' id='normalize-css' href='http://www.ringtv.com/wp-content/themes/thering/css/normalize.css' type='text/css' media='all'/>
<link rel='stylesheet' id='grid12-css' href='http://www.ringtv.com/wp-content/themes/thering/css/grid12.css' type='text/css' media='all'/>
<link rel='stylesheet' id='movingboxes-css' href='http://www.ringtv.com/wp-content/themes/thering/css/movingboxes.css' type='text/css' media='all'/>
<link rel='stylesheet' id='customscrollbar-css' href='http://www.ringtv.com/wp-content/themes/thering/css/jquery.mCustomScrollbar.css' type='text/css' media='all'/>
<link rel='stylesheet' id='owlcarousel-css' href='http://www.ringtv.com/wp-content/themes/thering/css/owl.carousel.css' type='text/css' media='all'/>
<link rel='stylesheet' id='fancybox-css' href='http://www.ringtv.com/wp-content/themes/thering/css/jquery.fancybox.css' type='text/css' media='all'/>
<link rel='stylesheet' id='stylesheet-css' href='http://www.ringtv.com/wp-content/themes/thering/style.css?ver=7087586e79110fdc66a69ca2a63b4ab2' type='text/css' media='all'/>
<link rel='stylesheet' id='responsive-css' href='http://www.ringtv.com/wp-content/themes/thering/css/responsive.css?ver=7087586e79110fdc66a69ca2a63b4ab2' type='text/css' media='all'/>
<script type='text/javascript' src='http://www.ringtv.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='http://www.ringtv.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='http://www.ringtv.com/wp-content/themes/thering/js/countdown.js'></script>
<link rel='https://api.w.org/' href='http://www.ringtv.com/wp-json/'/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://www.ringtv.com/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://www.ringtv.com/wp-includes/wlwmanifest.xml"/>
<meta name="generator" content="WordPress 4.7.3"/>
<link rel='shortlink' href='http://www.ringtv.com/?p=490141'/>
<link rel="alternate" type="application/json+oembed" href="http://www.ringtv.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.ringtv.com%2F490141-dougies-monday-mailbag-65%2F"/>
<link rel="alternate" type="text/xml+oembed" href="http://www.ringtv.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fwww.ringtv.com%2F490141-dougies-monday-mailbag-65%2F&#038;format=xml"/>
</head>
<body class="post-template-default single single-post postid-490141 single-format-standard loading dougies-monday-mailbag-65 unknown">
<div id="mobile-nav">
<a href="#" class="btn-close-mob"></a>
<div class="mob-logo"><img src="http://www.ringtv.com/wp-content/themes/thering/images/ring-logo.png" alt=""></div>
<ul id="menu-main-menu" class="mob-nav"><li id="menu-item-151" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-151"><a href="http://www.ringtv.com/">Home</a></li>
<li id="menu-item-152" class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-has-children menu-item-152"><a href="http://www.ringtv.com/news/">News</a></li>
<li id="menu-item-158" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-158"><a href="http://www.ringtv.com/videos/">Videos</a></li>
<li id="menu-item-153" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-153"><a href="http://www.ringtv.com/photos/">Photos</a></li>
<li id="menu-item-155" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-155"><a href="http://www.ringtv.com/ratings/">Ratings</a></li>
<li id="menu-item-156" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156"><a href="http://www.ringtv.com/schedule/">Schedule</a></li>
<li id="menu-item-249" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-249"><a target="_blank" href="https://esolutionsmnec.ecenergy.com/eCatalog/Account/AnonymousLogon/38?customerName=RING">Shop</a></li>
<li id="menu-item-159" class="hlogin-btn menu-item menu-item-type-custom menu-item-object-custom menu-item-159"><a href="https://ssl.palmcoastd.com/28501/apps/LOGINSSO">Login</a></li>
<li id="menu-item-157" class="hsubscribe-btn menu-item menu-item-type-post_type menu-item-object-page menu-item-157"><a href="http://www.ringtv.com/subscribe/">Subscribe</a></li>
</ul> <ul class="mobile-nav-social">
<li><a href="http://www.ringtv.com/search"><i class="fa fa-search"></i></a></li>
<li><a href="https://www.facebook.com/RingTV" target="_blank"><i class="fa fa-facebook"></i></a></li> <li><a href="https://www.youtube.com/user/TheRingDigital?sub_confirmation=1" target="_blank"><i class="fa fa-youtube"></i></a></li> <li><a href="https://twitter.com/ringmagazine" target="_blank"><i class="fa fa-twitter"></i></a></li> <li><a href="http://instagram.com/ringtv" target="_blank"><i class="fa fa-instagram"></i></a></li> </ul>
</div> 
<div class="header">
<div class="header-inner">
<a href="http://www.ringtv.com" class="logo"><img src="http://www.ringtv.com/wp-content/themes/thering/images/ring-logo.png" alt=""></a>
<ul id="menu-main-menu-1" class="main-nav"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-151"><a href="http://www.ringtv.com/">Home</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page current_page_parent menu-item-has-children menu-item-152"><a href="http://www.ringtv.com/news/">News</a>
<ul class="sub-menu">
<li id="menu-item-458877" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-458877"><a href="http://www.ringtv.com/category/boxing/">Boxing</a></li>
<li id="menu-item-163" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-163"><a href="http://www.ringtv.com/category/mma/">MMA</a></li>
<li id="menu-item-162" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-162"><a href="http://www.ringtv.com/category/kickboxing/">Kickboxing</a></li>
<li id="menu-item-164" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-164"><a href="http://www.ringtv.com/category/press-releases/">Press Releases</a></li>
<li id="menu-item-161" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-161"><a href="http://www.ringtv.com/category/exclusive-editorial/">Exclusive Editorial</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-158"><a href="http://www.ringtv.com/videos/">Videos</a>
<ul class="sub-menu">
<li id="menu-item-165" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-165"><a href="http://www.ringtv.com/videos/">Latest</a></li>
<li id="menu-item-166" class="menu-item menu-item-type-taxonomy menu-item-object-video_cat menu-item-166"><a href="http://www.ringtv.com/video-category/featured/">Featured</a></li>
<li id="menu-item-167" class="menu-item menu-item-type-taxonomy menu-item-object-video_cat menu-item-167"><a href="http://www.ringtv.com/video-category/classic-fights/">Classic Fights</a></li>
<li id="menu-item-168" class="menu-item menu-item-type-taxonomy menu-item-object-video_cat menu-item-168"><a href="http://www.ringtv.com/video-category/live-events/">Live Events</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-153"><a href="http://www.ringtv.com/photos/">Photos</a>
<ul class="sub-menu">
<li id="menu-item-169" class="menu-item menu-item-type-taxonomy menu-item-object-photo_cat menu-item-169"><a href="http://www.ringtv.com/photo-category/featured/">Featured</a></li>
<li id="menu-item-171" class="menu-item menu-item-type-taxonomy menu-item-object-photo_cat menu-item-171"><a href="http://www.ringtv.com/photo-category/classic/">Classic</a></li>
<li id="menu-item-170" class="menu-item menu-item-type-taxonomy menu-item-object-photo_cat menu-item-170"><a href="http://www.ringtv.com/photo-category/boxing/">Boxing</a></li>
<li id="menu-item-172" class="menu-item menu-item-type-taxonomy menu-item-object-photo_cat menu-item-172"><a href="http://www.ringtv.com/photo-category/mma/">MMA</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-155"><a href="http://www.ringtv.com/ratings/">Ratings</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-156"><a href="http://www.ringtv.com/schedule/">Schedule</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-249"><a target="_blank" href="https://esolutionsmnec.ecenergy.com/eCatalog/Account/AnonymousLogon/38?customerName=RING">Shop</a></li>
<li class="hlogin-btn menu-item menu-item-type-custom menu-item-object-custom menu-item-159"><a href="https://ssl.palmcoastd.com/28501/apps/LOGINSSO">Login</a></li>
<li class="hsubscribe-btn menu-item menu-item-type-post_type menu-item-object-page menu-item-157"><a href="http://www.ringtv.com/subscribe/">Subscribe</a></li>
</ul>
<div class="mobile-menu-btn"><i class="fa fa-bars"></i></div>
<ul class="head-social">
<li><a href="http://www.ringtv.com/search"><i class="fa fa-search"></i></a></li>
<li><a href="https://www.facebook.com/RingTV" target="_blank"><i class="fa fa-facebook"></i></a></li> <li><a href="https://www.youtube.com/user/TheRingDigital?sub_confirmation=1" target="_blank"><i class="fa fa-youtube"></i></a></li> <li><a href="https://twitter.com/ringmagazine" target="_blank"><i class="fa fa-twitter"></i></a></li> <li><a href="http://instagram.com/ringtv" target="_blank"><i class="fa fa-instagram"></i></a></li> </ul>
</div> 
</div> 
<div class="sub-header">
<div class="wrap-inner">
<h1>News</h1>
<div class="ads728-90"><script id="mNCC" language="javascript">
   medianet_width = "728";
   medianet_height = "90";
   medianet_crid = "766595921";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUV3K88Q' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script>
</div>
</div>
</div> 
<div class="sub-content-wrap">
<div class="a-d-wrap">
<div class="wrap-inner">
<div class="row">
<div class="col-lg-8 col-md-8 col-sm-12 col-xs-12 news-content">
<div class="full-post">
<h1>Dougie&#8217;s Monday mailbag</h1>
</div>
</div>
</div>
<div class="row">
<div class="col-lg-8 col-md-8 col-sm-8 col-xs-12 news-content">
<div class="full-post">
<div class="imagebox"><img src="http://www.ringtv.com/wp-content/uploads/2017/03/Golovkin-attacks-Jacobs_Hoganphotos-770x513.jpg" alt=""></div>
<div class="image-desc">Photo / Tom Hogan-HoganPhotos / K2 Promotions</div>
<div class="a-d-468x60-post hidden-md visible-sm visible-xs"><script id="mNCC" language="javascript">
   medianet_width = "468";
   medianet_height = "60";
   medianet_crid = "887466222";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUV3K88Q' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script></div>
<div class="text-wrap">
<div class="date-col">
<div class="day">20</div>
<div class="month">Mar</div>
</div>
<div class="a-d-468x60-post hidden-sm hidden-xs"><script id="mNCC" language="javascript">
   medianet_width = "468";
   medianet_height = "60";
   medianet_crid = "887466222";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUV3K88Q' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script></div>
<div class="posted-by"><a href="http://www.ringtv.com/author/doug/">by Doug Fischer</a></div>
<p><strong>THE BIG AND LITTLE DRAMA SHOWS</strong></p>
<p>Dear Mr Fischer,</p>
<p>While I&#8217;m pleased to have spent my Saturday night watching the big and little drama shows, and pleased to have been able to bring three new initiates into the boxing fandom fold, I can&#8217;t say that the night was an overwhelming success.</p>
<p>The four of us had a hard time stomaching the results of Roman Gonzales and Srisaket Sor Rungvisai&#8217;s fight. None of us, me least of all, could figure out why Steve Willis only had the doctor look at the cuts (plural!) on Chocolatito&#8217;s head once, and didn&#8217;t do a better job of watching for the clashes. After four rounds, I figured the fight would go the same way as Sor Rungvisai&#8217;s loss to Carlos Cuadras and be stopped and sent to the cards (which Chocolatito seemed sure to carry after round 3) well before the championship rounds. The result sits worse for me than Andre Ward&#8217;s &#8220;win&#8221; over Sergey Kovalev, watching Chocolatito&#8217;s cutman&#8217;s hands shake because of his inability to stop the bleeding (and I assume his care for his fighter) was heartbreaking. The champion deserved better. I will leave the scoring controversy (all the minds in the room with me were as one) to people who understand boxing scoring better than me; I&#8217;m more confused the longer I follow the sport.</p>
<p>The Gennady Golovkin-Daniel Jacobs fight was easier to watch, if not what I was expecting. I have to give credit to Andre Rozier, Virgil Hunter, and the rest of Jacob&#8217;s team, they had an exceptional fight plan. I do not agree with Jacobs or Rozier that he won the fight, nor do I think that he could &#8220;win every round&#8221; if he just kept to boxing GGG (something Rozier told him after the knockdown). I saw the fight going the distance after the third round, Jacobs was big and it was clear that he had no plans to engage enough to take meaningful risks (apart from the obviously enormous risk of stepping into the ring with GGG). After 12, we in the room believed that Golovkin had done more than enough to win the fight (with the knockdown providing a cushion for an otherwise close fight), but everyone was hoping for a little more action (I had shown them Golovkin&#8217;s fights against Kell Brook, Curtis Stevens, and David Lemieux). Apart from the lack of sustained action, which seemed to take the crowd out of most of the fight, what was the atmosphere inside the Garden? What was your assessment of the fight?</p>
<p>Thanks again for all you do with the mailbags and articles. I hope you had a great weekend and that it didn&#8217;t make for too much work (although it&#8217;s hard to envy you that, given where some of it occurs). I hope also that this finds you and yours well, and that you are back with your family by the time this mailbag hits the press. I send the very best. Peace. – John</p>
<p><strong>Thanks for the very kind words and for sharing your thoughts on Saturday’s show, John. I compiled this mailbag while waiting for my flight out of New York City at LaGuardia airport and began answering it while waiting for my wife (with kids) to pick me up from LAX. So, yes, the family is good, and yes, I was back home before this edition of the Monday mailbag was published.</strong></p>
<p><strong>Also, thanks for bringing in three boxing fan newbies with Saturday’s pay-per-view card. Hopefully, the sustained action of the junior bantamweight title bout made more of an impression than questionable scoring.</strong></p>
<p><em>The four of us had a hard time stomaching the results of Roman Gonzales and Srisaket Sor Rungvisai&#8217;s fight.</em> <strong>That’s probably because you see and think clearly. </strong></p>
<p><em>None of us, me least of all, could figure out why Steve Willis only had the doctor look at the cuts (plural!) on Chocolatito&#8217;s head once, and didn&#8217;t do a better job of watching for the clashes.</em> <strong>Perhaps ol’ Crazy Eyes just viewed it as an unfortunate byproduct of the fighters’ ultra-aggressiveness and the clash of their orthodox and southpaw stances.</strong></p>
<p><em>The result sits worse for me than Andre Ward&#8217;s &#8220;win&#8221; over Sergey Kovalev, watching Chocolatito&#8217;s cutman&#8217;s hands shake because of his inability to stop the bleeding (and I assume his care for his fighter) was heartbreaking. </em><strong>Gonzalez was worked on by a hall-of-fame cutman, Miguel Diaz, between rounds, but alas age has probably caused the veteran cornerman’s hands to betray him.</strong></p>
<p><em>The champion deserved better.</em> <strong>I agree. So did every member of press row that I spoke to after the fight, and the vast majority of the crowd inside MSG.</strong></p>
<p><em>I will leave the scoring controversy (all the minds in the room with me were as one) to people who understand boxing scoring better than me; I&#8217;m more confused the longer I follow the sport.</em> <strong>I don’t think anyone who covers or follows pro boxing understands the sport’s scoring anymore. The way it USED to be was the dude who landed the more meaningful punches on a round by round basis was the dude who won the fight if it went to the scorecards, but evidently that’s no longer the case. Gonzalez landed more punches in 10 of the 12 rounds he fought with Sor Rungvisai and even set a junior bantamweight CompuBox record by landing 372 power shots (56.4%) and he STILL somehow lost the fight! Arrrrgh!</strong></p>
<p><em>The Gennady Golovkin-Daniel Jacobs fight was easier to watch, if not what I was expecting.</em> <strong>I’m an unapologetic blood-thirsty ghoul, so Gonzalez-Sor Rungvisai was much easier for me to watch than Golovkin-Jacobs. I appreciated the ring generalship, defense and strategy exhibited by both middleweights but I was waiting for fireworks to explode and all I got was a slow-burning fuse for 12 rounds.</strong></p>
<p><em>I have to give credit to Andre Rozier, Virgil Hunter, and the rest of Jacob&#8217;s team, they had an exceptional fight plan.</em> <strong>They did a lot of things right – including coming in as heavy as possible on fight night (and to hell with the IBF), staying off the ropes for much of the bout, switching to southpaw for periods, and going to GGG’s body during the second half of the fight.</strong></p>
<div id="attachment_490146" style="width: 410px" class="wp-caption alignleft"><img class="size-full wp-image-490146" src="http://www.ringtv.com/wp-content/uploads/2017/03/Golovkin-jabs-Jacobs_Hoganphotos.jpg" alt="" width="400" height="292" srcset="http://www.ringtv.com/wp-content/uploads/2017/03/Golovkin-jabs-Jacobs_Hoganphotos.jpg 400w, http://www.ringtv.com/wp-content/uploads/2017/03/Golovkin-jabs-Jacobs_Hoganphotos-300x219.jpg 300w" sizes="(max-width: 400px) 100vw, 400px"/><p class="wp-caption-text">Photo / Tom Hogan-HoganPhotos / K2 Promotions</p></div>
<p><em>I do not agree with Jacobs or Rozier that he won the fight, nor do I think that he could &#8220;win every round&#8221; if he just kept to boxing GGG (something Rozier told him after the knockdown).</em> <strong>Well, here’s the thing, I’m sure that advice kept Jacobs upright for the next eight rounds, but there’s more to effective “boxing” than lateral movement and an occasional flurry – especially when your guy is getting out-jabbed.</strong></p>
<p><em>I saw the fight going the distance after the third round, Jacobs was big and it was clear that he had no plans to engage enough to take meaningful risks (apart from the obviously enormous risk of stepping into the ring with GGG).</em> <strong>It seemed to me that Jacobs took the game plan of Martin Murray (another very big, very mobile middleweight but not as athletic as the Brooklynite) to another level.</strong></p>
<p><em>After 12, we in the room believed that Golovkin had done more than enough to win the fight (with the knockdown providing a cushion for an otherwise close fight)…</em> <strong>Seems to me that you and your three boxing new-comer guests have better eyes and sensibility than a lot of the self-proclaimed hardcore fans shooting their mouths off on Twitter.</strong></p>
<p><em>Apart from the lack of sustained action, which seemed to take the crowd out of most of the fight, what was the atmosphere inside the Garden?</em> <strong>It was all the way live, John. It was as loud as you’d expect from nearly 20,000 passionate fans and very intense, with enough Jacobs fans to put up counter cheers and chants to the obvious crowd favorite (occasionally boiling over into some unfortunate fist fights in the audience).</strong></p>
<p><em>What was your assessment of the fight? </em><strong>It was a tactical bout, interesting to watch live but not as entertaining as I’d hoped it would be. I thought Jacobs fought the fight of his life and legitimately won anywhere from four to six rounds, but I do not think he did enough to beat Golovkin, who to my eyes was the ring master that night.</strong></p>
<p>&nbsp;</p>
<p><strong>GREAT FIGHTS, BAD DECISIONS</strong></p>
<p>Dougie,</p>
<p>Saturday night was such an amazing night of boxing but I can&#8217;t help but feel that the wrong guy won both the co-main event and the main event. Now I&#8217;m not stubborn or a person that isn&#8217;t up for debate but I truly feel Chocolatito and Daniel Jacobs legitimately had their well earned victory taken away from them.</p>
<p>I am a boxing fan to the max and I was watching the fight with people who I was trying to introduce the sport of boxing at its best to. Fights were enjoyed and people were excited but when decisions were announced even people who don&#8217;t know the sport understood that the scores should of been the other way.</p>
<p>I personally had Jacobs winning 8 rounds to 4 with the extra point for GGG for the knockdown but I understand that rounds are close but man I really felt that Jacobs had the victory locked in and GGG needed a knockdown to at least get the draw. How did you score it?</p>
<p>Dougie, idk about you but I really feel HBO commentators are losing their step. Not all of them but def Roy Jones and Jim Lampley. I love hearing Max Kellerman. My dream team of commentators would be Kellerman, Paulie Malignaggi, and a head trainer for every fight. How about you?</p>
<p>Mythical matchups:</p>
<p>Tito Trinidad vs GGG-</p>
<p>Arturo Gatti vs Mayorga-</p>
<p>Shawn Porter vs Maidana-</p>
<p>Thanks a lot for reading my email. I love hearing your opinions on the current boxing world and I will continue to tune in every week to your mailbag.  – Juan M</p>
<p><strong>Thanks Juan.</strong></p>
<p><strong>I saw a competitive middleweight fight but recognized Golovkin’s superior jab, defensive prowess and consistent offense, and scored seven rounds to the defending unified beltholder – Rounds 1, 3, 4, 5, 8, 9, and 12 – for a 115-112 tally. Jacobs was definitely in the fight. The New Yorker had a 144-126 edge in power shots landed, according to CompuBox, but from my vantage point Golovkin (the more accurate and economical puncher) landed the cleaner power shots between his constant jab (which often landed with head-snapping authority).</strong></p>
<p><strong>I’m OK with judge Max DeLuca’s 114-113 scorecard for Golovkin, but I’m also fine with folks who scored eight rounds for the unbeaten Kazakh (116-111).</strong></p>
<p><strong><img class="alignright size-full wp-image-490148" src="http://www.ringtv.com/wp-content/uploads/2017/03/Golovkin-Jacobs-CompuBox.jpg" alt="" width="400" height="225" srcset="http://www.ringtv.com/wp-content/uploads/2017/03/Golovkin-Jacobs-CompuBox.jpg 400w, http://www.ringtv.com/wp-content/uploads/2017/03/Golovkin-Jacobs-CompuBox-300x169.jpg 300w" sizes="(max-width: 400px) 100vw, 400px"/>I expected some fans and media to score the fight for Jacobs if it went the distance, and I expected debate as to who was the superior “boxer.” There&#8217;s always going to be heated debate as to who <em>really</em> won after a style matchup between a strong, busy, come-forward technician and fast, flashy, mobile boxer-puncher.<br/>
</strong></p>
<p><strong>With the exception of my boyhood idol, Sugar Ray Leonard (against Marvin Hagler 30 years ago), I generally don’t side with the boxer who moves about the ring and gets off in offensive spurts in a close fight against a more offensively consistent hard-punching stalker. I still think Kovalev beat Ward and I still think Badou Jack beat James DeGale.</strong></p>
<p><em>Dougie, idk about you but I really feel HBO commentators are losing their step.</em> <strong>I don’t always agree with Jim, Roy, Max and Harold, but I think they – as well as Showtime’s various boxing broadcast booths – are among the best in the world.</strong></p>
<p><em>Not all of them but def Roy Jones and Jim Lampley.</em> <strong>Roy’s my favorite. Jim’s a broadcast legend.</strong></p>
<p><em>My dream team of commentators would be Kellerman, Paulie Malignaggi, and a head trainer for every fight. How about you?</em> <strong>Nobody currently following the sport will agree with me, but if I could bring back the retired sportscaster Tim Ryan and resurrect hall-of-fame trainer/manager Gil Clancy to do one more show, that old CBS boxing commentator duo would be my dream team.</strong></p>
<p><strong>Your mythical matchups:</strong></p>
<p><strong>Tito Trinidad vs GGG- Golovkin by decision or late stoppage</strong></p>
<p><strong>Arturo Gatti vs Mayorga- Mayorga by late stoppage (probably on cuts)</strong></p>
<p><strong>Shawn Porter vs Maidana- Porter by close but unanimous decision</strong></p>
<p>&nbsp;</p>
<p><strong>WHAT’S NEXT FOR GONZALEZ, INOUE?</strong></p>
<p>Hi, Doug!</p>
<ol>
<li>Gonzalez-Sor Rungvisai was a terrific fight, but I was upset by the outcome: I think Gonzalez won by 115-111.</li>
</ol>
<p>Still, I cannot call it a robbery since it was legitimately close, and it&#8217;s clear that at 115 he isn&#8217;t the beast that he used to be at 108/112.</p>
<p>I admire those who move up to fight the best, but sometimes I wish they stayed where they can perform best.</p>
<ol start="2">
<li>And with Gonzalez defeated, I wonder what Inoue will do next.</li>
</ol>
<p>Inoue was willing to make a US debut and fight Gonzalez, but probably he won&#8217;t be very interested in Sor Rungvisai, who isn&#8217;t so popular but is as dangerous as Gonzalez.</p>
<p>If he doesn&#8217;t fight the Thai, I want him to move up immediately to 118 and fight Yamanaka before the RING bantamweight king gets too old.</p>
<ol start="3">
<li>If Inoue leaves 115, the superflyweight division will turn into a chaos.</li>
</ol>
<p>Sor Rungvisai is very dangerous but beatable, Cuadras didn&#8217;t look sharp tonight, Gonzalez seems to have hit the ceiling, and Estrada may not be as effective as he was at 112 too.</p>
<p>Who will emerge as the king of the division?</p>
<p>Mythical matchups:</p>
<p>Salvador Sanchez vs Julio Cesar Chavez at 130 in 1984 &#8212; What would have happened to Chavez&#8217;s legacy and record if Sanchez hadn&#8217;t been killed?</p>
<p>The GGG that fought Jacobs vs the best version of Sergio Martinez at 160</p>
<p>Cheers. – Taku from Japan</p>
<p><strong>I’ll start with your interesting m</strong><strong>ythical matchups:</strong></p>
<p><em>Salvador Sanchez vs Julio Cesar Chavez at 130 in 1984 &#8212; What would have happened to Chavez&#8217;s legacy and record if Sanchez hadn&#8217;t been killed?</em> <strong>I think Sanchez would have outpointed him in a very close, hotly contested fight, and maybe done so in a rematch that would have shortened the Mexico City native’s career, but I think Chavez still would have gone on to become a legend of the sport.</strong></p>
<p><em>The GGG that fought Jacobs vs the best version of Sergio Martinez at 160 –</em> <strong>I can see the best version of Martinez outworking and outmaneuvering Saturday’s version of Golovkin to a close points win, but my pick would be GGG by late TKO. I think Golovkin’s steady pressure, stiff, well-timed jab, accurate power shots, and Maravilla’s own warrior spirit would get the better of the Argentine southpaw in a very good fight. Unlike Jacobs, who may have been 10-15 pounds heavier than Golovkin, Martinez didn’t have the size to withstand the pressure for 12 rounds.</strong></p>
<p><em>Gonzalez-Sor Rungvisai was a terrific fight, but I was upset by the outcome: I think Gonzalez won by 115-111.</em> <strong>You, my friend, had the correct scorecard (official judges and Twitter nerds be damned). Like you, I thought Chocolatito clearly won eight rounds (and with his knockdown and Sor Rungvisai’s point deduction that winds up being a 115-111 tally). It was indeed a terrific fight, a Fight of the Year candidate in my opinion. </strong></p>
<p><em>Still, I cannot call it a robbery since it was legitimately close, and it&#8217;s clear that at 115 he isn&#8217;t the beast that he used to be at 108/112.</em> <strong>OK, don’t call it a robbery; call it a gift for Sor Rungvisai. Of course, Gonzalez isn’t at his best at 115 pounds. He began his career at 105 pounds and he’s had a lot of hard championship fights over the past eight and half years. But the fact that he doesn’t dominate as much at 115 as he did the lighter divisions does not negate the fact that he soundly outworked, out-jabbed, outslugged and out-landed the Thai challenger.</strong></p>
<p><em>I admire those who move up to fight the best, but sometimes I wish they stayed where they can perform best.</em> <strong>Had Gonzalez stayed at 112, or immediately returned to flyweight after beating Cuadras, you know as well as I do that all those hardcore nutcakes hanging out there in comment sections and the Twitterverse would claim he’s avoiding your boy Inoue and a rematch with Principe.</strong></p>
<p><em>I wonder what Inoue will do next? Inoue was willing to make a US debut and fight Gonzalez, but probably he won&#8217;t be very interested in Sor Rungvisai, who isn&#8217;t so popular but is as dangerous as Gonzalez.</em> <strong>Hey, Inoue doesn’t lack confidence. Sor Rungvisai has the WBC belt, which holds a lot of weight in Japan, and there’s a Japan-Thailand rivalry that exists. I can see Inoue going for WBO-WBC title unification bout, or allowing Gonzalez to try to avenge his loss and then taking on the winner of the rematch.</strong></p>
<p><em>If he doesn&#8217;t fight the Thai, I want him to move up immediately to 118 and fight Yamanaka before the RING bantamweight king gets too old.</em> <strong>That’s a passing-of-the-torch match that I’d love to see. It would be the first time an all-Japanese matchup up was between two pound-for-pound rated fighters with a RING title on the line.</strong></p>
<p><em>If Inoue leaves 115, the super flyweight division will turn into a chaos. Sor Rungvisai is very dangerous but beatable, Cuadras didn&#8217;t look sharp tonight, Gonzalez seems to have hit the ceiling, and Estrada may not be as effective as he was at 112 too.</em> <strong>Yeah, but you know what? No matter how you match them up among themselves, they make for BADASS fights, so I don’t care. If Inoue stays at 115, all the better. </strong></p>
<p><em>Who will emerge as the king of the division?</em> <strong>I gotta favor Inoue if he sticks around. The Monster has size, youth and natural talent on his side.</strong></p>
<p>&nbsp;</p>
<p><strong>GGG’S RAZOR-THIN WIN</strong></p>
<p>Hey Dougie,</p>
<p>Hope you had a great time in NYC. Both fights were close but one had the wrong winner.</p>
<p>First let’s start with GGG, I thought he did enough to win 6 to 7 rounds, felt he let go several rounds looking for openings to try to keep the KO streak alive. If he hadn&#8217;t done that and kept throwing he jab and body shots he would&#8217;ve made it much easier on himself.</p>
<p>I give Danny Jacobs a lot of credit because he came very close in unseating the middleweight champ. It’s obvious a lot of GGG haters and Canelo lovers are going to cry robbery and that’s OK, it was close, it’s part of how social media works, but let’s be honest, there was only one man that seemed to be hurt by the other guy&#8217;s punches, and that was Jacobs.</p>
<p>Man, GGG has a chin doesn&#8217;t he? Every time GGG landed flush you could see that Jacobs felt it. There&#8217;s a reason one man hit the deck and the other didn’t.</p>
<p>Now, Chocolatito&#8230; man it was sad seeing his unbeaten record go in a fight like this where he did everything a human being can do to fight against all sorts of adversity. To me he&#8217;s still the best boxing machine in the business and the only reason he&#8217;s going to lose legitimately is because of size not skill.</p>
<p>Overall a good card. Worth the money as always. I do see these two warriors losing soon as Father Time is creeping up on them. Still my two favorite fighters currently (not Lomachenko as HBO wants me to believe). Safe trip. – Juan Valverde</p>
<p><strong>I had a safe trip to and from NYC and a great time (as always) while I was there (I didn’t even mind the cold weather or all the drunk St. Patrick’s Day celebrators).</strong></p>
<p><strong>Age/wear and tear has indeed begun to take a toll on the Dynamic Duo but they remain the best one-two punch in boxing in terms of entertainment value and live in-arena experience. And they remain masters of their craft. Golovkin’s ring generalship is not appreciated or recognized by all, but it’s amazing, and Chocolatito’s high-volume body-head combination attack is absolutely awe inspiring – especially when you take into consideration that he’s in his fourth weight class with 16 world title bouts under his belt.</strong></p>
<p><em>First let’s start with GGG, I thought he did enough to win 6 to 7 rounds, felt he let go several rounds looking for openings to try to keep the KO streak alive.</em> <strong>I agree, but I’m going to give Jacobs credit for neutralizing GGG’s aggression to an extent with lateral movement and sporadic offense that kept the defending titleholder on his toes and always ready to take a step back. </strong></p>
<p><em>If he hadn&#8217;t done that and kept throwing he jab and body shots he would&#8217;ve made it much easier on himself.</em> <strong>Golovkin definitely needed to go to the body more than he did. </strong></p>
<p><em>I give Danny Jacobs a lot of credit because he came very close in unseating the middleweight champ.</em> <strong>He fought an excellent fight and game plan, and he really dug deep. Jacobs and his team – which obviously had a great training camp – should be proud of the effort he put forth on Saturday.</strong></p>
<p><em>It’s obvious a lot of GGG haters and Canelo lovers are going to cry robbery and that’s OK, it was close, it’s part of how social media works, but let’s be honest, there was only one man that seemed to be hurt by the other guy&#8217;s punches, and that was Jacobs.</em> <strong>That’s what I saw from my seat on press row, but other writers (who were closer to the ring) believe that they saw Jacobs buzz or stun Golovkin more than a few times. As for the GGG haters (and the Canelo lovers – although I don’t hear much from them), they can bring it on social media, I’ve got something for their stankin’ asses. I’m dishin’ out grief all week and I hope the replay of the fight pisses them off even more.</strong></p>
<p><em>Man, GGG has a chin doesn&#8217;t he?</em> <strong>Arguably the best in the sport.</strong></p>
<div id="attachment_490151" style="width: 410px" class="wp-caption alignleft"><img class="size-full wp-image-490151" src="http://www.ringtv.com/wp-content/uploads/2017/03/Gonzalez-right-hand-Rungvisai_Hoganphotos.jpg" alt="" width="400" height="267" srcset="http://www.ringtv.com/wp-content/uploads/2017/03/Gonzalez-right-hand-Rungvisai_Hoganphotos.jpg 400w, http://www.ringtv.com/wp-content/uploads/2017/03/Gonzalez-right-hand-Rungvisai_Hoganphotos-300x200.jpg 300w" sizes="(max-width: 400px) 100vw, 400px"/><p class="wp-caption-text">Photo / Tom Hogan-HoganPhotos / K2 Promotions</p></div>
<p><em>Now, Chocolatito&#8230; man it was sad seeing his unbeaten record go in a fight like this where he did everything a human being can do to fight against all sorts of adversity.</em> <strong>Yeah, that decision sucked in my opinion, but my hat is off to Sor Rungvisai. That little Thai warrior came to die on Saturday. He took shots that he shouldn’t have been able to absorb, but his mind and will and spirit were so strong he fought through Gonzalez’s punch storm.</strong></p>
<p><em>To me he&#8217;s still the best boxing machine in the business and the only reason he&#8217;s going to lose legitimately is because of size not skill.</em> <strong>Agreed. His heart/will/spirit is just as strong as Sor Rungvisai’s, and NOBODY can outwork him.</strong></p>
<p>&nbsp;</p>
<p><strong>SCORING SHENANIGANS &amp; ONLINE PPVS</strong></p>
<p>Dougie!</p>
<p>What is up? Hoping to make the mailbag with some of my thoughts on the solid if unspectacular GGG vs. Jacobs PPV. I&#8217;ll try to be concise with my points.</p>
<ol>
<li>I thought Chocolatito clearly beat Sor Rungvisai, by 2 or 3 rounds. Several times I thought he was close to stopping the little Thai badass with the iron chin, but somehow he was able to stay on his feet. However, I was physically sick, then seething with rage, when the scores were read and we somehow had a new champion. Bad judging just has to stop. It ruined what was a wonderful fight with a bad decision. I can&#8217;t imagine how it feels to gut through the awful cuts and early knockdown Choco dealt with to be robbed. Boxing needs to do better.</li>
</ol>
<ol start="2">
<li>I thought Jacobs did a good job of making things hard for GGG, but I also thought GGG won the fight clearly. I had it 115-112 for Golovkin. I don&#8217;t know about the speculation that GGG is getting old or that he looked bad. I think it was more that he was fighting the 2nd best middleweight in world, dressed in a cruiserweight costume(180+ in the ring), and his usually withering power shots didn&#8217;t have the same effect. However, every jab seemed to snap Jacobs head back, Jacobs missed a ton, was hurt often, and boxing is scored on clean punching first and foremost. Also, GGG stalked Jacobs like he does most opponents, which gives him ring generalship, but Jacobs tied him up effectively and used his size, speed and boxing ability to go the distance. A moral victory for Jacobs, but a clear GGG win. Some fans just give fighters too much credit for fleeing the action and not landing punches. I thought Jacobs, to his credit, had some success trading with GGG and definitely was very competitive when he actually stood toe to toe and looked to brawl. Maybe he should put on his big boy pants and come to fight in an eventual rematch? Either way, I&#8217;m gonna catch his next fight, and hope its not 18 months from now.</li>
</ol>
<ol start="3">
<li>Can we please get more PPVs available online? The ringtv.com stream had some hiccups at first, but by the middle of the Cuadras fight the stream was smooth and clear, and the international broadcast team did a good job. Boxing needs to get with the times. The next step is a great app, like the UFC one, that offers an all boxing sub service along with PPV, and to get as many promoters on it as you can. I&#8217;d gladly pay for access to non PPV cards, big and small, and the ability to buy legit PPV&#8217;s without getting raped by the cable company. Get your ringtv nerds working on that ASAP. Will the Canelo-Chavez fight be available online at least?</li>
</ol>
<p>I&#8217;ll just close with 2 questions:</p>
<ol>
<li>Where should Chocolatito go next? I&#8217;m saying he should take the big money Inoue fight before his body gives out on him after all these hellacious wars.</li>
</ol>
<ol start="2">
<li>What do you think of GGG&#8217;s performance? Do you think this changes how a BJS or Canelo fight would play out?</li>
</ol>
<p>Thanks for the mailbags and for fighting the good fight against the dummygraphic on social media! Keep that block button handy&#8230; – Tom, PA</p>
<p><strong>Oh I don’t block right away, my man. I like to engage a bit, definitely more so than we saw with GGG and Danny, but maybe not as much as Chocolatito and Sor Rungvisai. I think I’m going to use this week as an excuse to unfollow any idiotic fans that I follow for no particular reason, and I’ll probably use the MUTE button more than the BLOCK. That MUTE function is like a good jab among young prospects – underused.</strong></p>
<ol>
<li><em> Where should Chocolatito go next? I&#8217;m saying he should take the big money Inoue fight before his body gives out on him after all these hellacious wars.</em> <strong>I’ve read where Gonzalez wants an immediate rematch with Sor Rungvisai and I think he has a right to try to regain his title after suffering what most viewed as a controversial decision loss. If Inoue were suddenly challenge Gonzalez and record money was put up for that fight, maybe that’s a course that Choco would take, but I don’t see that happening any time soon.</strong></li>
</ol>
<ol start="2">
<li><em> What do you think of GGG&#8217;s performance?</em> <strong>Solid, effective but unspectacular.</strong></li>
</ol>
<p><em>Do you think this changes how a BJS or Canelo fight would play out?</em> <strong>No, but it changes the way many will view those potential matchups (especially the Canelo showdown).</strong></p>
<p><em>I thought Chocolatito clearly beat Sor Rungvisai, by 2 or 3 rounds.</em> <strong>That’s because you’re not blind.</strong></p>
<div id="attachment_490114" style="width: 310px" class="wp-caption alignright"><img class="size-medium wp-image-490114" src="http://www.ringtv.com/wp-content/uploads/2017/03/Gonzalez-Rungvisai_Hoganphotos-300x210.jpg" alt="" width="300" height="210" srcset="http://www.ringtv.com/wp-content/uploads/2017/03/Gonzalez-Rungvisai_Hoganphotos-300x210.jpg 300w, http://www.ringtv.com/wp-content/uploads/2017/03/Gonzalez-Rungvisai_Hoganphotos-768x537.jpg 768w, http://www.ringtv.com/wp-content/uploads/2017/03/Gonzalez-Rungvisai_Hoganphotos-1024x716.jpg 1024w" sizes="(max-width: 300px) 100vw, 300px"/><p class="wp-caption-text">Photo by Tom Hogan &#8211; Hoganphotos/K2 Promotions</p></div>
<p><em>Several times I thought he was close to stopping the little Thai badass with the iron chin, but somehow he was able to stay on his feet.</em> <strong>Thai challengers are seldom victorious here in the U.S. but they’re usually uncommonly durable and well-conditioned. Now that I think about it, Sor Rungvisai’s victory Saturday night has to be the biggest Thai upset on U.S. soil since Saman Sorjaturong stopped Humberto “Chiquita” Gonzalez at The Forum in Inglewood, California back in 1995 (and I was at that fight – as a fan!).</strong></p>
<p><em>Bad judging just has to stop. It ruined what was a wonderful fight with a bad decision. I can&#8217;t imagine how it feels to gut through the awful cuts and early knockdown Choco dealt with to be robbed. Boxing needs to do better.</em> <strong>I agree. I think Glenn Feldman, Julie Lederman and Waleska Roldan had a bad night at the office.</strong></p>
<p><em>I thought Jacobs did a good job of making things hard for GGG, but I also thought GGG won the fight clearly. I had it 115-112 for Golovkin.</em> <strong>Same here.</strong></p>
<p><em>I don&#8217;t know about the speculation that GGG is getting old or that he looked bad. I think it was more that he was fighting the 2nd best middleweight in world, dressed in a cruiserweight costume (180+ in the ring), and his usually withering power shots didn&#8217;t have the same effect.</em> <strong>I agree. To say Golovkin is suddenly “old” or that he had a bad night takes away from Jacobs’ fine performance as well as his stature within the sport.</strong></p>
<p><em>However, every jab seemed to snap Jacobs head back, Jacobs missed a ton, was hurt often, and boxing is scored on clean punching first and foremost.</em> <strong>That’s what I saw. I saw Jacobs nail Golovkin with some solid shots, but I also witnessed him miss a lot and land a lot of punches on GGG’s gloves and arms (and I thought his technique fell off as his activity grew in the later rounds).</strong></p>
<p><em>Also, GGG stalked Jacobs like he does most opponents, which gives him ring generalship, but Jacobs tied him up effectively and used his size, speed and boxing ability to go the distance.</em> <strong>I didn’t give Golovkin credit for merely stalking forward, I gave him credit for quickly finding range with his jab and landing it consistently all night (without getting tagged too much in return). I didn’t care much for Jacobs’ holding tactics but it was effective in that it prevented Golovkin from getting off inside and also seemed to frustrate the odds/media favorite. </strong></p>
<p><em>A moral victory for Jacobs, but a clear GGG win.</em> <strong>Absolutely. Both middleweights should be proud of going the 12-round distance in a closely contested fight.</strong></p>
<p><em>Some fans just give fighters too much credit for fleeing the action and not landing punches.</em> <strong>Not me.</strong></p>
<p><em>I thought Jacobs, to his credit, had some success trading with GGG and definitely was very competitive when he actually stood toe to toe and looked to brawl.</em> <strong>I agree. If he had started earlier or stood his ground more down the stretch maybe he could have won it on the official cards.</strong></p>
<p><em>Maybe he should put on his big boy pants and come to fight in an eventual rematch?</em> <strong>Aw, come on, man, don’t be mean to Danny!</strong></p>
<p><em>Either way, I&#8217;m gonna catch his next fight, and hope it’s not 18 months from now.</em> <strong>Jacobs’ adviser and management team need to take advantage of the career momentum he has right now and maneuver him into a significant middleweight (or super middleweight) match (and, yeah, hopefully within the next six-nine months). Chris Eubank Jr. is out there (running his mouth on Twitter), Hassan Ndam is the WBA’s No. 1 contender (so if Danny were to beat the veteran, he’d position himself for a rematch with GGG), there’s David Lemieux, Ryota Murata, Rob Brant, Willie Monroe Jr., and Sergey Derevyanchenko. There are legit contenders and solid up-and-comers for Jacobs to fight.</strong></p>
<p><em>Can we please get more PPVs available online?</em> <strong>Of course. That’s the plan!</strong></p>
<p><em><img class="alignleft size-medium wp-image-489604" src="http://www.ringtv.com/wp-content/uploads/2017/03/story-ggg-jacobs-header-300x225.jpg" alt="" width="300" height="225" srcset="http://www.ringtv.com/wp-content/uploads/2017/03/story-ggg-jacobs-header-300x225.jpg 300w, http://www.ringtv.com/wp-content/uploads/2017/03/story-ggg-jacobs-header-768x576.jpg 768w, http://www.ringtv.com/wp-content/uploads/2017/03/story-ggg-jacobs-header.jpg 800w" sizes="(max-width: 300px) 100vw, 300px"/>The ringtv.com stream had some hiccups at first, but by the middle of the Cuadras fight the stream was smooth and clear, and the international broadcast team did a good job</em>. <strong>Dave Bontempo and Kevin Kelley are veterans and they know what they’re looking at. I’m glad you appreciated them and I’m glad the hiccups were gone by the time the co-featured bouts began. That’s something we’ll have to improve on for the next online PPV.</strong></p>
<p><em>Boxing needs to get with the times.</em> <strong>Agreed, and I believe that it is. You’ll see that by the end of 2017.</strong></p>
<p><em>The next step is a great app, like the UFC one, that offers an all boxing sub service along with PPV, and to get as many promoters on it as you can.</em> <strong>That’s in the works, my man.</strong></p>
<p><em>I&#8217;d gladly pay for access to non PPV cards, big and small, and the ability to buy legit PPV&#8217;s without getting raped by the cable company.</em> <strong>We’re counting on fans like you.</strong></p>
<p><em>Get your ringtv nerds working on that ASAP.</em> <strong>My nerds are on it. </strong></p>
<p><em>Will the Canelo-Chavez fight be available online at least?</em> <strong>Of course it will, just as his last two pay-per-view shows (vs. Amir Khan and Liam Smith) were.</strong></p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p><em>Email Fischer at </em><a href="/cdn-cgi/l/email-protection#6a0e051f0d030f2a08051203040d070b0306080b0d44090507"><em><span class="__cf_email__" data-cfemail="fa9e958f9d939fba98958293949d979b9396989b9dd4999597">[email&#160;protected]</span><script data-cfhash='f9e31' type="text/javascript">/* <![CDATA[ */!function(t,e,r,n,c,a,p){try{t=document.currentScript||function(){for(t=document.getElementsByTagName('script'),e=t.length;e--;)if(t[e].getAttribute('data-cfhash'))return t[e]}();if(t&&(c=t.previousSibling)){p=t.parentNode;if(a=c.getAttribute('data-cfemail')){for(e='',r='0x'+a.substr(0,2)|0,n=2;a.length-n;n+=2)e+='%'+('0'+('0x'+a.substr(n,2)^r).toString(16)).slice(-2);p.replaceChild(document.createTextNode(decodeURIComponent(e)),c)}p.removeChild(t)}}catch(u){}}()/* ]]> */</script></em></a><em>. Follow him on Twitter at @dougiefischer</em></p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<div class="clearboth"></div>
</div> 
<div class="share-story">
<div class="title-text">Share this story</div>
<ul class="share-social">
<li><a href="#" class="addthis_button_facebook"><i class="fa fa-facebook"></i></a></li>
<li><a href="#" class="addthis_button_twitter"><i class="fa fa-twitter"></i></a></li>
</ul>
</div>
<div class="comment-app">
<div id="disqus_thread">
<div id="dsq-content">
<ul id="dsq-comments">
<li class="comment even thread-even depth-1" id="dsq-comment-135021">
<div id="dsq-comment-header-135021" class="dsq-comment-header">
<cite id="dsq-cite-135021">
<span id="dsq-author-user-135021">David Telfer</span>
</cite>
</div>
<div id="dsq-comment-body-135021" class="dsq-comment-body">
<div id="dsq-comment-message-135021" class="dsq-comment-message"><p>I&#8217;m sick to death of boxing fans crying robbery whenever a close decision doesn&#8217;t go the way they want it to. Both fights on Saturday night were close and IMO could&#8217;ve went either way. FWIW I think the right man won in both fights but you could tell from GGG&#8217;s face at the end he wasn&#8217;t convinced that he&#8217;d won. Also, the Thai guy was just too big and solid for Gonzalez&#8230;he took everything he could throw and kept firing back.</p>
</div>
</div>
<ul class="children">
<li class="comment odd alt depth-2" id="dsq-comment-135027">
<div id="dsq-comment-header-135027" class="dsq-comment-header">
<cite id="dsq-cite-135027">
<span id="dsq-author-user-135027">disqus_EewaFe3EB6</span>
</cite>
</div>
<div id="dsq-comment-body-135027" class="dsq-comment-body">
<div id="dsq-comment-message-135027" class="dsq-comment-message"><p>I had jacobs winning 7 rounds, so it was a draw on my score.<br/>
I think that Rozier didn&#8217;t believe in his man enough, though. He held him back too much. Had Jacobs exchanged a little more he would&#8217;ve stole all the swing rounds and pulled the clear upset.</p>
</div>
</div>
<ul class="children">
<li class="comment even depth-3" id="dsq-comment-135036">
<div id="dsq-comment-header-135036" class="dsq-comment-header">
<cite id="dsq-cite-135036">
<span id="dsq-author-user-135036">ceylon mooney</span>
</cite>
</div>
<div id="dsq-comment-body-135036" class="dsq-comment-body">
<div id="dsq-comment-message-135036" class="dsq-comment-message"><p>yea. it took a min for jacobs to get confident and turned on. he def brought enuf to to the ring to win; he almost used enuf of it. </p>
</div>
</div>
</li> 
</ul> 
</li> 
<li class="comment odd alt depth-2" id="dsq-comment-135033">
<div id="dsq-comment-header-135033" class="dsq-comment-header">
<cite id="dsq-cite-135033">
<span id="dsq-author-user-135033">ceylon mooney</span>
</cite>
</div>
<div id="dsq-comment-body-135033" class="dsq-comment-body">
<div id="dsq-comment-message-135033" class="dsq-comment-message"><p>according to the criteria for scoring pro fights, gonzales won by a few rounds. fight was great but not that close. being able to take an ass beating is not in the 4 criteria. dude was frick TOUGH and in the fight all the way. </p>
</div>
</div>
<ul class="children">
<li class="comment even depth-3" id="dsq-comment-135042">
<div id="dsq-comment-header-135042" class="dsq-comment-header">
<cite id="dsq-cite-135042">
<span id="dsq-author-user-135042">David Telfer</span>
</cite>
</div>
<div id="dsq-comment-body-135042" class="dsq-comment-body">
<div id="dsq-comment-message-135042" class="dsq-comment-message"><p>Ok but surely hurtful punching counts for something? Gonzalez was hurt and too many people are making out like Thai guy got a beat down when that&#8217;s just not the case. Sure he was rocked as well but he was happy to stand toe to toe in spots. Close fight.</p>
</div>
</div>
<ul class="children">
<li class="comment odd alt depth-4" id="dsq-comment-135050">
<div id="dsq-comment-header-135050" class="dsq-comment-header">
<cite id="dsq-cite-135050">
<span id="dsq-author-user-135050">ceylon mooney</span>
</cite>
</div>
<div id="dsq-comment-body-135050" class="dsq-comment-body">
<div id="dsq-comment-message-135050" class="dsq-comment-message"><p>gonzales hurt rungvisai a few times, but dudes tough as shit! </p>
<p>meaningful punches counts. if 2&#8217;guys hit each other anout the same and only one guys punches do anything that one guy gets the round. </p>
</div>
</div>
</li> 
</ul> 
</li> 
</ul> 
</li> 
<li class="comment even depth-2" id="dsq-comment-135045">
<div id="dsq-comment-header-135045" class="dsq-comment-header">
<cite id="dsq-cite-135045">
<span id="dsq-author-user-135045">Mitchell Nelms</span>
</cite>
</div>
<div id="dsq-comment-body-135045" class="dsq-comment-body">
<div id="dsq-comment-message-135045" class="dsq-comment-message"><p>I think that was the face of frustration and fatigue. Jacobs did work his body well and held at the right times, maybe even excessively.</p>
<p>But yeah, I&#8217;m with you on the overuse of certain words like robbery, hypejob(which isn&#8217;t a word), and exposed.</p>
</div>
</div>
</li> 
</ul> 
</li> 
<li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-135022">
<div id="dsq-comment-header-135022" class="dsq-comment-header">
<cite id="dsq-cite-135022">
<span id="dsq-author-user-135022">Orca</span>
</cite>
</div>
<div id="dsq-comment-body-135022" class="dsq-comment-body">
<div id="dsq-comment-message-135022" class="dsq-comment-message"><p>Nice mailbag and I&#8217;m glad I can stop refreshing the screen here at work now. I&#8217;ll be very surprised if Gonzalez doesn&#8217;t ask for an immediate rematch. Not sure if there was a clause in the contract to force it. I had Chocolatito winning 7-4-1, so a 2 point win for Roman. Great fight and a great illustration of the kind of fighter this guy is. He did everything in his power to get the win. He left it all in the ring. We all know he is at least 1 division too high but there&#8217;s no going back now. I think he has it in him to beat Rungvisai (again) in a rematch, shut Cuadras up for good and bid farewell. The man has nothing left to prove.</p>
</div>
</div>
<ul class="children">
<li class="comment even depth-2" id="dsq-comment-135073">
<div id="dsq-comment-header-135073" class="dsq-comment-header">
<cite id="dsq-cite-135073">
<span id="dsq-author-user-135073">Jorge</span>
</cite>
</div>
<div id="dsq-comment-body-135073" class="dsq-comment-body">
<div id="dsq-comment-message-135073" class="dsq-comment-message"><p>He already has&#8230; not sure if he can comeback that quick after cuts.</p>
</div>
</div>
</li> 
<li class="comment odd alt depth-2" id="dsq-comment-135207">
<div id="dsq-comment-header-135207" class="dsq-comment-header">
<cite id="dsq-cite-135207">
<span id="dsq-author-user-135207">ceylon mooney</span>
</cite>
</div>
<div id="dsq-comment-body-135207" class="dsq-comment-body">
<div id="dsq-comment-message-135207" class="dsq-comment-message"><p>i def think he can beat rungsavi again</p>
</div>
</div>
</li> 
</ul> 
</li> 
<li class="comment even thread-even depth-1" id="dsq-comment-135024">
<div id="dsq-comment-header-135024" class="dsq-comment-header">
<cite id="dsq-cite-135024">
<span id="dsq-author-user-135024">Tony Nightstick</span>
</cite>
</div>
<div id="dsq-comment-body-135024" class="dsq-comment-body">
<div id="dsq-comment-message-135024" class="dsq-comment-message"><p>I didn&#8217;t see Golovkin-Jacobs, and therefore have no opinion on the fight. I am bothered, however, by reports that Jacobs may have come in as heavy as 180. Who&#8217;s he all of a sudden, Rocky Marciano? While I&#8217;m not at all a fan of having 17 weight divisions, what&#8217;s the point of having any if their limits are so flagrantly flaunted? Even the WWE has introduced a cruiserweight division, recognizing that pitting a guy at 175 against another at 350 isn&#8217;t exactly competitive.</p>
</div>
</div>
<ul class="children">
<li class="comment odd alt depth-2" id="dsq-comment-135039">
<div id="dsq-comment-header-135039" class="dsq-comment-header">
<cite id="dsq-cite-135039">
<span id="dsq-author-user-135039">ceylon mooney</span>
</cite>
</div>
<div id="dsq-comment-body-135039" class="dsq-comment-body">
<div id="dsq-comment-message-135039" class="dsq-comment-message"><p>same day weigh ins please</p>
<p>and having 112, 115 &amp; 118 is really stupid. 112 to 118 is a better jump. </p>
</div>
</div>
<ul class="children">
<li class="comment even depth-3" id="dsq-comment-135053">
<div id="dsq-comment-header-135053" class="dsq-comment-header">
<cite id="dsq-cite-135053">
<span id="dsq-author-user-135053">Tony Nightstick</span>
</cite>
</div>
<div id="dsq-comment-body-135053" class="dsq-comment-body">
<div id="dsq-comment-message-135053" class="dsq-comment-message"><p>Completely agree.</p>
<p>And back to eight&#8230;maybe nine.</p>
</div>
</div>
<ul class="children">
<li class="comment odd alt depth-4" id="dsq-comment-135149">
<div id="dsq-comment-header-135149" class="dsq-comment-header">
<cite id="dsq-cite-135149">
<span id="dsq-author-user-135149">ceylon mooney</span>
</cite>
</div>
<div id="dsq-comment-body-135149" class="dsq-comment-body">
<div id="dsq-comment-message-135149" class="dsq-comment-message"><p>gotta have 200 in there. 175 to 250 is way top big a jump. </p>
</div>
</div>
</li> 
</ul> 
</li> 
</ul> 
</li> 
</ul> 
</li> 
<li class="comment even thread-odd thread-alt depth-1" id="dsq-comment-135030">
<div id="dsq-comment-header-135030" class="dsq-comment-header">
<cite id="dsq-cite-135030">
<span id="dsq-author-user-135030">Michel Desgrottes</span>
</cite>
</div>
<div id="dsq-comment-body-135030" class="dsq-comment-body">
<div id="dsq-comment-message-135030" class="dsq-comment-message"><p>More online ppvs? How bout no more ppvs to begin with</p>
<p>114-113 Jacobs</p>
<p>Jacobs should apply to be in the WBO rankings and shoot for an England fight with BJS</p>
<p>Danny stock went up Saturday night, ggg remained stagnant, if not went down a little </p>
<p>Shout out to Curtis Stevens putting pressure on dougie on twitter</p>
<p>Doug in all seriousness u gotta watch your mouth, these dudes will bump into you at your workplace, any venue, anywhere, don&#8217;t talk with your chest out unless u ready to throw hands with Curtis </p>
</div>
</div>
<ul class="children">
<li class="comment odd alt depth-2" id="dsq-comment-135047">
<div id="dsq-comment-header-135047" class="dsq-comment-header">
<cite id="dsq-cite-135047">
<span id="dsq-author-user-135047">disqus_EewaFe3EB6</span>
</cite>
</div>
<div id="dsq-comment-body-135047" class="dsq-comment-body">
<div id="dsq-comment-message-135047" class="dsq-comment-message"><p>What happened with Stevens and Doug?</p>
</div>
</div>
<ul class="children">
<li class="comment even depth-3" id="dsq-comment-135124">
<div id="dsq-comment-header-135124" class="dsq-comment-header">
<cite id="dsq-cite-135124">
<span id="dsq-author-user-135124">Michel Desgrottes</span>
</cite>
</div>
<div id="dsq-comment-body-135124" class="dsq-comment-body">
<div id="dsq-comment-message-135124" class="dsq-comment-message"><p>Doug was talking greasy on twitter making jokes about Stevens getting KO, Stevens said he gonna slap em</p>
</div>
</div>
<ul class="children">
<li class="comment odd alt depth-4" id="dsq-comment-135126">
<div id="dsq-comment-header-135126" class="dsq-comment-header">
<cite id="dsq-cite-135126">
<span id="dsq-author-user-135126">Jorge</span>
</cite>
</div>
<div id="dsq-comment-body-135126" class="dsq-comment-body">
<div id="dsq-comment-message-135126" class="dsq-comment-message"><p>Gossip Queen, you&#8217;re the last one who should speak on twitter drama.</p>
</div>
</div>
<ul class="children">
<li class="comment even depth-5" id="dsq-comment-135159">
<div id="dsq-comment-header-135159" class="dsq-comment-header">
<cite id="dsq-cite-135159">
<span id="dsq-author-user-135159">Michel Desgrottes</span>
</cite>
</div>
<div id="dsq-comment-body-135159" class="dsq-comment-body">
<div id="dsq-comment-message-135159" class="dsq-comment-message"><p>Ain&#8217;t gossip, advising him to watch his mouth before dude slaps him</p>
</div>
</div>
</li> 
</ul> 
</li> 
<li class="comment odd alt depth-4" id="dsq-comment-135127">
<div id="dsq-comment-header-135127" class="dsq-comment-header">
<cite id="dsq-cite-135127">
<span id="dsq-author-user-135127">Jorge</span>
</cite>
</div>
<div id="dsq-comment-body-135127" class="dsq-comment-body">
<div id="dsq-comment-message-135127" class="dsq-comment-message"><p>Gossip Queen, you&#8217;re the last one who should speak on twitter drama.</p>
</div>
</div>
</li> 
<li class="comment even depth-4" id="dsq-comment-135251">
<div id="dsq-comment-header-135251" class="dsq-comment-header">
<cite id="dsq-cite-135251">
<span id="dsq-author-user-135251">disqus_EewaFe3EB6</span>
</cite>
</div>
<div id="dsq-comment-body-135251" class="dsq-comment-body">
<div id="dsq-comment-message-135251" class="dsq-comment-message"><p>haha</p>
</div>
</div>
</li> 
</ul> 
</li> 
</ul> 
</li> 
<li class="comment odd alt depth-2" id="dsq-comment-135056">
<div id="dsq-comment-header-135056" class="dsq-comment-header">
<cite id="dsq-cite-135056">
<span id="dsq-author-user-135056">Mitchell Nelms</span>
</cite>
</div>
<div id="dsq-comment-body-135056" class="dsq-comment-body">
<div id="dsq-comment-message-135056" class="dsq-comment-message"><p>In your opinion&#8230; Yes, Jacobs fought the fight of his life and did well, but lost. His stock did go up, but to say Golovkin&#8217;s went stagnant is absurd, he took on a the second best middleweight for 12 rounds and won. Buster Douglas fought the fight of his life against Tyson in the 80&#8217;s, and then came in fat against Holyfield.</p>
</div>
</div>
<ul class="children">
<li class="comment even depth-3" id="dsq-comment-135118">
<div id="dsq-comment-header-135118" class="dsq-comment-header">
<cite id="dsq-cite-135118">
<span id="dsq-author-user-135118">Michel Desgrottes</span>
</cite>
</div>
<div id="dsq-comment-body-135118" class="dsq-comment-body">
<div id="dsq-comment-message-135118" class="dsq-comment-message"><p>And he was marketed as a big drama show that would KO a chinny Jacobs, didn&#8217;t happen, was getting outboxed after telling people he allows himself to be hit, he was supposed to impress casuals on the big stage ppv msg with Mexican style and KO him, he didn&#8217;t, stock didn&#8217;t go up, especially compared to what he was being propped up to be</p>
</div>
</div>
</li> 
</ul> 
</li> 
<li class="comment odd alt depth-2" id="dsq-comment-135085">
<div id="dsq-comment-header-135085" class="dsq-comment-header">
<cite id="dsq-cite-135085">
<span id="dsq-author-user-135085">Jorge</span>
</cite>
</div>
<div id="dsq-comment-body-135085" class="dsq-comment-body">
<div id="dsq-comment-message-135085" class="dsq-comment-message"><p>This guy&#8230;</p>
</div>
</div>
</li> 
<li class="comment even depth-2" id="dsq-comment-135252">
<div id="dsq-comment-header-135252" class="dsq-comment-header">
<cite id="dsq-cite-135252">
<span id="dsq-author-user-135252">maxx</span>
</cite>
</div>
<div id="dsq-comment-body-135252" class="dsq-comment-body">
<div id="dsq-comment-message-135252" class="dsq-comment-message"><p>Dude get over it he LOST!</p>
</div>
</div>
</li> 
</ul> 
</li> 
<li class="comment odd alt thread-even depth-1" id="dsq-comment-135059">
<div id="dsq-comment-header-135059" class="dsq-comment-header">
<cite id="dsq-cite-135059">
<span id="dsq-author-user-135059">Already956</span>
</cite>
</div>
<div id="dsq-comment-body-135059" class="dsq-comment-body">
<div id="dsq-comment-message-135059" class="dsq-comment-message"><p>Random MM </p>
<p>Mikey Garcia vs Edwin Valero @ 130/135</p>
<p>Lennox Lewis vs Larry Holmes </p>
<p>Ricky Hatton vs Arturo Gatti @ 140</p>
<p>Bernard Hopkins vs James Toney @ 160</p>
<p>Jose Luis Castillo vs Jorge Linares @ 135</p>
</div>
</div>
<ul class="children">
<li class="comment even depth-2" id="dsq-comment-135062">
<div id="dsq-comment-header-135062" class="dsq-comment-header">
<cite id="dsq-cite-135062">
<span id="dsq-author-user-135062">Mitchell Nelms</span>
</cite>
</div>
<div id="dsq-comment-body-135062" class="dsq-comment-body">
<div id="dsq-comment-message-135062" class="dsq-comment-message"><p>Holmes wins a decision. Holmes was too slick, fast and crafty for Lennox.</p>
</div>
</div>
</li> 
<li class="comment odd alt depth-2" id="dsq-comment-135109">
<div id="dsq-comment-header-135109" class="dsq-comment-header">
<cite id="dsq-cite-135109">
<span id="dsq-author-user-135109">Jorge</span>
</cite>
</div>
<div id="dsq-comment-body-135109" class="dsq-comment-body">
<div id="dsq-comment-message-135109" class="dsq-comment-message"><p>Mikey in a great fight of contrasting styles, Holmes wins the jab duel, Hatton UD in a fun fight, Toney in a lackluster fight, Castillo with the body shots ko&#8217;s linares late.</p>
</div>
</div>
</li> 
<li class="comment even depth-2" id="dsq-comment-135140">
<div id="dsq-comment-header-135140" class="dsq-comment-header">
<cite id="dsq-cite-135140">
<span id="dsq-author-user-135140">Colin Mc Flurry.</span>
</cite>
</div>
<div id="dsq-comment-body-135140" class="dsq-comment-body">
<div id="dsq-comment-message-135140" class="dsq-comment-message"><p>Garcia &#8211; better skills<br/>
Lewis &#8211; too big<br/>
Hatton &#8211; the Hatton that beat Tszyu, would fuck Gatti up.<br/>
Hopkins &#8211; Toney too inconsistent at 160lb. Reggie Johnson? Dave Tiberi?<br/>
Castillo &#8211; Linares for all his talent, has that fragility about him.</p>
</div>
</div>
</li> 
<li class="comment odd alt depth-2" id="dsq-comment-135144">
<div id="dsq-comment-header-135144" class="dsq-comment-header">
<cite id="dsq-cite-135144">
<span id="dsq-author-user-135144">Jody Hanna</span>
</cite>
</div>
<div id="dsq-comment-body-135144" class="dsq-comment-body">
<div id="dsq-comment-message-135144" class="dsq-comment-message"><p>Mikey stops Valero at either weight, but takes some punishment before he does.<br/>
Holmes outpoints Lewis in a bore.<br/>
Gatti wins on points in a lacklustre fight which is booed by the crowd from start to finish due to lack of action.<br/>
Toney outslicks Hopkins.<br/>
Castillo wins by split decision in a barnburner.</p>
</div>
</div>
</li> 
<li class="comment even depth-2" id="dsq-comment-135248">
<div id="dsq-comment-header-135248" class="dsq-comment-header">
<cite id="dsq-cite-135248">
<span id="dsq-author-user-135248">maxx</span>
</cite>
</div>
<div id="dsq-comment-body-135248" class="dsq-comment-body">
<div id="dsq-comment-message-135248" class="dsq-comment-message"><p>Valero by knockout.<br/>
Lewis by unanimous decision due to a couple of knockdowns in a classic jabfest.<br/>
Gatti by one punch knockout in a fight were he is behind on all judges scorecards.<br/>
Bernard Hopkins wins by utilizing very cagey stick and move tactics.<br/>
Castillo stop Linares late in a battle of attrition.</p>
</div>
</div>
</li> 
</ul> 
</li> 
<li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-135067">
<div id="dsq-comment-header-135067" class="dsq-comment-header">
<cite id="dsq-cite-135067">
<span id="dsq-author-user-135067">Sidewinder</span>
</cite>
</div>
<div id="dsq-comment-body-135067" class="dsq-comment-body">
<div id="dsq-comment-message-135067" class="dsq-comment-message"><p>Regarding the same day weigh in debate, just want some opinions.</p>
<p>Lets imagine the weigh in is on fight night. Fight is at 154 lbs.</p>
<p>Keith Thurman comes in weighing 154 and at his optimum fighting weight maybe or maybe not, but lets just say he&#8217;s well hydrated. His opponent Jermall Charlo a big JMW also came in at 154 but dry as a prune, we all know he boils himself down to make 154.</p>
<p>So does Charlo have a chance to beat Thurman?<br/>
Or lets say its Terence Crawford instead of Thurman, can Charlo defeat Crawford?</p>
</div>
</div>
<ul class="children">
<li class="comment even depth-2" id="dsq-comment-135129">
<div id="dsq-comment-header-135129" class="dsq-comment-header">
<cite id="dsq-cite-135129">
<span id="dsq-author-user-135129">FreeWilly</span>
</cite>
</div>
<div id="dsq-comment-body-135129" class="dsq-comment-body">
<div id="dsq-comment-message-135129" class="dsq-comment-message"><p>I don&#8217;t think it matters whether fighters should have same day weigh-in or a day before. The rule should that a fighter should enter the ring no more than the minimum weight of the next division. E.g. a welterweight should not weigh at 154 or above. Simples.</p>
</div>
</div>
</li> 
<li class="comment odd alt depth-2" id="dsq-comment-135130">
<div id="dsq-comment-header-135130" class="dsq-comment-header">
<cite id="dsq-cite-135130">
<span id="dsq-author-user-135130">FreeWilly</span>
</cite>
</div>
<div id="dsq-comment-body-135130" class="dsq-comment-body">
<div id="dsq-comment-message-135130" class="dsq-comment-message"><p>I don&#8217;t think it matters whether fighters should have same day weigh-in or a day before. The rule should that a fighter should enter the ring no more than the minimum weight of the next division. E.g. a welterweight should not weigh at 154 or above. Simples.</p>
</div>
</div>
</li> 
<li class="comment even depth-2" id="dsq-comment-135162">
<div id="dsq-comment-header-135162" class="dsq-comment-header">
<cite id="dsq-cite-135162">
<span id="dsq-author-user-135162">DBone</span>
</cite>
</div>
<div id="dsq-comment-body-135162" class="dsq-comment-body">
<div id="dsq-comment-message-135162" class="dsq-comment-message"><p>Day before weigh ins aren&#8217;t the perfect solution but much better than the alternative. Same day weigh ins are more dangerous to the fighters than one guy having a weight advantage. Fighters are still gonna kill themselves to get into their most advantageous weight class regardless of which day the weigh ins are. If there are any alternative ideas to these two options id like to hear them</p>
</div>
</div>
<ul class="children">
<li class="comment odd alt depth-3" id="dsq-comment-135199">
<div id="dsq-comment-header-135199" class="dsq-comment-header">
<cite id="dsq-cite-135199">
<span id="dsq-author-user-135199">ceylon mooney</span>
</cite>
</div>
<div id="dsq-comment-body-135199" class="dsq-comment-body">
<div id="dsq-comment-message-135199" class="dsq-comment-message"><p>fighters arent going to lose a fight just to make weight. </p>
<p>its a much bigger risk to sweat off 15 pounds than 7. </p>
</div>
</div>
<ul class="children">
<li class="comment even depth-4" id="dsq-comment-135216">
<div id="dsq-comment-header-135216" class="dsq-comment-header">
<cite id="dsq-cite-135216">
<span id="dsq-author-user-135216">DBone</span>
</cite>
</div>
<div id="dsq-comment-body-135216" class="dsq-comment-body">
<div id="dsq-comment-message-135216" class="dsq-comment-message"><p>Guys literally died to do it</p>
</div>
</div>
</li> 
</ul> 
</li> 
</ul> 
</li> 
</ul> 
</li> 
<li class="comment odd alt thread-even depth-1" id="dsq-comment-135070">
<div id="dsq-comment-header-135070" class="dsq-comment-header">
<cite id="dsq-cite-135070">
<span id="dsq-author-user-135070">Jorge</span>
</cite>
</div>
<div id="dsq-comment-body-135070" class="dsq-comment-body">
<div id="dsq-comment-message-135070" class="dsq-comment-message"><p>What do great middleweights like Monzon, Hagler, Leonard do to a guy like Jacobs Saturday night?</p>
</div>
</div>
</li> 
<li class="comment even thread-odd thread-alt depth-1" id="dsq-comment-135088">
<div id="dsq-comment-header-135088" class="dsq-comment-header">
<cite id="dsq-cite-135088">
<span id="dsq-author-user-135088">J Scorpio</span>
</cite>
</div>
<div id="dsq-comment-body-135088" class="dsq-comment-body">
<div id="dsq-comment-message-135088" class="dsq-comment-message"><p>Why do people seem pissed off with Jacobs for this fight, for his tactics of box and move, don&#8217;t get caught, don&#8217;t get involved in a close scrap if you can avoid it and don&#8217;t engage unnecessarily? Golovkin fans visibly pissed that Jacobs didn&#8217;t &#8216;do enough and came to survive&#8217;. If Golovkin is the unbeatable and totally dominant middlweight of his generation then why on earth would or could Jacobs do anything but this? Jacobs came with a game plan, he stuck to it and provided as decent a challenge as Golovkin has faced, or is likely to. Did he come with enough to truly outstrip all 4 belts and really make the judges demand GGG hand the straps over? That&#8217;s comletely debateable and subjective, personally I had the fight a draw, but am not surprised the champion got the nod. It was a close fight, so close that no decision would have been a &#8216;robbery&#8217;, but Jacobs box-and-moving, and constantly walking is a compliment to Golovkin&#8217;s style that his fans are in contradiction with if they&#8217;re annoyed Jacobs didn&#8217;t just stand toe to toe with him for and exchange. Jacobs said before the fight he was weary of his power so came with a top game plan and did himself proud.</p>
</div>
</div>
</li> 
<li class="comment odd alt thread-even depth-1" id="dsq-comment-135094">
<div id="dsq-comment-header-135094" class="dsq-comment-header">
<cite id="dsq-cite-135094">
<span id="dsq-author-user-135094">Billy ray cyrus</span>
</cite>
</div>
<div id="dsq-comment-body-135094" class="dsq-comment-body">
<div id="dsq-comment-message-135094" class="dsq-comment-message"><p>Jacob is a 2nd tier fighter I don&#8217;t care how much he weighed and this is the same ggg who want to fight a natural 140 pounder who happen to move up two weight classes to win a title. I wouldn&#8217;t pay two cents to watch this guy fight Canelo but that&#8217;s just me</p>
</div>
</div>
<ul class="children">
<li class="comment even depth-2" id="dsq-comment-135100">
<div id="dsq-comment-header-135100" class="dsq-comment-header">
<cite id="dsq-cite-135100">
<span id="dsq-author-user-135100">Jorge</span>
</cite>
</div>
<div id="dsq-comment-body-135100" class="dsq-comment-body">
<div id="dsq-comment-message-135100" class="dsq-comment-message"><p>This sounds like the first time you have seen Jacobs. He doesn&#8217;t usually fight like that and ko&#8217;s guys, he had a good game plan and GGG at times didn&#8217;t have answers for it.</p>
</div>
</div>
<ul class="children">
<li class="comment odd alt depth-3" id="dsq-comment-135204">
<div id="dsq-comment-header-135204" class="dsq-comment-header">
<cite id="dsq-cite-135204">
<span id="dsq-author-user-135204">ceylon mooney</span>
</cite>
</div>
<div id="dsq-comment-body-135204" class="dsq-comment-body">
<div id="dsq-comment-message-135204" class="dsq-comment-message"><p>yea that was impressive. i didnt see ggg adjust i saw the oppoosite&#8211;he appeared to do less of the same as the fight went on. that last round he was in slow motion. </p>
<p>jacobs had a damn good plan and did good n well with it. </p>
</div>
</div>
</li> 
</ul> 
</li> 
<li class="comment even depth-2" id="dsq-comment-135202">
<div id="dsq-comment-header-135202" class="dsq-comment-header">
<cite id="dsq-cite-135202">
<span id="dsq-author-user-135202">ceylon mooney</span>
</cite>
</div>
<div id="dsq-comment-body-135202" class="dsq-comment-body">
<div id="dsq-comment-message-135202" class="dsq-comment-message"><p>who is the natural 140 pounder golovkin wanted to fight? </p>
</div>
</div>
</li> 
</ul> 
</li> 
<li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-135103">
<div id="dsq-comment-header-135103" class="dsq-comment-header">
<cite id="dsq-cite-135103">
<span id="dsq-author-user-135103">Colin Mc Flurry.</span>
</cite>
</div>
<div id="dsq-comment-body-135103" class="dsq-comment-body">
<div id="dsq-comment-message-135103" class="dsq-comment-message"><p>Macklin.<br/>
Stevens.<br/>
Geale.<br/>
Murray.<br/>
Monroe jr.<br/>
Lemieux.<br/>
Wade.<br/>
Couldn&#8217;t get a job painting the the outside walls of the boxing HOF&#8230;.never mind get the fuck in.</p>
</div>
</div>
</li> 
<li class="comment even thread-even depth-1" id="dsq-comment-135106">
<div id="dsq-comment-header-135106" class="dsq-comment-header">
<cite id="dsq-cite-135106">
<span id="dsq-author-user-135106">EastMan</span>
</cite>
</div>
<div id="dsq-comment-body-135106" class="dsq-comment-body">
<div id="dsq-comment-message-135106" class="dsq-comment-message"><p>When golovkin fought welterweight Brook-its normal,when Jacobs put on some weight-it&#8217;s criminal.Stupid crasy fanatics&#8230;</p>
</div>
</div>
<ul class="children">
<li class="comment odd alt depth-2" id="dsq-comment-135158">
<div id="dsq-comment-header-135158" class="dsq-comment-header">
<cite id="dsq-cite-135158">
<span id="dsq-author-user-135158">ceylon mooney</span>
</cite>
</div>
<div id="dsq-comment-body-135158" class="dsq-comment-body">
<div id="dsq-comment-message-135158" class="dsq-comment-message"><p>u remember brook was bigger and heavier<br/>
than golovkin every step of the way?</p>
</div>
</div>
<ul class="children">
<li class="comment even depth-3" id="dsq-comment-135182">
<div id="dsq-comment-header-135182" class="dsq-comment-header">
<cite id="dsq-cite-135182">
<span id="dsq-author-user-135182">D Johnson</span>
</cite>
</div>
<div id="dsq-comment-body-135182" class="dsq-comment-body">
<div id="dsq-comment-message-135182" class="dsq-comment-message"><p>Cmon man! why you gotta poke holes in his conspiracy theories? </p>
</div>
</div>
</li> 
<li class="comment odd alt depth-3" id="dsq-comment-135183">
<div id="dsq-comment-header-135183" class="dsq-comment-header">
<cite id="dsq-cite-135183">
<span id="dsq-author-user-135183">D Johnson</span>
</cite>
</div>
<div id="dsq-comment-body-135183" class="dsq-comment-body">
<div id="dsq-comment-message-135183" class="dsq-comment-message"><p>Cmon man! why you gotta poke holes in his conspiracy theories? </p>
</div>
</div>
</li> 
</ul> 
</li> 
<li class="comment even depth-2" id="dsq-comment-135179">
<div id="dsq-comment-header-135179" class="dsq-comment-header">
<cite id="dsq-cite-135179">
<span id="dsq-author-user-135179">Juan Manuel Valverde</span>
</cite>
</div>
<div id="dsq-comment-body-135179" class="dsq-comment-body">
<div id="dsq-comment-message-135179" class="dsq-comment-message"><p>Why is this a problem? Both Jacobs and Brooks came in at the middleweight limit. Its the way sports play out. That was Jacobs&#8217; advantage and it worked for him. One day his body will pay for it thats for sure, but for now if it works I would keep doing it. Look at Chavez Jr, he exploited that and when he moved up his limitations where exposed. </p>
</div>
</div>
</li> 
</ul> 
</li> 
<li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-135112">
<div id="dsq-comment-header-135112" class="dsq-comment-header">
<cite id="dsq-cite-135112">
<span id="dsq-author-user-135112">Colin Mc Flurry.</span>
</cite>
</div>
<div id="dsq-comment-body-135112" class="dsq-comment-body">
<div id="dsq-comment-message-135112" class="dsq-comment-message"><p>Jacobs is a good fighter&#8230;but he ain&#8217;t Sugar ray robinson or Sugar ray Leonard, hell he might not even be Sugar ray seals..</p>
</div>
</div>
<ul class="children">
<li class="comment even depth-2" id="dsq-comment-135255">
<div id="dsq-comment-header-135255" class="dsq-comment-header">
<cite id="dsq-cite-135255">
<span id="dsq-author-user-135255">maxx</span>
</cite>
</div>
<div id="dsq-comment-body-135255" class="dsq-comment-body">
<div id="dsq-comment-message-135255" class="dsq-comment-message"><p>Prime Jermain Taylor is better than Jacobs.Kudos</p>
</div>
</div>
</li> 
</ul> 
</li> 
<li class="comment odd alt thread-even depth-1" id="dsq-comment-135115">
<div id="dsq-comment-header-135115" class="dsq-comment-header">
<cite id="dsq-cite-135115">
<span id="dsq-author-user-135115">Jody Hanna</span>
</cite>
</div>
<div id="dsq-comment-body-135115" class="dsq-comment-body">
<div id="dsq-comment-message-135115" class="dsq-comment-message"><p>Here goes&#8230;&#8230;I saw Danny Jacobs win i the early hours if Sunday morning. When I watched it again late Sunday afternoon, with pen and paper, I scored it a draw, and if I watched it again tonight, I wouldn&#8217;t be surprised if I scored it for Golovkin.<br/>
I think subconsciously I gave more credit than was due to Jacobs because he was doing better than expected, by the midway point I was sensing the upset and was going with it. At the end I was convinced Jacobs had pulled it off, and was wounded for him not to get the decision. I make no apologies for this, because I am a boxing fan, not a judge, I couldn&#8217;t be a professional judge because I enjoy the fights too much and get emotionally involved. It was a close fight, but far from a robbery.<br/>
As for people claimimg Canelo will beat Golovkin now that he&#8217;s &#8216;been exposed&#8217; (there are some), Canelo couldn&#8217;t fight the fight Jacobs fought Saturday, styles make fights and Canelo is a completely different fighter than Jacobs, and at 160, I believe an inferior one.</p>
</div>
</div>
<ul class="children">
<li class="comment even depth-2" id="dsq-comment-135120">
<div id="dsq-comment-header-135120" class="dsq-comment-header">
<cite id="dsq-cite-135120">
<span id="dsq-author-user-135120">Jorge</span>
</cite>
</div>
<div id="dsq-comment-body-135120" class="dsq-comment-body">
<div id="dsq-comment-message-135120" class="dsq-comment-message"><p>Spoken like a true man&#8230; I think most boxing fans do this in a lot of fights, myself included. But that&#8217;s just a part of being a true fan. It was a close fight. I was just more impressed with Jacobs. As far as canelo, I think he poses a different type of fight and challenge to GGG that is different from Jacobs.</p>
</div>
</div>
</li> 
<li class="comment odd alt depth-2" id="dsq-comment-135121">
<div id="dsq-comment-header-135121" class="dsq-comment-header">
<cite id="dsq-cite-135121">
<span id="dsq-author-user-135121">Jorge</span>
</cite>
</div>
<div id="dsq-comment-body-135121" class="dsq-comment-body">
<div id="dsq-comment-message-135121" class="dsq-comment-message"><p>Spoken like a true man&#8230; I think most boxing fans do this in a lot of fights, myself included. But that&#8217;s just a part of being a true fan. It was a close fight. I was just more impressed with Jacobs. As far as canelo, I think he poses a different type of fight and challenge to GGG that is different from Jacobs.</p>
</div>
</div>
<ul class="children">
<li class="comment even depth-3" id="dsq-comment-135165">
<div id="dsq-comment-header-135165" class="dsq-comment-header">
<cite id="dsq-cite-135165">
<span id="dsq-author-user-135165">Juan Manuel Valverde</span>
</cite>
</div>
<div id="dsq-comment-body-135165" class="dsq-comment-body">
<div id="dsq-comment-message-135165" class="dsq-comment-message"><p>We tend to find reasons to score for the guy we think or we would like to win. I myself, a GGG fan, scored the fight 7-5 for him and could&#8217;ve easily seen it 6-6 or 7-5 the other way. Felt GGG heavier punches were the difference</p>
</div>
</div>
</li> 
</ul> 
</li> 
</ul> 
</li> 
<li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-135134">
<div id="dsq-comment-header-135134" class="dsq-comment-header">
<cite id="dsq-cite-135134">
<span id="dsq-author-user-135134">Don Badowski</span>
</cite>
</div>
<div id="dsq-comment-body-135134" class="dsq-comment-body">
<div id="dsq-comment-message-135134" class="dsq-comment-message"><p>I&#8217;d like everyone to take a look at the scorecards for the Golovkin / Jacobs fight.<br/>
All 3 judges were unanimous in Golovkin winning R1. 2 of the 3 had him winning R2. 1 had him winning round 3. All had Golovkin winning R4 because of the KD of course. All had him winning R5.<br/>
And the really funny thing, HBO scorer Harold Lederman scored Rounds 1 and 2 for Jacobs.<br/>
Where it really gets weird is Rounds 10, 11 and 12. I was sure everyone could see Golovkin winning R12, but 2 of the 3 judges gave it to Jacobs. The HBO crew had R12 for Golovkin.<br/>
Simply put, the scores by round for this fight are all over the place, but all were unanimous in the decision for Golovkin.</p>
</div>
</div>
<ul class="children">
<li class="comment even depth-2" id="dsq-comment-135155">
<div id="dsq-comment-header-135155" class="dsq-comment-header">
<cite id="dsq-cite-135155">
<span id="dsq-author-user-135155">FreeWilly</span>
</cite>
</div>
<div id="dsq-comment-body-135155" class="dsq-comment-body">
<div id="dsq-comment-message-135155" class="dsq-comment-message"><p>Actually, if you take the judges scores per round and score the round for each fighter based on the majority; you actually see that both fighters won six rounds apiece and the difference was the KD. Therefore, you can conclude that GGG won by a point and rightly so. Simples.</p>
</div>
</div>
</li> 
<li class="comment odd alt depth-2" id="dsq-comment-135219">
<div id="dsq-comment-header-135219" class="dsq-comment-header">
<cite id="dsq-cite-135219">
<span id="dsq-author-user-135219">Jorge</span>
</cite>
</div>
<div id="dsq-comment-body-135219" class="dsq-comment-body">
<div id="dsq-comment-message-135219" class="dsq-comment-message"><p>Yeah they were, the knockdown helped a lot for golovkin, But you can see it was a close fight as people have to reference the compustats. close fight.</p>
</div>
</div>
</li> 
<li class="comment even depth-2" id="dsq-comment-135277">
<div id="dsq-comment-header-135277" class="dsq-comment-header">
<cite id="dsq-cite-135277">
<span id="dsq-author-user-135277">Left Hook</span>
</cite>
</div>
<div id="dsq-comment-body-135277" class="dsq-comment-body">
<div id="dsq-comment-message-135277" class="dsq-comment-message"><p>Judges need to be moved back from the ring. They need to sit where they can see the entire fight&#8211;because that is what they are supposed to be judging. Before TV, sure, maybe you needed different angles to make sure punches were or were not landing. But now??&#8230;put them in the HBO van to score. If their scores more closely resemble the masses on TV, it gives more faith (deserved or not) in the process. Perception is 9/10 of reality, and the perception of judges is that they don&#8217;t know what they are doing. Also, this is where judges should actually use the 10 point must system. 10-10 even, 10-9 close, 10-8 clear, 10-7 dominant. That is what the AIBA says. No mention of knockdowns to show it was clear. These clowns score a round that could go either way 10-9, but a clear round, where one fighter refuses to engage or does nothing or gets slapped around the exact same.</p>
</div>
</div>
</li> 
</ul> 
</li> 
<li class="comment odd alt thread-even depth-1" id="dsq-comment-135137">
<div id="dsq-comment-header-135137" class="dsq-comment-header">
<cite id="dsq-cite-135137">
<span id="dsq-author-user-135137">Ciscostudent561</span>
</cite>
</div>
<div id="dsq-comment-body-135137" class="dsq-comment-body">
<div id="dsq-comment-message-135137" class="dsq-comment-message"><p>I&#8217;m all for same day weigh Ins. But what I don&#8217;t get is how everyone was all givin Lemieux props even tho he was tippin the scales. Now that Danny is much bigger it&#8217;s a problem. I&#8217;m just callin it like I see it. </p>
</div>
</div>
<ul class="children">
<li class="comment even depth-2" id="dsq-comment-135198">
<div id="dsq-comment-header-135198" class="dsq-comment-header">
<cite id="dsq-cite-135198">
<span id="dsq-author-user-135198">ceylon mooney</span>
</cite>
</div>
<div id="dsq-comment-body-135198" class="dsq-comment-body">
<div id="dsq-comment-message-135198" class="dsq-comment-message"><p>lemieux got the same criticism for skipping the 2nd<br/>
weigh in. plus the additional flak for missing weight in the past. hes gotten some shit too for fighting that guy who just came up from 154 </p>
</div>
</div>
</li> 
</ul> 
</li> 
<li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-135147">
<div id="dsq-comment-header-135147" class="dsq-comment-header">
<cite id="dsq-cite-135147">
<span id="dsq-author-user-135147">DBone</span>
</cite>
</div>
<div id="dsq-comment-body-135147" class="dsq-comment-body">
<div id="dsq-comment-message-135147" class="dsq-comment-message"><p>I don&#8217;t know what&#8217;s funnier. The guy who wrote in saying he gave Jacobs 8 rds or the guy in the comments section yesterday who said he had Jacobs winning by a point and the fight was one of the biggest robberies he&#8217;s ever seen. Man there are some dumb bastards out there. Sorry but if you gave Jacobs more than 6 rds you are seeing what you want to see.</p>
</div>
</div>
<ul class="children">
<li class="comment even depth-2" id="dsq-comment-135185">
<div id="dsq-comment-header-135185" class="dsq-comment-header">
<cite id="dsq-cite-135185">
<span id="dsq-author-user-135185">D Johnson</span>
</cite>
</div>
<div id="dsq-comment-body-135185" class="dsq-comment-body">
<div id="dsq-comment-message-135185" class="dsq-comment-message"><p>Lol totally agree! </p>
</div>
</div>
</li> 
</ul> 
</li> 
<li class="comment odd alt thread-even depth-1" id="dsq-comment-135152">
<div id="dsq-comment-header-135152" class="dsq-comment-header">
<cite id="dsq-cite-135152">
<span id="dsq-author-user-135152">Juan Manuel Valverde</span>
</cite>
</div>
<div id="dsq-comment-body-135152" class="dsq-comment-body">
<div id="dsq-comment-message-135152" class="dsq-comment-message"><p>Canelo fans, did you guys forget you barely got passed Austin Trout with the help of a Knockdown? And let me tell you something, Trout ain&#8217;t Jacobs. There are close fights in boxing and the difference comes down to damage. The only guy I could see that got hurt in this fight was Jacobs and thats why he lost. </p>
</div>
</div>
<ul class="children">
<li class="comment even depth-2" id="dsq-comment-135171">
<div id="dsq-comment-header-135171" class="dsq-comment-header">
<cite id="dsq-cite-135171">
<span id="dsq-author-user-135171">Jorge</span>
</cite>
</div>
<div id="dsq-comment-body-135171" class="dsq-comment-body">
<div id="dsq-comment-message-135171" class="dsq-comment-message"><p>I will say this styles make fights, and GGG had trouble with the southpaw stance which Trout favors. If Trout was a true middleweight I think he would have presented a lot of problems to GGG as he did to Cotto and Canelito.</p>
</div>
</div>
<ul class="children">
<li class="comment odd alt depth-3" id="dsq-comment-135189">
<div id="dsq-comment-header-135189" class="dsq-comment-header">
<cite id="dsq-cite-135189">
<span id="dsq-author-user-135189">D Johnson</span>
</cite>
</div>
<div id="dsq-comment-body-135189" class="dsq-comment-body">
<div id="dsq-comment-message-135189" class="dsq-comment-message"><p> A huge southpaw whose power he had to respect. that wouldn&#8217;t be the case with trout.</p>
</div>
</div>
<ul class="children">
<li class="comment even depth-4" id="dsq-comment-135195">
<div id="dsq-comment-header-135195" class="dsq-comment-header">
<cite id="dsq-cite-135195">
<span id="dsq-author-user-135195">Jorge</span>
</cite>
</div>
<div id="dsq-comment-body-135195" class="dsq-comment-body">
<div id="dsq-comment-message-135195" class="dsq-comment-message"><p>Maybe but Jacobs switching to southpaw he didn&#8217;t carry that power anymore, just from his jabs. I thought what troubled GGG was not the power but the movement and boxing.</p>
</div>
</div>
<ul class="children">
<li class="comment odd alt depth-5" id="dsq-comment-135225">
<div id="dsq-comment-header-135225" class="dsq-comment-header">
<cite id="dsq-cite-135225">
<span id="dsq-author-user-135225">D Johnson</span>
</cite>
</div>
<div id="dsq-comment-body-135225" class="dsq-comment-body">
<div id="dsq-comment-message-135225" class="dsq-comment-message"><p> How do you know he didn&#8217;t carry that power anymore? he was still throwing hard to my eyes . If triple G fought trout he would have an entire training camp to train for a southpaw. Also they would be roughly the same size on fight night. </p>
</div>
</div>
</li> 
<li class="comment even depth-5" id="dsq-comment-135231">
<div id="dsq-comment-header-135231" class="dsq-comment-header">
<cite id="dsq-cite-135231">
<span id="dsq-author-user-135231">Jorge</span>
</cite>
</div>
<div id="dsq-comment-body-135231" class="dsq-comment-body">
<div id="dsq-comment-message-135231" class="dsq-comment-message"><p>I think because his best shot or power punch is the right hand. He was using it as a jab when switching if that makes sense. So it didn&#8217;t carry the power if he was throwing it from his normal stance. While effective as a jab its not the same as an overhand right or straight right hand. </p>
</div>
</div>
</li> 
</ul> 
</li> 
</ul> 
</li> 
</ul> 
</li> 
</ul> 
</li> 
<li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-135168">
<div id="dsq-comment-header-135168" class="dsq-comment-header">
<cite id="dsq-cite-135168">
<span id="dsq-author-user-135168">D Johnson</span>
</cite>
</div>
<div id="dsq-comment-body-135168" class="dsq-comment-body">
<div id="dsq-comment-message-135168" class="dsq-comment-message"><p>I said before the fight we&#8217;d see the best version that Danny Jacobs had offer and we did. That being said I still had to GGG winning 8 rounds. I think people&#8217;s expectations that Danny was going to get steamrolled affected their scorecards. GGG controlled most of the action with a hard jab that had Danny&#8217;s face busted up pretty good by the end of the fight. He knocked him down and out landed him in almost every round. Good close fight but there is no controversy in my opinion. </p>
</div>
</div>
<ul class="children">
<li class="comment even depth-2" id="dsq-comment-135192">
<div id="dsq-comment-header-135192" class="dsq-comment-header">
<cite id="dsq-cite-135192">
<span id="dsq-author-user-135192">ceylon mooney</span>
</cite>
</div>
<div id="dsq-comment-body-135192" class="dsq-comment-body">
<div id="dsq-comment-message-135192" class="dsq-comment-message"><p>i was wrong about jacobs. his last 3 fights dint show me anything that wouldnlast<br/>
him very long, and daaaaam was i wrong. tense, close matchup. </p>
<p>he brought enuf to win, just didnt do enuf with it. </p>
</div>
</div>
</li> 
</ul> 
</li> 
<li class="comment odd alt thread-even depth-1" id="dsq-comment-135210">
<div id="dsq-comment-header-135210" class="dsq-comment-header">
<cite id="dsq-cite-135210">
<span id="dsq-author-user-135210">Left Hook</span>
</cite>
</div>
<div id="dsq-comment-body-135210" class="dsq-comment-body">
<div id="dsq-comment-message-135210" class="dsq-comment-message"><p>Did anybody else think this was George Foreman-Tommy Morrison 2? Two big hitters, you know somebody is going down&#8230;.and then you get a boxing match?</p>
</div>
</div>
<ul class="children">
<li class="comment even depth-2" id="dsq-comment-135213">
<div id="dsq-comment-header-135213" class="dsq-comment-header">
<cite id="dsq-cite-135213">
<span id="dsq-author-user-135213">ceylon mooney</span>
</cite>
</div>
<div id="dsq-comment-body-135213" class="dsq-comment-body">
<div id="dsq-comment-message-135213" class="dsq-comment-message"><p>ha! good call </p>
</div>
</div>
</li> 
<li class="comment odd alt depth-2" id="dsq-comment-135232">
<div id="dsq-comment-header-135232" class="dsq-comment-header">
<cite id="dsq-cite-135232">
<span id="dsq-author-user-135232">Barney mcgrew</span>
</cite>
</div>
<div id="dsq-comment-body-135232" class="dsq-comment-body">
<div id="dsq-comment-message-135232" class="dsq-comment-message"><p>I hate it when that happens.</p>
</div>
</div>
</li> 
<li class="comment even depth-2" id="dsq-comment-135238">
<div id="dsq-comment-header-135238" class="dsq-comment-header">
<cite id="dsq-cite-135238">
<span id="dsq-author-user-135238">Jorge</span>
</cite>
</div>
<div id="dsq-comment-body-135238" class="dsq-comment-body">
<div id="dsq-comment-message-135238" class="dsq-comment-message"><p>Chiquita Gonzalez v Carbajal 2</p>
</div>
</div>
</li> 
</ul> 
</li> 
<li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-135228">
<div id="dsq-comment-header-135228" class="dsq-comment-header">
<cite id="dsq-cite-135228">
<span id="dsq-author-user-135228">Barney mcgrew</span>
</cite>
</div>
<div id="dsq-comment-body-135228" class="dsq-comment-body">
<div id="dsq-comment-message-135228" class="dsq-comment-message"><p>To stop all of these fights ending in controversial decisions, I propose fights to the finish.</p>
</div>
</div>
<ul class="children">
<li class="comment even depth-2" id="dsq-comment-135283">
<div id="dsq-comment-header-135283" class="dsq-comment-header">
<cite id="dsq-cite-135283">
<span id="dsq-author-user-135283">Left Hook</span>
</cite>
</div>
<div id="dsq-comment-body-135283" class="dsq-comment-body">
<div id="dsq-comment-message-135283" class="dsq-comment-message"><p>Do you think that fewer, longer rounds would get us to that end? Like, 5 7-minute rounds? I am wondering how long a fighter can hold up in a round. Much different than MMA. Of course, ward/klit/broner could hug alllll niggghtttt long&#8230;</p>
</div>
</div>
</li> 
</ul> 
</li> 
<li class="comment odd alt thread-even depth-1" id="dsq-comment-135241">
<div id="dsq-comment-header-135241" class="dsq-comment-header">
<cite id="dsq-cite-135241">
<span id="dsq-author-user-135241">maxx</span>
</cite>
</div>
<div id="dsq-comment-body-135241" class="dsq-comment-body">
<div id="dsq-comment-message-135241" class="dsq-comment-message"><p>Excellent mailbag as always Doug, good analysis of GGG vs Maravilla&#8230;&#8230;..I am completely gutted by the controversial Gonzalez loss, the damn judges have taken the oooomph of out the superfight with Inoue and lucky you being at the Sorjaturong vs Gonzalez classic.Kudos Doug.</p>
</div>
</div>
</li> 
<li class="comment even thread-odd thread-alt depth-1" id="dsq-comment-135245">
<div id="dsq-comment-header-135245" class="dsq-comment-header">
<cite id="dsq-cite-135245">
<span id="dsq-author-user-135245">John Swan</span>
</cite>
</div>
<div id="dsq-comment-body-135245" class="dsq-comment-body">
<div id="dsq-comment-message-135245" class="dsq-comment-message"><p>Quick ballbag? </p>
<p>1. Golovkin-Jacobs decision. I didn’t score the fight but I watched on Boxnation, who scored it to Jacobs, and I didn’t feel what they were saying was against what I was seeing myself. On that basis I have no problem with anybody who scored it in favour of Jacobs (and for that I await the wrath of the self-appointed Grand Judging Master Dougie 😉 . Perhaps if I scored it myself or rewatched it I’d think differently, but as with the Kovalev-Ward fight, I don’t think it’s the type of fight that warrants a repeat viewing. I haven’t seen the full set of press scorecards yet but I’m assuming they’ll reflect similarly to how Kovalev-Ward did, with the majority for Kovalev/GGG.</p>
<p>2. Is Golovkin on the slide? I’m not sure, but at 35 he’s already peaked physically. He can still take a hell of a punch without flinching (I didn’t see anything to suggest he was hurt in any way, contrary to what was reported by a few journalists), though I do wonder if there may have been even the slightest element of beginning to hold back on pulling the trigger. Maybe he gave Jacobs too much respect, or maybe Jacobs size and power was enough to warrant it – it’s difficult for us observers to know for sure. Overall I can’t help but be a little disappointed with what I saw from Golovkin. Maybe I overrated him and underrated Jacobs (my prediction was an easy KO win for Golovkin).</p>
<p>3. Jacobs tactics. I hate runners and though Jacobs was in some quarters being accused of fighting to survive as opposed to win the titles, I felt that assessment was harsh. For me he did enough to stay out of trouble while still doing enough to win rounds and deter his opponent from committing too much to his offence. Golovkin stalked and stalked, yet Jacobs was quick and accurate enough to counter effectively. I couldn’t help but think during the fight when his corner told him to “soften him up first” , that it was Jacobs himself being softened up and I feared it might turn out too much like Stevenson-Bellew where Bellew himself got softened up and taken out before he ever got a chance to launch an offence of his own. Thankfully I was wrong, the tactics were excellent and were carried out brilliantly. On another night and without the knockdown he may just have won a decision.</p>
<p>4. Rematch? Doubtful for this year, but likely for 2018 assuming GGG settles business with Canelo and Jacobs can continue to make weight and get another win or two of his own. Of the two and considering their ages, I think Jacobs is the more likely to grow and improve from their first fight.</p>
<p>5. The little king is dead, long live the king. With Gonzales now beaten, albeit under controversial circumstances, does that now elevate Andre Ward to no.1? No doubt there will be groans all around if that’s the case, but I don’t think GGG’s win over Jacobs was impressive enough for him to rise above the American. For what it&#8217;s worth, having a little guy, no matter how good he is, sitting at the top of the P4P rankings never sat well with me. My bad.</p>
</div>
</div>
</li> 
<li class="comment odd alt thread-even depth-1" id="dsq-comment-135261">
<div id="dsq-comment-header-135261" class="dsq-comment-header">
<cite id="dsq-cite-135261">
<span id="dsq-author-user-135261">Larry Connor</span>
</cite>
</div>
<div id="dsq-comment-body-135261" class="dsq-comment-body">
<div id="dsq-comment-message-135261" class="dsq-comment-message"><p>I don&#8217;t care what excuses any of the ggg nut huggers have to say, ggg loss a close fight. </p>
<p>GGG looks awesome when fighting subpar low level guys or guys with skills two weight classes smaller than he is, but put him the ring with a guy with a boxing pulse and suddenly ggg looks ordinary. Suddenly he looks fearful of return fire, suddenly his extrodinary ring cutting ability looks hesitant and suspect. All I wanted to see was ggg in the ring with one &#8220;Elite fighter/toss up type fight&#8221; on paper so I could properly judge if ggg was the true goods or not and it didn&#8217;t even take an &#8220;elite fighter&#8221; for me to find out. GGG is solid, but not special. He&#8217;s a great marketing product. Hats off to his promoter and the huge HBO marketing machine for created this mythical beast. </p>
<p>GGG has fought over 30 something fights, he&#8217;s in his 30&#8217;s and this is first time fighting someone on Jacobs&#8217;s level?? Yet ggg was being considered one of aMW&#8217;s monster of all times?? Nawww we need to stop that BS. Like I said, ggg is solid, but not special. After Saturday&#8217;s fight, no where in Dr Strange&#8217;s universe could I see ggg jumping up 2 weight class&#8217;s to fight an elite bigger guy as Brooks and Khan did. If ggg did decide to do that, well we saw what happened to Brooks and Khans. </p>
<p>End of the day ggg will do ok in the Watered down MW division, but I believe it&#8217;s in ggg&#8217;s best interest to stay in his current division. GGG has a mystic of being an animal, but I see a few guys putting on their horse breaking gear and looking forward to exposing your boy. </p>
</div>
</div>
<ul class="children">
<li class="comment even depth-2" id="dsq-comment-135280">
<div id="dsq-comment-header-135280" class="dsq-comment-header">
<cite id="dsq-cite-135280">
<span id="dsq-author-user-135280">NaoyaSantaCruz</span>
</cite>
</div>
<div id="dsq-comment-body-135280" class="dsq-comment-body">
<div id="dsq-comment-message-135280" class="dsq-comment-message"><p>how the f*ck does someone named Larry Connor not know English?<br/>
&#8220;&#8230;ggg was being considered one of aMW&#8217;s monster of all times?&#8221;<br/>
&#8220;GGG has a mystic of being an animal&#8221;<br/>
and WTF is a &#8220;boxing pulse&#8221;<br/>
obviously u r stupid as all hell and your opinions r worthless.</p>
</div>
</div>
</li> 
</ul> 
</li> 
<li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-135265">
<div id="dsq-comment-header-135265" class="dsq-comment-header">
<cite id="dsq-cite-135265">
<span id="dsq-author-user-135265">Marxuach</span>
</cite>
</div>
<div id="dsq-comment-body-135265" class="dsq-comment-body">
<div id="dsq-comment-message-135265" class="dsq-comment-message"><p>You must be a GGG hater or delusional if you scored it for Jacobs. </p>
</div>
</div>
</li> 
<li class="comment even thread-even depth-1" id="dsq-comment-135268">
<div id="dsq-comment-header-135268" class="dsq-comment-header">
<cite id="dsq-cite-135268">
<span id="dsq-author-user-135268">NaoyaSantaCruz</span>
</cite>
</div>
<div id="dsq-comment-body-135268" class="dsq-comment-body">
<div id="dsq-comment-message-135268" class="dsq-comment-message"><p>f*ck kellerman! dude is fucking tool and half. all he wants to do is tell what he thinks is &#8220;the narrative&#8221; of the fight over and over again, plus he&#8217;s a douche-bag, at this point i dont even think that kellerman is really even a hardcore fan. give me Al Bernstein over that twatter any day. </p>
<p>commentary dream team:<br/>
blow x blow = Lamps (also a casual, and he can b a douche too but he has the golden voice and he would better if kellerman and rjj werent dragging him down). </p>
<p>expert commentator = Fisher (not to kiss-ass but the brother is mostly always on point)</p>
<p>former boxer/trainer role = Malignaggi (he can be annoying especially when defending light-fisted punchers and defensive-stylist, or defending his sometimes bizarre scoring of fights, but still i think he&#8217;s good at what he does)</p>
</div>
</div>
</li> 
<li class="comment odd alt thread-odd thread-alt depth-1" id="dsq-comment-135286">
<div id="dsq-comment-header-135286" class="dsq-comment-header">
<cite id="dsq-cite-135286">
<span id="dsq-author-user-135286">Suk me dong</span>
</cite>
</div>
<div id="dsq-comment-body-135286" class="dsq-comment-body">
<div id="dsq-comment-message-135286" class="dsq-comment-message"><p>Blow job saunders &amp; then the Mexican chicken will be sliced and diced.</p>
</div>
</div>
</li> 
</ul>
</div>
</div>
</div>
</div> 
</div>
<div class="col-lg-4 col-md-4 col-sm-4 col-xs-12 right-sidebar">
<div id="sidebar_300x250_ad_widget-2" class="widget-1 widget-first widget-odd each-block Sidebar_300x250_Ad_Widget"><script id="mNCC" language="javascript">
   medianet_width = "300";
   medianet_height = "250";
   medianet_crid = "366235639";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUV3K88Q' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script></div><div id="callouts-2" class="widget-2 widget-even each-block widget_callouts box-img">
<ul class="most-active-posts">
<li>
<div class="thumbnail"><a href="http://www.ringtv.com/490141-dougies-monday-mailbag-65/">
<img src="http://www.ringtv.com/wp-content/uploads/2017/03/Golovkin-attacks-Jacobs_Hoganphotos-80x80.jpg" alt="Dougie&#8217;s Monday mailbag"/>
</a>
</div>
<div class="text-wrap">
<a class="title" href="http://www.ringtv.com/490141-dougies-monday-mailbag-65/">Dougie&#8217;s Monday mailbag</a>
<div class="posted-by">by Doug Fischer</div>
</div>
</li>
<li>
<div class="thumbnail"><a href="http://www.ringtv.com/490129-gennady-golovkin-mortal-victorious-weekend-review/">
<img src="http://www.ringtv.com/wp-content/uploads/2017/03/golovkin-jacobs-celebration-80x80.jpg" alt="Gennady Golovkin mortal but victorious: Weekend Review"/>
</a>
</div>
<div class="text-wrap">
<a class="title" href="http://www.ringtv.com/490129-gennady-golovkin-mortal-victorious-weekend-review/">Gennady Golovkin mortal but victorious: Weekend Review</a>
<div class="posted-by">by Michael Rosenthal</div>
</div>
</li>
<li>
<div class="thumbnail"><a href="http://www.ringtv.com/490057-chocolatito-upset-srisaket-sor-rungvisai-loses-pound-pound-perch/">
<img src="http://www.ringtv.com/wp-content/uploads/2017/03/Gonzalez-Rungvisai_Hoganphotos-80x80.jpg" alt="Chocolatito upset by Sor Rungvisai, loses pound-for-pound perch"/>
</a>
</div>
<div class="text-wrap">
<a class="title" href="http://www.ringtv.com/490057-chocolatito-upset-srisaket-sor-rungvisai-loses-pound-pound-perch/">Chocolatito upset by Sor Rungvisai, loses pound-for-pound perch</a>
<div class="posted-by">by Mitch Abramson</div>
</div>
</li>
<li>
<div class="thumbnail"><a href="http://www.ringtv.com/490003-golovkin-wins-close-decision-resilient-jacobs/">
<img src="http://www.ringtv.com/wp-content/uploads/2017/03/Golovkin-Jacobs_Hoganphotos-80x80.jpg" alt="Golovkin wins close decision against resilient Jacobs"/>
</a>
</div>
<div class="text-wrap">
<a class="title" href="http://www.ringtv.com/490003-golovkin-wins-close-decision-resilient-jacobs/">Golovkin wins close decision against resilient Jacobs</a>
<div class="posted-by">by Mitch Abramson</div>
</div>
</li>
<li>
<div class="thumbnail"><a href="http://www.ringtv.com/490020-gennady-golovkin-escapes-narrow-victory-daniel-jacobs/">
<img src="http://www.ringtv.com/wp-content/uploads/2017/03/unnamed-1-1-80x80.jpg" alt="Gennady Golovkin escapes with narrow win over Daniel Jacobs"/>
</a>
</div>
<div class="text-wrap">
<a class="title" href="http://www.ringtv.com/490020-gennady-golovkin-escapes-narrow-victory-daniel-jacobs/">Gennady Golovkin escapes with narrow win over Daniel Jacobs</a>
<div class="posted-by">by Michael Rosenthal</div>
</div>
</li>
</ul>
</div><div id="sidebar_200x200_ad_widget-2" class="widget-3 widget-odd each-block Sidebar_200x200_Ad_Widget"><script id="mNCC" language="javascript">
   medianet_width = "200";
   medianet_height = "200";
   medianet_crid = "227933193";
   medianet_versionId = "111299";
   (function() {
       var isSSL = 'https:' == document.location.protocol;
       var mnSrc = (isSSL ? 'https:' : 'http:') + '//contextual.media.net/nmedianet.js?cid=8CUV3K88Q' + (isSSL ? '&https=1' : '');
       document.write('<scr' + 'ipt type="text/javascript" id="mNSC" src="' + mnSrc + '"></scr' + 'ipt>');
   })();
</script></div><div id="text-6" class="widget-4 widget-even current-poll each-block widget_text"><h2>Current Poll</h2> <div class="textwidget"><script type="text/javascript" charset="utf-8" src="http://static.polldaddy.com/p/9664256.js"></script>
<noscript><a href="http://polldaddy.com/poll/9664256/">What will be the result of the Canelo Alvarez-Julio Cesar Chavez Jr. fight?</a></noscript></div>
</div><div id="sidebar_160x90_ad_widget-2" class="widget-5 widget-odd each-block Sidebar_160x90_Ad_Widget"><a href="http://bit.ly/fightersnetwork"><img src="http://www.ringtv.com/custom-ads/fightersnetwork/160x90/160x90FN.png"></a></div><div id="extension-slug-widget--2" class="widget-6 widget-last widget-even each-block widget_callouts box-img">
<h2>Ratings: Junior Featherweight</h2>
<div class="boxer-ratings">
<div class="each-row">
<div class="imagebox">
<img src="http://www.ringtv.com/wp-content/uploads/2016/07/rigondeaux-ratings-270x270.jpg" alt="Guillermo Rigondeaux"/>
</div>
<div class="number">1</div>
<div class="text">Guillermo Rigondeaux</div>
<div class="text">Record: 17-0-0 (11 KOs)</div> </div>
<div class="each-row">
<div class="imagebox">
<img src="http://www.ringtv.com/wp-content/uploads/2016/08/Jessie-Magdaleno-ratings-Al-Applerose-Top-Rank-Promotions-270x270.jpg" alt="Jessie Magdaleno"/>
</div>
<div class="number">2</div>
<div class="text">Jessie Magdaleno</div>
<div class="text">Record: 24-0-0 (17 KOs)</div> </div>
<div class="each-row">
<div class="imagebox">
<img src="http://www.ringtv.com/wp-content/uploads/2015/01/Rey-Vargas-small-Promociones-del-Pueblo-site-270x270.jpg" alt="Rey Vargas"/>
</div>
<div class="number">3</div>
<div class="text">Rey Vargas</div>
<div class="text">Record: 29-0-0 (22 KOs)</div> </div>
<div class="each-row">
<div class="imagebox">
<img src="http://www.ringtv.com/wp-content/uploads/2016/08/genesis-servania-ratings-270x270.jpg" alt="Genesis Servania"/>
</div>
<div class="number">4</div>
<div class="text">Genesis Servania</div>
<div class="text">Record: 27-0-0 (11 KOs)</div> </div>
<div class="each-row">
<div class="imagebox">
<img src="http://www.ringtv.com/wp-content/uploads/2016/08/nonito-donaire-ratings-farina-270x270.jpg" alt="Nonito Donaire"/>
</div>
<div class="number">5</div>
<div class="text">Nonito Donaire</div>
<div class="text">Record: 37-4-0 (24 KOs)</div> </div>
<div class="each-row">
<div class="imagebox">
<img src="http://www.ringtv.com/wp-content/uploads/2016/08/moises-flores-ratings-270x270.jpg" alt="Moises Flores"/>
</div>
<div class="number">6</div>
<div class="text">Moises Flores</div>
<div class="text">Record: 25-0-0 (17 KOs)</div> </div>
<div class="each-row">
<div class="imagebox">
<img src="http://www.ringtv.com/wp-content/uploads/2016/08/diego-de-la-hoya-vs-giovanni-delgado-04-photo-by-naoki-fukuda-270x270.jpg" alt="Diego De La Hoya"/>
</div>
<div class="number">7</div>
<div class="text">Diego De La Hoya</div>
<div class="text">Record: 17-0-0 (9 KOs)</div> </div>
<div class="each-row">
<div class="imagebox">
<img src="http://www.ringtv.com/wp-content/uploads/2016/07/Hugo-Ruiz-ratings-270x270.jpg" alt="Hugo Ruiz"/>
</div>
<div class="number">8</div>
<div class="text">Hugo Ruiz</div>
<div class="text">Record: 36-4-0 (32 KOs)</div> </div>
<div class="each-row">
<div class="imagebox">
<img src="http://www.ringtv.com/wp-content/uploads/2016/12/yukinori-oguni-ratings-270x270.jpg" alt="Yukinori Oguni"/>
</div>
<div class="number">9</div>
<div class="text">Yukinori Oguni</div>
<div class="text">Record: 19-1-1 (7 KOs)</div> </div>
<div class="each-row">
<div class="imagebox">
<img src="http://www.ringtv.com/wp-content/uploads/2016/08/Jonathan-Guzman_Dave-Nadkarni-PBC-270x270.jpg" alt="Jonathan Guzman"/>
</div>
<div class="number">10</div>
<div class="text">Jonathan Guzman</div>
<div class="text">Record: 22-1-0 (22 KOs)</div> </div>
</div>
</div>
</div>
</div>
<div class="clearboth"></div>
</div>
</div>  
</div> 
<div class="footer-wrap">
<div class="bg-top"></div>
<div class="wrap-inner">
<a class="foot-go-top-btn visible-xs" href="#"></a>
<div class="row">
<div class="col-lg-3 col-md-3 col-sm-6 col-xs-12 hidden-xs">
<div class="foot-logo"><img src="http://www.ringtv.com/wp-content/themes/thering/images/ring-logo.png" alt=""></div>
<div class="foot-small-desc">Your destination for the best boxing news, videos and live streams!</div>
<ul class="foot-social">
<li><a href="https://www.facebook.com/RingTV" target="_blank"><i class="fa fa-facebook"></i></a></li> <li><a href="https://www.youtube.com/user/TheRingDigital?sub_confirmation=1" target="_blank"><i class="fa fa-youtube"></i></a></li> <li><a href="https://twitter.com/ringmagazine" target="_blank"><i class="fa fa-twitter"></i></a></li> <li><a href="http://instagram.com/ringtv" target="_blank"><i class="fa fa-instagram"></i></a></li> </ul>
</div>
<div class="col-xs-12 hidden-lg hidden-md hidden-sm visible-xs">
<h3>Quicklinks</h3>
<ul id="menu-footer-menu" class="foot-quicklinks"><li id="menu-item-186" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-186"><a href="http://www.ringtv.com/terms-conditions/">Terms &#038; Conditions</a></li>
<li id="menu-item-185" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-185"><a href="http://www.ringtv.com/privacy-policy/">Privacy Policy</a></li>
</ul> </div>
<div class="col-lg-3 col-md-3 col-sm-6 col-xs-12">
<h3>Contact Us</h3>
<div class="contact-info-row">
<span class="icon"><i class="fa fa-home"></i></span>
P.O. Box 90254<br> Brooklyn, NY 11209 </div>
<div class="contact-info-row">
<span class="icon"><i class="fa fa-phone"></i></span>
<a class="telnum" href="tel:+">215-643-3069</a>
</div>
<div class="contact-info-row">
<span class="icon"><i class="fa fa-envelope-o"></i></span>
<a class="email" href="/cdn-cgi/l/email-protection#64100c01160d0a03241701141106080d0705100d0b0a174a070b09"><span class="__cf_email__" data-cfemail="b7c3dfd2c5ded9d0f7c4d2c7c2d5dbded4d6c3ded8d9c499d4d8da">[email&#160;protected]</span><script data-cfhash='f9e31' type="text/javascript">/* <![CDATA[ */!function(t,e,r,n,c,a,p){try{t=document.currentScript||function(){for(t=document.getElementsByTagName('script'),e=t.length;e--;)if(t[e].getAttribute('data-cfhash'))return t[e]}();if(t&&(c=t.previousSibling)){p=t.parentNode;if(a=c.getAttribute('data-cfemail')){for(e='',r='0x'+a.substr(0,2)|0,n=2;a.length-n;n+=2)e+='%'+('0'+('0x'+a.substr(n,2)^r).toString(16)).slice(-2);p.replaceChild(document.createTextNode(decodeURIComponent(e)),c)}p.removeChild(t)}}catch(u){}}()/* ]]> */</script></a>
</div>
</div>
<div class="col-lg-3 col-md-3 col-sm-6 col-xs-12 hidden-xs">
<h3>Quicklinks</h3>
<ul id="menu-quicklinks" class="foot-quicklinks"><li id="menu-item-178" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-178"><a href="http://www.ringtv.com/about-us/">About Us/Staff</a></li>
<li id="menu-item-179" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-179"><a href="http://www.ringtv.com/contact-us/">Contact Us/Advertise</a></li>
<li id="menu-item-180" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-180"><a href="http://www.ringtv.com/subscribe/">Subscribe</a></li>
</ul> </div>
<div class="col-lg-3 col-md-3 col-sm-6 col-xs-12 hidden-xs">
<h3>Join Our Newsletter</h3> <div class="foot-newsletter">
<div class="desc">Join our newsletter to get info about latest events and deals!</div>
<script type="text/javascript">(function() {
	if (!window.mc4wp) {
		window.mc4wp = {
			listeners: [],
			forms    : {
				on: function (event, callback) {
					window.mc4wp.listeners.push({
						event   : event,
						callback: callback
					});
				}
			}
		}
	}
})();
</script> <form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-462750" method="post" data-id="462750" data-name="Newsletter Subscription"><div class="mc4wp-form-fields"><input class="textbox" type="email" name="EMAIL" placeholder="YOUR EMAIL ADDRESS" required />
<input class="btn-light-pink" type="submit" value="Subscribe"><div style="display: none;"><input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off"/></div><input type="hidden" name="_mc4wp_timestamp" value="1490020955"/><input type="hidden" name="_mc4wp_form_id" value="462750"/><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1"/></div><div class="mc4wp-response"></div></form>  </div>
</div>
<div class="col-xs-12 hidden-lg hidden-md hidden-sm visible-xs">
<ul class="foot-social">
<li><a href="https://www.facebook.com/RingTV" target="_blank"><i class="fa fa-facebook"></i></a></li> <li><a href="https://twitter.com/ringmagazine" target="_blank"><i class="fa fa-twitter"></i></a></li> <li><a href="http://instagram.com/ringtv" target="_blank"><i class="fa fa-instagram"></i></a></li> </ul>
<div class="foot-logo"><img src="http://www.ringtv.com/wp-content/themes/thering/images/ring-logo.png" alt=""></div>
<div class="foot-small-desc">Your destination for the best boxing news, videos and live streams!</div>
</div>
</div> 
</div>
</div> 
<div class="footer-bottom">
<div class="wrap-inner">
<ul id="menu-footer-menu-1" class="foot-btm-links"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-186"><a href="http://www.ringtv.com/terms-conditions/">Terms &#038; Conditions</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-185"><a href="http://www.ringtv.com/privacy-policy/">Privacy Policy</a></li>
</ul> <div class="copyright">&copy; 2017 RING TV LIVE. All rights reserved. </div>
</div>
</div>
<div style="display: none;">
<div class="subscribe-modal" id="subscribe-now">
<div class="inner">
<span class="modal-logo"><img src="http://www.ringtv.com/wp-content/themes/thering/images/ring-logo.png" alt=""></span>
<h4>Get Our Newsletter.</h4> <p>Subscribe to our newsletter to get the latest news, events and deals in your inbox!</p> <div class="clearfix"></div>
</div>
<div class="mc-form">
<div class="inner">
 <form id="mc4wp-form-2" class="mc4wp-form mc4wp-form-462750" method="post" data-id="462750" data-name="Newsletter Subscription"><div class="mc4wp-form-fields"><input class="textbox" type="email" name="EMAIL" placeholder="YOUR EMAIL ADDRESS" required />
<input class="btn-light-pink" type="submit" value="Subscribe"><div style="display: none;"><input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off"/></div><input type="hidden" name="_mc4wp_timestamp" value="1490020955"/><input type="hidden" name="_mc4wp_form_id" value="462750"/><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-2"/></div><div class="mc4wp-response"></div></form>  </div>
</div> 
</div>
</div>
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
  (adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-7578637367237225",
    enable_page_level_ads: true
  });
</script>
<script type="text/javascript">(function() {function addEventListener(element,event,handler) {
	if(element.addEventListener) {
		element.addEventListener(event,handler, false);
	} else if(element.attachEvent){
		element.attachEvent('on'+event,handler);
	}
}function maybePrefixUrlField() {
	if(this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if( urlFields && urlFields.length > 0 ) {
	for( var j=0; j < urlFields.length; j++ ) {
		addEventListener(urlFields[j],'blur',maybePrefixUrlField);
	}
}/* test if browser supports date fields */
var testInput = document.createElement('input');
testInput.setAttribute('type', 'date');
if( testInput.type !== 'date') {

	/* add placeholder & pattern to all date fields */
	var dateFields = document.querySelectorAll('.mc4wp-form input[type="date"]');
	for(var i=0; i<dateFields.length; i++) {
		if(!dateFields[i].placeholder) {
			dateFields[i].placeholder = 'YYYY-MM-DD';
		}
		if(!dateFields[i].pattern) {
			dateFields[i].pattern = '[0-9]{4}-(0[1-9]|1[012])-(0[1-9]|1[0-9]|2[0-9]|3[01])';
		}
	}
}

})();</script><script type='text/javascript' src='http://www.ringtv.com/wp-content/plugins/contact-form-7/includes/js/jquery.form.min.js?ver=3.51.0-2014.06.20'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpcf7 = {"recaptcha":{"messages":{"empty":"Please verify that you are not a robot."}}};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.ringtv.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=4.6'></script>
<script type='text/javascript' src='http://www.ringtv.com/wp-content/themes/thering/js/jquery.flexslider.js'></script>
<script type='text/javascript' src='http://www.ringtv.com/wp-content/themes/thering/js/jquery.easing.js'></script>
<script type='text/javascript' src='http://www.ringtv.com/wp-content/themes/thering/js/jquery.movingboxes.js'></script>
<script type='text/javascript' src='http://www.ringtv.com/wp-content/themes/thering/js/instafeed.min.js'></script>
<script type='text/javascript' src='http://www.ringtv.com/wp-content/themes/thering/js/jquery.cycle2.min.js'></script>
<script type='text/javascript' src='http://www.ringtv.com/wp-content/themes/thering/js/jquery.mCustomScrollbar.concat.min.js'></script>
<script type='text/javascript' src='http://www.ringtv.com/wp-content/themes/thering/js/fitvids.min.js?ver=7087586e79110fdc66a69ca2a63b4ab2'></script>
<script type='text/javascript' src='http://www.ringtv.com/wp-content/themes/thering/js/owl.carousel.min.js'></script>
<script type='text/javascript' src='http://www.ringtv.com/wp-content/themes/thering/js/jquery.lazy.min.js?ver=1.0.1'></script>
<script type='text/javascript' src='http://www.ringtv.com/wp-content/themes/thering/js/jquery.fancybox.pack.js'></script>
<script type='text/javascript' src='http://www.ringtv.com/wp-content/themes/thering/js/js.cookie.js'></script>
<script type='text/javascript' src='http://www.ringtv.com/tweetie.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_var = {"url":"http:\/\/www.ringtv.com\/wp-admin\/admin-ajax.php","nonce":"957f361c98"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.ringtv.com/wp-content/themes/thering/js/global.js?ver=7087586e79110fdc66a69ca2a63b4ab2'></script>
<script type='text/javascript' src='http://www.ringtv.com/wp-includes/js/wp-embed.min.js?ver=4.7.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"platform":"wordpress@4.7.3","language":""},"disqusIdentifier":"490141 http:\/\/www.ringtv.com\/?p=490141","disqusShortname":"theringonline","disqusTitle":"Dougie\u2019s Monday mailbag","disqusUrl":"http:\/\/www.ringtv.com\/490141-dougies-monday-mailbag-65\/","options":{"manualSync":false},"postId":"490141"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.ringtv.com/wp-content/plugins/disqus-comment-system/media/js/disqus.js?ver=4.7.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"theringonline"};
/* ]]> */
</script>
<script type='text/javascript' src='http://www.ringtv.com/wp-content/plugins/disqus-comment-system/media/js/count.js?ver=4.7.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var mc4wp_forms_config = [];
/* ]]> */
</script>
<script type='text/javascript' src='http://www.ringtv.com/wp-content/plugins/mailchimp-for-wp/assets/js/forms-api.min.js?ver=4.0.11'></script>
<!--[if lte IE 9]>
<script type='text/javascript' src='http://www.ringtv.com/wp-content/plugins/mailchimp-for-wp/assets/js/third-party/placeholders.min.js?ver=4.0.11'></script>
<![endif]-->
<script type='text/javascript' src='http://www.springboardplatform.com/jsapi/embed'></script>
<script>
 (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
 (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
 m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
 })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

 ga('create', 'UA-77508658-1', 'auto');
 ga('send', 'pageview');

</script>
 
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-5MLLG9" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-5MLLG9');</script>
 
 
<script type="text/javascript" src="//s7.addthis.com/js/300/addthis_widget.js#pubid=ra-4ef3d09874f075c2"></script>
<script type="text/javascript">
    
	jQuery(function($){
		if (typeof(Cookies.get('subscribemod')) == 'undefined' || Cookies.get('subscribemod') == null) {
			//cookie is not present
			
			$.fancybox( {href : '#subscribe-now', openEffect : 'none', closeEffect : 'none', padding : 0, closeClick : false, afterClose: function(){
				Cookies.set('subscribemod', 'done', { path: '/', expires: 7 });
			} } ); 
			
			$('.joinus-modal').on('click',function(){
				Cookies.set('subscribemod', 'done', { path: '/', expires: 365 });
				$(this).parents('form').submit();
			});
		}	
		
     
	})
	
    var j = jQuery.noConflict();
    
	j(window).load(function(){
		
	});
	

    
    
</script>
<script>/* <![CDATA[ */(function(d,s,a,i,j,r,l,m,t){try{l=d.getElementsByTagName('a');t=d.createElement('textarea');for(i=0;l.length-i;i++){try{a=l[i].href;s=a.indexOf('/cdn-cgi/l/email-protection');m=a.length;if(a&&s>-1&&m>28){j=28+s;s='';if(j<m){r='0x'+a.substr(j,2)|0;for(j+=2;j<m&&a.charAt(j)!='X';j+=2)s+='%'+('0'+('0x'+a.substr(j,2)^r).toString(16)).slice(-2);j++;s=decodeURIComponent(s)+a.substr(j,m-j)}t.innerHTML=s.replace(/</g,'&lt;').replace(/\>/g,'&gt;');l[i].href='mailto:'+t.value}}catch(e){}}}catch(e){}})(document);/* ]]> */</script></body>
</html>